Jump to content

cmf

cmf

Member Since 11 Jun 2006
Offline Last Active Private
-----

Posts I've Made

In Topic: OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

16 November 2013 - 02:46 AM

okay, a bit weird, but if the BIOS says it is a GK110B, it is one.

 

also: 10.9.1 has no updated nvidia drivers :( just some new GeForceTesla drivers (still R310) and updated OpenCL framework (so you might want to give this a try).

In Topic: OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

15 November 2013 - 01:17 PM

yeah, definitely GK110B: "GK110B P2083 SKU 21 VGA BIOS" (@0x686)
original GTX 780 is just "GK110" and "SKU 20", Titan is "SKU 10" and GTX 780 Ti is "SKU 30".

The "A1" in GPU-Z might be hardcoded, what does it say in the OS X System Information / Revision ID?

In Topic: OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

15 November 2013 - 07:58 AM

http://www.insanelym...288721-gtx-780/

And yes, GPU-Z should be able to dump the BIOS.

I also noticed that Nvidia actually announced CUDA 6 yesterday (for whatever reason not on their own blog ...), but no SDK or OS X drivers yet. The R330 Windows/Linux drivers have support for it though.

In Topic: OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

15 November 2013 - 12:59 AM

What's the device id and revision id of your card? And can you make a BIOS dump and upload it?
I wasn't aware of any chip changes in the GTX 780 line, but they might have started using the same revised chips that they're also using for the GTX 780 Ti (GK110B).

I'm also annoyed by the 10.9.1/10.9.2 situation. I did expect a release this week, but maybe next week then ...
On another note: CUDA 6 will be released soon™ (maybe at SC13 next week?), so I also expect new drivers from Nvidia (probably R330 if they had to do the same changes/additions like they had to on Linux/Windows).


@any mod who's reading this: could splice the last few posts into the GTX 780 thread (#125 onwards)? Because this really doesn't belong here.
And then close this thread, because there is nothing more to say since 10.9.

In Topic: OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

14 November 2013 - 08:46 AM

I don't know about Clover, but in chameleon I have to disable the "GraphicsEnabler", otherwise I wouldn't even get to the login screen. But since it's working fine if I disable that option, this obviously means the card is supported as-is by OS X (full EFI support I guess?). Does Clover have a similar option?
And yeah, if OpenCL doesn't work properly, you're screwed, because CoreImage uses it - so about _everything_ in OS X.

I'm using the MacPro5,1 profile btw, but this shouldn't make much of a difference.
© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy