Jump to content

sw170

sw170

Member Since 29 Mar 2009
Offline Last Active Nov 23 2014 11:28 PM
-----

Posts I've Made

In Topic: working sleep but reboot on wake-up

20 February 2014 - 05:24 PM

Its different which smbios i use:

MBA6,2: x8, x28, x29, x30, x31, x32

MBP11,2: x8, x17, x28, x29, x30, x31, x32

 

Thats normal, with xcpm there are not all steps used... on real MacBooks there is the same:-)

look in this thread:

http://www.insanelym...63cl-i7-4700mq/

 

The steps are different on smbios and CPU that you use...

 

Cheers :-)

Ok, I thought x86platformplugin makes pstates behave different, thanks.

In Topic: working sleep but reboot on wake-up

20 February 2014 - 12:47 PM

Hey Ramalama,

Thanks for all the links and help, doing more research & testing now

one question: do you use HWMonitor on your notebook with 10.9.1 ? Im checking my desktop now with i7 CPU and Pstates are jumping from min to high only, x86platformplugin not loaded

How does it work on your i7 with x86platformplugin ?

 

thanks

s

In Topic: working sleep but reboot on wake-up

19 February 2014 - 08:10 PM

Try this one!

Ramalama I dont think we will get anywhere with this, from what I read about X86Platform kext it needs to be loaded to have pstates working on computers with Ivy bridge. And my pstates and cstates are already working and doubt my laptop got Ivy bridge on it.

What do you know about X86Platform ? Why do you think it should be loaded on my system ?

In Topic: working sleep but reboot on wake-up

19 February 2014 - 07:29 PM

If you change in your DSDT the length to 0x08, instead of 0x02, you will get:

pmset -g rtc

raw bytes: 0x00000000 0x00000000
PM Byte = On (0x00)
LW Byte = OK (0x00)

yes, I`ve got the same RTC results - errors on my desktop and dv9040 where everything works fine so that is not an issue


add the attached ssdt-6 to your patched folder and see if you get errors, and if x86platformplugin loads

more or less the same - no pstates and cstates and:

19/02/2014 19:18:57.000 kernel[0]: X86PlatformShim::sendStepper - Stepper dictionary from plist is NULL!
19/02/2014 19:18:57.000 kernel[0]: X86PlatformShim::start - Failed to send stepper

In Topic: working sleep but reboot on wake-up

19 February 2014 - 06:54 PM

2.26 GHz Intel Core 2 Duo

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy