Jump to content

jriker1

jriker1

Member Since 01 Mar 2009
Offline Last Active Aug 25 2011 12:09 AM
-----

Topics I've Started

Remove and Readd kext and now getting invalid magic number

13 August 2011 - 05:17 PM

I am on 10.7 and it was solid. In attempting to fix the shutdown options based on suggestion moved the NullCPUPowerManagement kext to the root of the drive. Then rebooted and it crashed. So I moved the NULLCPUPowerManagement kext back to the E/E folder and get the below:

kxld[com.apple.driver.AppleRTC]: The Mach-O file is malformed: Invalid magic number: 0xbebafeca.
Can't load kext com.apple.driver.AppleRTC - link failed
Failed to load executable for kext com.apple.driver.AppleRTC
Filaed to load kext com.apple.driver.AppleRTC (erroc 0xdc008016)
Couldn't alloc calss "AppleRTC"
com.apple.driver.AppleRTC


It eventually hangs. A bit further down but never saw this message before so assume this is the issue. I've verified all the kext file owners and settings recursively but all look OK. Am I missing something? Do I have to remove something so it can redo some cache or something? Tried booting with no cache but no joy either.

Ugh. Any help would be appreciated.

JR

EDIT: As an FYI I tried replacing the AppleRTC.kext file from the original source media and repair permissions but no joy.

Request for DSDT for Dell M6400

13 August 2011 - 12:52 PM

I have been using OS 10.6.3 - 10.6.7 on my Dell M6400 for a while now. Funny how it runs rings around my co-workers who have "real" Mac's. Anywho. I am now on Lion 10.7 and still continue to not being able to shutdown, reboot, and oh boy, DON'T CLOSE THE LID!!!!!

I digress. I currently only have altered my DSDT file to accommodate my NVida Quadro 3700M, otherwise untouched. Was wondering what advice there was, what I could provide, etc to have the ability to shutdown, restart, and close the lid to sleep. Would accept just being able to shutdown completely.

If anyone has any advice, let me know. I can provide any details or files from my system as requested.

JR

Edit: By the way, reading the entries in the forum, download and ran RunMe and attached the results.

AppleACPIPlatform.kext and IOPCIFamily.kext replace fix?

29 July 2011 - 02:52 PM

I have a Dell Precision M6400 laptop. The only way using a variety of suggested install methods including the sticky's in this forum have failed. I can only get to the install screen by replacing the AppleACPIPlatform.kext and IOPCIFamily.kext files with the ones from my 10.6.7 install that I am "upgrading" to Lion. Problem is it then installs and reboots, and get the spinning icon and then immediately crashes with:



Can't load kext com.apple.iokit.IOPCIFamily - link failed

Has a bunch others I can send but don't have it in front of me. Looking at a blurry photo I took of the screen. Also mentions:



Couldn't alloc class "AppleACPIPlatformExpert" Unable to find driver for this platform: \"ACPI\",\n"@/Source......

Anyone else having this incompatibility with replacing those two files? Again, gets the install done but then on reboot chokes.

Thanks.

JR

Dell M6400 What network card?

16 May 2011 - 04:23 PM

So I have a Dell M6400 Precision running at 90% OSX. Only things not working now is shutdown which I think I can overcome and the Intel 5300 network card which I haven't seen anyone get working. Does anyone have any suggestions of another internal card that would work with the M6400 or even a USB based card that is a micro mini card that I can leave in all the time that would be compatible with OSX86? Running 64-bit 10.6.7 by the way.



Thanks.



JR
© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy