Jump to content

skinmunster

skinmunster

Member Since 27 Dec 2008
Offline Last Active Jul 08 2016 06:00 AM
-----

Posts I've Made

In Topic: Clover General discussion

14 April 2013 - 02:58 PM

@fau7i

I'm currently also trying to patch the connectors, because my Sapphire 7950 Boost has four connectors (not standard) DP, HDMI, DVD-D and DVD-I. May i ask you:
1. Is your card listet later as PCI-card in Systemprofiler? (my is not listed, only visible within graphics/display tab)
2. Can you post your config.plist (regarding graphic card and kext-patches).

Must i use GraphicInjections (default is on) or not to get full/native usage of my card? My card uses the standard PCI-ID's for 7950 (0x1002/0x679a),, but with GraphicsInjector No and Futomaki frame buffer the system will not display desktop.

Thank you.

P.S. Posted from iPad, sorry for bad words.

In Topic: Clover General discussion

09 April 2013 - 10:09 PM

skinmunster: please attach your original ssdt


Ok, added in previous post.

@All: Seems to be fixed now - after changing systemtype from Macmini6,2 to iMac13.2, custom ssdt is loaded and applied, going to desktop. Now X86-Plugin is also loaded (hook inside custom ssdt). Got now 16,35,37,38,39 as CPU-Pstates, if i remember right same as with iMac-Definition / Chamelon. With MacMini6.2/Chamelon i got some more in the middle, like 23 ..

@Slice: I also tried GenerateIvyStates (without custom ssdt), but only getting CPU-States 16 and 35, and no X86-Plugin loaded.


Wondering why MacMini doesn't work here?


Ok, finished for this evening, thank you all for fast help! Will come back tomorrow.


Bye

In Topic: Clover General discussion

09 April 2013 - 07:24 PM

Hi, how did you create your SSDT? Maybe it causes the problem. This script works pretty well.

EDIT:
You can attach files in an archive.

Hi k3nny, i read your other asus Thread here, got some ideas from there. Ssdt was generated by the Script from Pike. I will try to attach Logs later.
Im currently using macmin6,2 as Modell, wil try later imac13,2.

Bye

In Topic: Clover General discussion

09 April 2013 - 06:08 PM

Hi there,
i'm a little lost getting my Custom SSDT working, need some fresh ideas, cause system stucks in a kind of loop, does not switch to desktop, if a custom ssdt is loaded (no custom DSDT) Booting in single user mode is ok, but after exiting this, it will not switch to desktop. If i remove custom SSDT it works as desired, but X86Plugin is not loaded.

Ok, i switched from Chamelon to Clover-UEFI boot. Within Chamelon SSDT works, X86Plugin is loaded, Speedstep is ok!

I dumped with UEFI-Clover my OEM-Tables:

6:278 0:001 Tables in Xsdt: 8
6:278 0:000 0. DDABF428: 'FACP', 'A M I', Rev: 5, Len: 268 -> FACP.aml
6:280 0:001 (Dsdt: DDAB4170, Facs: DDBE8080, XDsdt: DDAB4170, XFacs: 0)
6:280 0:000 DDAB4170: 'DSDT', 'A M I', Rev: 2, Len: 45745 -> DSDT.aml
6:282 0:002 DDBE8080: 'FACS', Ver: 2, Len: 64 -> FACS.aml
6:284 0:001 1. DDABF538: 'APIC', 'A M I', Rev: 3, Len: 146 -> APIC.aml
6:285 0:001 2. DDABF5D0: 'FPDT', 'A M I', Rev: 1, Len: 68 -> FPDT.aml
6:286 0:001 3. DDABF618: 'MCFG', 'A M I', Rev: 1, Len: 60 -> MCFG.aml
6:288 0:001 4. DDABF658: 'HPET', 'A M I', Rev: 1, Len: 56 -> HPET.aml
6:289 0:001 5. DDABF690: 'SSDT', 'SataTabl', Rev: 1, Len: 877 -> SSDT-0.aml
6:290 0:001 6. DDAC0408: 'SSDT', 'CpuPm', Rev: 1, Len: 2706
Found hidden SSDT 4 pcs
6:290 0:000 * DBEA8018: 'SSDT', 'CpuPm', Rev: 1, Len: 2706 53 53 44 54 92 0A 00 00 01 3D 50 6D 52 65 66 00 Internal length = 2706 -> SSDT-2x.aml
6:291 0:001 * DDA49A98: 'SSDT', 'ApIst', Rev: 1, Len: 771 53 53 44 54 03 03 00 00 01 76 50 6D 52 65 66 00 Internal length = 771 -> SSDT-3x.aml
6:293 0:001 * DDA48018: 'SSDT', 'Cpu0Cst', Rev: 1, Len: 2107 53 53 44 54 3B 08 00 00 01 D8 50 6D 52 65 66 00 Internal length = 2107 -> SSDT-4x.aml
6:294 0:001 * DDA4AC18: 'SSDT', 'ApCst', Rev: 1, Len: 281 53 53 44 54 19 01 00 00 01 EC 50 6D 52 65 66 00 Internal length = 281 -> SSDT-5x.aml
6:295 0:001 -> SSDT-1.aml
6:296 0:001 7. DDABFA58: 'SSDT', 'Cpu0Ist', Rev: 1, Len: 2474 -> SSDT-6.aml

I named custom SSDT.aml as SSDT-2.am, i can see its detected, but always hangs. I also tried as -0, -1, -1 or -8, no change. Also (my initial approach), dropping OEMSSDT does not help.

System Details: Asus P8Z77-M Pro, i7-3770k. Sapphire 7950.

EFI/OEM/P8Z77-M\ PRO/config.plist, ACPI related:

<key>ACPI</key>
[font='courier new', ', courier, monospace} '] <dict>[/font]
[font='courier new', ', courier, monospace} '] <key>DropOEMSSDT</key>[/font]
[font='courier new', ', courier, monospace} '] <string>No</string>[/font]
[font='courier new', ', courier, monospace} '] <key>GenerateCStates</key>[/font]
[font='courier new', ', courier, monospace} '] <string>No</string>[/font]
[font='courier new', ', courier, monospace} '] <key>GeneratePStates</key>[/font]
[font='courier new', ', courier, monospace} '] <string>No</string>[/font]
[font='courier new', ', courier, monospace} '] <key>FixDsdtMask</key>[/font]
[font='courier new', ', courier, monospace} '] <string>0x0004</string>[/font]
[font='courier new', ', courier, monospace} '] </dict>[/font]


EFI/OEM/P8Z77-M\ PRO/ACPI/patched/ssdt-2.aml

Hmm. can't attach here ?

(You aren't permitted to upload this kind of file)
SSDT and boot.log - /Library/Logs/CloverEFI/will not be filled if boot hangs :-(

Ok, also attached original dumped SSDT.

Thank you very much, skinmunster

In Topic: Unigine Valley (Highend OpenGL) Benchmark

18 February 2013 - 06:13 PM

Ok, just another ATI 6870 (XFX Dual Fan), but running only on x8 PCIe 2.0 slot.Basic, with disabled AA:Cheers!
Attached File  Valley.jpg   75.83KB   1 downloads

Ok, additional values with the oclBandwidthTest-Tool (Thanks, mitch!)


Running on...

ATI Radeon Barts XT Prototype

Quick Mode


Host to Device Bandwidth, 1 Device(s), Paged memory, direct access

Transfer Size (Bytes) Bandwidth(MB/s)

33554432 2618.5


Device to Host Bandwidth, 1 Device(s), Paged memory, direct access

Transfer Size (Bytes) Bandwidth(MB/s)

33554432 2940.6


Device to Device Bandwidth, 1 Device(s)

Transfer Size (Bytes) Bandwidth(MB/s)

33554432 105993.3


[oclBandwidthTest] test results...

PASSED

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy