Jump to content

TimeWalker75a

TimeWalker75a

Member Since 30 May 2008
Offline Last Active Dec 06 2017 09:54 AM
*****

#2284474 OSX on DELL Vostro 3450 / Inspiron N4110 / XPS L702x UEFI Clover

Posted by TimeWalker75a on 24 September 2016 - 07:36 PM

Gave Sierra a quick whirl jumping from my Yosemite install. Besides the card reader not appearing as an internal device (but working nonetheless) and USB property merging not showing up due to USBMergeNub changes I had no issues, at all. Oh, the XHCI ports for FL chipset worked, but would be finicky after sleep. The reason all this is in past tense is because the SSD I had cloned the system died after a dozen restarts (HWMonitor was reporting 45% health) and wouldn't even get scanned via fsck, system just halts right away .. so I've wasted a couple hours and suffered some pain along the way. Will rinse and repeat when I've recovered ... Sent from my SM-G920F using Tapatalk

#2251899 Lenovo ThinkPad T420 with UEFI Only

Posted by TimeWalker75a on 12 July 2016 - 06:25 PM

So here's the gist. 
 Having started executing _WAK upon wake it determines waking from S3. 
 If Intel IGD graphics are in use, as determined by \VIGD, it then signals IGD that all LID devices have awoken by calling GLIS and passing the evaluation of _LID as an arg to it. Which _LID returns the value of a EC register HPLD (H = H8 = EC, P = Probe, LD = LID). This value happens to be 1 on wake, meaning internal (LFP) LID is open. GLIS notifies IGPU with 0, but it does not notify the LID device itself, an extra notification has to be issued. If you look at _Q2B, which is responsible for preparing the system for sleep when LID is closed, it calls GLIS followed by a status change notification to LID. Never happens in _WAK tough ... So add that an voila, no darwake nor HID tickle is required to wake display when you open the LID.    If (LEqual (Arg0, 0x03))   {   ...   If (\VIGD)   {      \_SB.PCI0.IGPU.GLIS...

#2249397 Lenovo ThinkPad T420 with UEFI Only

Posted by TimeWalker75a on 08 July 2016 - 06:46 PM

I update it but It display error : winflash flash bios is not an upgrade (same or older version number)I've managed to make a typo in the flash_custom.bat .. it should be '/sa' not '/ca', as in .. skip all (checks). Should be same command set as in the Readme.

#2247909 Lenovo ThinkPad T420 with UEFI Only

Posted by TimeWalker75a on 05 July 2016 - 06:30 PM

I'll post the BIOS, including details over at bios-mods with proper credits as there's still someone out there who is charging a substantial amount for each of these mods for this series of laptops.   It's HERE if you feel adventurous. 

#2247446 Lenovo ThinkPad T420 with UEFI Only

Posted by TimeWalker75a on 03 July 2016 - 05:10 PM

Ok, here I go with my shenanigans - picked up a T420s, pretty basic config - i5-2520M, HD3000, 4Gb DDR3, Toshiba 128Gb SSD.  The machine didn't have any OS on-board, so to do some basic testing I tossed original Win 7 Professional on there from recovery media. That didn't go well - laptop idled at 98C so needed a clean up, desperately.  After de-dusting and re-pasting things got better, but it still easily reaches 80C with average load, while my Dell will barely climb to mid-70s. And an added bonus is that fan controller from EC tends to lock up the fan at 4K RPM, even though the temps be sitting at 44C.. Besides the fan (which I have ordered a Toshiba make replacement), so far there are only two things I dislike about this machine compared to my (also business class) Vostro - no keyboard backlight (but Thinklight is surprisingly good) and the fact that the speakers sound so darn tiny I fail to see how this can be classified as audio system at all.  Moving o...

#2181623 OSX on DELL Vostro 3450 / Inspiron N4110 / XPS L702x UEFI Clover

Posted by TimeWalker75a on 24 October 2015 - 03:22 PM

November is going to be crazy business trip busy for me, so no chance to try it out. So don't expect anything until late November to early December, probably. I barely had time to install Capitan on my Macbook last week and now 10.11.1 hit already... Rehabman has revamped the backlight kext, I just need to see whether it will work ok on Yosemite and if so ditch everything from ACPI as this is where it was going in regards to that. As fast as USB go, I saw someone put a legacy that enabled Fresco Logic 1009 work, but I highly doubt that a legacy will do anything  for older units with NEC chips.  Oh, an I have the laptop sitting at my desk most of the time these days going in an out of sleep without any obvious performance impact issues, so I guess the safest bet would be to try resetting nvram, otherwise what @jkbuha said.

#2172129 OSX on DELL Vostro 3450 / Inspiron N4110 / XPS L702x UEFI Clover

Posted by TimeWalker75a on 02 October 2015 - 11:15 AM

LCD backlight control require re-work from scratchUSB require re-work in general (patch set for DSDT)USB 3.0 ports won't work without third party kext - not something I'm a huge fan of. All in all, I'm staying away from 10.10 until at least 10.10.1 is released and the fuss calms down.Support will come, eventually .. as I use this computer for work I can't really scrape everything off and start fresh any minute.

#2161016 OSX on DELL Vostro 3450 / Inspiron N4110 / XPS L702x UEFI Clover

Posted by TimeWalker75a on 17 August 2015 - 07:05 AM

Nope, not yet. I know for a fact that USB3 will be a problem in 10.11 as Fresco Logic FL1009 doesn't seem to be supported not to mention the NEC chips on the FastEthernet daughterboardsAlso, MacBookPro8 range never came with USB3 support. The rest seems like a no-brainer .. RehabMan addressed brightness control issues as far as I know.

#2150596 OSX on DELL Vostro 3450 / Inspiron N4110 / XPS L702x UEFI Clover

Posted by TimeWalker75a on 04 July 2015 - 05:54 AM

The files on that usb stick are just temporary to get you through the I installatIon, but not for daily use as they lack serial and other proprietary configuration. You are meant to install SCT package, which combines the settings you choose into a proper boot loader configuration...

#2149565 Clover General discussion

Posted by TimeWalker75a on 30 June 2015 - 06:44 PM

Without confirmation it is only speculation.Details mentioned are actually the much needed confirmation. 

#2149463 Clover General discussion

Posted by TimeWalker75a on 30 June 2015 - 11:16 AM

Anyone experiencing waking from sleepimage to a black screen with working keyboard and soundon on a laptop , but no image on display after laptop resumes from hibernate?It requires a semi-sleep cycle via closing the lid and re-opening it back up to get to the login window. This is with hibernate mode set to 7 and AptioFix2. I recall it worked a treat before, but since then I've only changed my EDID override and progressively updated Clover. Not something that you encounter on a daily basis, so I haven't noticed the precise moment is stopped working properly. 

#2149200 OSX on DELL Vostro 3450 / Inspiron N4110 / XPS L702x UEFI Clover

Posted by TimeWalker75a on 29 June 2015 - 07:13 AM

These buttons from the guides you found don't do anything on a regular PC, nor there's a chime on start up since the physilcal chip that does all these things is absent. nvram.plist is no longer being used because AptioFix driver can provide native NVRAM functionality and when it doesn't find EmuVariable driver loaded, the plist to pick up nvram variables won't load either. As a last resort to get rid of the message (which the only thing it causes is annoyance), you can try to wipe the NVRAM from BIOS update package, just add /cvar flag to it, as instructed in the SCT package for cases of encountered system slowness. 

#2145180 AppleHDA for El Capitan discussion

Posted by TimeWalker75a on 15 June 2015 - 07:10 AM

Actually, 11D41983 is not new per se.It used to be there until 10.8 was released, so it was last seen in 10.7 and was meant to be zeroed. Looks like Apple is bringing the check sequence back from the days of Lion ... 

#2141962 OSX on DELL Vostro 3450 / Inspiron N4110 / XPS L702x UEFI Clover

Posted by TimeWalker75a on 05 June 2015 - 10:04 AM

No, you don't need to disconnect anything (nor you can, actually), just try to get the OS on the machine.In post-install, use AMD, because it will then apply the rules to disable discrete graphics chip, thus probably allowing your laptop to roam free with just the Intel graphics. 

#2141957 OSX on DELL Vostro 3450 / Inspiron N4110 / XPS L702x UEFI Clover

Posted by TimeWalker75a on 05 June 2015 - 09:40 AM

There's a fair possibility, because AMD card will be physically (on hardware level) disconnected from rendering the image regardless of computer use.

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy