Jump to content

empty-space

empty-space

Member Since 03 Feb 2006
Offline Last Active May 09 2010 11:48 PM
-----

Topics I've Started

Widescreen S-Video/Composite Output on the Intel Macbook/MacMini

12 June 2007 - 02:45 AM

(Note: not sure if this is the right place, but it seems like it will fit in)

I have a Macbook and when plugging the miniDVI to Video adapter into it, only 4:3 resolutions are available. This was unexpected, since the same adapter can output 4:3 and 16:9 resolutions on my intel iMac, all the way to 1280x720. The goal is to enable at least one widescreen resolution over S-Video, so that I can use the device with an HDTV (with only component in, before you say "go DVI!"). The loss of quality is not a serious issue, so standard definition is expected.

What I know so far:

- The available resolutions are graphics card/driver dependent, since the same adapter provides different results on different hardware.
- The Macbook uses the same graphics device as the intel Mac Mini, so the solution is likely to work with the Mini's s-Video adapter as well. Also, a solution could be spread to also support other OSX86 systems with the same chipset.
- The adapter activates the TV-Out module in the intel (or ATI, in the iMac's case) chipset. AFAIK, the only thing in the video dongle is a chip providing EDID information, and maybe some analog circuitry. (unsure about this)

EDID:

Extended display identification data, or EDID, is information sent by the monitor to the computer, so that the computer knows the available modes and resolutions for that monitor. Apple's adapter uses custom EDID data (not conforming to the usual parameters). My best guess is that OSX detects this strange EDID data and then enables a bit of "enable TV-Out" code. The EDID DDC (extracted by SwitchResX) is below:

0 1 2 3 4 5 6 7 8 9 A B C D E F
-----------------------------------------------------
0 | 00 FF FF FF FF FF FF 00 06 10 08 9D 01 01 01 01
1 | 07 0C 01 03 10 00 00 96 30 67 A9 A0 56 47 99 26
2 | 11 48 4C 00 00 61 01 01 01 01 01 01 01 01 01 01
3 | 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
4 | 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
5 | 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
6 | 01 01 01 01 01 01 01 01 01 01 01 01 00 00 00 FC
7 | 00 4E 54 53 43 2F 50 41 4C 0A 20 20 20 20 00 38

(For those not so fluent in monitor codes, in hex no less, all those 0101s in the middle are normally descriptive data)

TV-Out Module:
The intel chipset includes dedicated TV-Out circuitry. This circuitry handles (from what I can tell) hardware scaling, interlacing, and modulation of the composite, s-video, and even component output (although there is no component dongle for the macbook, and I'm not sure if the mini-dvi connector has provisions for it). The module supports both PAL and NTSC, and progressive as well as interlaced modes. The chipset uses a 108MHz pixel clock (8x multiplier applied)

Interesting Attempt:
I have been using SwitchResX to test different output modes on the "NTSC/PAL" display device. Most output an unsynchronized mess, but there are a few exceptions. Outputting arbitrary resolutions with the pixel clock set to 108MHz (which results in ridiculously high reported refresh rates) displays the screen, with the correct (widescreen) aspect ratio, in black and white and off center. I tried several resolutions, the most recent being 853x480 (480i 16:9), and they all came up with the same results. Note: If I create a 800x600 mode with this method, the output is identical in appearance and position to 800x600 50Hz PAL. This might indicate that, while generating a screen mode "from scratch" will enable interlaced tv-out, somehow the NTSC/PAL flag is lost. Alternatively, it could just be a lack of colour burst and maladjusted front/back porch lengths. In any case, it seems as though the intel chipset is able to

Ideal Solution:
The best way to implement s-video and composite widescreen modes would be a driver modification or display mode override for the dongle. Another solution would be to "trick" OSX into using a widescreen resolution, and then using software or hardware scaling to squeeze the image down to a 4:3 output mode to be sent out to the TV, which can stretch it back to 16:9 (using non-square pixels). This may be what the TV-Out module is doing already.

Personally, I have no experience in Mac device drivers and the display system, however I am a recent electronics engineering graduate and I know enough about NTSC signals and hardware level configuration to get by. I am going to keep trying to figure out the exact method of configuration for the TV-Out module, and I will report any progress. Hopefully someone out there can help me implement a solution. Also, any tips or help would be GREATLY appreciated. I know the OSX86 community has some brilliant folks in it. Thanks!


Some resources:
Mobile Intel 945 Express Chipset Family Datasheet
Intel Technology Journal regarding TVOut in Centrino systems
xserver-xorg-video-intel Package (Linux driver for this chip, which has TV-Out implemented)

Installer Wont Start

08 July 2006 - 09:12 PM

I've been searching but I cant find anyone with the same problem


I have an Averatec 1020 laptop with the following specs:

Intel Celeron M ULV 373 (1.0 GHz)
60 GB Hard Drive
512MB DDR
Intel i855 Graphics
AC97 Audio

The hard drive was completely cleared off before all attempts, no OS or any partitions. I am aiming for a single-boot, no Windows involved.

I havethe following: a Jas 10.4.6 disk, a "Mac.OSX.10.4.5.Universal" (not sure WHO's this is) disk, another "Universal" 10.4.4 disk, an unlabelled 10.4.3 disk (my roommate has successfully used this), and a 10.4.1 disk. They are burned on a variety of brands of DVD-R and DVD+R.

Out of that collection, I can get 10.4.1 to install perfectly. All of the others boot off the disk, get to the grey Apple logo screen, and stop. Disk activity stops, I DON'T get any (/) slashed circle error image, or any errors at all. The spinner never appears on any of the installs after any reasonable amount of time (I even tried overnight with the 10.4.6 disk). The DVD can be ejected, and shows no signs of being active.

I've tried using the -v flag, and there were no apparent error messages.

Nearly all my hardware has been confirmed working, I have the drivers I need for non-crucial devices, and if only I could get it to install I'm sure i could get the system running nicely.

Does anyone have any suggestions? Should I keep downloading different patched DVDs and trying again? Does the disk need to be partitioned or formatted in any particular way? Is it normal/understandable for the system to stop at this point? Should I wait hours with each disk, in case one of them eventually loads? Is there any other solution for installing that I can try?

EDIT:
In comparing the verbose outputs of the 10.4.1 and the others, it seems as though they are never loading the kernel. The installs hang at the point where the 10.4.1 verbose output (for lack of a better description) "changes fonts". My linux experience tells me that is a kernel problem. Maybe that will help diagnose.


Thanks in advance. I'm really hoping to get this working.
© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy