Jump to content

nmarques

nmarques

Member Since 19 Mar 2008
Offline Last Active Jan 05 2014 12:45 AM
-----

Topics I've Started

HP EliteBook 8560p - AMD/ATI 6470M - Mavericks custom kexts?

04 January 2014 - 06:05 AM

Hi all,

 

I'm having some issues with a HP EliteBook 8560p (Full HD, 1980x1080p) which has a AMD/ATI 6470M graphics adapter. Most of the stuff works more or less. This laptop has a Sandy Bridge CPU (i5) but the Intel GPU has been disabled by HP and isn't available (I might be able to dump the BIOS and brute force it, but I'm not really much inclined to go that way).

 

I've spent already quite a few hours following tutorials and testing stuff out (trial/error) without much success; appart from the VGA output (which was working with acceleration) the internal LVDS refuses to work. I haven't got much success with the dual-link.

 

I've fired up a Fedora LiveCD and dumped the ATI VBIOS and grabbed the default DSDT (in attachment); Would anyone be kind enough to help me (actually do it for me) patching a Mavericks AMD6000 kext based on files attached?

 

If I understood correctly from several documents/topics/howto's, for the LVDS to work properly the binary needs to be patched with the correct information from the ATI VBIOS. Help? Please? :)

 

The attached archive has both the vanilla DSDT and the ATI VBIOS dump; I would assume any OS has the necessary tools to open the archive (zlib/tar). Thanks in advance guys. Also If there's a breakthrough here, I would like to continue exploring and improving deployments of OSX86 on this specific model in the future (this is the first time I'm looking into this hackintosh stuff for real).

 

This information might also be useful:

 

AMD 6470M: 0x67601002

Personality used: Ipomoea

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy