Jump to content

RogerMac

RogerMac

Member Since 19 Nov 2007
Offline Last Active Jan 17 2016 02:08 PM
-----

#2004441 10.9.2 on Optiplex 755

Posted by RogerMac on 15 March 2014 - 08:12 PM

SUCCESS. Optiplex 755 fully working with 10.9.2.On 2 machines, one equipped with E4400 dual core and GeForce 8400 and the other with E6600 Quad Core and ASUS EN210. The solution is basically the one I outlined some posts ago (4 kexts from 10.8.4), even though refining the solution was particularly tricky, for a mix of three basic reasons: REASON A ) 755 is a machine based on previous generation chipsets from Intel (it comes from 2007, so it's 7 years old...). This time we had hard time with integrated SATA, but the next we can experience the same with all the remaining 0x8086 drivers. Those are getting progressively unsupported by Apple, therefore with each release - as soon as the system kext are updated by Apple to support newer hardware - something ceases to work on 755 (because Apple ceases progressively supporting older macs). We've seen differences between 10.9.1 and 10.9.2, expect further problems with 10.9.3, 10.9.4, 10.9.5... Let's say that I believe that Maverick...

#2000234 10.9.2 on Optiplex 755

Posted by RogerMac on 04 March 2014 - 08:14 PM

Guys, actually I understood what's wrong with AHCI, and managed to boot the machine in 10.9.2, and it's working, by an operating system point of view. What I still can't get is the video, 'cause none of the OOB cards I was using (ASUS EN210, Nvidia 7500), neither the onboard GMA950 manage to switch from the text screen to the graphics. This is probably due to the changes I had to mage to the AHCI kext, but still no success in having graphics (but the machine comes alive and can be accessed from the network via ssh). Also vmc technically works, but it is obviously transmitting a black screen (the Graphics card is logically started but not active). Hoping you can suggest me what I'm missing, here is what I have discovered and what I have done. a) the 755 has an ICH9R sata controller. This is not recognized in 10.9, thus no bootable disk without patch.  B) the trick that allowed to mount the SATA controller in 10.9.1 was to substitute AppleAHCIPort, IOAHCIFamily, IO...
© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy