Jump to content

ccx4700

ccx4700

Member Since 28 Oct 2007
Offline Last Active Dec 28 2014 02:01 PM
-----

Posts I've Made

In Topic: [How To] Install Leopard Retail DVD on ASUS P6T Deluxe LGA 1366 (core i7)

05 January 2009 - 09:35 AM

Great tutorial!
It may help many users who are using P6T Deluxe.

In Topic: Upcoming Intel X58 Mobos & Core i7 CPUs

03 January 2009 - 02:42 PM

anyone has the ADI A2000B working on asus board?


@vailancer:
Use this kext (at post #7).
http://forum.insanel...amp;mode=linear
But only 2ch stereo output is working.

In Topic: Upcoming Intel X58 Mobos & Core i7 CPUs

18 December 2008 - 08:38 AM

Big (and I'm afraid maybe stupid) question about this: would this work on any install (iDeneb, iAtkos), or do you need to have a retail install and EFI boot for this? As I'm still not entirely aware of the DSDT phenomenon, especially not how it can affect the work of the cores of a CPU...? (it's mostly power states of the system and cpu, as far as I could find until now.. does that mean the other cores don't get powered because of the alias thing..? I'm so confused :wacko: )

@ChipX, ccx4700
I had to leave home just after getting iAtkos in; had time to look into the huge amount of options and descriptions on it.. wow :blink: Let's just say I'd like to print that out and read it sometime, might give me a bit more insight on how it all works. I'll try one or two installs tomorrow, any tips and suggestions (except ChipX's experience, which will be taken along :) ) or even testing requests? I'll be happy to oblige ^_^

@AiBear:
I used retail Install method. I described how I did it at an older post.
To run all cores, we must use bootloder that can loding DSDT.aml, so I installed pcefi_v9 manually.

iAtkos5 RUNNING WITH ALL CORES ENABLED! ;)
bios settings: all cores enabled and HT enabled
used DSDT patcher, method discribed above.
btw, it boots alot faster, it doesnt break anymore.


the strange thing is that System Profiler says this:
Number of Processors: 0 ( where the hell did he went to?! :unsure: lol )
Total Number Of Cores: 5 ( where are those 3 nasty cores missing.. ehehe )

on geekbench:
Physical Processors: 0 ( he likes to play hiding :P )
Logical Processors: 8 ( jackpot)

AiBear ccx4700, i think we need to solve this kinda bug..eheheh , or at least try to :P
AiBear, good luck with the tweaking ;) hope you can bring us some good news ;)

Congratulations!
Your "Total Number Of Cores" string is really interesting, mine is showing 4. (even HT on)
Maybe System Profiler says number of physical cores, not logical cores by HT tech.
And I think Mac OS X finds Physical Processors by looking FSB, but i7 doesn't have FSB(yeah, renewed by QPI), so it shows 0. There is no evidence, just my idea.


There is DSDT.aml that I'm using. For P6T deluxe.
I'm not sure it works well for you, because of bios version, bios setteings.

In Topic: Upcoming Intel X58 Mobos & Core i7 CPUs

17 December 2008 - 02:00 PM

ALL CORES WORKING ON P6T DELUXE!!
Hey guys, I did it!

First, I must apologize to THEHAWKs for my jumping conclusion.
You are true, it was Alias problem.
I believed that DSDT patcher deletes Alias strings automatically, but it doesn't.

By deleting Alias, I can get all cores working. Not only 4 cores, I can enable HT so it works as 8 cores.
So, here is a METHOD.

1. Run the DSDT Patcher to make dsdt.dsl.
2. Open a dsdt.dsl in Debug folder by nano. like:
$ nano Debug/dsdt.dsl
3. Delete Alias strings.
Scope (_PR)
{
Processor (P001, 0x01, 0x00000810, 0x06) {}
Alias (P001, CPU1)
Processor (P002, 0x02, 0x00000000, 0x00) {}
Alias (P002, CPU2)
Processor (P003, 0x03, 0x00000000, 0x00) {}
Alias (P003, CPU3)
Processor (P004, 0x04, 0x00000000, 0x00) {}
Alias (P004, CPU4)
Processor (P005, 0x05, 0x00000000, 0x00) {}
Alias (P005, CPU5)
Processor (P006, 0x06, 0x00000000, 0x00) {}
Alias (P006, CPU6)
Processor (P007, 0x07, 0x00000000, 0x00) {}
Alias (P007, CPU7)
Processor (P008, 0x08, 0x00000000, 0x00) {}
Alias (P008, CPU8)
Processor (P009, 0x09, 0x00000000, 0x00) {}
Alias (P009, CPU9)
Processor (P010, 0x0A, 0x00000000, 0x00) {}
Processor (P011, 0x0B, 0x00000000, 0x00) {}
Processor (P012, 0x0C, 0x00000000, 0x00) {}
Processor (P013, 0x0D, 0x00000000, 0x00) {}
Processor (P014, 0x0E, 0x00000000, 0x00) {}
Processor (P015, 0x0F, 0x00000000, 0x00) {}
Processor (P016, 0x10, 0x00000000, 0x00) {}
}

to

Scope (_PR)
{
Processor (P001, 0x01, 0x00000810, 0x06) {}
Processor (P002, 0x02, 0x00000000, 0x00) {}
Processor (P003, 0x03, 0x00000000, 0x00) {}
Processor (P004, 0x04, 0x00000000, 0x00) {}
Processor (P005, 0x05, 0x00000000, 0x00) {}
Processor (P006, 0x06, 0x00000000, 0x00) {}
Processor (P007, 0x07, 0x00000000, 0x00) {}
Processor (P008, 0x08, 0x00000000, 0x00) {}
Processor (P009, 0x09, 0x00000000, 0x00) {}
Processor (P010, 0x0A, 0x00000000, 0x00) {}
Processor (P011, 0x0B, 0x00000000, 0x00) {}
Processor (P012, 0x0C, 0x00000000, 0x00) {}
Processor (P013, 0x0D, 0x00000000, 0x00) {}
Processor (P014, 0x0E, 0x00000000, 0x00) {}
Processor (P015, 0x0F, 0x00000000, 0x00) {}
Processor (P016, 0x10, 0x00000000, 0x00) {}
}

4. Run DSDT Patcher again on Terminal.
$ ./DSDT\ Patcher Debug/dsdt.dsl
5. Rename and copy dsdt.aml to root.
$ cp dsdt.aml /DSDT.aml
6. Now you can boot without cpus flag. ENJOY!

Finally, I really want to say thank you to THEHAWKs, without your reply, I might not get this result.

In Topic: Upcoming Intel X58 Mobos & Core i7 CPUs

17 December 2008 - 12:05 PM

nice :D i will go for vodoo then :D

but before that, i will try again iatkos 5.. just for testing.

and tomorrow.. OVERCLOCK timeeee :D hope i can get my i7 920 working at least at 4.1ghz.. psu modded again.. maybe some vmod if vdrop is too big.. cooler is not a problem, water ..eheh .. wish me luck, i will put some nasty voltage on the baby.. and i will try to get my rams to 1800mhz.. gogo baby ;)


SUCESS AGAIN :D :D

system:

cpu: intel core i7 920
motherboard: asus P6T Deluxe
graphic card: 9800gt 512m


Status: iAtkos 5 working ( as far as i notice is stable )

Installation:

kernel Vodoo 9.5.0
intel AHCI
nvinject

thats the only options i made ..

install went perfect.. but for booting into OSX after install i used this flags:
cpus=1
busratio=20

hope this will be usefull to you guys ..

@ChipX
You said "thats the only options i made", I'm curious about AppleACPIPlatform.kext what you are using.
I used older one in iDeneb, so its verison is 1.0.3 (showed in Info.plist)
I can't boot P6T without 1.0.3 kext.
But you seemed NOT to use 1.0.3. What's your kext version?
I'll very surprised if you're using vanilla AppleACPIPlatform.kext.
© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy