Jump to content

Fjtorsol

Fjtorsol

Member Since 01 Aug 2007
Offline Last Active Nov 14 2014 07:58 PM
-----

Posts I've Made

In Topic: QE/CI - ATI Mobility Radeon HD 31xx 32xx 34xx 42xx & Radeon HD 42xx (Coll...

22 December 2012 - 12:38 PM

acceleration is there and can be activated

It is actually there and working the problem is that the accelerator is unable to write the rendered pixels to the display frame buffer. I suspect that as Apple decided to replace the display detection routines by fixed value tables there is some value that the accelerator requires to properly write the accelerated pixels in the correct memory offset. What is clear is that ATIRadeonX2000GA enables the creation of hardware accelerated overlays and is properly creating them but no content is written to such overlays. PD: I use Chameleon with a custom EFI graphics property list based on the EFI values of an iMac8,1. The boot loader has nothing to do here. I edited my connector values in the ATIRadeon2600 frame buffer to get the internal LVDS to work (only 16-bit colour depth as I don't know the correct dithering values for my panel). Also as my GPU is an ATI Mobility Radeon HD 2600 XT (the same as iMac8,1) my hardware ID is already present in all the required kexts.

In Topic: QE/CI - ATI Mobility Radeon HD 31xx 32xx 34xx 42xx & Radeon HD 42xx (Coll...

21 December 2012 - 05:26 PM

The ATI HD 2XXX and 3XXX graphics cards which share many architectural similitudes won't work properly on Mac OS X 10.6 and up due to apple replacing hardware detection routines by fixed value tables. These cards might work properly in Mac OS X 10.5.x with hardware acceleration (GL, QE, CI, and Video) but considering the Mac App Store requires applications to be compiled for Mac OS X 10.6.x as a minimum with no backwards compatibility you will only be able to run outdated versions of most of applications. The most I have managed to get with one of these cards (ATI Radeon HD 2600 XT) in Mac OS X 10.6 is a fully working frame buffer which gives support for up to two monitors with cloning and desktop expansion modes (no backlight control for my LVDS CCFL backlighted display). I even managed to check that in fact graphic acceleration works for this graphics cards in Mac OS X 10.6 but for some reason the hardware accelerated surfaces are not written back to the display frame buffer.
Posted Image
If you boot with the graphic acceleration kexts loaded you get a dirty frame buffer which renders previous non cleared (obviously non overwritten) GPU memory regions resulting in your display showing a collage of what was previously displayed by your GPU with a working hardware accelerated cursor. About flashing an original Mac GPU bios, it might result useless as most of PC versions of this GPUs only have a 64 Kb on-board EPROM while a Mac GPU bios has 128 Kb of size being the last bytes of the bios image the ones that contain the EFI initialization code that makes Mac bios different from PC. So to make these graphics cards work in reasonable useful way in Mac OS X you would have to understand the disassemblies of the hardware acceleration driver components, specially the part that refers to writing rendered pixels to display buffers. I did many tests without success, it is pretty complex as acceleration is based on lots of hardware instructions with nearly any open source reference.

In Topic: [Guide and Solved] Ati Radeon HD 2600 Pro 512 MB kext on lion 10.7.2 working

07 February 2012 - 01:13 PM

Please could you specify what is working for you with these drivers??

Working card-specific framebuffer -> Results in ability to properly set display resolutions, gamma management and hardware cursor
Working GA -> Results in OpenGL and Video Acceleration (OpenCL not applicable for RV6XX and RV7XX due to the lack of shared memory functionality)
© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy