Jump to content

STLVNUB

STLVNUB

Member Since 17 Jul 2007
Offline Last Active Private
*****

#2312178 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 02 November 2016 - 01:07 AM

ha ha ok, is enabled by default. correct.So that need just "--std-ebda" as arg. Ok will add an opt in dev mode "build CloverEFI with --std-ebda"Good way to test iso is in VirtualBox.32bit legacy don't boot 64bit does.Will work on a debug extension to the script to sort problems like this out  ;)

#2311557 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 01 November 2016 - 01:26 AM

Ok also if compiling in Linux, IF gcc=6.2.1 use GCC53 else GCC49 etc in ebuild.shUSE_LOW_EBDA=1 450KB :(USE_LOW_EBDA=0 483KB :)

#2309505 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 30 October 2016 - 12:55 AM

about the pkg or the iso in linux. .. I don't know. May be possible to build both, but also runnable?Only one way to find out, will try when have time/inspiration

#2309485 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 30 October 2016 - 12:00 AM

all ok now had to get your script to recompile it. edit:had gettext installed with HomeBrew, had to uninstall HomeBrew and re-install for Sierra. DID NOT use Homebrew to install getttext. bug is if you try developer mode pkg build and NO gettext installed, it will give that error, and manually running buildgettext.sh puts it into MODE "S" folder if you get my meaning.running your script correctly installs it into MODE "R" folder

#2309059 OZMTool - An Ozmosis Toolbox

Posted by STLVNUB on 29 October 2016 - 01:04 PM

Problem is OzMTool  is compressed.Here is uncompressed 0.3 Attached Files  OzMToolDarwin.zip 1.46MB 25 downloads

#2300578 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 15 October 2016 - 10:35 PM

Might be good idea to catch the return value of ebuild.sh  ( and probably makepkg/buildiso ) and Continue if it succeeds and Stop when it fails.At present it will build a Pkg regardless.

#2296273 Clover General discussion

Posted by STLVNUB on 09 October 2016 - 06:24 AM

How about adding a menu in SMBIOS section to select what model you want to use?Save a lot of typing/editing config.plist etc to test different models on the fly.

#2286556 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 27 September 2016 - 02:00 AM

The OvmfPkg needs a few other Pkgs to compile, namely: OptionRomPkgCryptoPkgFatPkg

#2285059 ECS G31T-M7 Ozmosis Need

Posted by STLVNUB on 25 September 2016 - 03:02 PM

You need UEFI Firmware to use Ozmosis, so unfortunately your out of options on that MB.

#2285034 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 25 September 2016 - 02:53 PM

Seeing as how the script can update itself, it maybe idea to move all your user selectable settings to a config file.e.gMODE="S"I use MODE="R" So if I update script at present it is in "S" modeIf you use a config file it will read it and remain as "R" etc... Good job so far, OH I haven't tried it in Ubuntu yet, but will try it in Windows Bash!

#2284702 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 25 September 2016 - 06:22 AM

Hello, you must manually install uuid-dev, subversion and Nasm by typing in Terminal. And relaunch the script.Script SHOULD do this itself, "sudo apt-get install etc"Obviously it doesn't do it, YET!

#2279580 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 17 September 2016 - 10:27 AM

Maybe a useful feature:Debug menu:Debugging/testing GUI/Clover ( UEFI and legacy ) using iso with either qemu or some other VM.

#2277537 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 13 September 2016 - 02:04 AM

Don't know if anyone else is having problems with svnversion: E155036: The working copy at '/Volumes/Development/Clover-Development/Clover/src/edk2/BaseTools'is too old (format 29) to work with client version '1.9.4 (r1740329)' (expects format 31). You need to upgrade the working copy first.===============================================================================Updating Clover <----------------------------------------------------an error was encountered syncing the repository:------------------------------svn: E155036: Please see the 'svn upgrade' commandsvn: E155036: The working copy at '/Volumes/Development/Clover-Development/Clover/src/edk2/Clover'is too old (format 29) to work with client version '1.9.4 (r1740329)' (expects format 31). You need to upgrade the working copy first.------------------------------Can be temporarily, retry later or seek for help.This is after updating El Crappo to Sierra, Xcode7.? to Xcode8.Svn has been updated....

#2276179 Is it possible to directly upgrade to Sierra?

Posted by STLVNUB on 10 September 2016 - 11:03 AM

Made a DVD and installed straight over El Crappo,A few apps not compatible but rest AOK, user settings, home folder etc.

#2268341 Build_Clover.command, another Script to build standard Clover (or customized)

Posted by STLVNUB on 21 August 2016 - 09:04 AM

Probably wouldn't hurt to rebuild BaseTools IF it gets updated as well.Otherwise Great job...

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy