Jump to content

srsx

srsx

Member Since 10 Jan 2013
Offline Last Active Oct 31 2013 04:22 PM
-----

Posts I've Made

In Topic: Sapphire Radeon 6670 recognized as 'AMD Radeon 6xxx 1024MB'

18 February 2013 - 09:20 PM

@alexander -

Rampage's Guide. Something about DIGA and DIGB or similar in the editing section

@Rampage Dev -

I couldn't understand it, for the personality editing part. It was too confusing. Booting with AtiConfig=Lotus, and Ipomoea do not yeild a working framebuffer (Just AMDRadeonFrameBuffer from ioreg)

@Slice

I'm not using Clover. But it looks like you got it to work, although yours has only 3 ports. My ROM output has 4, I believe I need a personality with 4, despite the back of my card having only 3 ports.
Would I need to use Clover to get these settings? Trying yours now.

Where is the sense ID in my rom? :


194X1306.S22:

TURKS XT C33302 GDDR5 64Mx32                                                

Subsystem Vendor ID: 174b
       Subsystem ID: e194
Object Header Structure Size: 246
Connector Object Table Offset: 3e
Router Object Table Offset: 0
Encoder Object Table Offset: b5
Display Path Table Offset: 12
Connector Object Id [19] which is [DISPLAY_PORT]
encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false
Connector Object Id [12] which is [HDMI_TYPE_A]
encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false
Connector Object Id [2] which is [DVI_I]
encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
Connector Object Id [2] which is [DVI_I]
encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false

In Topic: Sapphire Radeon 6670 recognized as 'AMD Radeon 6xxx 1024MB'

18 February 2013 - 01:24 AM

Alright then...

Either this guide is absolute trash or I can't understand it. I don't know where to find the DIG output or anything, I have my rom in plaintext right here. It says nothing about DIG.

In Topic: Sapphire Radeon 6670 recognized as 'AMD Radeon 6xxx 1024MB'

17 February 2013 - 11:49 PM

Could I ge the output for 3 aswell? I'll be able to start modding afterwards.

Thanks for all your help

In Topic: Sapphire Radeon 6670 recognized as 'AMD Radeon 6xxx 1024MB'

17 February 2013 - 11:28 PM


Johns-Mac-Pro:ati-personality.pl.0.10 john$ perl ati-personality.pl ATI6000Controller.kext
Kext /System/Library/Extensions/ATI6000Controller.kext/Contents/MacOS/*Controller
Personality: Pithecia
ConnectorInfo count in decimal: 0
Disk offset in decimal 101682
Personality: Bulrushes
ConnectorInfo count in decimal: 0
Disk offset in decimal 101738
Personality: Cattail
ConnectorInfo count in decimal: 0
Disk offset in decimal 101801
Personality: Hydrilla
ConnectorInfo count in decimal: 0
Disk offset in decimal 101858
Personality: Duckweed
ConnectorInfo count in decimal: 0
Disk offset in decimal 101914
Personality: Fanwort
ConnectorInfo count in decimal: 0
Disk offset in decimal 106185
Personality: Elodea
ConnectorInfo count in decimal: 0
Disk offset in decimal 108770
Personality: Kudzu
ConnectorInfo count in decimal: 0
Disk offset in decimal 109030
Personality: Gibba
ConnectorInfo count in decimal: 0
Disk offset in decimal 109086
Personality: Lotus
ConnectorInfo count in decimal: 0
Disk offset in decimal 112802
Personality: Ipomoea
ConnectorInfo count in decimal: 0
Disk offset in decimal 112858
Personality: Muskgrass
ConnectorInfo count in decimal: 0
Disk offset in decimal 114882
Personality: Juncus
ConnectorInfo count in decimal: 0
Disk offset in decimal 114938
Personality: Osmunda
ConnectorInfo count in decimal: 0
Disk offset in decimal 114994
Personality: Pondweed
ConnectorInfo count in decimal: 0
Disk offset in decimal 115748
Personality: Spikerush
ConnectorInfo count in decimal: 0
Disk offset in decimal 115811
Personality: Typha
ConnectorInfo count in decimal: 0
Disk offset in decimal 115868
Johns-Mac-Pro:ati-personality.pl.0.10 john$

Here is my output. I'll skip to the redsocks BIOS decoder now, and I'll probably use Pithecia or Ipomoea.

And copy what? What do I have to copy from? Yours?

I also think I have 4 ports (back panel has only 3) because of this:

Connector Object Id [19] which is [DISPLAY_PORT]
encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false
Connector Object Id [12] which is [HDMI_TYPE_A]
encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false
Connector Object Id [2] which is [DVI_I]
encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
Connector Object Id [2] which is [DVI_I]
encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false

In Topic: Sapphire Radeon 6670 recognized as 'AMD Radeon 6xxx 1024MB'

17 February 2013 - 10:02 PM

Yeah, I realize that is how it should look. I know how to program perl, nonetheless execute it. Check the end of the rampage guide, someone else has had it. I have no idea here.

Any ideas? :s

EDIT: Dug around, turns out I don't have something called 'otool', let me finish setting up Xcode.
© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy