Jump to content

PokeHerOne

PokeHerOne

Member Since 02 Dec 2012
Offline Last Active Aug 13 2014 01:29 PM
-----

Topics I've Started

Enabling QE/CI on SVE1711X1EB

13 December 2012 - 12:48 PM

Good afternoon, hope you are all well.

My first post here and it is to ask of some assistance, sorry! (Like the pass quiz to post idea, great idea!)

After a long struggle I have installed Mountain Lion 10.8.2 on my Sony Vaio E Series (2012) laptop (SVE1711X1EB), I had to replace my wifi card but I have got most other features working. I will gladly post a guide for others to use when I can get my graphics acceleration to work. Would really appreciate some help with this.

My specs are:
Laptop: Sony Vaio E Series (2012) - SVE1711X1EB
CPU: Intel Core i7 3612QM
RAM: 8GB DDR3 1600Mhz
GFX: Intel HD4000 Integrated Graphics
GFX2: AMD HD Radeon 7650M
SSD: Corsair GTForce 90GB (Primary and has dual boot with Win8)
HDD: WD 750GB 5400RPM
Screen: 1920x1080
WiFi: Atheros AR9287

I Can't get Graphics Acceleration to work :( I have AMD 7650 HD which isn't going to work (at least not yet), but I also have Intel HD4000 which should work. The problem I am having is that when I boot GE=Yes, it attempts to load the ATI card, even with PCIRootUID=0 or 1 it attempts to load the ATI, I thought specifying PCIRootUID was chosing your graphics card slot?

I think either need a way to disable my ATI so that I can run GE=Yes or I need to get my HD4000 to run with GE=No (I think). I have tried all of the HD4000PlatformIDs (0-9,a, b ) and I've tried some EFI string injections, I can't inject a string that I generate myself with gfxutil as I need to get my device ID (right?) which isn't loaded in IOReg. The biggest downer is that I can't set my VRAM in the BIOS.... I do not have a modded bios and I'm pretty locked down. I have requested a bios mod but not much seems to be happening with it. My Video memory is displayed at 7mb :( you can imagine what that's like! Is there another way to set VRAM and/or is there a way to find out what the default setting is for my BIOS? (I have InsydeH20 R0200E6)

Is it possible to modify my VRAM in my DSDT? I'm currently not using a DSDT but I have extracted mine before and I have successfully booted from it. I've tried changing the GFX0 fields to IGPU as aI read somewhere that it could work, I did boot ok with it but sadly, no QE/CI.

Speaking of DSDT, can I disable my AMD card in there? If so, could someone point me in the right direction?

I have hunted around the web now for what seems to me like decades (realistically it's probably about 2 weeks), followed all the main guides (stuffed cow blog, tonymac, macbreaker etc)

So, can anyone see a way around my problem? Or am I stuck without QE/CI until I get a BIOS mod?

Many Thanks
© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy