Jump to content



Member Since 01 Aug 2012
Offline Last Active Jul 13 2015 10:19 AM

Topics I've Started


12 March 2013 - 12:16 PM

Finally I've got my Sony VAIO VPCEB4C5E works good with OS X 10.8 (updated to 10.8.4)!
Only ethernet and card reader not work, but I'm working on it.

By the way I've putted all my work, with some istructions (see the README!.txt) in a dropbox folder.
There's also a txt with all the hardware and related Vid&Pid

If is needed, dump your own DSDT, ACPI and other tables with AIDA64.

I'll update it every time I'll update something on my Hackintosh.

Here's the link: https://www.dropbox....56pq/uQI_SEcd1d (Revision 1.8)

Do NOT use SMBIOSEFI.kext on 10.8.3, it cause kernel panic and OS X will not boot!
<- Kext removed

If you have some trouble or can help me to improve it feel free to reply to this thread. :D

- QE/CI!
- WebCamera
- Bluetooth
- WiFi (by puttin' Vid&Pid in the original Apple kext)
- Audio (With Voodoo HDA) [but sometimes sound crappy <- Seems this doesn't happens anymore]
- Keyboard
- Trackpad (as mouse, for now)
- Volume buttons
- Wireless switch (not fully tested, but for now seems ok)
- Power button
- DVD/BD drive (my machine have a BD Writer manufactured by Pioneer, but not tested if can burn discs yet)
- About this Mac (Thank you artur-pt (10.8.2)! / Thank you apianti for new Clover (10.8.3)!)
- Sleep (seems ok, but hibernation not works, so do not remove the battery or let it fully discharge!)

- iCloud, iMessage, AppStore (see the How to!)
- HDMI! (But, for now, without audio :( )

- VGA port, but by plugging in BEFORE boot OS X (You could have glitches on main LVDS if you change some display parameters or resolution)

Not works:
- Ethernet (by adding Vid&Pid in the original Apple kext OS X recognize it but does not connect)
- Card Reader
- Bright buttons
- DVD Player (crash but VLC or XBMC works good) [Must do other tests]

Known Problems:
- The accelleration seems working a bit bad, FlashPlayer is lagging and the UI sometimes lag... <- Just reinstalled OS X directly from 10.8.3 and seems work good now. Maybe was an issue during various updates, or maybe a my fault while modifying some kexts related to the VGA.
- OS X cannot recognize RAM modules, so "About this Mac" crash. Also "System Information" say there's an error about Memories... Dunno why! ç_ç <- Fixed with latest Clover (r1344), you don't need SMBIOSEFI.kext anymore!


29 December 2012 - 12:00 PM

Hi all, I'm trying to add a patch to the DSDT to make AppleHDA works with my Vaio. I've dumped it with Windows, Linux and DarwinDumper on OS X, but it have many errors (about 166), and can't compile.
If I push "Fix Errors" I can compile it, but when OS X start it crash immediately.
I'm a dumb in DSDT, so I'm asking for someone can help me to fix it so I can add HDEF patch and many more... :(
(This dump was made with Linux)

Many, many Thanks!
© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy