Jump to content

franmglp

franmglp

Member Since 16 Jul 2012
Offline Last Active Today, 05:17 AM
-----

Topics I've Started

(Solucionado) Pendrives no son reconocidos en puertos USB 3.0

19 August 2014 - 11:26 PM

Hola, tengo un problema con los puertos USB 3.0 de mi hackintosh. Resulta que funcionan correctamente exceptuando que no reconocen pendrives ya sean USB 2.0 o USB 3.0...

 

La motherboard es una Gigabyte Z77X-UD3H con dos puertos USB 3.0 con chipset Intel. OS X los reconoce "OOB" sin instalar ningún kext y puedo conectar mi disco externo USB 3.0, mouse USB 1.0, receptor de teclado USB 1.0, etc. Lo que no reconoce son los pendrives, tengo uno 2.0 y uno 3.0. Mi cámara digital por USB 2.0 tampoco la reconoce. Los dos pendrives y la cámara funcionan bien en los puertos USB 2.0 frontales.

 

Que puede ser?

 

Saludos.

(Solucionado) Reinicios aleatorios al arranque en Mavericks e Yosemite

19 August 2014 - 05:02 PM

Hola, les comento sobre un problema que tengo desde que me pasé a Clover a ver si me pueden ayudar. Resulta que muy de vez en cuando mi máquina se reinicia al arrancar, después de que aparece el logo de Apple y antes de que aparezca la rueda de carga en Mavericks o la barra en Yosemite. Creo que es algún problema de power management en Clover. Les dejo mi archivo config.plist y la máquina es la primera de mi firma. En la segunda que es una notebook viejuna con procesador Arrandale funciona perfecto el power management y no se reinicia. El problema es con mi Ivy Bridge en Clover.

 

Saludos.

(Solucionado) No logro C-States y P-States al mismo tiempo

11 July 2014 - 02:42 AM

Hola, tengo un problema con los C-States. No entiendo como hacerlos funcionar. Al parecer se comprueba con este comando en Terminal pero a mí no me devuelve nada.

ioreg -lw0 | grep AICPMVers

Solamente me devuelve información si no uso tablas SSDT para tener speedstep ya sea desde Clover o con un SSDT.aml parcheado.
 
Cuando uso un SSDT.aml o extraigo las tablas SSDT desde Clover siempre tengo el mismo resultado. Me funciona el power management pero no tengo C-States. Tengo estos estados:
 
AICPUPMI: CPU P-States [ 16 17 18 19 20 21 28 34 36 37 38 ]
 
Agrego lo que me devuelve el comando:

    | | |       "AICPMVers" = 19136773

Y una captura de SMC Monitor:

 

Attached File  Captura de pantalla 2014-07-10 a la(s) 23.54.04.png   70.05KB   5 downloads

 

Esto es cuando no uso ninguna tabla SSDT y no tengo power management (solamente 1.60 y 3.40 GHz).

 

Cuando tengo los 11 estados (1.60, 1.70, 1.80, 1.90, 2.00, 2.10, 2.80, 3.40, 3.60, 3.70 y 3.80 GHz) el comando no me devuelve nada y la ventana de SMC Monitor está vacía.

 

De más está decir que no entiendo nada sobre esto. Espero su ayuda.
 
Saludos.

Instalador USB de Yosemite Developer Preview

06 June 2014 - 04:39 AM

TbEjmdw.png

 

A. Crear instalador USB vanilla.
 
A1. Descargar el instalador de OS X Yosemite a través de la App Store (es necesario unirse al Beta Program) o mediante otra fuente.
 
A2. Montar la imagen InstallESD.dmg que se encuentra dentro de Install OS X Yosemite Developer Preview.app/Contents/SharedSupport.
 
A3. Montar la imagen BaseSystem.dmg que se encuentra dentro del volúmen OS X Install ESD:
 
open /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg
 
A4. Restaurar el volúmen OS X Base System en nuestro USB y una vez finalizado expulsar la imagen BaseSystem.dmg, desmontar y montar nuestro USB.
 
A5. Borrar el alias Packages ubicado en el directorio /System/Installation de nuestro instalador USB y pegar aquí la carpeta Packages de OS X Install ESD:
 
rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages
cp -R /Volumes/OS\ X\ Install\ ESD/Packages /Volumes/OS\ X\ Base\ System/System/Installation
 
A6. Copiar los archivos ocultos BaseSystem.dmg y BaseSystem.chunklist del volúmen OS X Install ESD a la raíz de nuestro USB:
 
cp /Volumes/OS\ X\ Install\ ESD/BaseSystem.* /Volumes/OS\ X\ Base\ System
 
A7. Listo nuestro instalador USB vanilla sin modificaciones, podemos expulsar la imagen InstallESD.dmg para comenzar a instalar lo necesario para nuestro hackintosh.
 
B. Instalar herramientas hackintosh.
 
B1. Copiar nuestros kexts necesarios en una carpeta llamada /kexts en la raíz de nuestro USB. Los vamos a necesitar durante la instalación.
 
En mi caso copio FakeSMC.kext que es el único que necesito y dejo el AppleHDA.kext para después de la instalación.
 
B2. Instalar bootloader Clover. Por el momento Chameleon no funciona con Yosemite.
 
https://www.dropbox....k_r2694.pkg.zip
 
B3. Configurar Clover y agregar estos argumentos:
 
-s kext-dev-mode=1
 
C. Instalar OS X Yosemite.
 
C1. Arrancar desde el USB y seleccionar el instalador en Clover comprobando que estamos usando -s kext-dev-mode=1.

 

C2. Una vez que entramos en el modo single-user escribimos las siguientes líneas para cargar el FakeSMC.kext y poder arrancar la instalación:

 

/sbin/fsck -fy

/sbin/mount -uw /

chmod -R 775 /kexts/FakeSMC.kext

chown -R root:wheel /kexts/FakeSMC.kext

cp -R /kexts/FakeSMC.kext /System/Library/Extensions/

kextload -v /System/Library/Extensions/FakeSMC.kext

exit

 

C3. Una vez inicie la instalación realizamos todos los pasos necesarios para instalar Yosemite y reiniciamos.

 

C4. Ingresamos de nuevo al instalador de OS X, vamos a Utilities>Terminal y escribimos:

 

cp -R /Volumes/OS\ X\ Base\ System/kexts/FakeSMC.kext /Volumes/Macintosh\ HD/System/Library/Extensions

sudo touch /Volumes/Macintosh\ HD/System/Library/Extensions

 

Hacemos lo mismo con todos nuestros kexts. Hay que asignar los permisos correctos a cada kext (chmod -R 755 y chwon -R root:wheel).

 

C5. Reiniciamos y arrancamos desde el USB. Elegimos la partición donde instalamos OS X y entramos.

 

C6. Instalar Clover en nuestro disco y configurarlo. Recuerden usar kext-dev-mode=1 y los flags que necesiten.

 

Listo!

Barra de timeout en Chameleon se traba

22 November 2013 - 04:49 AM

Hola, puse "Timeout=5" en o.c.B.p para que arranque automáticamente pero hay un problema con la barra de progreso de Chameleon que no avanza fluidamente y creo que tarda más que 5 segundos en arrancar. Probé con varios themes y en todos pasa lo mismo.

 

Estoy usando Chameleon 2266 y el archivo o.c.B.p lo tengo así:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>DropSSDT</key>
	<string>Yes</string>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>Graphics Mode</key>
	<string>1920x1080x32</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string>
	<key>HDAEnabler</key>
	<string>Yes</string>
	<key>HDEFLayoutID</key>
	<string>0C000000</string>
	<key>IntelCapriFB</key>
	<string>0</string>
	<key>Kernel Flags</key>
	<string>npci=0x2000</string>
	<key>Theme</key>
	<string>Default</string>
	<key>Timeout</key>
	<string>5</string>
	<key>UseKernelCache</key>
	<string>Yes</string>
</dict>
</plist>

¿Qué puede ser?

 

Saludos.

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy