Jump to content

9800 GTX working in OSX86


  • Please log in to reply
522 replies to this topic

#1
aqua-mac

aqua-mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 839 posts
  • Gender:Male
  • Location:England
Got my 9800 GTX 512 Working in OSX 86 Leopard only!

Posted Image

Download these Kexts:

WITH 10.5.3 THERE IS NO NEED TO DOWNLOAD THE KEXTS BELOW!

[url="http://rapidshare.com/files/106584355/aquamac.zip.html"""]http://rapidshare.com/files/106584355/aquamac.zip.html[/url]

and this version of NVInject:

Click Here

You need to swap these kexts into your Extensions folder. You may need to delete the original kexts as opposed to just replacing first on some of them. You must then run this permissions repair script -See Below:

Let it run till finished, it takes a while.

Then Delete the Extensions.mkext and reboot.

You will regain your translucent menubar your drop down menus.

EDIT:
Dashboard now works correctly!

The card is currently using the 8600 GTS open GL Engine but this does not hurt performance. We will probably have to wait for 10.5.3 for that to be fixed.

Posted Image

Attached Files



#2
EGOvoruhk

EGOvoruhk

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 259 posts
How did you get this to work? I'm currently trying to get my 9800 GX2 to work

#3
aqua-mac

aqua-mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 839 posts
  • Gender:Male
  • Location:England
Well I think you might have problems with that as not only does OSX86 struggle with 2 cards but is not keen on SLi or 2 chip cards. I have edited NVInject for your cards details (See Below).This may cause your computer to Kernel Panic at startup as it tries to initialise your card. You would be well advised to instal the kexts in my post above too and repair permissions but you could just try the NVInject on it's own if you want.

Do you have another drive you can boot from if you have to remove NVInject?

Attached Files



#4
bender12

bender12

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts
Think this will work on a regular Mac Pro? I'm thinking of trying a 9800 GTX in mine. Of course, I won't get the gray screen and apple logo on boot, but I can use my 7300 as the 'primary' card.

#5
vbetts

vbetts

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,620 posts
  • Gender:Male
No surprise that it's working. The 9800GTX is based on the G92.

#6
aqua-mac

aqua-mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 839 posts
  • Gender:Male
  • Location:England
Thats true, but there were many glitches including invisible white menu items - all drop down menu items showed as white only/no transparent menu bar etc. 8800 GT does not have this problem. You need the above kexts otherwise the card shows as unknown open gl engine in 10.5.2.

Posted Image

Bender12, I really am not sure if you will get a mac pro to boot with the card in, you could always install the above nvinject and give it a go. However, I think you would want to borrow a card. I would not want to lay out the money and not be sure.

#7
vbetts

vbetts

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,620 posts
  • Gender:Male
I'm not saying they're the exact same thing, so any kext the 8800 g92 uses, the 9800 will work perfectly! Nope, not saying that. Only thing I'm saying, is since it's using the same core, the kext has a base of what it is. Sort of makes the job easier.

#8
Karakino

Karakino

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Perugia, Italy

Got my 9800 GTX 512 Working in OSX 86 Leopard only!

Download these Kexts:

[url="http://rapidshare.com/files/106584355/aquamac.zip.html"""]http://rapidshare.com/files/106584355/aquamac.zip.html[/url]

and this version of NVInject:

Click Here

You need to swap these kexts into your Extensions folder. You may need to delete the original kexts as opposed to just replacing first on some of them. You must then run this permissions repair script -See Below:

Let it run till finished, it takes a while.

Then Delete the Extensions.mkext and reboot.

You will regain your translucent menubar your drop down menus.

EDIT:
Dashboard now works correctly!

The card is currently using the 8600 GTS open GL Engine but this does not hurt performance. We will probably have to wait for 10.5.3 for that to be fixed.

So practically you're saying that the 9800gtx (want to buy the Asus model) is working under Leopard osx86?
Or one should wait some time after 10.5.3 is released to wait for more stable kexts?
Greaaaat news anyway ^__^
I've been waiting for this news to come out to decide to buy my new video card that would be a good
choice for both osx and microsh*t os! :rolleyes:

#9
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
Forcing 8600GT OpenGL Engine ftw ! :rolleyes:

#10
aqua-mac

aqua-mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 839 posts
  • Gender:Male
  • Location:England
Hi Cyclone,

Long time no hear. Yes forcing 8600 GTS, you got it! For some reason the unknown open GL engine seemed to be causing various glitches on this one. I have had this before with certain cards but it usually only amounted to no ripple on Dashboard. On this one there seemed to be more problems. Anyway the card is screaming in OSX. I have not really looked at the GX2 version. Do you think there is any chance with that card. I do not know if it would be seen as an SLi card (two separate cards) or if the bios of the card hides that from the operating system. If it did maybe there would be some chance of it being made to work.

Karakino,

Card is working really nicely and 100% stable. My computer has been up since that post - 2 days now with no problems. Runs well with Quake 4, Doom etc. Download all the kexts in my first post.

#11
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
Yeah using the 8600GTS OGL engine is fine, it's basically the same engine as the G92 and G92 hasn't any new features than G84 OpenGL Engine.

About a GX2 it won't work, it's basically two 8800GT in SLI = no go on OSX.

#12
aqua-mac

aqua-mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 839 posts
  • Gender:Male
  • Location:England
Yeah, thought that was probably the case!

#13
Karakino

Karakino

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Perugia, Italy

Karakino,

Card is working really nicely and 100% stable. My computer has been up since that post - 2 days now with no problems. Runs well with Quake 4, Doom etc. Download all the kexts in my first post.



WHOAAAAA!!!!

SHOPPING TIME ;)

#14
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
aquamac, you really have better fps than 8800GT for sure so it works fine.

Would you be able to try Crossover with 3DMark 03 ? just for fun to see your results :) Just by checking game test 1, 2, 3 please.

#15
Hyper X

Hyper X

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 245 posts
  • Location:Utrecht Netherlands
  • Interests:Furry, Video Games, Sci-Fi, Comedy, Movies, Computers, Macs, Cars, Anime, and RPG's
Now get to work on the 9600GT chop chop ;P

#16
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
You surely didn't read ANY post about 9600 GT : you can't get this to work, it's G94 based and Apple's drivers don't support G94 (yet).

#17
tjesis

tjesis

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Netherlands
Thank you very much Aqua-Mac.
Works almost perfectly for my 9800GTX from Point of View.

I followed your guide and now I have correct resolution etcetera.
Only thing is that quartz-extreme is still unsupported.
Any ideas how to enable this feature?

Below is the output of system-profiler:
NVIDIA GeForce 9800 GTX DDL:

Chipset Model: NVIDIA GeForce 9800 GTX DDL
Type: Display
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0612
Revision ID: 0x00a2
ROM Revision: 0x00981
Displays:
SyncMaster:
Resolution: 1680 x 1050 @ 60 Hz
Depth: 32-bit Color
Core Image: Software
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Not Supported
Display Connector:
Status: No display connected

#18
aqua-mac

aqua-mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 839 posts
  • Gender:Male
  • Location:England
Hi Tjesis,

What motherboard do you have? I have found that the card responds well to using GFX strings. This is instead of NVInject and is what I am now using. I also made an apple.com.boot.plist for a friend and his is working 100 % when he had problems with NVInject. The only thing I really need to know is the position of your graphics card slot. Do you have other PCIe slots above it and if so how many. If you let me know I can upload a copy.

Cyclone,

Still downloading 3D Mark - wow I have not run that for a few years!

#19
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
That's really weird because these tests work on 8600 / 8800 GT :/

#20
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years
Sweet !!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy