Jump to content

Dell Laptops Post-installer - XPS, Inspiron, Vostro, Lattitude


  • Please log in to reply
1016 replies to this topic

#961
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

Just noticed that I have no battery meter at the top.. any suggestions? thanks..

did you try this one? I have my notebook at work at the moment and can't check mine. I thought I got it. will let you know later.

#962
icecold

icecold

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Just noticed that I have no battery meter at the top.. any suggestions? thanks..



here use this package, credit to noob for this, its on his generic install guide.


Ice

Attached Files



#963
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas
sweet thanks...

Edit: I installed it... battery worked... but screen stop working... completely... think it just gave up the ghost... guess I might be buying a real mac soon...

here use this package, credit to noob for this, its on his generic install guide.


Ice



#964
rohizzle121

rohizzle121

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 159 posts
  • Gender:Male
  • Location:The Woodlands , Texas
that battery PKG didnt work for me :(
i have a m1210 and it says "no batteries available"

what should i do?

#965
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany
good news for those of use with gma950. apparently, apple will release 64bit kexts with 10.6.2, according to Netkas

#966
razr1983

razr1983

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Location:the energy efficient state
That's some good news! Dell Inspiron FTW!!!
BTW I am thinking of setting up a small page and uploading all the Dell Inspiron drivers there because many of the link are dead here... What do you think ?

#967
Yuriy Havryliv

Yuriy Havryliv

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Ukraine, Lviv
Hi,

I have successfully installed SL to USB HDD.
Thanks to noob guide and comments from TheGreatDeceiver.

I have several questions

Broadcom 440x is not working, do we have driver for SL or i should use the old one from 10.5 (which stop working from time to time)?

The second question is about sleep. Monitor sleep well. I tried to use Deep Sleep but it doesn't work. I tried hibernatemode 1 and 5(with secure virtual memory).
But now I'm thinking that the problem is because of USB HDD. It goes to sleep before sleep image is actually created. Am I right?

I don't want to replace my 10.5.8 with SL on internal HDD before it'll be 100% working :D

#968
Yuriy Havryliv

Yuriy Havryliv

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Ukraine, Lviv
I think that problem with my broadcon 440x is because of of problems in DSDT as other people have is out of the box.

#969
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

I think that problem with my broadcon 440x is because of of problems in DSDT as other people have is out of the box.

I thought there are still a number of ppl with this problem since sometime after 10.5.4 or so. I never tried mine so I won't be able to tell you. Deep sleep from a USB drive may be the cat biting its own tail :D . Make sure you have USB wake on sleep disabled in the BIOS, otherwise you have a conflict. Which graphics card do you have?

#970
Yuriy Havryliv

Yuriy Havryliv

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Ukraine, Lviv

. Which graphics card do you have?


I have GMA 950.
I know that it doesn't support regular sleep.

To tell the truth I was not able to make my dell to go to deep sleep on 10.5.x
It just turn off the monitor and when I move the mouse it turn it back normally so it's not a real sleep. And it doesn't matter what i put into hibernatemode 0 1 5 or 3. So end up with 0 and erased sleepimage file and got + 2GB of space.

So I'm trying to have a deep sleep on 10.6

#971
aperuz

aperuz

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey everyone, what's up? :censored2:
A few days ago I've installed iAtkos 7 (10.5.7) on my Dell Vostro 1310, after installation no keys or touchpad were working, PS2 kexts helped, also I ran a Dell Laptop Post Installer 1.4.1 to get my wifi in a work state - all good, all was working then, but I cannot get him to wake up after sleep, just blank black screen and no response to any touch.
Does anyone have any idea to solve this?
Thanks in advance

#972
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

well, it's a start:

Type of Submission: 10.6.1 links
Dell Laptop Model: E1505/6400
Fully working? - fully, cpus=2, thanks to voodooTSCSync by cosmo1t
x32 or x64 or both? - only x32 because there are no gma950 64bit kexts
Thanks to noob766 for his guide. Note that you only need to follow instructions for the hidden EFI partition. One requirement is that you have to have OSX (e.g. Leopard) already installed on another partition.

Because gma950 still has wake/sleep problem at login you need to use screen sleeper solution. Use an external monitor to apply sleep/wake display activate in expose and install this script, also disable autologin.
If you have a Core2Duo the system will boot into 64bit by default. You need to add
<key>arch</key>
<string>i386</string>
to your com.apple.boot.plist (preferably on the EFI partition) to force it to 32bit. Otherwise your gma950 kexts will not load and you only get default vga, no qe, ci and only 1024x768.

Extra kexts I am using:
-> voodoohda for sound. Works just like under leopard
-> voodoops2controller, need to load this in Extra of EFI partition to get mouse and keyboard working from the getgo.
-> voodoosdhc allows reading/writing of SDHC cards
-> voodoopower to get speedstep
-> voodooTSCSync enables both cores on C2D
thanks to the voodoo team!

with noob's guide I personally do not think a postinstaller is necessary, especially since there is no distro out there at all at the moment. Noob766 has an Inspiron E1505 himself.
Noob766 made a generic 132boot iso for the E1505/6400 already: Inspiron6400.iso.zip
Note that he uses an older IOGraphics kext and Frambuffer.kext to boot without gma950 problems. You will later need to remove these (they will be located on the EFI partition) and use the stock kexts to avoid artifacts and apply the above screen sleeper patch.
attached is my com.apple.boot.plist which loads gma950 EFI string. Note that without the EFI string the system will KP before login. (if you use it remove cpus=1 unless you need it, with voodooTSCSync not necessary). If you would like to have a look at contents of my EFI partition, it's located here. including a DSDT.aml for my particular hardware config.

good luck


just updated to 10.6.2 without problems.

made backup of kernel and extensions, updated and worked without a problem. no need to patch anything back.
cool. now trying to figure out how to get gma950 64bit to work. just greeted with a black screen when I boot with 64bit. everything working 100% 32bit.

#973
jbclw2009

jbclw2009

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hello, noob here trying to get osx86 working on the following hardware.
Dell Insperon e1705 intel dual core t2500 @2.0 ghz
320 sata drive, nvidia geforce go 7900gs.
i got OSx86 10.5.7 initially loaded successfully however when it boots, it come up with the kernel panic to turn off and restart the computer.
i currently run Windows 7 and i downloaded the dell laptop post installer but im not sure how to deal with the .pkg or to apply the .pkg to the panic install.
only the cd boot allows F8 to specify -s or -v.

#974
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

Hello, noob here trying to get osx86 working on the following hardware.
Dell Insperon e1705 intel dual core t2500 @2.0 ghz
320 sata drive, nvidia geforce go 7900gs.
i got OSx86 10.5.7 initially loaded successfully however when it boots, it come up with the kernel panic to turn off and restart the computer.
i currently run Windows 7 and i downloaded the dell laptop post installer but im not sure how to deal with the .pkg or to apply the .pkg to the panic install.
only the cd boot allows F8 to specify -s or -v.


if you can't get into the os then there is no way of installing the .pkg file. Unless you unpack it with pacifist and copy the kexts over to the non booting osx from another osx or from your win7 via MacDrive v8. If you are lucky you may be able to boot with -x (safe mode). hit F8 when your system boots and at darwin prompt type -x -v.
-v will show you what causes the kernel panic in addition. you can try that by itself before you do -x. Make a note of the kernel panic (or take a picture, if it scrolls by too fast, take a movie). Then come back with specifics if -x did not help.

also need more specifics: which release of 10.5.7 did you install? iPC's? and which kernel, system.kext combination did you choose?

good luck.

ooohh, aahh, 777, I think this will bring luck :P

#975
jbclw2009

jbclw2009

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
iDeneb v1.5.1 with pre-applied PPF patches. i wil try to hit f8 to add -v -x so far i have not had much luck.
Im running the standard kernel that it comes with, there are some custom options to run the amd kernel, but i did not try it since i have intel. when i tried checking some of the stuff beyond the basic install, i would get a screen saying it was not possible to proceed with the install.
i will unrar macdrive 8 now and see what i can do.

if you can't get into the os then there is no way of installing the .pkg file. Unless you unpack it with pacifist and copy the kexts over to the non booting osx from another osx or from your win7 via MacDrive v8. If you are lucky you may be able to boot with -x (safe mode). hit F8 when your system boots and at darwin prompt type -x -v.
-v will show you what causes the kernel panic in addition. you can try that by itself before you do -x. Make a note of the kernel panic (or take a picture, if it scrolls by too fast, take a movie). Then come back with specifics if -x did not help.

also need more specifics: which release of 10.5.7 did you install? iPC's? and which kernel, system.kext combination did you choose?

good luck.

ooohh, aahh, 777, I think this will bring luck :)



#976
nabil choudhary

nabil choudhary

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Is it possible to get dual monitors working with the screen sleeper solution??

#977
Bayu Sasongko

Bayu Sasongko

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Where Can I Find driver BCM 94312MC...??PLease Help Me....

#978
devildogs

devildogs

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:france
Hi thegreatdeceiver!
Could you give me a pack of GMA950 kexts? I try to install SL thanks to a retail DVD, so I make a complete list of kexts I neeed!

thanks!

#979
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

Hi thegreatdeceiver!
Could you give me a pack of GMA950 kexts? I try to install SL thanks to a retail DVD, so I make a complete list of kexts I neeed!

thanks!


I am using stock gma950 kexts. not sure if that's what you really need. they are here. in addition my entire extension folder is here as well. If you need gma950 kexts that let you boot into SL on first boot without using external monitor you can use the ones provided by noob766. link to his files is in my sig. More on this here.

#980
Aleksandrs

Aleksandrs

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
Okay I installed iATKOS v7, booted up and installed the post installer and selected the bits I wanted then restarted. Now if I boot up I get a black screen, or if I boot up in -x I cant use mouse or keyboard.

I think a post installer for SL would be perfect for the 9400, because I am struggling so hard to get it working!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy