Jump to content

Kalyway no arranca sin su DVD


  • Please log in to reply
34 replies to this topic

#1
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Bueno yo estoy arto y DESEPERADO, he probado todos los metods que existen o que se para solucionarlo y no lo consigo...

- Ni el script que activa la particion como booteabe desde el propio leopard.
- Ni haciendo la partición como arrancable desde liveCD o con terminal en el instalador.
- Ni instalando primero sin vanilla.

De ninguna manera, me toca iniciar con el DVD puesto, tengo...

- Gigabyte X38-DQ6 (chipset Intel X38 ICH9)
- Core 2 Duo E8400 (3.0GHz)

Alguien sabe que puedo hacer???
GRACIAS

#2
Schweppes

Schweppes

    Hackintosh fan

  • Members
  • PipPipPipPipPipPipPip
  • 800 posts
  • Gender:Male
Tenes configurado el disco como AHCI desde la BIOS ??? tenes que configurarla asi para que Leopard funcione (segun la HCL ese mother funciona con ToH 10.5 asi que deberia funcionar con Kalyway).

#3
macoff

macoff

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,432 posts
  • Gender:Male
Apolo, puede ser lo que dice Schweppes. Aparte de eso es posible que tengas que chequear tu bios con respecto a la CPU.
C1, Vanderpool y esas cosas...

MacOff

#4
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

Tenes configurado el disco como AHCI desde la BIOS ??? tenes que configurarla asi para que Leopard funcione (segun la HCL ese mother funciona con ToH 10.5 asi que deberia funcionar con Kalyway).

Lo he probado tanto sin AHCI como con el, lo único que me queda por probar es esquema de particiones GUID, que pese a saber que es el mejor metodo, la instalación de Kalyway se me rompe antes de terminar si tengo particionado en GUID, con MRB la instalo bien.
Que es HLC? La Wiki? ToH 10.5 lleva su kernel, o trae Vanilla?

Apolo, puede ser lo que dice Schweppes. Aparte de eso es posible que tengas que chequear tu bios con respecto a la CPU.
C1, Vanderpool y esas cosas...

MacOff

Idem, la desesperación me ha hecho probar todo, y porsupuesto he intentado bootear coon y sin C1, Vanderpool no se donde encontrarlo, per vamos dudo mucho que fuese esto.

Ahora estoy descargando Leo4All a ver que pasa pero estoy desesperadito.
GRACIAS A LOS 2

#5
macoff

macoff

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,432 posts
  • Gender:Male
Bueno si tu lo dices...

MacOff

#6
aabensur

aabensur

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 336 posts
  • Gender:Male
  • Location:LIMA - PERU
una pregunta algo tonta...pero.... estas seguro que has instalado EFI?????? :S

#7
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Si si claro, SIEMPRE lo instalo, en mi caso EFI MRB

#8
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

Bueno si tu lo dices...

MacOff

Porque dices eso, tan relevante puede ser para el arranque los parametros de la CPU? De todas maneras la unica cosa que se me a ocurrido tocar o que he visto que se puede tocar en la BIOS sobre la CPU es el C1, y segun la Wiki mi CPU no da problemas por eso decia que tiene que ser la placa...

Por cierto acabo de probar el Leo4All y como a muchos otros usuarios en el primer reinicio se queda después del mensaje de que el teclado HID no tiene dependencias.

Otra cosa que quería probar es poner en AHCI el disco duro antes de instalar, pero de esta manera el DVD no me arranca, y eso que segun mi placa soporta HDDs y lectores en AHCI, pero enfín... me queda provar a poner 10.5.0 aver si chuta bien, pero vamos en 10.5.1 o inicio con DVD dentro o no se como hacerlo, Alguna idea?

#9
multivac

multivac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Location:España
Yo tengo básicamente la misma placa y la única manera con la que he logrado arrancar es con un disco dedicado únicamente para el mac haciendo dos particiones GuiD una como hfs+ llamada leopard y otra en fat 32 llamada pc. De esta manera instalo Iatkos con el script que activa la partición y sin activar ninguna opción. Tienes que arrancar con el DVD. Después instalas Efi v8 y es cuando ya puedes quitar el DVD para arrancar. Me tiré una semana instalando y formateando para llegar a esta conclusión. Estaré atento por si consigues hacerlo de otra manera.

¿Después de instalar el Efi, sustituyes el Applesmbios.kext que viene con el efiv8? a mi es a partir de este momento cuando me empieza a arrancar sin el dvd

Otra cosa: Tienes que tener desactivado en la placa el "CPU EIST" y activar "No-execute Memory Protect"

un saludo

#10
macoff

macoff

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,432 posts
  • Gender:Male

Porque dices eso, tan relevante puede ser para el arranque los parametros de la CPU? De todas maneras la unica cosa que se me a ocurrido tocar o que he visto que se puede tocar en la BIOS sobre la CPU es el C1, y segun la Wiki mi CPU no da problemas por eso decia que tiene que ser la placa...

Por cierto acabo de probar el Leo4All y como a muchos otros usuarios en el primer reinicio se queda después del mensaje de que el teclado HID no tiene dependencias.

Otra cosa que quería probar es poner en AHCI el disco duro antes de instalar, pero de esta manera el DVD no me arranca, y eso que segun mi placa soporta HDDs y lectores en AHCI, pero enfín... me queda provar a poner 10.5.0 aver si chuta bien, pero vamos en 10.5.1 o inicio con DVD dentro o no se como hacerlo, Alguna idea?


Pues claro que es relevante, si no afinas bien la bios con respecto a la CPU pues pasan estas cosas, reinicios continuos, mala instalción, etc...
Claro que debes de hacer la instalación en AHCI.

Multivac te está dando la solución, hechale un vistazo.

MacOff

#11
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

Yo tengo básicamente la misma placa

Pues sí, al DS5 y la DQ6 son casi identicas, cambian pocas cosas...

la única manera con la que he logrado arrancar es con un disco dedicado únicamente para el mac

Yo tambien uso un HDD dedicado a OSX

haciendo dos particiones GuiD una como hfs+ llamada leopard y otra en fat 32 llamada pc

En Disck Utillities (DVD instalación) puedo formatearlo en esquema de particiones GUID pero si hago esto Kalyway antss de terminar la instalación me da un error desconocido por lo que hasta ahora solo he podido instalarlo con MRB.
Si tienes un HDD dedicado a Mac porque 2 particiones? Y más que nada porque la 2a en FAT32?

Tienes que arrancar con el DVD. Después instalas Efi v8 y es cuando ya puedes quitar el DVD para arrancar. ¿Después de instalar el Efi, sustituyes el Applesmbios.kext que viene con el efiv8? a mi es a partir de este momento cuando me empieza a arrancar sin el dvd

A mi esque iAtkos lo probe poco y como vi que la primera vez tampoco me arrancaba con o sin DVD, pues no he provado mucho esta release.
Lo que me mosquea un poco es que segun la Wiki en 10.5.0 "nuestra" placa va 100% bien.

Claro que debes de hacer la instalación en AHCI.

Y alguna idea de porque si pongo ENABLED ACHI el DVD no me arranca? Porque si el DVD no me arranca poco voy a instalar.

Muchas gracias por segir ayudandome, de verdad a ver si lo consiguiese. GRACIAS

#12
multivac

multivac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Location:España
Con Iatkos a mi solo me arranca como te he puesto. La razón no la se. Inténtalo hacer como yo te digo.
¿No te arranca el DvD en ACHI si usas Iatkos o cualquiera de los dos? Mi dvd es Sata y lo tengo conectado a la otra controladora "la morada" no se si se llama Micrón

#13
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Mi DVD es SATA tambien (pioneer 215BK) y lo tengo conectado a la controladora amarilla de al lado de la morada, porque así tenia HDD de Windos en SATAII0, el de OSx en SATAII1 y el DVD en SATAII3, pero vamos que si eso lo pongo en la controladora morada a ver si chuta, respecto a la release ya te dio que solo he provado en Kalyway probare tambien en iATKOS a ver.

GRACIAS

#14
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Bueno vengo con resultado, no muy esclarecedores l verdad.

Si pongo ACHI en BIOS
El DVD en el SATAII3(Amarillo) = El DVD NO arranca
El DVD en el SATAIIA(Morado) = El DVD Sí arranca
En la instalación ahora el icono del HDD está pintado de naranja, antes tenia el icono normal de HDD de Mac
Con esquema de particiones GUID la instalación termina con un ERROR (ya he leido que no soy el unico)
Con esquema de particiones MRB la instalación termina bien

De ninguna de las maneras consigo bootear sin DVD dentro, ni siquiera poniendole el script activar particion.

Cuando tenga tiempo lo siguiente será=
- Instalar sin EFI (juraria que ya lo probe y no iniciaba)
- Probar GUID con iATKOS

PD. Si dejaba el DVD en la controladora morade Windows hiba a pedales, muy lento y entre crtandose, vuelve a estar ahora mismo en SATAII3

SALUDOS

#15
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

Haber vamos por pasos que no entiendo como no arranca...

Dices que no arranca tu Mac recién Instalado, y sólo con el DVD de Instalación arranca???

ó nunca has podido instalar ni iniciar el Instalador???

Si el Mac va perfecto y he hecho mil cosas con el incluso photoshop i tal, pero para iniciar necesito tener puesto el DVD de instalación, le pasa a mucha gente... pero en nuestro caso es un poco distinto.

-Bueno, la primera que se me ocurre, si Instalaste Kalyway, pero al reiniciar no arranca el Leopard recién instalado:

Primero tienes que ver si tienes Darwin Boot, es decir al iniciar la PC sin DVD (después de cargar la BIOS) presionas la Tecla F8... Si no hay Darwin Boot, pues te tiraría algún mensaje de error como ...waiting for root device... Por lo que hay un problema con el Disco Duro, o la Controladora ICH9, así que lo de la BIOS no es mala opción, hay que desactivar TODOS los servicios de "ahorro de energía", para la controladora activar el modo AHCI o probar los otros (Legacy, etc...), incluso hay desactivar algunas opciones de Puertos Paralelos, si no aparece dicho error de Disco también puede ser la Tarjeta Gráfica...

Pero si no es el caso, y te carga el Darwin Boot, entonces podrías iniciar con Flags el Darwin Boot...

Si ves el Darwin Boot después de presionar F8, claramente vienen las instrucciones... Pero bueno, puedes añadir -v -f esto te dará el posible error que no permite iniciar o iniciarás normalmente... Así que acá lo comentas...

Segundo estás seguro que activaste la Partición o el Disco Duro para iniciar con Leopard???

Es que no entiendo bien tu problema...

A ver todo lo que dices está mas que claro, probado, investigado, y probado de mil maneras, el problema al igual que a multivac es un problema más a o menos "comun" en segun que placas con chipset x38 y mal de solucionar en nuestra placa.
De verdad, las maneras comunes para solucionar este problema en nuestro caso no son las típicas.
Aun así se agradece tu ayuda.

Por cierto multivac 2 post más arriba tienes los resultados al cambiar a la controladora Micron "Morada"+ACHI+Kalyway y no son muy buenos resultados

#16
multivac

multivac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Location:España
Pero has probado a hacer lo que yo te digo. Hasta conseguir instalarlo he pasado por mil combinaciones y aunque no tenga sentido es imprescindible hacer las particiones como yo te digo. Unas hfs+ y la otra fat . Si me dices que así no lo consigues no tengo nada que decir pero a mi me ha funcionado en dos ocasiones. El efi que viene con iatkos pasa de él a mi no me arrancaba cuando lo instalaba. Lo de la controladora "morada" no se si es importante yo lo tengo así. En la bios tienes que hacer esto también, desactivar el "CPU EIST" y activar "No-execute Memory Protect"

Dices que con esquema de particiones GUID la instalación termina con un ERROR. ¿Cuando utilizas iatkos o Kalyway?

Buscando he encontrado tres casos con la misma placa y todos usan Iatkos

suerte, yo también me estaba volviendo majareta con el tema pero al final más o menos lo conseguí.

#17
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

Pero has probado a hacer lo que yo te digo. Hasta conseguir instalarlo he pasado por mil combinaciones y aunque no tenga sentido es imprescindible hacer las particiones como yo te digo. Unas hfs+ y la otra fat . Si me dices que así no lo consigues no tengo nada que decir pero a mi me ha funcionado en dos ocasiones. El efi que viene con iatkos pasa de él a mi no me arrancaba cuando lo instalaba. Lo de la controladora "morada" no se si es importante yo lo tengo así. En la bios tienes que hacer esto también, desactivar el "CPU EIST" y activar "No-execute Memory Protect"

Dices que con esquema de particiones GUID la instalación termina con un ERROR. ¿Cuando utilizas iatkos o Kalyway?

suerte, yo también me estaba volviendo majareta con el tema pero al final más o menos lo conseguí.

No aun no he probado lo de las 2 particiones, cosa que no entiendo pero lo probaré, ahora voy a estar hasta el sabado tarde un poco liado, voy a dejar esatar esto un par de días y el sabado suiegiré con ello.
SALUDOS Y GRACIAS TIO, EL SABADO SEGUIMOS

#18
multivac

multivac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Location:España
Si , te entiendo. Tenemos que currar. Esta cosas para el fin de semana.. :(

#19
Apolo

Apolo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Pues he visto en la Wiki que mi placa X38-Dq6 es 100% funcional en con 10.5.0 y he pensado que igual si instlao primero esto y luego la 10.5.1 no tengo el problema de arrancar sin DVD, quiero hacer todas las pruevas posibles y mientras que descargo esta me voy a poner a probar con iatkos.

Así que que ealease 10.5.0 es la mejor para intel? algun link a torrent que vaya bien rapidito.
GRACIAS A VER SI LO SOLUCIONAMOS.

#20
diegah

diegah

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male
  • Location:Buenos Aires
no arranca es igual a cursor que titila en la esquina A?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy