Jump to content

[Guide] XPS M1710 OS X Leopard

- - - - -

  • Please log in to reply
118 replies to this topic

#81
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
Salut Freak!
i've modded sigmatel 9200 (following Devilhood advice) in order to get mute working. The kext is in my installer. Feel free to extract it then posting here :(

#82
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France
@Fourof4 : Thanks for the info' man, it's working !!! Dual core working !!

Attached File  core2duo_screen.jpg   16.83KB   82 downloads

@Sonotone, Merci mon ami ! I follow your work, but at the moment can't go upper than 10.5.2 because USB freeze finder...

#83
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France
Hi all, today I installed Dell TrueMobile 1490 and it's work perfectly !
No more horrible wifi usb key on my Hackintosh ! :(

#84
Sparta1

Sparta1

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

7. Customization

7.1 Fix CPU to one core
Not necessary if you check "Boot_with_cpus=1_flag"


After the installation, can I enable in the Bios the Multi cpu support ?

#85
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France
Yes you can !

If you become expert, there is a better solution to activate both core !
Look at Fourof4 post.

#86
thomaske

thomaske

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts

@Fourof4 : Thanks for the info' man, it's working !!! Dual core working !!

Attached File  core2duo_screen.jpg   16.83KB   82 downloads

@Sonotone, Merci mon ami ! I follow your work, but at the moment can't go upper than 10.5.2 because USB freeze finder...


Ha glad to hear this man :) This is a huge step closer to full time hackintosh use :P
But does this mean we have to be carefull to update? and wait for new kernel to keep dual core working? or can we update just like we did with vanilla kernel?

#87
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France

But does this mean we have to be carefull to update? and wait for new kernel to keep dual core working?

I tried few days 10.5.2 kalyway and "dual core kernel 9.2.0" : no specific problems.
But I am testing iAktos 10.5.4. Can't confirm stability for this hacked kernel.

Give it a try with OSX86 tool and reverse if your system hang.

#88
youdonotexist

youdonotexist

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 3 posts
Has there been any progress on getting the external speakers to mute when headphones are plugged in?

Thanks,
Mike

#89
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France
Yes, there are hacked kext works, take a look on Sonotone's DELL post installer.
I will update the guide soon.

#90
youdonotexist

youdonotexist

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 3 posts
Thanks fr34k,

I attempted to install the Sigmatel 9200 kext from the Sonotone 1.2 Dell Post Installer onto a Dell XPS 1710, but it ended up removing sound capabilities altogether.

I'll check out your changes to the guide to make sure I did it right.

Thanks for all your hard work!!!

Mike

#91
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France
Hello all,

I'm sorry I can't update guide at the moment, I have lot of personal things to do.
So I upload my kexts and tools here : http://dl.free.fr/pwMMvGARH

They make my 10.5.2 is near perfect (DVD player with blank screen and sometimes shutdown doesn't work)

Hope It will help you.

#92
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States

Hello all,

I'm sorry I can't update guide at the moment, I have lot of personal things to do.
So I upload my kexts and tools here : http://dl.free.fr/pwMMvGARH

They make my 10.5.2 is near perfect (DVD player with blank screen and sometimes shutdown doesn't work)

Hope It will help you.



I also lost all sound capabilities following these steps. My output devices are no longer shown in Audio settings. Ran ALC268 Installer 2 (worked), then deleted ALCInject.kext (deleted my output device), restarted, installed HDAEnabler.kext, fixed permissions and restarted. I am stuck on the step "make sure that Internal Speakers is selected in Audio Settings" because there ARE NO INTERNAL SPEAKERS ANYMORE! :P

Is this all you did to make the Audio work perfectly? ..I was so close before (mute, subwoofer control), now I'm so far ^_^

I'm still having fun getting this m1710 to near perfect hackintosh though! :)

P.S.
Has anyone noticed that http://wiki.taruga.net/ is down?? That really stinks because I now can't figure out how to get the audio back.. {censored}..

#93
youdonotexist

youdonotexist

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 3 posts

I also lost all sound capabilities following these steps. My output devices are no longer shown in Audio settings. Ran ALC268 Installer 2 (worked), then deleted ALCInject.kext (deleted my output device), restarted, installed HDAEnabler.kext, fixed permissions and restarted. I am stuck on the step "make sure that Internal Speakers is selected in Audio Settings" because there ARE NO INTERNAL SPEAKERS ANYMORE! :P

Is this all you did to make the Audio work perfectly? ..I was so close before (mute, subwoofer control), now I'm so far :wacko:

I'm still having fun getting this m1710 to near perfect hackintosh though! :rolleyes:

P.S.
Has anyone noticed that http://wiki.taruga.net/ is down?? That really stinks because I now can't figure out how to get the audio back.. {censored}..


Correct me if I'm wrong, but I believe there may be two different on-board sound chips: the standard board and the HD chipset. Mine uses the Sigmatel chipset, which is a HD chipset with subwoofer. The other might be something different.

Mine did the same thing, too. I believe this is because the first time you follow the tutorial (the one above) it guides you to install the sigmatel9200.txt using the HDA (high def audio) patcher. I can't remember if mine worked with th 9200, but I know that it worked with one of the sigmatel patches (9221, perhaps.)

#94
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States

@Fourof4 : Thanks for the info' man, it's working !!! Dual core working !!

Attached File  core2duo_screen.jpg   16.83KB   82 downloads

@Sonotone, Merci mon ami ! I follow your work, but at the moment can't go upper than 10.5.2 because USB freeze finder...



Did you have to change the "Boot cpus=1 flag", or does the kernel fix this automatically?

#95
herbert123

herbert123

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Thanks to everyone for all this info; I got Kalyway 10.5.2 running well (including dual core) on my m1710.

However, it runs too hot - in Windows I use i8kfangui to set the fans to full blast. A bit noisy, but I can live with that, because my previous 7900gs overheated during a session of FarCry. I also bought a zm-nc2000 notebook cooler to get the temperature down even more. So my new Quadro FX2500M 512mb and cpu are quite cool now. (this temp problem hits most m1710's)

However, the mac runs H.O.T.! I tried smcfancontrol, but that won't run - no values.

Basically, I want all the fans to run at full speed. Any pointers, anyone? I read through through the fan related posts, but perhaps someone knows the solution for the m1710?

Thanks!

#96
herbert123

herbert123

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
So I have found an answer to my own question today by sheer accident, and thought people might be interested in this. My fans work at full speed now (or any speed I want them to)! It's a 'cool' mac now (no pun intended) ;-)

This is what I do to control my fans manually (this procedure presupposes a dual boot system that boots into Mac):

1 - boot into windows first (F8), install i8kfangui21 (http://www.diefer.de/i8kfan/index.html)

2 - run i8kfangui. I set it to run at windows start up.

3 - set the fans to full blast - however, any setting can be made, if you feel that the highest setting is too much.

4 - Next, restart (shutdown, restart in windows)

5 - you will notice that the fans keep running at the setting you selected - right into Mac!

I checked the temperatures using temperature monitor. Idle: hd - 28*c. dual cores: 26*c and 27*c. According to i8kfagui in Windows, the gpu never gets hotter than about 45*c for normal work.

Though this method has the disadvantage of booting into Windows first, I am now completely certain my 'mac' will never overheat (unlike 'true' mac notebooks that tend to get very hot).

Hope this is helpful.

#97
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States
Please help!..

I have royally screwed up my sound. After attempting the headphones fix above I lost all sound, but reinstalled my backup appleHDA.kext which seemed to fix the problem. I then retried the headphones fix - again did not work (ALC268 Installer gets rid of output devices) - only this time, reinstalling the appleHDA.kext isn't helping. I found Taruga's appleHDA Patcher1.20 and went back to Taruga's first site (to get the sigmatel9200.txt). This is the problem - after dragging the .txt into the icon and entering my password I get this error: *Detected unsupported codec
This was not an issue when I installed 10.5.1 and had to do this step.

..I've tried deleting all HDA kexts and attempted to drag sigmatel9200.txt into Taruga's Patcher v1.20 again to no avail.. (same error)

Again, PLEASE PLEASE HELP!


Edit: Come to find out, ALC268 (in the download folder) prevented me from installing sigmatel9200.txt. Deleted it and reinstalled the .txt with Taruga's Patcher. Shwooo.. was nervous..

Anyway, when I plug headphones in it still does not auto-mute internal speakers, but I do hear sound out of headphones. I'm hoping fr3ak! will update his guide soon (although it seems this has become somewhat of a dead post..) :blink:

#98
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France
Guys, my house was burglarized. My M1710 was stolen.
I will not work anymore on this guide.

#99
RickyX

RickyX

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
I did install iPC OSx86 Public and everything working, except my sound (Sigmatel STAC 9200)

Did anyone try to install iPC on XPS m1710?

#100
jjones

jjones

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Here is the tools I used for NVCAP.

Before modification save NVinject.kext (or NVinjectGo.kext)
If you have any problems, boot with -x and install your saved NVinject.kext

1. Boot under DOS and use NVFLASH to dump your graphic card firmware (nvflash -b save.rom)


Could you elaborate on how you did this? I can't seem to make a proper dos usb drive. They all end up being 1.44 mb and have no room for the nvflash tool.


Thanks





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy