Jump to content

[Guide] XPS M1710 OS X Leopard

- - - - -

  • Please log in to reply
118 replies to this topic

#21
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:France
Thanks for reply JonZ ;)

I'm surprise, you use NVinject 2.1 512Mb, maybe i must use it, i keep NVinjectGO 0.2.0b_512Mb, Photo booth crash sometimes can be the cause.

I have some questions for you :

Did you verify temperature and fan, are they OK ?
Did you notify differences between NVinject and NVinjectGO ?
Colors seems to be good, no branding with gradient or movies ?
Did you try external monitor or TV ?

#22
JonZ

JonZ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
I admit, I did not have time to notice all these issues, the only thing I did first is to install Adobe CS3 and Painter :P .

I don't know how to check the temperatures (gpu? cpu?) you speak about.

The only odd thing I noticed is the unconstant wake up issues.

For one, I have no trouble with sleep-wake issues when I specificaly only choose Vanilla Kernel. The issue I have with the wake issue is IF I assign my display to shut down before the computer do.
My display will turn on but my screen will remain black. The workaround I've found is to put the Sleep equal to the display sleep.

I don't see the banding issues the people speak about. I have problem to watch dvds, only black pictures, it appears to be a codec problem,
but some mpeg and .mov videos look to be sharp.


I never been able to install the Go installer for nVidia, for some reason it will makes the OS unbootable (blue-black screen of death).

Unfortunately I have no knowledge at all on how to remove things I installs, so I do an Acronis restore everytime things go bad.


UPDATE: I finally cornered the shutdown problem and I attribute it to the AppleHDAudio patcher 1.20
http://forum.insanel...&...st&p=675194

When I install the patch txt file (9200), the audio work fine, but then I have that shutdown problem.

I tried with 1.18 version (1.19) and it fixed back the shutdown, but the audio was gone (permanently muted).

It appear there is no fix at this moment :P



with nVinject 0.2.0b,
If I activate my secondary display with a VGA cable, the OS freeze. No KP.
If I boot with the VGA plugged, the display switch back to the laptop display, but crash (freeze) if I reactivate the secondary display.

If I activate my secondary display with a DVI cable, the OS also freeze, No KP.
If I boot with the DVI, I get the black screen with cursor, and freeze (crash) if I press the button to activate the second display.


with nVinject 0.2.1
same issues as above.

#23
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States
Well, I've been playing around with things (drivers, .kext, etc..) and have seemed to notice a few more issues that would make this thing run sweet.

First, scrolling - it would be great to have 2-finger, or even 1-finger for that matter. If anyone has a fix already that'd be great, otherwise my searching has turned up nothing so far. Im assuming we all have the Synaptics touchpad..

I was having an issue with the Airport Utility dropping signal often. This was easily fixed by going to Software Update and installing the latest Airport Utility Update.

I still can't seem to get my bluetooth issue fixed. Is that happening with anyone else? I've tried re-installing the bluetooth.bundle, deleting and re-installing old 10.5.1 Kalyway 'bluetooth.kext'. ..nothing.

Also..

Is anyone else having problems with the System Profiler giving the "There was an error while gathering this information."? I've tried multiple versions of AppleSMBIOS.kext with no luck.

Overheating does not seem to be an issue.

'DVD Player' does not work properly. I found that if you 'downgrade' your "Leopard Graphics Update" (assuming you used Software Update to get the latest Leopard Graphics Update) to the previous version. Still has a glitch on menu screens, but DVDs play.

To answer your question XPS_M1710 - I do have the LCD sleep issue. I have not really messed with it yet but I'll follow the advice of trying new kernals.

Glad to see someone got their Toaster to work. Mines running fine, as well as iLife '08 and iWork '08.

>iSOJO

#24
thomaske

thomaske

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts

First, scrolling - it would be great to have 2-finger, or even 1-finger for that matter. If anyone has a fix already that'd be great, otherwise my searching has turned up nothing so far. Im assuming we all have the Synaptics touchpad..

i have 2 (actualy 1 finger scrolling) working on my dell xps m1710 (it's an synaptics touchpad) used this tutorial http://forum.insanel...showtopic=88811

I was having an issue with the Airport Utility dropping signal often. This was easily fixed by going to Software Update and installing the latest Airport Utility Update.

does the wirless work on your machine??

'DVD Player' does not work properly. I found that if you 'downgrade' your "Leopard Graphics Update" (assuming you used Software Update to get the latest Leopard Graphics Update) to the previous version. Still has a glitch on menu screens, but DVDs play.

DVD Player also does not work properly but i use VLC, that works great. but i have a bad gradient on :(

does anyone know, is there a solution for the 57xx driver yet?

#25
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States
~"does the wirless work on your machine??"

First off, thanks for the fix - this is GREAT!

As for my wireless, I'm on the machine typing this right now - connected to a wireless router on my home network. So Yes, out of the box. Yours doesn't seem to be working?

#26
JonZ

JonZ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts

~"does the wirless work on your machine??"

First off, thanks for the fix - this is GREAT!

As for my wireless, I'm on the machine typing this right now - connected to a wireless router on my home network. So Yes, out of the box. Yours doesn't seem to be working?


you must have a different wifi device cuz my Intel Pro is not working at this point. (Jasouvi working on it tho, there's hope).

#27
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States

you must have a different wifi device cuz my Intel Pro is not working at this point. (Jasouvi working on it tho, there's hope).


I am using - Ethernet: Broadcom NetXtreme Gigabit Ethernet PCI-E, 57XX Gigabit Integrated Controller.
*Edit - Wireless: Dell Wireless 1500 Draft 802.11n WLAN Mini-Card

Does your wireless work in Windows?

#28
JonZ

JonZ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
Not at all.That's your ethernet card BTW. The same as mine, which is impossible at this moment to surf on net with wired connection. Or you'd be a miracle :)Which installer did you use? (Kalyway, iATKOS?)you must look under airport device instead , i think. Or if you still have a Windows installation you can check up in the device manager, but it certainly not the ethernet card broadcom 57xx).




BTW I didn't tried this but, for those who have connection problems? what about VMWares? would it be working??



BTW2 I used Kalyway X5.2, I choosed Vanilla Kernel and LateNetkaspatch only, is there any issue with this? thanks.

#29
thomaske

thomaske

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
yeah my wireless isn't working too, like JonZ said, jalavoui is working on it at the moment ;)

just like my wireless, the wired also doesn't work. but if it's working on your machine, witch id is it?

#30
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States
You're right .. :wacko: ..

I fixed it in the post. I started with 2 partitions: a clean partition (prep'd for OSX) and my Windows partition.

In Windows, before installing Kalyway 10.5.1, I installed all IMPORTANT drivers first (i.e. Wireless, Ethernet, Audio, Video, Touchpad - made sure all was working correctly). Then followed Fr3ak's wonderful 10.5.1 guide (no more, no less) on my OSX partition and my bluetooth and wireless functioned properly out-of-the-box. Then, I used the iAtkos/Kalyway 10.5.2 Update, updated kernals and still wireless works fine.

Damn bluetooth...

#31
thomaske

thomaske

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
but what id has your wirless card, cause jalavoui is making a driver for de intel pro 3945, so if thats youre card, it's a miracle that it is working on your machine :D

and what do you mean with, "in windows", before installing kalyway, do you install the drivers within windows? :)

#32
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States
I had no idea most of everyone else w/ the M1710 doesn't have a wireless connection ^_^ . I'm starting to feel very lucky!

and what do you mean with, "in windows", before installing kalyway, do you install the drivers within windows? :P


Yes.

Before you install Kalyway X5.1, install the important drivers in Windows. They should be functioning in your Windows partition before you install OSX. Then install OSX on the assigned partition.

#33
JonZ

JonZ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts

I had no idea most of everyone else w/ the M1710 doesn't have a wireless connection ;) . I'm starting to feel very lucky!



Yes.

Before you install Kalyway X5.1, install the important drivers in Windows. They should be functioning in your Windows partition before you install OSX. Then install OSX on the assigned partition.



You must have a different wifi device. Most of us have Intel Pro 3945, but I reckon some people with the same laptop have Dell Wifi Device which seems to be compatible OOTB. You can check the device id in Utilities (Alt+Shift+U) and run System Profiler and you might check under Network>Airport. Report back what you have under Airport Device, or you can just check out with Windows if you have a dual boot.

#34
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States
I have the Dell Wifi Device.

#35
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:France

thomaske : DVD Player also does not work properly but i use VLC, that works great. but i have a bad gradient on

Same issue with DVD Player, i can hear sound but blank screen

What's you're NVinject version ?
I keep NVinjectGO_0.2.0b_512 and no gradient effect in VLC

#36
thomaske

thomaske

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts

Same issue with DVD Player, i can hear sound but blank screen

What's you're NVinject version ?
I keep NVinjectGO_0.2.0b_512 and no gradient effect in VLC


it's not only in VLC it's on the whole laptop. i do not have gradient at all :)
i got same NVinject version as you.

EDIT: i have attached an image where you can see what i mean.

Attached Files



#37
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:France
I saw this "gradient effect" on all the desktop, but when i install NVinject_0.2.0b just after kalyway installation, it disappear.

Today i play with NVinstaller0.41, then NVinject_0.2.1 with customize NVCAP and this problem came back on internal display.
Impossible to resolve it with 0.2.0b... I investigate, the good thing is VGA work without this horrible 24bits color effect !!

#38
fr3ak!

fr3ak!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:France
Can't find solution for this "color banding" problem ... (try NvidiaEFI, laptopdisplay.kext, GraphicUpdate, NVinstaller, ...)
I need to reinstall os x, my leo is now instable. :(

I want to share the NVinject_0.2.1 customized for DELL Geforce Go 7950 GTX. NVCAP extracted from graphic rom.
Enjoy !

Attached File  NVinject_0.2.1_7950_GTX.zip   11.75KB   71 downloads

#39
thomaske

thomaske

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
thx m8!

but what do you mean with customized? i mean what is different with the other drivers?

#40
JonZ

JonZ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
That probably mean that the external display could work :)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy