Jump to content

AppleHDA ALC268 Shutdown Issues [SOLVED!]


  • Please log in to reply
209 replies to this topic

#81
zebek

zebek

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Rapidshare link not working, was working 2 days ago, but now...anyone have the files.........not in .001 etc

#82
nofearl

nofearl

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
http://filebeam.com/...127a96da31b654c

#83
MadTux

MadTux

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male

I have a dv9543cl (see sig) with a realtek ALC268 sound card...
soo... i used Taruga's ALC268 Installer2 to install, but doing this breaks my shutdown even though it fixes sound
does anybody know of any solutions (ive searched for days but couldn't find any...)

thanks :blink:
-hplaptopmac

EDIT: THERE IS NOW A WORKING FIX:

The Definitve Guide to Fixing the Realtek ALC268 Soundcard (With Working Shutdown!!!!) In Leopard

1.Run ALC268Installer 2 or 1. (Depending on which works for you.)
2.Before Restarting delete /System/Library/Extensions/ALCInject.kext
3.Use Kext Helper b7 to install HDAEnabler.kext
4.Fix Permissions with Disk Utility
5.Restart and make sure that Internal Speakers is selected in Audio Settings
6. Then run HDA Fix v3 (Riavvia in seguito means Restart later, Riavvia means Restart now)
7. Click Restart Later
8.Repair permissions with Disk Utility
9.Restart
10.Bootup and sound and shutdown should work
http://rapidshare.co...8/ALC268FIX.zip


No need for this, try:
http://forum.insanel...mp;#entry918477

It is new HDA for ALC268 it has pins from like in installer 2 coz I dont't have installler 1, but U can post there installer 1 and I can make and that one.
Try and post if it works

#84
M@dMac

M@dMac

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Mérida, Venezuela
http://www.megauploa.../de/?d=S3HMABJL

that's for ALC268_Installer1.zip.

Will try MadTux's way this afternoon.

MadTux: plz take a look at this codec & advise if necesary.

Attached Files



#85
collit99

collit99

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
Hi,

I'm currently testing an AppleHDA.kext for ALC268 with Headphone,Internal Mic/Speaker working. The big deal is I can shutdown with this kext without the use of any fix.

What I tried...

HDEnabler+AppleHDA+Natit=shutdown works
HDEnabler+AppleHDA=shutdown works

Will do more testing, keep you posted.

#86
bozon42

bozon42

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts
Hello collit99,

can you put the files online so others (me as well :-)) can test it?

Thanks and regards,

bozon42

#87
Wiwi

Wiwi

    InsanelyMac Guy

  • Members
  • PipPipPipPip
  • 212 posts
  • Gender:Male
Ok men, i really need your help, because i haven't vista anymore, just XP, and because we've got similar HDA cards and we need a key from Vista registry Explorer about PinConfig of ACL660/ACL660vd cards to make these working complete (=SHUTDOWN)

So please, can you search in your registry the key "PinConfigOverrideVerb" and dump results here ????????

Thanks...

This will look like that : (ACL268 dump)

Windows Registry Editor Version 5.00
 
 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}000\PinConfigOverrideVerbs]
"0000"=hex:f0,1c,27,01
"0001"=hex:11,1d,27,01
"0002"=hex:11,1e,27,01
"0003"=hex:41,1f,27,01
"0004"=hex:f0,1c,37,01
"0005"=hex:11,1d,37,01
"0006"=hex:11,1e,37,01
"0007"=hex:41,1f,37,01
"0008"=hex:1f,1c,47,01
"0009"=hex:10,1d,47,01
"0010"=hex:21,1e,47,01
"0011"=hex:02,1f,47,01
"0012"=hex:10,1c,57,01
"0013"=hex:01,1d,57,01
"0014"=hex:13,1e,57,01
"0015"=hex:99,1f,57,01
"0016"=hex:f0,1c,67,01
"0017"=hex:11,1d,67,01
"0018"=hex:11,1e,67,01
"0019"=hex:41,1f,67,01
"0020"=hex:40,1c,87,01
"0021"=hex:98,1d,87,01
"0022"=hex:a1,1e,87,01
"0023"=hex:02,1f,87,01
"0024"=hex:41,1c,97,01
"0025"=hex:09,1d,97,01
"0026"=hex:a3,1e,97,01
"0027"=hex:99,1f,97,01
"0028"=hex:4e,1c,a7,01
"0029"=hex:30,1d,a7,01
"0030"=hex:81,1e,a7,01
"0031"=hex:02,1f,a7,01
"0032"=hex:f0,1c,c7,01
"0033"=hex:11,1d,c7,01
"0034"=hex:11,1e,c7,01
"0035"=hex:41,1f,c7,01
"0036"=hex:2d,1c,d7,01
"0037"=hex:95,1d,d7,01
"0038"=hex:17,1e,d7,01
"0039"=hex:40,1f,d7,01
"0040"=hex:30,1c,e7,01
"0041"=hex:11,1d,e7,01
"0042"=hex:45,1e,e7,01
"0043"=hex:02,1f,e7,01
"NumVerbs"=hex:2c,00,00,00

That key have to be injected in AppleHDAController's plist file, most of us have a ACL268 or ACL880 PinConfig, that make the OS can't shutdown properly the card...

#88
MadTux

MadTux

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male

http://www.megauploa.../de/?d=S3HMABJL

that's for ALC268_Installer1.zip.

Will try MadTux's way this afternoon.

MadTux: plz take a look at this codec & advise if necesary.


http://forum.insanel...howtopic=129485

#89
collit99

collit99

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

Hello collit99,

can you put the files online so others (me as well :-)) can test it?

Thanks and regards,

bozon42


Sure, this one works on may acer aspire 4310.

Just check the permission.

Attached File  alc268.zip   600.08KB   179 downloads

#90
bozon42

bozon42

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts
Hello collit99,

thanks for th zip file. Hope to have time to test it tonight on Acer5220.
I presume to remove all old files from my system (and to backup them before, of course)
that are similar to those in yuor zip.
I will try to use the KextHelper_b7.
Regards,

bozon42

#91
bozon42

bozon42

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts

Hello collit99,

thanks for th zip file. Hope to have time to test it tonight on Acer5220.
I presume to remove all old files from my system (and to backup them before, of course)
that are similar to those in yuor zip.
I will try to use the KextHelper_b7.
Regards,

bozon42


Hello collit99,
I have realized that I used Run ALC268Installer 1 from ALC268FIX.zip (see post 83 above)
and my shutdown is ok. The only problem is with Headphone. (and probably the mic - can you give me a hint how to try it?)
Is it possible to remove theALC268Installer 1 and try with ALC268Installer 2?
Or with your alc268.zip?

Regards,

bozon42

#92
collit99

collit99

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

Hello collit99,
I have realized that I used Run ALC268Installer 1 from ALC268FIX.zip (see post 83 above)
and my shutdown is ok. The only problem is with Headphone. (and probably the mic - can you give me a hint how to try it?)
Is it possible to remove theALC268Installer 1 and try with ALC268Installer 2?
Or with your alc268.zip?

Regards,

bozon42


Just back-up /System/Library/Extensions/AppleHDA.kext

then use kexthelper to install the AppleHDA inside the alc268.zip. repair permission using disk utility and reboot.

By the way you also need to remove the HDAloader inside the startupitems and also the taruga folder inside /S/L/E.

If this work, you can try the other kext with autosensing. That one is really cool.

Good Luck.

#93
bozon42

bozon42

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts

Just back-up /System/Library/Extensions/AppleHDA.kext

then use kexthelper to install the AppleHDA inside the alc268.zip. repair permission using disk utility and reboot.

By the way you also need to remove the HDAloader inside the startupitems and also the taruga folder inside /S/L/E.

If this work, you can try the other kext with autosensing. That one is really cool.

Good Luck.


Hello collit99,

thanks for the explanation and for the procedure.
I have thought KextHelper_b7 does everything so repairing with DU is not needed.
What is autosensing BTW?
Regards,

bozon42

#94
collit99

collit99

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

Hello collit99,

thanks for the explanation and for the procedure.
I have thought KextHelper_b7 does everything so repairing with DU is not needed.
What is autosensing BTW?
Regards,

bozon42


Yup kexthelper can do that, but just to make sure try running DU.

Auto sensing
When you plug a headphone or external speakers it would automatically switch to "headphones" when you unplug it, it will switch back to "Internal speakers".

#95
bozon42

bozon42

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts

Yup kexthelper can do that, but just to make sure try running DU.

Auto sensing
When you plug a headphone or external speakers it would automatically switch to "headphones" when you unplug it, it will switch back to "Internal speakers".


Yeap - more clear, thanks.

Regards,

bozon42

#96
moderndrummer

moderndrummer

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Thessaloniki, GREECE
People I did pretty much everything I got in this thread..

EDIT: THERE IS NOW A WORKING FIX:

The Definitve Guide to Fixing the Realtek ALC268 Soundcard (With Working Shutdown!!!!) In Leopard

1.Run ALC268Installer 2 or 1. (Depending on which works for you.)
2.Before Restarting delete /System/Library/Extensions/ALCInject.kext
3.Use Kext Helper b7 to install HDAEnabler.kext
4.Fix Permissions with Disk Utility
5.Restart and make sure that Internal Speakers is selected in Audio Settings
6. Then run HDA Fix v3 (Riavvia in seguito means Restart later, Riavvia means Restart now)
7. Click Restart Later
8.Repair permissions with Disk Utility
9.Restart
10.Bootup and sound and shutdown should work


The thing is that Shutdown is working.. but it is giving me a reboot instead.. I have to manually shut down by holding the power button after the pc is rebooted. I'm using a Toshiba u300-154..

Anyone stumbled upon the same issue??
Btw, awesome forum, great work guys..All of you. Keep it up!

#97
yoplaid

yoplaid

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hi, I also after installing hdafix v.3 when I trie to shutdonw, the computer reboots instead. What shoud I do??
thanks

Hi, I also after installing hdafix v.3 when I trie to shutdonw, the computer reboots instead. What shoud I do??
thanks

#98
bozon42

bozon42

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts

Just back-up /System/Library/Extensions/AppleHDA.kext

then use kexthelper to install the AppleHDA inside the alc268.zip. repair permission using disk utility and reboot.

By the way you also need to remove the HDAloader inside the startupitems and also the taruga folder inside /S/L/E.

If this work, you can try the other kext with autosensing. That one is really cool.

Good Luck.


Hello collit99,

followed your lines:

OK 1./System/Library/Extensions/AppleHDA.kextbackupedandremoved
OK 2./System/Library/Extensions/AppleHDA.tarugabackupedandremoved
NOK 3.remove HDAloader inside the startupitems---> not found - it was empty!!
OK 4.your AppleHDA.kext from alc268.zipinstalledwithKextHelper_b7+repairpermissionswithDU
OK 5.1.Run ALC268Installer 2
OK 5.2.Before Restarting delete /System/Library/Extensions/ALCinject.kext
OK .Use Kext Helper b7 to install HDAEnabler.kext
OK4.With DiskUtility Fix permissions
OK 5.5.Restart and make sure that Internal Speakers is selected in Audio Settings
OK 5.6. Then run HDA Fix v3 (Riavvia in seguito means Restart later, Riavvia means Restart now)
OK 5.7. Click Restart Later
OK 5.8.Repair permissions with Disk Utility
OK 5.9.Restart
OK 5.10.Bootup and sound and shutdown should work.

Result: Wouw!!
1.Sound from Internal Speaker...OK (as before)
2.Sound from Headphone...OK!!!Cool(it was not working before)
Note:
I was too tired yesterday so did not look for autosensing button. Is there any? I had to change in Audio Setting
from Internal Speaker to Headphone in System Preferences to have it OK.

3. Mic ---In fact I do not know how to test it. Any hints?
4.Shutdown tried twice ...OK.

Thanks for the help!!!

bozon42

#99
collit99

collit99

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

Hello collit99,

followed your lines:

OK 1./System/Library/Extensions/AppleHDA.kextbackupedandremoved
OK 2./System/Library/Extensions/AppleHDA.tarugabackupedandremoved
NOK 3.remove HDAloader inside the startupitems---> not found - it was empty!!
OK 4.your AppleHDA.kext from alc268.zipinstalledwithKextHelper_b7+repairpermissionswithDU
OK 5.1.Run ALC268Installer 2
OK 5.2.Before Restarting delete /System/Library/Extensions/ALCinject.kext
OK .Use Kext Helper b7 to install HDAEnabler.kext
OK4.With DiskUtility Fix permissions
OK 5.5.Restart and make sure that Internal Speakers is selected in Audio Settings
OK 5.6. Then run HDA Fix v3 (Riavvia in seguito means Restart later, Riavvia means Restart now)
OK 5.7. Click Restart Later
OK 5.8.Repair permissions with Disk Utility
OK 5.9.Restart
OK 5.10.Bootup and sound and shutdown should work.

Result: Wouw!!
1.Sound from Internal Speaker...OK (as before)
2.Sound from Headphone...OK!!!Cool(it was not working before)
Note:
I was too tired yesterday so did not look for autosensing button. Is there any? I had to change in Audio Setting
from Internal Speaker to Headphone in System Preferences to have it OK.

3. Mic ---In fact I do not know how to test it. Any hints?
4.Shutdown tried twice ...OK.

Thanks for the help!!!

bozon42


Good! but you don't have to install the HDA fix and the ALCinstaller2...

Just back-up the old Applehda.kext, delete taruga folder delete hdaloader at /Library/StartupItems then install my AppleHDA.kext from the zip using kexthelper repair permission using DU, reboot test audio test shutdown.

Because this kext doesn't need that HDA fix v3 the shutdown is fix on this kext.

The kext with autosensing is in my sig you cant test it.

Sorry if I did not explain to you clearly. English is not my first language.

#100
bozon42

bozon42

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts
Hello collit99,

1.I simply re-moved
/System/Library/Extensions/AppleHDA.kext
/System/Library/Extensions/AppleHDA.taruga to
/Users/me/old_AppleHDA.kext
/Users/me/old_AppleHDA.taruga
2. there was no HDAloader in /System/Library/StartupItems dir.
3. Added your AppleHDA.kext with Kexthelper and repaired paermissions in DU + did reboot.

But no sound appeared in System Preferences.

I try to add ALC268Installer2 only (without the fix v3 for HDA) and report you.

Result: as before: Internal Sound OK, Headphone OK but only when I change in System Preferences - no autosensing.
Probably I am missing something (or there is something extra :-))).

Regards,

bozon42





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy