Jump to content

Solving USB problems; USB devices do not mount


  • Please log in to reply
407 replies to this topic

#401
wwfff

wwfff

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
mark,thanks

#402
chloe warrington

chloe warrington

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hello all,

I used the installer, now I cannot get my mac to start unless it is in boot mode. How can I uninstall it again? Which files from S/L/E do i need to remove?

Please help xxx

#403
wwfff

wwfff

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hello all,
Why my IDeneb 1.5.8 usb mouse cannot work ,however usb disk can work?
it is the info
Root <class IORegistryEntry>
1: UHCI Root Hub Simulation@1D <class IOUSBRootHubDevice>
1: EHCI Root Hub Simulation@1D,7 <class IOUSBRootHubDevice>
2: iPod@fd300000 <class IOUSBDevice>
1: UHCI Root Hub Simulation@1D,2 <class IOUSBRootHubDevice>
1: UHCI Root Hub Simulation@1D,1 <class IOUSBRootHubDevice>
2: IOUSBCompositeDevice@3d200000 <class IOUSBDevice>

i surffer this long time.
thanks!



#404
d-track

d-track

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
hi,

not all of my usb ports worked till i installed IOPCIFamily.kext
now all of them working but SOMETIMES my usb pen drive or my nokia phone in data storage mode (basically a usb drive) not working.
sometimes i just have to re-plug but sometims re-boot needed.

vanilla 10.6.4
asus p5gc-mx1333 motherboard and i use a dsdt for that.
the same problem anyone?

#405
InsanelyOsx86

InsanelyOsx86

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Well, hello to everyone...it's been tough to read all these posts, No solution worked for me though.

iPhone is recognized under USB tab in System Profiler but nothing happens, it's not recognized in itunes or it doesn't even charges up.

So can anyone please provide me any solution?

Snow Leopard 10.6.7 software succesfully updated to 10.6.8
No problem in system.kext
Everything works fine except iPhone.
Other USB ports and devices work perfect.

What may be wrong?

#406
lincolnsixecho

lincolnsixecho

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Oh gosh USB is working now! Thank you man ;)

#407
stidrvr

stidrvr

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
Just wanted to throw in my Thank You as well... so... ah... Thanks!!!

#408
rdf1

rdf1

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:McCrae, Australia

As a final contribution to this topic, I'd like to add a word of warning to people who have not been able to get the USB ports of their Hackintoshes to work properly, and to recognise external USB devices when they are plugged in. So far I've successfully installed OS 10.6.8 on an HP Compaq Presario, a Dell Inspiron 6400, and an HP dx2300. My latest challenge was to do so on a Toshiba Satellite A200 laptop, owned by a friend who wanted to experience the Mac environment, but who was a little short on cash to buy a genuine MacBook. Since I've had the best results from the iATKOS distribution, I installed 10.6.3 on the Toshiba, and it worked pretty well from the get-go. However, none of its 4 USB ports recognised external devices like memory sticks or hard drives, and this was put down to the IOUSBMassStorageClass.kext not being loaded during boot, even though it was installed in /S/L/E. Wire and wireless mice worked fine, however, through any USB port. I spent hours trying to resolve the issue, including reading all the pages in this thread for possible clues, but to no avail. In desperation, I reinstalled Windows XP to check if the problem was there too. Sure enough, external USB devices were not recognised by XP either. The ports were not working because there was a mobo fault, impossible to repair. The owner has since revealed that she knew the ports weren't working, but thought that installing Mac OSX might fix them!! So, to state the obvious, if you're contemplating a Hackintosh, make sure the machine functions as intended as a PC beforehand. You'll certainly avoid the grief I've suffered!!

 

In conclusion, my friend has a nice laptop which now operates under 10.6.8, and has purchased some genuine Apple software to run on it. Only problem is she's forever prevented from using its USB interface.







2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy