Jump to content

[HOW TO] ATI Radeon HD 2400 / 2600 / 2900 / 3850 / 3870 on Leopard


  • Please log in to reply
559 replies to this topic

#101
ufo_all

ufo_all

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
till today there is no solution for ATI HD 2400 :hysterical:

#102
Threepwood

Threepwood

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 224 posts
Why don't people state what brand their card is? Saying that "the Radeon 2600 PRO works if you do this!" is a bit fuzzy, since there are 20 different cards out there with that chip. This makes it really hard for those looking for a new gfx card. Please, don't forget the brand when you're posting here or on the HCL.

#103
drumthrasher109

drumthrasher109

    InsanelyMac Legend

  • Guests
  • PipPipPipPipPipPipPip
  • 528 posts

Why don't people state what brand their card is? Saying that "the Radeon 2600 PRO works if you do this!" is a bit fuzzy, since there are 20 different cards out there with that chip. This makes it really hard for those looking for a new gfx card. Please, don't forget the brand when you're posting here or on the HCL.


Also post your device ID too. Just because you have a 2600PRO doesn't mean that it has the same device ID as others either.

#104
Wingleader

Wingleader

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
As stated by me i've got an Sapphire 2600 Pro 512MB pciid 0x95891002. (174B-E410 extra info from everest)
And everything is working correctly now for me even QE/CI dvd's play, frontrow is working. I'm a happy camper..

@drumtrasher did you use the whitemenufix for 10.5.1 (from the front page)? and did you have a working desktop before applying adding the pciid and menufix?
It worked for me at 640 or 800 can't remember with the standard install and after only installing the Natit.kext.tar.bz2 => natit.kext from 16/1/2008 with a contents of 16/2/08. (got this one from natit site)

#105
ufo_all

ufo_all

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
hey Threepwood.

I have ATI Radeon HD 2400 Pro with 256 mb and id is 0x94c31002 .. osx is kalyway 10.5.2..hope this is clear for you

#106
drumthrasher109

drumthrasher109

    InsanelyMac Legend

  • Guests
  • PipPipPipPipPipPipPip
  • 528 posts

As stated by me i've got an Sapphire 2600 Pro 512MB pciid 0x95891002. (174B-E410 extra info from everest)
And everything is working correctly now for me even QE/CI dvd's play, frontrow is working. I'm a happy camper..

@drumtrasher did you use the whitemenufix for 10.5.1 (from the front page)? and did you have a working desktop before applying adding the pciid and menufix?
It worked for me at 640 or 800 can't remember with the standard install and after only installing the Natit.kext.tar.bz2 => natit.kext from 16/1/2008 with a contents of 16/2/08. (got this one from natit site)


I downloaded the 10.5.2 white menu fix because thats what I have...
Yes I had a working desktop before doing all of this...or I wouldn't have been able to do any of it in the first place.

#107
Threepwood

Threepwood

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 224 posts

hey Threepwood.I have ATI Radeon HD 2400 Pro with 256 mb and id is 0x94c31002 .. osx is kalyway 10.5.2..hope this is clear for you

Ok, what manufacturer is it? Does it work correctly with dual monitors? I need a fanless card with DVI-I connectors.There's a fanless 2600 PRO from both HIS and PowerColor, I don't know which one I should get. Anyone with experience?

#108
zaishu

zaishu

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
My card is Sapphire HD2400XT PCI-E 256MB DDR3,id 0x94c11002,not working and flower death,please help.

#109
xavinoiz

xavinoiz

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

till today there is no solution for ATI HD 2400 :wallbash:

Hi ufo_all, check out my thread i got my HD2400PRO 0x94c3 working on Kalyway 10.5.2. Heres the link: DIAMOND ATI HD2400PRO PCI-E 0x94c3 (Problems)
Hope i can help
Xavier

#110
erikk

erikk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 199 posts
thx for sharing that infos...

it might be that my sapphire hd2600xt works now... but i have still a bug... hope somebody can help me.

i never tried a game before and i was wondering why graphic intensive programms (like logic8 with graphic analyzer) crashs sometimes.
so yesterday i installed this drivers here and tried to play a 3d game... i found out that i have still graphic card problems.

my problem is: that opengl seems working, but i get graphic bugs, it looks like when i overclock a graphic card in windows.
it dont crash at me, but the game enviroment looks crazy, polygon errors, etc...

so i switched back to my old natit.kext (where only dvi2vga works) and i have the same problem... so i dont think that natit is fault...

my question: is it an opengl problem? or might it be an atindrv problem?

many thx...

#111
drumthrasher109

drumthrasher109

    InsanelyMac Legend

  • Guests
  • PipPipPipPipPipPipPip
  • 528 posts

I am using leo4all v2 vanilla 9.2.


I am using an Radeon HD 2600


Type: Display
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
Vendor: ATI (0x1002)
Device ID: 0x9581
Revision ID: 0x0000
Kernel Extension Info: No Kext Loaded
Displays:
Display:
Resolution: 1024 x 768
Depth: 32-bit Color
Core Image: Software
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Not Supported

In Extensions

EAP-RSA.ppp
EAP-KRB.ppp
DVFamily.bundle
dsmos.kext
DSAuth.ppp
DSACL.ppp
Dont Steal Mac OS X.kext
CRYPTOCardPCCard.kext
CMD646Root.kext
CM4040.kext
cddafs.kext
Caches
BootCache.kext
IOFireWireSerialBusProtocolTransport.kext
IOFireWireSBP2.kext
IOFireWireIP.kext
IOFireWireFamily.kext
IOFireWireAVC.kext
IODVDStorageFamily.kext
IOCDStorageFamily.kext
IOBluetoothHIDDriver.kext
IOBluetoothFamily.kext
IOBDStorageFamily.kext
IOAudioFamily.kext
IOATAFamily.kext
IOAHCIFamily.kext
IOADBFamily.kext
IOACPIFamily.kext
IO80211Family.kext
ImmersionForceFeedback.kext
ICAFWKodakProDriver.kext
ICAClassicNotSeizeDriver.kext
I2CGPIO.kext
GeForceVADriver.bundle
GeForceGA.plugin
GeForceFXGLDriver.bundle
GeForce8xxxGLDriver.bundle
GeForce7xxxGLDriver.bundle
GeForce3GLDriver.bundle
GeForce2MXGLDriver.bundle
EAP-TLS.ppp
IOI2CLM8x.kext
IOI2CLM7x.kext
IOI2CLM6x.kext
IOI2CHWClock.kext
IOI2CFamily.kext
IOSCSIParallelFamily.kext
IOSCSIArchitectureModelFamily.kext
IOI2CDriveBayGPIO.kext
IOI2CDeviceLMU.kext
IOI2CDeviceFCU.kext
IOI2CCPUVoltage.kext
IOI2CControllerSMU.kext
IOI2CControllerPPC.kext
IOI2CControllerPMU.kext
IOI2CADT746x.kext
IOI2CAD741x.kext
IPFirewall.kext
IOVideoFamily.kext
IOUSBMassStorageClass.kext
IOUSBFamily.kext
IOStreamFamily.kext
ATIRadeonX2000VADriver.bundle
ATIRadeonX2000GLDriver.bundle
ATIRadeonX2000GA.plugin
ATIRadeonX1000VADriver.bundle
ATIRadeonX1000GLDriver.bundle
ATIRadeonX1000GA.plugin
ATIRadeonGLDriver.bundle
IOI2CMotionSensor.kext
IOI2CMaxim6690.kext
IOI2CMaxim1989.kext
IOI2CMaxim1631.kext
ATINDRV.kext
IOPlatformPluginFamily.kext
IOPlatformFunction.kext
IOPCIFamily.kext
IOPCCardFamily.kext
IONetworkingFamily.kext
IONDRVSupport.kext
IOKeyLargo.kext
IOI2CSMUSat.kext
IOI2CSlewClock.kext
IOI2CPulsar.kext
autofs.kext
AudioIPCDriver.kext
AudioDeviceTreeUpdater.kext
ATTOExpressPCIPlus.kext
ATIRadeonGA.plugin
ATIRadeonDVDDriver.bundle
ATIRadeon9700VADriver.bundle
ATIRadeon9700GLDriver.bundle
ATIRadeon9700GA.plugin
ATIRadeon9700DVDDriver.bundle
ATIRadeon8500VADriver.bundle
ATIRadeon8500GLDriver.bundle
ATIRadeon8500GA.plugin
ATIRadeon8500DVDDriver.bundle
IOHIDFamily.kext
IOHDIXController.kext
IOGraphicsFamily.kext
IOStorageFamily.kext
IOSMBusFamily.kext
IOSerialFamily.kext

ATIRadeonX2000.kext doesn't appear....????



I don't know how to add my ID card.Please! Can you help me


Install the Leopard Graphics Update then look for it.

#112
tvt

tvt

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Install the Leopard Graphics Update then look for it.

thank!
but after update,reboot ,i have reinstall OS!!!!!

#113
drumthrasher109

drumthrasher109

    InsanelyMac Legend

  • Guests
  • PipPipPipPipPipPipPip
  • 528 posts

thank!
but after update,reboot ,i have reinstall OS!!!!!



No you don't, you get a kernel panic.

Boot with -s, cd to /system/library/extensions and rm -r NVDAresman.kext. I'll post more help if you need it.

#114
tvt

tvt

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

No you don't, you get a kernel panic.

Boot with -s, cd to /system/library/extensions and rm -r NVDAresman.kext. I'll post more help if you need it.


if you have the time.Now,i post an image of screen after update
it's possible can you tells me what does that mean,kernel panic?Thank again!

Attached Files



#115
ufo_all

ufo_all

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts

Ok, what manufacturer is it? Does it work correctly with dual monitors? I need a fanless card with DVI-I connectors.There's a fanless 2600 PRO from both HIS and PowerColor, I don't know which one I should get. Anyone with experience?


Here i attach pics of my ati graphic card and the graphics model

HD2400 PRo Sonic -PCI-E 256MB DDR2 TV-OUT DVI as it is mention on the label.

Attached Files



#116
drumthrasher109

drumthrasher109

    InsanelyMac Legend

  • Guests
  • PipPipPipPipPipPipPip
  • 528 posts

if you have the time.Now,i post an image of screen after update
it's possible can you tells me what does that mean,kernel panic?Thank again!


Oh thats easy, do the following:
1. When you're at the Darwin/x86-Boot, type -s and press enter.
2. Once its done type /sbin/mount -uw / and press enter.
3. Then type cd /system/library/extensions and press enter.
4. Next do the following:
rm -r Natit.kext
rm - NVDAresman.kext
5. Finally do this: reboot

If it doesn't work, do the same thing but instead of removing Natit.kext and the NVDAresman.kext, this time remove ATIRADEONX2000.kext.

#117
optikol1

optikol1

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Hey Guys,

After hours of reading , I praise you all for your time into this as without a group effort we would be nowhere! However in the midst of this almost being perfect I have a small problem that I seek your expertise on for closure...

Is there anyway to get my pci e Visiontek HD 2600 Pro 512 mb to become supported for Quartz Extreme. Running Kalyway 10.5.2

It is being recognized as a 2600XT however without support for Quartz Extreme. I have tried the Natif way and still see no difference. Everything else is lovely. Any insight is appreciated.

Thanks.

#118
valdok

valdok

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:Peru
  • Interests:Video&Audio production
Thanks!
Tested and working QE/CI (DVI @ 1680x1050) with:

-> KalyWay 10.5.2 clean install (without Natit bundled)
-> Gecube ATI Radeon HD2600PRO 512Mb, Device ID: 0x9589

The instructions would be better adding this:
3. In Terminal:
SUDO NANO /System/Library/Extensions/ATIRadeonX2000.kext/Contents/Info.plist
add the PCI ID of your card (check in About this MAC) over IOPCIMatch, ie: 0x95891002
CTRL + O and ENTER to save the changes.
:D

#119
MorphewS

MorphewS

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
HD 2400 CI QE and DVI, ok, but i need white menu fix :D

Thx.


Sleep dont work, after wakeup image being corrupt :blink:

#120
mr_Harry_plotter_hk

mr_Harry_plotter_hk

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I have used the method described and it worked pretty well in my system..

I am using

gigabyte GA-945GCM(x)-S2
2G Ram DDR2 667
Asus EAH 2600 pro DDR256
CPU E2165
IDE 80G HD

Clean install with Karlway 10.5.1 DVD ( default setting)
with sound driver Azazila OUT

Below is the mac Grahics/Display dump

ATI Radeon HD 2600:

Chipset Model: ATI Radeon HD 2600
Type: Display
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
Vendor: ATI (0x1002)
Device ID: 0x9589
Revision ID: 0x0000
ROM Revision: 113-B1480A-236
EFI Driver Version: 01.00.236
Displays:
Philips 200WS:
Resolution: 1680 x 1050 @ 60 Hz
Depth: 32-bit Color
Core Image: Software
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Not Supported
Display Connector:
Status: No display connected


;)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy