Jump to content

[HOW TO] ATI Radeon HD 2400 / 2600 / 2900 / 3850 / 3870 on Leopard


  • Please log in to reply
559 replies to this topic

#421
drho2004

drho2004

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
  • Gender:Male
  • Location:redondo beach, ca USA
  • Interests:hardware, cars
BUMP

any body have any luck with getting the 3850hd to run on 10.5.1?

im about getting ready to return this card....

#422
drho2004

drho2004

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
  • Gender:Male
  • Location:redondo beach, ca USA
  • Interests:hardware, cars

This is a small guide on how to set up Natit for PCI-E Radeon HD graphics cards in Mac OS X Leopard (10.5.1 & 10.5.2). By following the steps below you will get full QE/CI/OpenGL and DVI output. I know there already is a guide but it is horribly outdated. It is actually a lot easier than you might think.

Supported Radeon HD cards:

  • Radeon HD 2400
  • Radeon HD 2600 Pro, Radeon HD 2600 XT
  • Radeon HD 2900 Pro, Radeon HD 2900 XT
  • Radeon HD 3850
  • Radeon HD 3870
  • Radeon HD 3870x2
  • Other Radeon HD 2x00/38x0 cards might work as well
Step by step guide:
  • Get Natit from here
  • Extract the archive and copy Natit.kext to /System/Library/Extensions
  • Locate ATIRadeonX2000.kext in /System/Library/Extensions, Open /System/Library/Extensions/ATIRadeonX2000.kext/Contents/Info.plist with the editor of your choice and add the PCI ID of your card (if it is not already in there). Save.
    • If you have a Radeon 2600 Pro or a Radeon 3850 and 10.5.1 download this (white menu fix)
      Extract it and replace the original ATIRadeonX2000GLDriver.bundle in /System/Library/Extensions with the one you have just downloaded.
    • If you have a Radeon 2600 Pro or a Radeon 3850 and 10.5.2 download this (white menu fix)
      Extract it and replace the original ATIRadeonX2000GLDriver.bundle in /System/Library/Extensions with the one you have just downloaded.
    • If you have a Radeon 2900 Pro or a Radeon 2900 XT download this
      Extract it and copy ATY_Franklin.kext to /System/Library/Extensions/ATINDRV.kext/Contents/PlugIns.
    • If you have a different chipset skip this step!
  • Open Terminal (if you haven't already done so) and type:
    cd /System/Library/Extensions
    sudo chown -R root:wheel *
    sudo chmod -R 755 *
    sudo rm /System/Library/Extensions.mkext
    sudo rm /System/Library/Extensions/Caches/com.apple.kext.info
  • You are done. Reboot and pray :)
Notes:
  • It is recommended to perform a clean install. Do not select any graphics-related things during the installation.
  • Radeon HD 2400 users: You do not get DVI support. You have to use a DVI2VGA-converter instead.
  • If DVI works, HDMI will work as well (with DVI2HDMI adaptor), no HDMI audio ATM
  • AGP versions of these cards require additional patching. I cannot test it and therefore this guide does only apply to the PCI-E versions.
Changelog:
  • 2008-04-03: updated 2900 information, added ATY_Franklin.kext link, added link to FAQ
Thanks to netkas who made these great drivers. For more information check the #radeonhd IRC channel at irc.osx86.hu
Please also have a look at this FAQ!


hello!

update!

unfortunely i had to install using the Triakis, the method u showed did not work..but...after installing the Triakis_2400_2600_3800.pkg from #RadeonHD channel on irc EVEYTHING WORKED!! i had resolution change, qe/ci etc. next i tried installing the white menu fix,(posted on this thread) and ...back to square one sad.gif
upon bootup i got blue screen.
now, i am able to boot using -x and it takes me to desktop.
any way around this? I installed the ATIRadeonX2000GLDriver.bundle (white menu fix) via Kexthelper, any way to get the 'old one back'? im sooo close, help please

#423
drho2004

drho2004

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
  • Gender:Male
  • Location:redondo beach, ca USA
  • Interests:hardware, cars

hello!

update!

unfortunely i had to install using the Triakis, the method u showed did not work..but...after installing the Triakis_2400_2600_3800.pkg from #RadeonHD channel on irc EVEYTHING WORKED!! i had resolution change, qe/ci etc. next i tried installing the white menu fix,(posted on this thread) and ...back to square one sad.gif
upon bootup i got blue screen.
now, i am able to boot using -x and it takes me to desktop.
any way around this? I installed the ATIRadeonX2000GLDriver.bundle (white menu fix) via Kexthelper, any way to get the 'old one back'? im sooo close, help please


bump


hello!

update!

unfortunely i had to install using the Triakis, the method u showed did not work..but...after installing the Triakis_2400_2600_3800.pkg from #RadeonHD channel on irc EVEYTHING WORKED!! i had resolution change, qe/ci etc. next i tried installing the white menu fix,(posted on this thread) and ...back to square one sad.gif
upon bootup i got blue screen.
now, i am able to boot using -x and it takes me to desktop.
any way around this? I installed the ATIRadeonX2000GLDriver.bundle (white menu fix) via Kexthelper, any way to get the 'old one back'? im sooo close, help please


bump

#424
mcsmart

mcsmart

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Germany
  • Interests:Un*x-like systems, PCs, Scripting and Programming
For historic reasons - this is the original post:

This is a small guide on how to set up Natit for PCI-E Radeon HD graphics cards in Mac OS X Leopard (10.5.1 & 10.5.2). By following the steps below you will get full QE/CI/OpenGL and DVI output. I know there already is a guide but it is horribly outdated. It is actually a lot easier than you might think.

Supported Radeon HD cards:
  • Radeon HD 2400
  • Radeon HD 2600 Pro, Radeon HD 2600 XT
  • Radeon HD 2900 Pro, Radeon HD 2900 XT
  • Radeon HD 3850
  • Radeon HD 3870
  • Radeon HD 3870x2
  • Other Radeon HD 2x00/38x0 cards might work as well
Step by step guide:
  • Get Natit from here
  • Extract the archive and copy Natit.kext to /System/Library/Extensions
  • Locate ATIRadeonX2000.kext in /System/Library/Extensions, Open /System/Library/Extensions/ATIRadeonX2000.kext/Contents/Info.plist with the editor of your choice and add the PCI ID of your card (if it is not already in there). Save.
    • If you have a Radeon 2600 Pro or a Radeon 3850 and 10.5.1 download this (white menu fix)
      Extract it and replace the original ATIRadeonX2000GLDriver.bundle in /System/Library/Extensions with the one you have just downloaded.
    • If you have a Radeon 2600 Pro or a Radeon 3850 and 10.5.2 download this (white menu fix)
      Extract it and replace the original ATIRadeonX2000GLDriver.bundle in /System/Library/Extensions with the one you have just downloaded.
    • If you have a Radeon 2900 Pro or a Radeon 2900 XT download this
      Extract it and copy ATY_Franklin.kext to /System/Library/Extensions/ATINDRV.kext/Contents/PlugIns.
    • If you have a different chipset skip this step!
  • Open Terminal (if you haven't already done so) and type:
    cd /System/Library/Extensions
    sudo chown -R root:wheel *
    sudo chmod -R 755 *
    sudo rm /System/Library/Extensions.mkext
    sudo rm /System/Library/Extensions/Caches/com.apple.kext.info
  • You are done. Reboot and pray :|
Notes:
  • It is recommended to perform a clean install. Do not select any graphics-related things during the installation.
  • Radeon HD 2400 users: You do not get DVI support. You have to use a DVI2VGA-converter instead.
  • If DVI works, HDMI will work as well (with DVI2HDMI adaptor), no HDMI audio ATM
  • AGP versions of these cards require additional patching. I cannot test it and therefore this guide does only apply to the PCI-E versions.
Changelog:
  • 2008-04-03: updated 2900 information, added ATY_Franklin.kext link, added link to FAQ
Thanks to netkas who made these great drivers. For more information check the #radeonhd IRC channel at irc.osx86.hu
Please also have a look at this FAQ!

#425
Onion_Skin

Onion_Skin

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hi mcsmart,

I downloaded your latest post of natit.kext, but the zip file extracts to a zero length natit.kext. Is it corrupted?


#426
mcsmart

mcsmart

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Germany
  • Interests:Un*x-like systems, PCs, Scripting and Programming

I downloaded your latest post of natit.kext, but the zip file extracts to a zero length natit.kext. Is it corrupted?[b]

This is/was a permission problem. If you were root you would have noticed that Natit.kext is not 0 kb. But I fixed the permissions now - just to make sure. Thanks for the hint.


- mcsmart

#427
samm5506

samm5506

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Ok, I have an extremely odd problem... the other day I was using this tutorial and managed to get my ATI Sapphire Radeon HD 2900 XT (PCI ID x9400) working, then after trying to fix a network problem, I had a kernel panic and did not know how to fix it. So... as the noob that I am I reinstalled iDeneb v4.1 10.5.6 (not knowing that I could use -s and remove the new kext) and the next time I try to use this tutorial, I get stuck on a blue screen when loading Leopard. I am probably on my 6th install of trying to get a good run with my graphics card. It's very frusterating and I don't know what to do now. Has anyone had this problem or know how to fix it?

#428
Caprica01

Caprica01

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Manchester, UK
I'm having problems with my Asus Radeon 3650 256mb PCI-e. Can not boot apart from in safe mode, so will take a closer look at this when I get home from work tonight.

#429
erick713006

erick713006

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
hey cool... your the first to put something... yay.... lol i just need to know how to install the HD 3850 AGP DRIVER! do you have any clue?

#430
DaaDaa

DaaDaa

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

hey cool... your the first to put something... yay.... lol i just need to know how to install the HD 3850 AGP DRIVER! do you have any clue?



#431
gymnastdaniel5

gymnastdaniel5

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
Does this work with the mobilities as well?
-Daniel

#432
DirtTrash

DirtTrash

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Radeon HD 2600PRO...

Showing...

"Quartz Extreme: Not Supported"

...in System Profiler

I keep getting the error message "unable to start up 3D acceleration". Any help would be great. THX

#433
DirtTrash

DirtTrash

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Does this work for the Radeon HD 2600PRO PCI-E...running 10.5.6???

#434
mcsmart

mcsmart

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Germany
  • Interests:Un*x-like systems, PCs, Scripting and Programming

Does this work for the Radeon HD 2600PRO PCI-E...running 10.5.6???

Of course. My 2600 Pro worked well under 10.5.6.

- mcsmart

#435
PSChild

PSChild

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hi all

I am really frustrated with my HD 2400 XT, 1024 display only.
I have tested with some distributions, and methods but I have nothing, a 22'' and a 23'' monitor with the poor 1024 resolution.

In the notebook with the Intel GMA X3100 I can get notebook 1280 and external 22'' or 23'' monitors with their perfect resolution, it changes automatically and I can change position of external with "Displays options".

But the DELL Inspiron 530s HD 2400 XT is a mistery, and after read near to 100 forum pages and reinstall near to 8 times, I post this to find directly help, (I thought that I can resolve the problem and not disturb, but I can't).

My DELL specs are the following

OSX86 iDeneb 1,4 - 10.5.6, (I have tried with iDeneb 1.3, iPC 10.5.6, iATHKOS)
MacOSX in Partition Journaled HFS+

Intel Core™2 Duo CPU E8400 @ 3 GHz
Start ROM MP31.88Z.006C.B05.0802291410 (Apple Inc.)
HL-DT-ST DVD+-RW GSA-H73N: ATAPI C108

ATI RADEON HD 2400 XT; ATI (0x1002) - 0x94c1 - 0x0000

I am making an Image disk now, because I am tired of reinstalling a setting up things than I can make work, but if I can't make ATI works, I think I will have to back to Windows, customers and work doesn't let me lost more time.

Please, anyone can help me.
Thanks all

#436
ufo_all

ufo_all

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
why does it says i dont have permission to download...

#437
HerX

HerX

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:CPG

why does it says i dont have permission to download...


Maybe you where not logged in :rolleyes:

On the other hand, I have 2900XT, tried all the possible drivers and all (iPC 10.5.6), but finally got CI/QE working with some prehistoric driver (EFI Driver Version: 01.00.207).

Now that I got all sorted out, I went to try playing a bit of World of Warcraft, everything runs nicely (about the same framerate as in Vista 64) and looks a bit better (prolly the calibration), but I have the freezing issue:
- all but mouse and sound freezes, I can't get to dock to force quit, so after a few mins like that I get complete system freeze

I've found some garbage in my system.log related to graphics driver, here is the beggining of it
Mar 14 22:17:16 vishnu kernel[0]: ** Device in slot: SLOT--1 **
Mar 14 22:17:16 vishnu kernel[0]: ** GPU Debug Info Start **
Mar 14 22:17:16 vishnu kernel[0]: 0x01019400 0000fdce 00009400 00000000
Mar 14 22:17:16 vishnu kernel[0]: 0x00632800 00000081 00000007 00000000
Mar 14 22:17:16 vishnu kernel[0]: 0x0011a010 00000000 00000000 31421002
Mar 14 22:17:16 vishnu kernel[0]: 0x00000000 00000001 00000001 fa508a06
Mar 14 22:17:16 vishnu kernel[0]: 0x80838647 000284c6 01000000 00001002
Mar 14 22:17:16 vishnu kernel[0]: 0x0a00100a 000000e0 00000020 00000002
Mar 14 22:17:16 vishnu kernel[0]: 0x0030003a 01300134 01600160 00200020
Mar 14 22:17:16 vishnu kernel[0]: 0x00e000e0 01520154 20000000 00100f0d
Mar 14 22:17:16 vishnu kernel[0]: 0x00000300 20000000 00000940 00001500

Do you guys have any idea if that is an issue with 2900XT generally with hack-drivers, or should I try to get newer drivers working anyway?

Oh btw, I tried the drivers on the iPC DVD, but all I get is a garbled screen (prolly FB f-ed up or something in them).

#438
corbzie

corbzie

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Just wanted to say thanks, this thread has helped solve my blank menu problems.

#439
irafaS

irafaS

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hey.
Can someone see what the problem is from the screenshot? This is from safemode.
I think the problem is my ATI HD3850 card.
If I install iPC 10.5.6 with a 7900GS card, it works, no kernel panic.
Thanks

Attached Files



#440
OniKami

OniKami

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I have an ATI Radeon HD 2600 pro AGP.

The installer ran fine up until the end. then, locked the machine, and on boot it will lock up.

I have an Intel Core 2 Duo 2.2
running OSx86 10.5.5


Any tips on how i could uninstall it and get it to boot up properly again or should i just forget about it.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy