Jump to content

Leo4All-10.5.2 Universal AMD/INTEL[SSE2/SSE3]


  • Please log in to reply
1391 replies to this topic

#21
Hbill

Hbill

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

lol, ;)


I work in that shop :) hehe

Does anyone know, if it is a must to have the ahci function on or off? Because my sony vaio bios is very limited, I can not change much.. Very strange. Since the laptop is just a month old I dont want to void the waranty because of a bios-hack.

So is it a must to have the ahci function on/off?

#22
Darrious

Darrious

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
Just to check up on this, I was wondering if it works with a Pentium 4 processor? I know I've had problems with leopard because iATKOS and Kalway offer the Vanilla Kernel that fixes the problem, but the vanilla kernel is not compatible with P4's.

#23
Jackobyte

Jackobyte

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
It should work with both AHCI or not. Very much depends on the motherboard.

#24
eddie11c

eddie11c

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 772 posts
OK to answer a few of the questions, it will work with an P4. Just choose Netkas 9.2.0 kernel if the Vanilla kernel does not work for you. AHCI can be on or off. But remember with it on you can only see 2 drives in Leopard, as it is a current limitation in the driver that is not open source. So I would recommend you turn it off.

#25
tomd

tomd

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Thanks for your time on this Eddie, hoping to get it working on my Dell (though I'm mainly a Mac user really, got MBs & Minis around the place & at work). Are you able to talk about the best place to get the image from to use & help seed it?

#26
Art?!

Art?!

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
Alright I installed it with success :D
My specs:
Motherboard: Asus P5KC
Processor: Intel 6750 @ 3,2 Ghz (overclocked)
Videocard: Asus EN7900GT
Sata Dvd drive

#27
eddie11c

eddie11c

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 772 posts

Alright I installed it with success :D
My specs:
Motherboard: Asus P5KC
Processor: Intel 6750 @ 3,2 Ghz (overclocked)
Videocard: Asus EN7900GT
Sata Dvd drive


Good to know my last second changes didn't break it. Thanks for letting me know.

#28
ammonsphoto

ammonsphoto

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I have a Dell Dimension 4700 what do I choose for the chipset? Sorry for the noob question, I am all mac typically so this is new to me.

#29
eddie11c

eddie11c

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 772 posts

I have a Dell Dimension 4700 what do I choose for the chipset? Sorry for the noob question, I am all mac typically so this is new to me.


Looks like an intel chipset, Jmicron which will install anyways will probably cover your IDE/SATA but you can check the ICHx just in case that motherboard uses it.

#30
ammonsphoto

ammonsphoto

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Just started the install without checking anything so I will report back asap. Very Excited. Like I said I am typically all mac and when I use the one PC I have at home it leaves me longer more and more for 10.5.

#31
eddie11c

eddie11c

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 772 posts
Just thought I would share something interesting, looking at the stats on my FTP. The handful of beta testers I had managed to use 209,367.33MB of bandwidth.

#32
WinLinMac01

WinLinMac01

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 315 posts
  • Gender:Male
  • Location:Earth
  • Interests:I am a technology enthusiast! I've been with InsanelyMac since January, 2008 (My other...
That number is out of the ballpart, wow. staggering... :D :D :) ;)

Just thought I would share something interesting, looking at the stats on my FTP. The handful of beta testers I had managed to use 209,367.33MB of bandwidth.



#33
Ongeloof

Ongeloof

    Irrevocably Insane

  • Donators
  • 1,007 posts
  • Location:The Infinite Loop
  • Interests:Your moma.
Eddie, Well Done, i will edit and post my specs for s successful install soon.

Think Mark

#34
eddie11c

eddie11c

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 772 posts
Oh btw, was the installation background ok? Added it in at the last minute just so it felt customized.

#35
ADoNuT333

ADoNuT333

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male

Just thought I would share something interesting, looking at the stats on my FTP. The handful of beta testers I had managed to use 209,367.33MB of bandwidth.



Well you did put up like 2 dvds of about 3.5 gigs each, split among 10+ testers some of which had to re-download parts of the rar (like me). So it almost understandable. Must be one hell of a usage bill. lol.

#36
ammonsphoto

ammonsphoto

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Installed just fine on the Dell Dimension 4700. Video seems a little shaky and I cannot open the System Profiler. This has the ATI x300 SE I believe. It was the option dell offered. Any ideas?

Oh yeah, Background Image worked great!

#37
eddie11c

eddie11c

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 772 posts
Your on your own with video, escpecially ATI cards. Try searching for it here or on google.

#38
sharpy

sharpy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
seeding as i promised eddie :P

#39
nytrider

nytrider

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

*******************************************************************************
Leo4All-10.5.2 Universal AMD/INTEL[SSE2/SSE3]
*******************************************************************************

-------------------------------------------------------------------------------
Release Notes
-------------------------------------------------------------------------------
This is a release I created for my own use. I have an AMD and an Intel computer
and wanted to simplify the install. I have made it with max compatability in
mind, but your mileage may vary. All original Languages are included.

-------------------------------------------------------------------------------
Install Notes
-------------------------------------------------------------------------------
The system is setup by default to boot in Verbose mode. You can change this yourself if you want in /Library/Preferences/SystemConfiguration/com.apple.Boot.plist. I included BBEdit with the applications, it can edit the file in place with correct permissions.

During the DVD bootup if your stuck at "waiting for root device" I am sorry your hardware is probably not supported. You can try changing some options in your BIOS, maybe you get lucky.

If you get error com.apple.boot.plist not found your DVD is most likely bad, burn it again at a lower speed.

If you have an AMD system please check the box for AMD-System-Fix to aplly the patches needed for Leopard to work!!

AHCI works, but you are limited to two drives, turn this off if you have more than 2 drives you need to access.

If you have an older computer with limited options in the BIOS(ACPI/APIC) and you are able to install but when you boot the freshly installed O/S you are stuck just after ACPI loads, try installing with the APIC-Fix checked. This will install an Older ACPIPlatform and APIC for better compatability.

Video Driver support is very hit or miss, please install first without it. You can easily add this yourself afterwards.

The EFI bootloader automatically detects and installs for MBR/GUID thanks to Dense, it may have specific problems for Bad-Axe 2 systems.

Please select your IDE/SATA chipset during install.(One and only one!)

Default selection for kernel is Netkas improved 9.2.0. If you select Vanilla kernel please uncheck Netkas kernel.

If during the inital account creation your system locks up, try disabling your Network card.

If you installed Video drivers during install(not recommended) and your system freezes before the desktop loads, boot with -s and remove the Video kexts.

If after you boot to the desktop you get an error about an Extension not being properly installed open the Application I included called Extensions-Repair to correct this automatically.

There is no way to support everyone as the drivers are just not available. If this does not work for you I am sorry. I will give what support I can and I am sure others with knowledge will too.

Please read the above comments before asking questions as many of the common issues are covered here.


Hi Guru Eddie11c, thanks for letting me be part of your betatesters..... and so sorry for my late feedback to you about testing it...

I did encounter some NForce errors... I think its becoz of my old chipset... my mobo is still an old msi k8n-neo2 platinum with an an NForce-3 chipset... 1 quick question... can i modify or inject an old NForce.kext or and old kernel.. since i was able to install tiger 10.4.10 and leopard 10.5.1... can i use the NForce.kext files from these versions?

Anyway, Hopefully your latest and final release is out and hope that this 1 would work... realy Great work Master..... And hopefully soon i'll be obtaining a newer mobo and amd processor and install onto it u rfinal release...

Thanks again....

#40
eddie11c

eddie11c

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 772 posts

Hi Guru Eddie11c, thanks for letting me be part of your betatesters..... and so sorry for my late feedback to you about testing it...

I did encounter some NForce errors... I think its becoz of my old chipset... my mobo is still an old msi k8n-neo2 platinum with an an NForce-3 chipset... 1 quick question... can i modify or inject an old NForce.kext or and old kernel.. since i was able to install tiger 10.4.10 and leopard 10.5.1... can i use the NForce.kext files from these versions?

Anyway, Hopefully your latest and final release is out and hope that this 1 would work... realy Great work Master..... And hopefully soon i'll be obtaining a newer mobo and amd processor and install onto it u rfinal release...

Thanks again....


You can certainly inject whatever kext you want in the extensions folder. AppleNforceATA.kext will need to be placed inside of IOATAFamily.kext replacing the old one. It was split on which version to use, only reason I inlcluded the newer one was alot of peoples SATA DVD's would not work at all with the older one. I will do some testing tonight if I have a chance. Maybe I can make a small patch that would allow people to revert to the older version without having to use transmac. Which version worked for you?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy