Jump to content

The 99% sure way to fix SoundMax Sound (ATTENTION UPDATED AS OF 11/24/07)


  • Please log in to reply
159 replies to this topic

#1
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male
UPDATE: November 24th 2007
Ive added RAMM'S super kext list to my sources of finding the kext you need for your ac97 audio :dev:. please read through my below post to find it.
------------------------------------------------------------------------------------------------------
OK im changing things a bit. before you do anything thing ask yourself "can i move the volume slider?" and if you can then chances are that you DO NOT need the kext so go ahead and skip down the the second part of my tutorial and try it and then if you still cant get things working the try to get the AC97Appleaudio.kext but if you can change the volume it technically means you have sound.


THIS IS FOR 10.4.3!!! (and possibly later versions but not older!)

- Copy or move the kext to your Desktop (EDIT: you must find the kext on your own i cannot give it to you anymore if you need help finiding it pm me or you can look here
RAMM'S SUPER KEXT LIST

once you have aquired the appropriate kext

- Open Terminal
- Type sudo su
- Give your password

Before copy the kext remove the old one:
- Type rm -fr /System/Library/Extensions/AppleAC97Audio.kext

Now copy it again from your user's Desktop:

- Type cp -R /Users/your-username/Desktop/AppleAC97Audio.kext /System/Library/Extensions/

- Type kextload -t /System/Library/Extensions/AppleAC97Audio.kext
if there are no errors Type kextcache -k /System/Library/Extensions and reboot

Of course change your-username to what ever you name it, in my case it's bryan, so the command for me is this:
cp -R /Users/bryan/Desktop/AppleAC97Audio.kext /System/Library/Extensions/
----------------
(thanks to RAMM for the SUPER LIST of kexts)
-----------------
ok now heres what I found out on accident(xD lol) that works for me AFTER FOLLOWING ABOVE INSTRUCTIONS AND REBOOTING (UNLESS YOU CAN MOVE THE VOLUME SLIDER THEN YOU CAN MOST LIKELY SKIP THE TOP SET OF INSTRUCTIONS sorry for the confusion)

go to applications-utilities folder-audio midi setup-audio devices and make sure you select to look at the OUTPUT not the input :D.

now change the channel setting to 6ch-16bit then go to "configure speakers" and make front left channel 3 then test it by clicking the icon then change the right channel to 6 and test it and TA DA sound.
now if you dont have the choice to make it 6 channel-16bit then for now your outta luck sorry. ask macgirl! lol she can probably help!

if you have any questions just let me kno. if this works for a lot of people maybe we can make this a sticky?

***NEW UPDATE***
if your having permission and or get a message like this:
"kextload: /System/Library/Extensions/AppleAC97Audio.kext: no such bundle file exists
can't add kernel extension /System/Library/Extensions/AppleAC97Audio.kext (file access/permissions) (run kextload on this kext with -t for diagnostic output)"

Then try this:
open terminal
sudo -s
enter password if asked
chmod -R 755 /System/Library/Extensions/<drivername>.kext
chown -R root:wheel /System/Library/Extensios/<drivername>.kext

its not guaranteed to fix your problem but there is a big chance it will atleast get the kext to load properly...now to fix the fact that alot of people cannot see more than 2 or three channels..instead of 6

---------------------------------------------------------
IF YOU HAVE C-Media 8738 and are having problems with it then look around here for a most likely fix ^_^ thanks Deffer for tellin me about this!
http://forum.osx86pr...h...ic=1656&hl=

#2
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male
well is it workin for anyone?

#3
GanTech

GanTech

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
I followed it to the letter and still no sound devices show up. :-(

I'll keep trying!!!

#4
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male

I followed it to the letter and still no sound devices show up. :-(

I'll keep trying!!!



what kind of error are you getting? or are you getting an error? and can you adjust the sound but no sound comes through or what?

#5
numberonekiwi

numberonekiwi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 319 posts
  • Gender:Male
  • Location:Tauranga NZ
I am getting these errors on 10.4.4 have tried chmod 644 and chmod 755 followed instructions fully in first post have even tried chown -R root:wheel and chown root:wheel to no luck

Obviously we need to wait for a 10.4.4 version

B.T.W ac97audiocodec ad198x.kext is what i need

<key>IOClass</key>
<string>AppleAC97CodecAD198x</string>
<key>IOProbeScore</key>
<integer>10000</integer>
<key>IOProviderClass</key>
<string>IOAC97CodecDevice</string>
<key>PNPVendorID</key>
<string>ADS71 ADS70 ADS69 ADS68</string>

here is the error


kextload -t /System/Library/Extensions/AppleAC97Audio.kext/
kernel extension /System/Library/Extensions/AppleAC97Audio.kext/ has problems:
Authentication failures
{
"File owner/permissions are incorrect" = (
"/System/Library/Extensions/AppleAC97Audio.kext/Contents/Info.plist"
"/System/Library/Extensions/AppleAC97Audio.kext/Contents"
"/System/Library/Extensions/AppleAC97Audio.kext/Contents/MacOS/AppleAC97Audio"
"/System/Library/Extensions/AppleAC97Audio.kext/Contents/MacOS"
)
}
Any Ideas or is it the 10.4.4 compatability issue?

#6
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male

I am getting these errors on 10.4.4 have tried chmod 644 and chmod 755 followed instructions fully in first post have even tried chown -R root:wheel and chown root:wheel to no luck

Obviously we need to wait for a 10.4.4 version

B.T.W ac97audiocodec ad198x.kext is what i need

<key>IOClass</key>
<string>AppleAC97CodecAD198x</string>
<key>IOProbeScore</key>
<integer>10000</integer>
<key>IOProviderClass</key>
<string>IOAC97CodecDevice</string>
<key>PNPVendorID</key>
<string>ADS71 ADS70 ADS69 ADS68</string>

here is the error
kextload -t /System/Library/Extensions/AppleAC97Audio.kext/
kernel extension /System/Library/Extensions/AppleAC97Audio.kext/ has problems:
Authentication failures
{
"File owner/permissions are incorrect" = (
"/System/Library/Extensions/AppleAC97Audio.kext/Contents/Info.plist"
"/System/Library/Extensions/AppleAC97Audio.kext/Contents"
"/System/Library/Extensions/AppleAC97Audio.kext/Contents/MacOS/AppleAC97Audio"
"/System/Library/Extensions/AppleAC97Audio.kext/Contents/MacOS"
)
}
Any Ideas or is it the 10.4.4 compatability issue?



email me and i could possibly help u...kanieski2006@gmail.com

#7
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male
is anyone having any problems with something OTHER than the kext? lol

#8
antonio giorlando

antonio giorlando

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
It said everything worked for me.. but there are no audio output devices after I rebooted. I got the kext from macgirl, still no worky :angel:
I'm running a Toshiba Qosmio F25-AV205 laptop.

Edit, Running 10.4.3

#9
Gooly

Gooly

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:India
Cehck if u have ATI chipset. AC97 wont work with ATI boards

It said everything worked for me.. but there are no audio output devices after I rebooted. I got the kext from macgirl, still no worky :(
I'm running a Toshiba Qosmio F25-AV205 laptop.

Edit, Running 10.4.3



#10
antonio giorlando

antonio giorlando

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
0 ATI Products on this laptop.
The graphics card is nVidia (works superb).
I'm almost certain it's an intel chipset, can anyone lend me a hand? :(
I have msn and all of that.

#11
mushupork5

mushupork5

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
think this might work with 10.4.5? I can give it a shot

#12
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male
yeah i just think that the only thing youll have problems finding is the kext but if you can move the slider that means you have sound. so if you can move the slider skip my terminal instructions for now and go and try thr chanell setup its worked for most everyone that could change there volume slider. let me kno how it goes.

#13
drummania

drummania

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Successful on my Dell 4700 PC. Thank you!

#14
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male
no problem glad i could help !! :)

#15
JJJJJ

JJJJJ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
mac-nipulate you are a genius works perfectly on 10.4.4

#16
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male

mac-nipulate you are a genius works perfectly on 10.4.4

lol XD HA HA thanks thanks but not quite yet lol :happymac:

#17
Suser

Suser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
I still have issues with my sound.
Card is the ADI AD1980 AC97 Soundmax chipset.
Mainboard : Asus K8V SE Deluxe.
I tried everything of the above, found an AC97 extension, also asked some of you here by pm for the extension but as for now I still didn't get it although promised.

Anyone who could give me advise or a working extension ?

#18
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male
im would like to apologize to everyone who i promised i would help "find" the kext you need ive just been very very busy with another project. so if youll give me till this weekend ill help EVERYONE who needs it. ^_- thanks guys. EDIT UPDATE:almost done with my project just hold tight!

#19
shyde

shyde

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I can adjust the sound but no sound comes through ~~~~!!!!!!!


help~~
10.4.3 g

#20
Grav3Mind

Grav3Mind

    Super l33t T3H HaX0r ARE YOU? WELL..I can..umm..HaX your Tires?

  • Members
  • PipPipPipPipPip
  • 324 posts
  • Gender:Male

I can adjust the sound but no sound comes through ~~~~!!!!!!!
help~~
10.4.3 g


did u follow my second set of instructions??????





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy