Jump to content

ATI Mac Drivers...


  • Please log in to reply
13 replies to this topic

#1
weisman87

weisman87

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
I have Mac OS X 10.5.1 installed on my "Hackintosh." I have an ATI Radeon 1650 256MB video card. I have no idea how I did it, but I fixed the "mouse tear" display issue that I had before, but I still have a TERRIBLE resolution (1024 x 768). I would like to have a 1280 x 1024 resolution like I do in Windows. I also cannot use my dual monitor setup with it either. Another thing, I have an intel D975XBX2 mobo and have no sound. Will someone please help me out? I've tried Natitx, or whatever it's called, but can't get it to work. I am completely new to Mac OS X, and am not sure about editing .kexts and things like that. If there are any drivers that can just be run and installed in Mac OS X, I'd like to have them. Hopefully someone out there can help me...

#2
Love_@_1st_Mac

Love_@_1st_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:In front of my OSX86
I had the same problem as you.
what did the trick for me was a fresh install (kalyway version in my case but they say it works with ToH also) and MacLovin's pack fr ATI Graphics cards Pack.
Here is the link to his post.
Good luck

http://forum.osx86sc...php?f=16&t=2312

#3
Love_@_1st_Mac

Love_@_1st_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:In front of my OSX86
another thing: in the installation, do not select any drivers for your card... this way the graphics card installation will be much easier.

#4
weisman87

weisman87

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Oh god...I hope I don't have to do a clean install. It took me forever, and applying the 10.5.1 patch was a pain. And I haven't even tried the 10.5.2 patch...

But thanks for your help. I'll try this and let you know how it goes. Any advice about not having sound?

#5
Synaesthesia

Synaesthesia

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,168 posts
  • Gender:Male
  • Location:South Africa

Any advice about not having sound?

AppleHDA Patcher 1.15.

I think your sound is Sigmatel 9220.

#6
weisman87

weisman87

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Thanks. I tried the MacLovin's ATI pack, and now my Mac won't boot at all. I'm thinking it's because I tried installing it without doing a clean install, but I'm not sure. The Mac OS I have installed won't boot up at all. Any ideas? And I'm currently downloading the Kalyway DVD, so I might try to reinstall with that. But I'd really rather not have to wait all that time for it to download...

#7
Synaesthesia

Synaesthesia

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,168 posts
  • Gender:Male
  • Location:South Africa
Is your Mac partition marked as active?

#8
Love_@_1st_Mac

Love_@_1st_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:In front of my OSX86
And did you select MBR? i know I had this problem. It wouldn't work with GUID, but worked perfectly with MBR.
Btw: you do know that Kalyway is made for intel PC's...yes?
here is the installation guide for intel > http://forum.insanel...showtopic=77069
here is the installation guide for AMD > http://forum.insanel...o...st&p=362834

#9
weisman87

weisman87

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Thanks for the replies. Hopefully I can answer both of you guys by explaining my setup. I have two hard drives, one with XP/Vista dual boot, and the other with JUST Mac OS X partition, and another partition for media files (no OS, just strict files). My Mac partition should have been marked as active, like you asked, but I can't remember for sure, I installed it in December. I am currently downloading the Kalway DVD now. Hopefully I can make a bootable disk and everything. I know Love@1stmac said to make the partition MBR, and the guide for Kalway said make it GUI, so I'm not sure what I'll do about that yet. My Mac partition is in HFS format I believe (since Mac worked before), so what I'm planning on doing is getting the DVD bootable, and going into disk utility and erasing my Mac partition, and reformatting it as Mac OS Extended, like I did before. After I do that, I'll install the OS. Love@, hopefully you can back me up here, I'm planning on installing both Vanilla kernels for the Kalway DVD, and installing the NATIT_ATIcards video drivers with it. For soundcard drivers, I'm not sure yet, I may have to look at the link you posted for me when I get that far. Do you recommend installing the Network drivers that come with the Kalway DVD? My LAN worked great with the previous Leopard Image I had. Also, should I install the "Bootloaders EFI" when I get that far?I'm not sure if my Mac partition is marked as active right now, I'm not positive how to check. I can't boot into Mac to check, either. Assuming that's how I do it?

#10
Love_@_1st_Mac

Love_@_1st_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:In front of my OSX86

I know Love@1stMac said to make the partition MBR, and the guide for Kalway said make it GUI, so I'm not sure what I'll do about that yet.

I just told you what worked for me... you can do what i did, or what you did... does not matter... installed it on MBR because on the same HDD i have another partition with XP on it...

Love@, hopefully you can back me up here, I'm planning on installing both Vanilla kernels for the Kalway DVD, and installing the NATIT_ATIcards video drivers with it.

Vanilla is another thing i did not install...
and no...do not install NATIT_ATIcards video drivers, if you want to install MacLovin's pack.
I have installed OSX 15 time in the past 2 weeks... never with the same options twice....just to see wather this is better than that.... and so on... I am not saing that I am right and you are wrong... something that works on your computer might not work for me...and the other way around.

Do you recommend installing the Network drivers that come with the Kalway DVD? My LAN worked great with the previous Leopard Image I had.

LAN should work out of the box.
In the Kalyway DVD 10.5.1 you have the option to install WiFi drivers...

#11
weisman87

weisman87

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
I just told you what worked for me... you can do what i did, or what you did... does not matter... installed it on MBR because on the same HDD i have another partition with XP on it...

Alright I'll look into it a little more and see what's recommended. I'll most likely do what you did and do MBR.

Vanilla is another thing i did not install...
and no...do not install NATIT_ATIcards video drivers, if you want to install MacLovin's pack.
I have installed OSX 15 time in the past 2 weeks... never with the same options twice....just to see wather this is better than that.... and so on... I am not saing that I am right and you are wrong... something that works on your computer might not work for me...and the other way around.

Do you have any idea what the Vanilla Kernel actually is? It says something about the original apple kernel, and supposedly fromt he forums I've seen, it's something that is recommended. I'm hoping the MacLovin's pack will definitely work with the Kalway DVD, it didn't for my other Mac install.

Any thoughts on the Soundcard drivers that come with Kalway? And I'm assuming the "Bootloaders EFI" needs to be installed for sure...

#12
Love_@_1st_Mac

Love_@_1st_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:In front of my OSX86

I'm hoping the MacLovin's pack will definitely work with the Kalway DVD, it didn't for my other Mac install.

It does work. I have Kalyway 10.5.1 and MacLovin pack
And yesterday night I Updated to 10.5.2 (Kalyway ComboUpdate 10.5.2) and it works perfectly.

#13
weisman87

weisman87

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

It does work. I have Kalyway 10.5.1 and MacLovin pack
And yesterday night I Updated to 10.5.2 (Kalyway ComboUpdate 10.5.2) and it works perfectly.



Alright cool. I'll try it when I get the time. What program did you use to make your bootable disk? I'm planning on using MagicISO or PowerISO. Anda gain, thanks for all your help, I'll let you know how things go.

#14
weisman87

weisman87

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
So I got Kalyway to install, but my Device ID for my graphics card is 7291. What MacLovin's pack should I use? I didn't see any that looked like they would work...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy