Jump to content

[Guide + Installer] Leopard Gigabyte GA-P35-DS3P/DS3R/DS4 (10.5.2 + EFI)


  • Please log in to reply
1127 replies to this topic

#1121
MistorOrange

MistorOrange

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male
  • Location:j-town
I have the exact same problem

#1122
ks2socal

ks2socal

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Thanks for the great guide!

Everything seems to work fine until I tried installing a "vanilla kernel" from nvinject

I thought that was for a 256mb 8600gts xfx card. My problem is the time it takes to login, it takes a few minutes and then it goes in.

It hangs with this system/library/coreservices/loginwindow.app/contents/macos/loginwindow27
login window application started.


How can I start fresh with the graphics drivers?

Also was just looking at the osx86tools, should I do a restore to default? Would that keep me at 10.5.4 still?

#1123
GREENBAG

GREENBAG

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

10.5.4 version of this guide is OUT! With control center app and Chameleon :D

http://forum.insanel...howtopic=121849

-------------------------------------------------------------------------------------------------------

This is a Leopard version of the Gigabyte GA-P35-DS3P/DS3R/DS4 guide and software install pack. It uses the Kalyway 10.5.1 DVD + Kalyway 10.5.2 combo update and its only compatible with Core 2 or Pentium Dual Core (not Pentium D) series processors.

This guide now comes in two versions:

Old Version (Manual Driver Installation)

  • 7 page full installation guide for installing Mac OS X 10.5.2 with full hardware and software support, 100% compatibility (Audio, LAN, Sleep, Shutdown, Restart) in DOC and PDF formats
  • ALC889a Audio Drivers for full output/input audio
  • Realtek RTL8111B Ethernet drivers
  • netkas 9.2.0 kernel with shutdown fix
  • Default AppleSMBIOS-27 by macdotnub
  • AppleACPIPlatform PS/2 keyboard and mouse fix
  • Latest ApplePIIXATA driver by Dune
New Version (Easy Automatic Driver Installer)
  • 6 page full installation guide for installing Mac OS X 10.5.2 with full hardware and software support, 100% compatibility (Audio, LAN, Sleep, Shutdown, Restart) in DOC and PDF formats
  • Automatic Driver Installer that installs all the kernels and kexts for you automatically!
-------------------------------------------------------------------------------------------------------

Update warning: Do not install the Time Machine update from Apple Software Update right now, it has not been tested on these boards and the results are unknown. Also do not install the 10.5.3 update, there are many bugs. Just wait for now.

Note about kalyway kernels package: Many people have said that they cannot find the kalyway kernels package that is required by this guide. So for you convenience, here is the link.

Bug in installer: Several people have said that there is a small bug in the installer where after you do a full install of all the drivers, sound still doesn't work. Thankfully, the simple fix is you run the installer a second time, this time ONLY choosing the sound drivers and nothing else.

The new version is recommended since it is the fastest and easiest, however both versions are up for download in case you want to go through the learning process ;

This has
been tested and checked thoroughly, includes a BIOS settings template, a couple screenshots and COMPLETE FULL instructions on a walkthrough of the 10.5.1 install and detailed 10.5.2 update instructions. Also includes many side tips that cover everything and make sure that you don't mess up.

This guide works with any Gigabyte GA-P35-DS3P and DS3R based motherboard (including P35C, EP35, etc.) This guide should also work for the DS4 model as it has the exact same hardware. I tested it on a DS3P, full specifications in sig.

Download


You can download the new version of this guide (7.89MB) with the easy installer here (RECOMMENDED)
Mirror for new version (with installer)

You can download the REV2 old manual installation version (5.65MB) of this guide here (HARDER)
Mirror for old version (manual install)
If you have any feedback or questions, please post them here :wacko:


Hiya.

I just want to say thanks because of your guide i have managed to successfully installed 3 boxes:
1) EP45 DS3L with core 2 duo
2)P5KSE with core 2 quad q6600
3) GA935GME with a dual core

now I just bought a GA EP45 DS3LR with intel chipset q9550.
I noticed a big difference in installing, the 3 boxes took less than 30 min to complete each fresh installation, but this mobo and chipset took me like 1 Hr and 40 min to finish fresh installing.
i have no idea . because since its a core 2 quad, it should be faster right?

prior to installing the kalyway 10.5.2, i made 3 partition in my 500GB drive.
50gb, 50Gb and the rest for data.
I installed the 50gb for xp
then i boot from the kalyway dvd and using the terminal to do the simple dual boot terminal commands from the site in wiki.osx86 regarding simple dual boot

then the next 50gb i installed kalyway 10.5.2 leopard.

then after the first install, my Computer Hangs at"Verifying DMI Pool Data".

now. my concern is not the about the hang part. its the time it takes to install. 1hr 40 min....it ust doesnt sems right as i've made 3 boxes successfully with installation under 30 min.

maybe you can help me out. is it the chipset q9550? or is ot the mobo. coz ur guide is about Ds3L.. mine is DS3LR

pls help me out. thanks you for your attention.

#1124
Johnny V

Johnny V

    InsanelyMac Sage

  • Donators
  • 375 posts
>guide is about Ds3L.. mine is DS3LR

Have you compared the specs between the two boards? Are the components the same?

The Q9550 shouldn't be an issue.

#1125
GREENBAG

GREENBAG

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

>guide is about Ds3L.. mine is DS3LR

Have you compared the specs between the two boards? Are the components the same?

The Q9550 shouldn't be an issue.


yes the boards are identical. the 'R' is just that it supports Raid.

in BIos mode, i have the option to set either AHCI or RAID. and i choose AHCI.

anyone else using the EP45 DS3LR version?

#1126
zim2dive

zim2dive

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts

Kronoid,

While poking around I went to the OSx86 Hardware Compatibility page and found info how others were able to run the 8400GS.

http://wiki.osx86pro...L_10.5.2#nVIDIA

OK I modified the two below NVInject.kext files for the the 8400GS 256MB

Try installing the first NVInject.kext file.

The easiest way to install is using Kext Helper.

Then restart!

It's that easy!

If the first file doesn't work properly with your card, then try the second NVInject.kext file.

Tell us how it goes!

Best,

John V.

Attached is the 0.2.1 NVInject.kext file for the 8400GS 256MB with the modified NVCAP string of 04000000 00000300 04000000 00000007 00000000 based on the Hardware Compatibility page:



Attached is the 0.2.1 NVInject.kext file for the 8400GS 256MB with the modified NVCAP string of 04000000 00000100 02000000 00000000 00000000 based on this thread:


the 2nd kext is the closest I've come with NVinject to getting my PNY GeForce 8400 GS VCG8400SXEB 256MB PCIe to work.

In general every method I try involves.. follow instructions.. boot to blue/black screen.. reboot to -s, cd to the extensions directory.. remove, reboot, and try again.

Using kext #2 I got 1920x1080 but the refresh rate looked off (kind of dull/fuzzy). I didn't see any good other resolutions to pick from on the Displays Pref Panel.. when I picked 1920x1080 @ 0 Hz.. well I kinda got exactly that.. nice blue screen :dance_24: (previous to this I did the cycle with kext #1, but that never booted to a usable screen)

As Murphy would have it.. now I can't even get back to getting kext #2 to work.. I keep booting to blue screen. I just used ox86tools to clear all caches, etc.

I can always get back to VESA by booting to -s, rm'ing, etc, but I seem to have very little ability to repeat the few partial successes I have (ie. tried kext #1 it failed, but kext #2 seemed close, and now I can't even get back to that...)

I've also tried EFI strings from OSX86Tools and EFI Studio for 8400gs256.. again, no luck.

Can anyone help me get this 8400gs working?

I am using iPC10.5.6

#1127
Teeno

Teeno

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

Kronoid,

Hope we can get your 8400GS going...but...looks like another successful 8800GT user above. :)

John


Hi I know this is an old post, but I am using the Asus EN8400GS (Silent) it is 512MB.
Will this method work for me ? Can I use the kext program and try the two kexts for nvidia you have posted?
does it matter that I have 512MB rather than 256 ? I can get screenoutput working. but no QE CI

thanks in advance.

#1128
Johnny V

Johnny V

    InsanelyMac Sage

  • Donators
  • 375 posts

Hi I know this is an old post, but I am using the Asus EN8400GS (Silent) it is 512MB.
Will this method work for me ? Can I use the kext program and try the two kexts for nvidia you have posted?
does it matter that I have 512MB rather than 256 ? I can get screenoutput working. but no QE CI

thanks in advance.


Are you running Leopard or Snow Leopard? Snow Leopard QE and CI does not show in System Profiler but still supported.

If you are running Leopard try the two kexts I've modified. Not sure if it will be an issue with the different VR sizes. Give it a try and get back to us.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy