Jump to content

Dell Vostro 1500 Mega Thread


  • Please log in to reply
473 replies to this topic

#441
medwezys

medwezys

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Vilnius, Lithuania

It`s already done!



I took the wrong nvidia driver, OS X 10.5.8 runs great now!

Thanks a lot to this thread ;)

Intel Wifi still does not work...Is there a solution?


Try Dell laptops post installer and choose Dell wireless kext, that should work. Also look at Dell laptops post installer readme instructions for wireless troubleshooting

#442
erq

erq

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I dont know why, but I cant' use my keyboard after I installed iatkos v7 ... I need help

I dont know why, but I cant' use my keyboard after I installed iatkos v7 ... I need help

#443
erq

erq

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I installed iatkos v7, but the audio dosn't work. Try to copy the AppleHDA.kext ,IOSDHCIBlockDevice and hdaenabler.kext to the sys/libr/extensions. But the system said these are not installed properly...

#444
Igortigor

Igortigor

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hello,
can you guys explain me step by step on how to do this kext thing to get sleep and battary indicator to work. I was trying to follow http://www.superhai.com/darwin.html guide, looked thru readme file, i just dont get it.


iATKOS v7
i have vostro 1500
8400 nvidia 128mb (installed 10.5.2_NVkexts+.pkg)
160gb hdd
4gb ram

#445
Jaggred

Jaggred

    InsanelyMac Protégé

  • Validating
  • Pip
  • 8 posts
  • Gender:Male

Anyone tried snow leo on vostro?


Im trying to do this, but ive got intel graphic, and need external monitor to start at all.

#446
ferroch85

ferroch85

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Hi everyone,
i've a dell vostro 1500 (8600m gt with core 2 duo t7300) and i NEED to install snow leopard on it.
I tried to search on the web some information, but every suggestion found is different. So i can't take a correct way to do this damn installation.
Can anyone give me a correct way to follow please?
Thank's

#447
sscotten

sscotten

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
looks like this thread is pretty much dead, but I figured I'd give it a try. I got my touchpad working via the PS2 fix (thanks to whoever posted that). It's kind of annoying that the tap-click doesn't work though. After looking thru this thread it looks like no one has gotten this to work, but any help regarding this would be appreciated.

#448
getthedrift86

getthedrift86

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I have successfully install snow leopard on a vostro 1500 with intel graphics using Empire EFI and retail disk. Upon booting the installer, the display goes dark. Wait 11 minutes or more and the display will go to sleep. Then move the mouse and the screen will turn on. After installing, I was getting kernel panics due to IOATAFamily.kext and Secondary IDE Channel disabled error. I read that this problem was fixed in 10.6.2+ so I booted using -x flag and used software update to install 10.6.3. After this, no more KPs.

My goal for this install is to keep System/Library/Extensions as close to 100% vanilla as possible. Currently, the only kexts I have added to S/L/E are VoodooPS2Controller and VoodooHDA, as I could not get these to load properly from /Extra/Extensions.

/Extra/Extensions includes
fakesmc.kext
NullCPUPowerManagement.kext
OpenHaltRestart.kext
PlatformUUID.kext
VoodooBattery.kext

Currently, I have no QE/CI or keyboard/trackpad in 64-bit mode. In 32-bit mode, I have QE/CI and keyboard/trackpad working. Restart and Shutdown are also working. Sleep does not work. I have not yet tried to mess with power management.

I believe that the X3100 can be made to work for 64-bit with DSDT fix now that snow leopard includes these drivers. I do not understand why VoodooPS2Controller is not working in 64-bits.

Also, VoodooBattery does not seem to be working quite right. It takes a long time (up to several minutes) in between updating the icon. For example, I can boot on AC power and then unplug, however the icon and the charge percentage/time does not change for several minutes. Additionally, VoodooBattery prints a ton of information to the system log, is this normal?

#449
ferroch85

ferroch85

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

I have successfully install snow leopard on a vostro 1500 with intel graphics using Empire EFI and retail disk. Upon booting the installer, the display goes dark. Wait 11 minutes or more and the display will go to sleep. Then move the mouse and the screen will turn on. After installing, I was getting kernel panics due to IOATAFamily.kext and Secondary IDE Channel disabled error. I read that this problem was fixed in 10.6.2+ so I booted using -x flag and used software update to install 10.6.3. After this, no more KPs.
.....


Do you have a BCM440X network card ? If yes, it's working correctly ? Because I've the same card but after few minutes of navigation I lose the connection!

#450
getthedrift86

getthedrift86

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Do you have a BCM440X network card ? If yes, it's working correctly ? Because I've the same card but after few minutes of navigation I lose the connection!


I had not checked my wired connection as I almost exclusively use wireless. There is no ethernet connection listed in the network menu. I'll have to see if I can figure this out.

#451
getthedrift86

getthedrift86

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I am having the same problem with the BCM440X. It looks like this is a known problem. Has anyone tried to compile the kext from the source?

Has anyone had success with the X3100 in 64bit mode? I have not been able to figure this out.

For what it's worth, I was able to get VoodooPS2 and VoodooHDA to load from /E/E so S/L/E is now 100% vanilla.

#452
Jaggred

Jaggred

    InsanelyMac Protégé

  • Validating
  • Pip
  • 8 posts
  • Gender:Male
I succesfully installed Snow on my Vostro 1500 with x3100 graphic with full QE/CI support.
Works everythink ok except Broadcom 440X. In 32 and 64 bit its lose connection after few minutes.

Somewhere i found that booting with maxmem=1024 sometimes helps.

Has anyone had success with the X3100 in 64bit mode? I have not been able to figure this out


What is your problem? Not QE/Ci support or black screen?

#453
getthedrift86

getthedrift86

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

I succesfully installed Snow on my Vostro 1500 with x3100 graphic with full QE/CI support.
Works everythink ok except Broadcom 440X. In 32 and 64 bit its lose connection after few minutes.

Somewhere i found that booting with maxmem=1024 sometimes helps.


What is your problem? Not QE/Ci support or black screen?



I have no QE/CI support. Well I used to. Now I can't boot into 64-bit at all. I originally installed snow on an external hard drive so that I wouldn't damage my leopard partition while I messed with snow. Once I got to a point where I was happy I used carbon copy cloner to put snow on the internal hard drive. Now when I boot from internal drive in 64-bit mode I get kernel panics due to HPET and AppleCPUPowerManagement. However, 32-bit works perfectly.

The only things that are different between the external drive and the internal drive are
1) External drive was GUID, internal drive is MBR
2) I used migration assistant to restore my files from my leopard installation.

I really don't know why either would cause a problem. I have NullCPUManagement and patched DSDT so I don't know why I am getting HPET errors.


Anyways, whats the trick to getting QE/CI for the X3100 in 64-bits?

#454
Jaggred

Jaggred

    InsanelyMac Protégé

  • Validating
  • Pip
  • 8 posts
  • Gender:Male
here is my drivers for x3100 for 64 bit
http://rapidshare.co..._QE_OK.zip.html

i needed to remove from my dsdt all CRT and TV devices. Otherwise the screen was black on start.
But with that drivers QE/CI works (changing resolution also)

Post your results.

#455
getthedrift86

getthedrift86

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

here is my drivers for x3100 for 64 bit
http://rapidshare.co..._QE_OK.zip.html

i needed to remove from my dsdt all CRT and TV devices. Otherwise the screen was black on start.
But with that drivers QE/CI works (changing resolution also)

Post your results.



No dice for me. I tried using your kexts (which seem to be older versions than mine) and still had no QE/CI in 64-bit. Additionally I was not able to run 32-bits anymore. Oh well, I guess I'll just stick with 32-bits, I don't know what else to try.

#456
cu3edweb

cu3edweb

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

No dice for me. I tried using your kexts (which seem to be older versions than mine) and still had no QE/CI in 64-bit. Additionally I was not able to run 32-bits anymore. Oh well, I guess I'll just stick with 32-bits, I don't know what else to try.


I was not able to get this to work either. I have not been able to get anything to work. The only way I can get a black screen is if I have the proper system kext from 10.6.2 update installed other then that I just get 1024x768 vesa with no kext loaded. When I do get the black screen the laptop monitor is completely off and if I plug in an external monitor it thinks it is a secondary desktop so I can't do anything from there. I am at a loss. I had so many problems getting the monitor to work with 10.5 and I never could get full 1680x1050 res the best I ever did was 1600x1000 but I did have QE/CI working which is more important to me. Vanilla snow leopard seems to run much smoother and the only thing that I need working is my x3100 with QE/CI. Anyone with some drivers or things that I can try?

#457
danfromwaterloo

danfromwaterloo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi all,

I've decided to take the plunge to try and convert my Vostro 1500 to a hackintosh. Does anybody know if there's a consolidated guide of some sort to getting Snow Leopard on my Vostro 1500 - if it's even possible? I can read through this, but it seems like it's only for Leopard. I need to do iPad dev, so I'm hoping it's possible so I won't need to buy a Mac.

Ideas? Much appreciated.

#458
imseth

imseth

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
Thanku

#459
Eddie09

Eddie09

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey guys ive tried a few years ago to do this and im going to give it another go later on this week but im stuck i cant find iatkosir2 anywhere should i get iatkos v7 instead?
so if the answer is yes, is this what i need or is there any updated version for the dell vostro 1500 on the web now?

1 x copy iATKOS v7 Burned to DVD
1 x copy GParted Live CD
1 x copy Windows XP Professional x64 Edition (I recommend a volume license, easier that way.)
1 x Vostro 1500 as configured above
1 x kalyway_hack_10.5.2ComboUpdate
1 x kalyway_10.5.2_kernels.mpkg.zip
Patience
Time
A basic working knowledge of your computer

thanks
eddie

#460
timeshifter

timeshifter

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts
I'm tempted to give this another go. I've had 10.5.2 (or 3 or 4, don't remember) in a second partition on my Vostro 1500. I boot it occasionally when needed. Power management never worked. Most other things did. But, without power management it's not too useful on a laptop.

I stumbled upon this:
http://wiki.osx86pro...les#Vostro_1500

Someone posted in the wiki and it seems they've got everything working with 10.6.5 on this machine. I'm tempted again. Looks like the key may be "Chameleon RC5 Unofficial by iFabio". I found this topic:

http://www.insanelym...howtopic=231075

Anyone else using that for a Vostro 1500?

It would be nirvana if I could get all that working AND my built-in WWAN card for AT&T 3G service.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy