Jump to content

Fully working 10.5.2 AppleSMBIOS and Source finally available!

* * * * * 4 votes

  • Please log in to reply
149 replies to this topic

#141
MacUser2525

MacUser2525

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,523 posts
  • Gender:Male
  • Location:Canada

hi...

can anyone pointing me on how to install AppleSMBios and make it work?

thanx all!


Download the the .kext version you want now it most probably went into your home Downloads directory so open your main OSX partition in finder click on your User_Name in the left of the window. Then double click on the Downloads folder do the same again on the zipped .kext to have it uncompressed. Look at the left pane again go there to click on the Applications folder scroll down until you can double click on the Utilities folder again scroll down until you can double click on the Terminal application when it opens put in this series of commands.

sudo -s

Type in the password you set for your account then hit the enter key.

mv /System/Library/Extensions/AppleSMBIOS.kext  /System/Library/Extensions/AppleSMBIOS.kext.backup
   cp -R ~/Downloads/AppleSMBIOS.kext /System/Library/Extensions/
   chown -R 0:0 /System/Library/Extensions/AppleSMBIOS.kext
   chmod -R 755 /System/Library/Extensions/AppleSMBIOS.kext
   diskutil repairPermissions /
   rm -r /System/Library/Extensions/Caches
   rm -r /System/Library/Extensions.mkext
   rm -r /System/Library/Caches

Now you reboot hitting the F8 when the OS starts when at the EFI boot menu that comes up do the hit any key it suggest and type in then hit the enter key -f to force the reload of all the .kext on the system if all went well then the new .kext you installed will be in use.

#142
E-Chris

E-Chris

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
Looks like this version of AppleSMBIOS (rev 6), causes FireWire 800 ports not to work.

I just reinstalled using iATKOS 2 (10.5.2), and using the default AppleSMBIOS.kext allows the firewire 800 drives to mount, but when I installed this AppleSMBIOS it causes the drive to no longer mount.

Any work-around for this?

#143
MacUser2525

MacUser2525

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,523 posts
  • Gender:Male
  • Location:Canada

Looks like this version of AppleSMBIOS (rev 6), causes FireWire 800 ports not to work.

I just reinstalled using iATKOS 2 (10.5.2), and using the default AppleSMBIOS.kext allows the firewire 800 drives to mount, but when I installed this AppleSMBIOS it causes the drive to no longer mount.

Any work-around for this?


Try using the AppleSMBIOSEFI in the thread below this way it is not necessary to replace the Apple one.

http://forum.insanel...o...108606&st=0

#144
crazyJAT

crazyJAT

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 301 posts
  • Gender:Male
  • Location:US
Website responds as if it were being hosted on a dial up connection. Something wrong with the server?

#145
rapt0r

rapt0r

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
main link not working . Can anyone upload applesmbios-27 on RS or here

#146
MacUser2525

MacUser2525

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,523 posts
  • Gender:Male
  • Location:Canada

main link not working . Can anyone upload applesmbios-27 on RS or here


Here is the version -28 I have.

Attached Files



#147
freanux

freanux

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hello

You're right, I cannot download mac.nub's source code. :huh:
Can someone upload the source code of the AppleSMBIOS-27-Rev6?

Thank you :thumbsup_anim:

#148
IntVar

IntVar

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Please, someone upload the source code for AppleSMBIOS-27-Rev6!! :( :unsure:

#149
gabriel.me

gabriel.me

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Here is the version -28 I have.


excuse me...

this AppleSMBIOSEFI_28.zip is compatible for AMD?

I use leo 10.5.6 ratail with kernel voodoo 9.5.0....


thank you

#150
gabriel.me

gabriel.me

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Which APPLESMBIOS do I apply in my AMD?

LEO 10.5.6





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy