Jump to content

Lenovo ThinkPad X61 Tablet


  • Please log in to reply
574 replies to this topic

#521
mulletman13

mulletman13

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
Just curious to the OP-- do all of these other kexts work fine with Snow Leopard? It seems that nearly everything works fine in 10.5 (from what I've been reading), but how about 10.6? I haven't found any good threads (other than this one) regarding the X61 due to the search function failing again and again.

How is the status of SL on an X61?

#522
insmacjo

insmacjo

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

About using the PCMCIA slot:

I installed chun nans device driver for pcmcia (in Extra). This kext contains a modified pci - device driver (v 2.6) and the pccard driver. It is working on a X61 Tablet. First, it broke the ability to sleep (S3). After that i entered System bios and switched from AHCI to Compatible mode (SATA Controller). After that, hdd performance is little bit slower, but the X61 is sleeping again. I bought a LogiLink eSata PCMCIA Card (2 x 150 MBit/s). It contains a Silicon Magic 3112a Chip. There is at that time not a driver for this chipset. You may use the appleviaata.kext, mod. it using the device id and product id of you SATA Card. So it works for me. I tried the driver for the Sil Magic 3132 to, this chipset is used in many ExpressCard eSATA Controllers. After deleting the JmicronATA driver and the generic apple piixata driver it worked too, its faster booting with that chip.

Alex, using a X61 Tablet with 10.6.2


Bios Versions up to 1.23 for X61t contain a bug (at least under Win) resulting in Bluescreens or system halts

http://forums.lenovo...;thread.id=3777

(last posting from me)

There is a newer Bios Ver 1.24 out. I will test this one under Win with a PCMCIA Sata Card based on Via6421 ...

Maybe it's just Win related, maybe not...

hope to help.

PS. What about Sound ? There once was a kext for sound, mic and headphones. Is there already a X64 version for that ?

Thx

#523
grandflash

grandflash

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts

Bios Versions up to 1.23 for X61t contain a bug (at least under Win) resulting in Bluescreens or system halts

http://forums.lenovo...;thread.id=3777

(last posting from me)

There is a newer Bios Ver 1.24 out. I will test this one under Win with a PCMCIA Sata Card based on Via6421 ...

Maybe it's just Win related, maybe not...

hope to help.

PS. What about Sound ? There once was a kext for sound, mic and headphones. Is there already a X64 version for that ?

Thx



Sound: Version 10.5.3 of AppleHDA.kext is working well. I used to modify a 10.6.2 Version of 64 bit AppleHDA, but without having mic in working.

PCMCIA: Might you test your PCMCIA Card with VIA Chip on Mac OS ? Could you test the AppleVIAATA.kext Version 0.2 ? http://darwin-ata.go...A.kext-v0.2.zip

My PCMCIA went back to AMAZON, cause the Sil3112 Chip was recocnized, but incredible slow writing data.

#524
insmacjo

insmacjo

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

Sound: Version 10.5.3 of AppleHDA.kext is working well. I used to modify a 10.6.2 Version of 64 bit AppleHDA, but without having mic in working.

PCMCIA: Might you test your PCMCIA Card with VIA Chip on Mac OS ? Could you test the AppleVIAATA.kext Version 0.2 ? http://darwin-ata.go...A.kext-v0.2.zip

My PCMCIA went back to AMAZON, cause the Sil3112 Chip was recocnized, but incredible slow writing data.



Regarding PCMCIA tests under Mac OS:

Atm I'm having no Mac system to test this. But as the holidays are getting closer so is spare time ...

I tried Sil3112 by myself under X61t running XP. Had several Bluescreens under heavy data traffic. Card was running hot, but as several users had the same prob with different Chipsets, this had to be a differnet problem. So the conclusion is Bios releated:

See this for further infos:

http://2xod.com/arti...61 Slow PCMCIA/

Send the card back as well.


But let's get back to Mac.


About Audio:

As you seem to be skilled enough :thumbsup_anim: to modify AppleHDA X64 ?:

http://www.insanelym...p...2676&st=160

post #174 talks in detail about pin configurations, maybe that's the path to wisdom ...

Maybe priitv8 should get contacted regarding mic.

Did I get you right: Speaker and Headphone is working with you modified X64 AppleHDA ?


Im getting slightly confused abou what works and what exactly is missing for a X61(t) to work unser SL X64 ...

Maybe outZider also finds some time to update his top posting for SL (X64).

Hanz

#525
grandflash

grandflash

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts

Regarding PCMCIA tests under Mac OS:

Atm I'm having no Mac system to test this. But as the holidays are getting closer so is spare time ...

I tried Sil3112 by myself under X61t running XP. Had several Bluescreens under heavy data traffic. Card was running hot, but as several users had the same prob with different Chipsets, this had to be a differnet problem. So the conclusion is Bios releated:

See this for further infos:

http://2xod.com/arti...61 Slow PCMCIA/

Send the card back as well.


But let's get back to Mac.


About Audio:

As you seem to be skilled enough :thumbsup_anim: to modify AppleHDA X64 ?:

http://www.insanelym...p...2676&st=160

post #174 talks in detail about pin configurations, maybe that's the path to wisdom ...

Maybe priitv8 should get contacted regarding mic.

Did I get you right: Speaker and Headphone is working with you modified X64 AppleHDA ?


I�m getting slightly confused abou what works and what exactly is missing for a X61(t) to work unser SL X64 ...

Maybe outZider also finds some time to update his top posting for SL (X64).

Hanz


Well, quite confusing. I can sent you latest AppleHDA.kext for 64bit (10.6.2 Version) in app. 6 hours, I will post it here. Speaker and Headphone works. I will check your link to.
I got all 64 bit drivers including wlan(atheros) / gmax3100 (breaks brightness) / mouse/keyboard / parallels 5 / eyetv

By the way, i bought http://www.firmtek.c...k/seritek-1sm2/ hope that one will work.

I use a modified bios for my x61 to enable certain wlan and umts cards. Maybe there is an update to. 1.24 works?

#526
insmacjo

insmacjo

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

Well, quite confusing. I can sent you latest AppleHDA.kext for 64bit (10.6.2 Version) in app. 6 hours, I will post it here. Speaker and Headphone works. I will check your link to.
I got all 64 bit drivers including wlan(atheros) / gmax3100 (breaks brightness) / mouse/keyboard / parallels 5 / eyetv

By the way, i bought http://www.firmtek.c...k/seritek-1sm2/ hope that one will work.

I use a modified bios for my x61 to enable certain wlan and umts cards. Maybe there is an update to. 1.24 works?


There is a tool from z***er that can patch normal bioses to those bios version you are talking about ...

#527
insmacjo

insmacjo

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Here:

http://www.kexts.com...2--64-bit).html

is a kext called HDAEnabler wich does "Inject audio layouts in conjunction with a modded AppleHDA"

would this be helpful in conjunction with the pin layout and the pin-modded AppleHDA from priitv8 mentioned above ?

Merry X-Mas

#528
grandflash

grandflash

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
Snow Leopard 10.6.2 and Bluetooth:

I got Bluetooth working by deleting AppleHPET.kext + AppleLPC.kext. I added Vendor-ID and Product-ID to IOBluetoothFamily.kext/Contents/Plugins/BroadcomUSBBluetoothHCIController.kext/Contents/Info.plist under scope Broadcom2046FamilyUSBBluetoothHCIController_D

#529
insmacjo

insmacjo

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

Snow Leopard 10.6.2 and Bluetooth:

I got Bluetooth working by deleting AppleHPET.kext + AppleLPC.kext. I added Vendor-ID and Product-ID to IOBluetoothFamily.kext/Contents/Plugins/BroadcomUSBBluetoothHCIController.kext/Contents/Info.plist under scope Broadcom2046FamilyUSBBluetoothHCIController_D


Nice :(

Can you make the kext available here ?

Well, quite confusing. I can sent you latest AppleHDA.kext for 64bit (10.6.2 Version) in app. 6 hours, I will post it here. Speaker and Headphone works.


This seem to be the longest 6 hours I've been waiting for ;)

Nice to hear from you. First I thought that you hadn't "Einen guten Rutsch".

PS. Do you need further help on WWAN Bios ?

#530
grandflash

grandflash

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts

Nice ;)

Can you make the kext available here ?



This seem to be the longest 6 hours I've been waiting for ;)

Nice to hear from you. First I thought that you hadn't "Einen guten Rutsch".

PS. Do you need further help on WWAN Bios ?

Attached Files



#531
insmacjo

insmacjo

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Thanks a lot grandflash.

Will try your files as soon as I have some spare time to completely set up an new SL64 on X61t.

I hope I don't stand as a leecher here ...

Time to sort tutorials, files and brains.

PS. Wenn Du mich mal in Deutsch kontaktieren möchtest (im TP Forum bspws.) dann gib kurz Laut hier.

#532
vmendez

vmendez

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I got Bluetooth working on my x61t with snow leopard. When I put it to sleep it will wake up right away. If I put it to sleep again then it will stay in sleep mode. The problem is when I wake from sleep, Bluetooth no longer works until I restart the machine again. Has anyone else seen this issue?

Thanks,

#533
MagiCicada

MagiCicada

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

I have a x60 Tablet with Snow Leopard, but I was not able to get the trackpoint working either. It worked on Leopard with the ApplePS2Controller.kext fix. However, both the VoodooPS2Controller and the ACPIPS2Nub+ApplePS2Controller result in the same result: the keyboard works but the trackpoint doesn't.


I have x60 tablet too! I have tried to install couple versions of snow leopard without any luck. I always have kernel panic. I installed leopard with "Leo4all v3" and it works fine. so which version of snow leopard that you used or how did you got your x60 tablet installed with snow leopard?? any hints will appreciate!! Thanks a lot.

#534
vmendez

vmendez

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

I have x60 tablet too! I have tried to install couple versions of snow leopard without any luck. I always have kernel panic. I installed leopard with "Leo4all v3" and it works fine. so which version of snow leopard that you used or how did you got your x60 tablet installed with snow leopard?? any hints will appreciate!! Thanks a lot.


To get past the kernel panic you need to disable AHCI from the BIOS. I did this on a X61t, I am not sure if you have the same hardware on the X60t. I installed from the Leo CD to the hard disk using a mac mini.

#535
yTsur

yTsur

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
To you guys running Snow Leopard, is your FSB being read correctly?

#536
Silencers

Silencers

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Riga, Latvia
For everyone with PS2 kexts problems, here are two different packs of PS2 kexts, both work on my T60p in 32-bit and x64.

The first one is Synaptics PS2 pack, which will allow you to use two finger scrolling on trackpad and there's also pref pane included to allow very fine tuning. But trackpoint won't work.
http://rapidshare.co...cs_ApplePS2.zip

The other is regular PS2 kexts which will work in x64, allowing to work both trackpoint and trackpad, but no two finger scrolling on trackpad. 
http://rapidshare.co.../Legacy_PS2.zip

I also include pfix 2.3 to use for kext caches regeneration. You can use PS2 kexts in /Extra/Extensions, but you MUST generate mkext cache, otherwise they won't get picked up during boot. So run pfix after any changes in your kexts.
http://rapidshare.co.../350254645/pfix

#537
michaaa62

michaaa62

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Berlin, Germany

I have x60 tablet too! I have tried to install couple versions of snow leopard without any luck. I always have kernel panic. I installed leopard with "Leo4all v3" and it works fine. so which version of snow leopard that you used or how did you got your x60 tablet installed with snow leopard?? any hints will appreciate!! Thanks a lot.


I used iPortable_Snow_x86_Installer, which also has a very fine documentation of the process.

But it needs a working Mac OSX install. Both iAtkosV7 and Leo4AllV3 worked on my x60t to get up with 10.5 Leopard.

#538
Defender666

Defender666

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
Hi.

i'm on an HP6710b notebook and use 10.6.2

I have the brightness fix in dsdt.aml to get brightness control, however it controls brightness not correctly. (uneven)

using the ./brithness tool i can dimm to 0.95

Do you also use the old FB-Kext for 10.6 ?? I currently use vanilla drivers and have vanilla power management working fine. The only issue is the brightness control.

Is there no way to reassign the range such that F13 /F14 (Scroll/Pause) control the brightness between 0.95 and 1 so it dimms nicely?

Is replacing the FB file the only option? Do you have any dsdt progress?

#539
grandflash

grandflash

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts

Hi.

i'm on an HP6710b notebook and use 10.6.2

I have the brightness fix in dsdt.aml to get brightness control, however it controls brightness not correctly. (uneven)

using the ./brithness tool i can dimm to 0.95

Do you also use the old FB-Kext for 10.6 ?? I currently use vanilla drivers and have vanilla power management working fine. The only issue is the brightness control.

Is there no way to reassign the range such that F13 /F14 (Scroll/Pause) control the brightness between 0.95 and 1 so it dimms nicely?

Is replacing the FB file the only option? Do you have any dsdt progress?


We use an EFI injection file (first page / first post) for X3100, Sound and Ethernet. This file is a PLIST file in XML schemata. So this EFI injection + "old" FB + DSDT entry may work for your computer also?

#540
menuhin

menuhin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Internal Mic Microphone working?

Hi all,

What is the state of the art now?
All friends here have snow leopard installed on their Thinkpad x61t / x60t?

I booted into my leopard (10.5) partition yesterday and found everything working smoothly - except for the internal microphone and the wacom tablet...
Hope to fix these some time in 2010.

- M





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy