Jump to content

Lenovo ThinkPad X61 Tablet


  • Please log in to reply
574 replies to this topic

#241
outZider

outZider

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 175 posts

how do i fix it, and get the tablet working?

Have you repaired permissions? Did you make any changes to Apple16X50Serial.kext?

#242
Doctor Paras

Doctor Paras

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
at my last try i used sudo chown -R root:wheel /System/Library/Extensions/Apple16X50Serial.kext and sudo chmod -R 755 /System/Library/Extensions/Apple16X50Serial.kext

in /System/Library/Extensions/Apple16X50Serial.kext/Contents/PlugIns/Apple16X50ACPI.kext/Contents/Info.plist i changed PNP0501' in 'WACF004'.

wich further steps are necessary?

#243
outZider

outZider

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 175 posts

at my last try i used sudo chown -R root:wheel /System/Library/Extensions/Apple16X50Serial.kext and sudo chmod -R 755 /System/Library/Extensions/Apple16X50Serial.kext

in /System/Library/Extensions/Apple16X50Serial.kext/Contents/PlugIns/Apple16X50ACPI.kext/Contents/Info.plist i changed PNP0501' in 'WACF004'.

wich further steps are necessary?

what does kextload -t /System/Library/Extensions/Apple16X50Serial.kext tell you?

#244
Doctor Paras

Doctor Paras

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
kextload tells me:

kextload: extension /System/Library/Extensions/Apple16X50Serial.kext appears to be loadable
kextload: /System/Library/Extensions/Apple16X50Serial.kext loaded successfully


what do i wrong?

#245
chonglinmao

chonglinmao

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I have a Lenovo x61 tablet too, and I followed this thread convert the laptop to a dual boot. Yesterday I updated to 10.5.6, after update, keyboard and mouse are not working, WLAN, powermanagement, and tablet are not working also, I just simply reload all the kext I download here, and it works fine now. Thanks everyone here, I had a lot fun with my Mac tablet :hysterical:

#246
Doctor Paras

Doctor Paras

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
did someone enable the screen rotation?

#247
Gh0sted

Gh0sted

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:New York
Thanks for updating the post; the Ethernet driver kext worked perfectly when installed with b7 on my x61 (restarting wasn't necessary).

#248
Gh0sted

Gh0sted

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:New York

Thanks for updating the post; the Ethernet driver kext worked perfectly when installed with b7 on my x61 (restarting wasn't necessary).


Hey, and apple's 10.5.6 combo update (from 10.5.5) works flawlessly with the DSDT patch + chameleon (v9) 1.0.12 on an x61, just make sure you install the AppleIntelCPUPowerManagement.kext from 10.5.5 after installing the DSDT patch but before the update (or else you will get a kernel panic during the installation). In addition, the TurnLidOn method no longer sleeps the kernel in 10.5.6, so you need to replace TurnLidOn.kext with ClamshellDisplay.kext, simply do a search for it in the meantime.

Here is a pic: 10.5.6

If people are still having keyboard and trackpoint trouble after updating, simply install the two (already patched) kexts linked here; the 10.5.5 CPUPowerManagement kext is also posted:

Attached Files



#249
nirvanaguy19

nirvanaguy19

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts
couple of x61 leopard questions

does speed step work when leopard is installed with vanilla kernel

how much battery life do you get in leopard

is it possible to increase/decrease lcd brightness

#250
acoma

acoma

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Trying to write an easy guide for iATKos 5i and x61 tablet as it's going to take forever to work through this thread (especially as I have to reboot out of osx whenever I want to get online!), progress so far - http://forum.insanel...howtopic=145282

#251
acoma

acoma

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
links for audio in first post don't work?

The link that says it's to a thread instead actually downloads 'appleps2keyboard.kext.zip' and the other link is 403 forbidden.

#252
mathmonkey

mathmonkey

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi. I'm an X61 tablet owner and would like to try this out. However, the first post of this thread says the instructions are out of date. Are there more recent instructions for installation anywhere? I'm a little confused about where to start.
Thanks.

#253
acoma

acoma

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
look 2 posts up.

#254
acoma

acoma

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Can anyone help? I've tried to get the tablet to workwith iATKos 5i like this -

TabletMagic - http://sourceforge.n...ts/tabletmagic/ (tried b14 and b15)
ThinkPadTabletEnabler.kext from above.

Copied /System/Library/Extensions/Apple16X50Serial.kext out to somewhere i didn't need elevated permissions to edit it.

view contents - went to /Contents/PlugIns/Apple16X50ACPI.kext viewed contents on that and went to /Contents/Info.plist double clicked to open in property list editor.
in that browse to Information Property List - > IOKitPersonalities -> ACPI 16X50 Serial Port -> IONameMatch : changed it to an array and added strings PNP0501 to WACF004, saved the file. (it looks identical to the one on offer to download here)

use kext helper to load the newly modified kext, also hit the kext permissions button and ran the script.

to all accounts this should have worked, but it has not for me, it has added serial0 to the dropdown in tabletmagic, but no tablet is detected :-(
I have tried with the serial port in the BIOS listed enabled and disabled it seems to make no difference to the number of serial ports TabletMagic lists.
x61t SXGA+.

checking ioreg -l it confirms that WACF004 is the correct string.
All i get is 'no tablet found' in TabletMagic.

#255
grandflash

grandflash

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
I confirm the SD Card Reader to be working in a L X61 Tablet PC.

Attached Files



#256
guffin

guffin

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I had a little bit of trouble getting my x61 to recognize the 38400 baud rate, so i downloaded the table magic source and replaced 19200 with 38400 everywhere. After compiling, it works perfectly! I attached the necessary replacement here:

Just follow the steps below

0) unzip TabletMagicDaemon.zip

1) In Tablet Magic, under "Extras" select "Kill Daemon"

2) In terminal, type

sudo cp /Library/PreferencePanes/TabletMagic.prefPane/Contents/Resources/TabletMagicDaemon /Library/PreferencePanes/TabletMagic.prefPane/Contents/Resources/TabletMagicDaemon.old
sudo cp /path/to/TabletMagicDaemon /Library/PreferencePanes/TabletMagic.prefPane/Contents/Resources/TabletMagicDaemon

3) In Tablet Magic, select "Enabled"

Note that under "Setup", the baud rate will appear as 2400. It will work anyway.

Hope this helps someone,

Cheers.

Attached File  TabletMagicDaemon.zip   31.19KB   136 downloads

#257
xto

xto

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

I had a little bit of trouble getting my x61 to recognize the 38400 baud rate, so i downloaded the table magic source and replaced 19200 with 38400 everywhere. After compiling, it works perfectly! I attached the necessary replacement here:

Just follow the steps below

0) unzip TabletMagicDaemon.zip

1) In Tablet Magic, under "Extras" select "Kill Daemon"

2) In terminal, type

sudo cp /Library/PreferencePanes/TabletMagic.prefPane/Contents/Resources/TabletMagicDaemon /Library/PreferencePanes/TabletMagic.prefPane/Contents/Resources/TabletMagicDaemon.old
sudo cp /path/to/TabletMagicDaemon /Library/PreferencePanes/TabletMagic.prefPane/Contents/Resources/TabletMagicDaemon

3) In Tablet Magic, select "Enabled"

Note that under "Setup", the baud rate will appear as 2400. It will work anyway.

Hope this helps someone,

Cheers.

Attached File  TabletMagicDaemon.zip   31.19KB   136 downloads



Hi Guffin!

Were you able to have your X61T touchscreen working?

I would presume your X61T is the Multi-Touch Multi-View screen as you are using 38400.
I downloaded your daemon and followed your procedure but i'm not getting positive results. And when i reboot the computer, it shows that Apple16X50Serial.kext cannot be used and was wrongly installed. Re-install/repaired permissions but tablet still not working. BTW i have changed WACF004 to WACF008 on the info.plist of Apple16X50ACPI.kext.

Appreciate if you can perhaps post your entire procedure here.

Have been working over a month to have my touchscreen work but still zero outcome.

#258
el31415

el31415

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
did anyone updated 10 10.5.6 ?

#259
acoma

acoma

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Many, it's easy from iatkos 5i with the right install options.

#260
digitalhav0c

digitalhav0c

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Can anybody connect to secured wireless access points? I purchased the atheros based ibm card from the first post, I can connect to unsecured access points fine but my system will not connect to secured. Does anyone know if there is a fix for this? Also can the the screen be rotated in mac osx?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy