Jump to content

'SAM Multimedia: READ or WRITE failed etc.' in WORKING LEOPARD INSTALL after inserting a CD/DVD in my SATA DVD-RW. the media doesn't mount either..


  • Please log in to reply
18 replies to this topic

#1
arthur5005

arthur5005

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
(I posted this on the NForce SATA Driver Thread, got no response, figured it was about time it merrited it's own post)

Got a minute? I promise you I'm mentally retarded or a selfish n00b, so if you can give me the time of day on this one, you'd make my day! lol.

Ok after spending on and off several weeks getting Leopard installed on my PC for the first time! (With my nforce 430 MCP51 chipset)
I was finally able to get my SATA drive to read and WRITE!! w00t!
(I had it installed on a partition on my External HD, inserted appropriate kexts using TransMac with the new MeDevil AppleNForceATA.kext, did a carbon copy over and VOILA, somehow it loaded without correcting permissions, which I corrected after it started up),

I've had a wonderful time getting my network card, sound card, and Nvidia card working with QI/CE (w00t).. and I thought all was perfectly well!!...

until I realized, that even though it recognized my DVD R/W under SATA controllers and a Burning Device.. it wouldn't mount any of the medias I put into it.. nor would it burn properly..

no disc icon on my desktop, my DVD-ROM drive would sit there and read away without and progression, and I could eject it with the button on my drive.

So I took a look in my system.log and I saw:

13/02/08 12:34:28 AM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x06, ASC = 0x29, ASCQ = 0x00

Which repeats a whole bunch of times, until I eject the DVD or CD.

I noticed some other people had a similar problem in the NForce SATA Driver thread, but after looking through nearly 20 pages no one has pointed out a solution, and all the forums I can find (here and through google) just make mention that the install DVD is a bad burn (this is of course in the context of an installation)

Has anyone solved this problem? Considering I started this endeavor just about a month ago, I'm still a bit confused about how the kernel extensions work exactly (It's my first hackintosh! please bear with me it's been many hours of dedicated reading, I know answers don't fall from the sky! lol).

I mean, thinking back is it really a good idea to have AppleNForceATA.kext in both the extensions folder AND in the IOATAFamily.kext/Contents/PlugIns/?


I know for a fact I don't have any other types of controllers, it says in my bios that both my HD and DVD-R/W are SATA controllers, and I can see clearly that my Windows Device Manager there's no IDE or other controllers.

I know both my Dev Ids are listed in the Info.plist of my AppleNForceATA.kext
I've tried removing all the Dev IDs for the PATA Controllers in my Info.plist (again refering to the AppleNForceATA.kext driver) with no change.

I can see that my Leopard partition is /dev/disk0s2
and my ASUS DVD R/W is /dev/disk1s0


Could anything be wrong with IRQs? In my startup I have this:

12/02/08 3:47:39 AM kernel Skipping duplicate extension "com.nvidia.driver.AppleNForceATA" with older/same  version (1.0.3 -> 1.0.3). 
12/02/08 3:47:39 AM kernel AppleNForceATA: sata phy reset done. 
12/02/08 3:47:39 AM kernel AppleNForceATA: sata phy reset done. 
12/02/08 3:47:39 AM kernel AppleNForceATA: found 1 units. 
12/02/08 3:47:39 AM kernel AppleNForceATA: found 1 units. 
12/02/08 3:47:39 AM kernel AppleNForceATA: NVIDIA nForce MCP 51 Serial ATA by MeDevil (CMD 0x970, CTR 0xb70, IRQ 23, BM 0xe008) 
12/02/08 3:47:39 AM kernel AppleNForceATA: NVIDIA nForce MCP 51 Serial ATA by MeDevil (CMD 0x9f0, CTR 0xbf0, IRQ 23, BM 0xe000) 
12/02/08 3:47:39 AM kernel Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SAT1@E/AppleNForceATARoot/PRI0@0/AppleNForceATA/ATADeviceNub@0/IOATABlockStorageDriver/IOATABlockStorageDevice/IOBlockStorageDriver/WDC WD800JD-75MSA3 Media/IOFDiskPartitionScheme/Untitled 2@2 
12/02/08 3:47:39 AM kernel AppleNForceATA: warning: phy connection failed. status=0x00000000 
12/02/08 3:47:39 AM kernel AppleNForceATA: warning: phy connection failed. status=0x00000000 
12/02/08 3:47:39 AM kernel AppleNForceATA: found 0 units. 
12/02/08 3:47:39 AM kernel AppleNForceATA: found 0 units.

I see it loads two seperate items (at least I'm assuming) with the same IRQ (23), but I know for a fact that my second SATA controller is 22..

So... If you've read this far, you're an angel, and may your Karma grow exponentially!!! ..(seriously, that was alot to read!)

just for FYI
My System:

Leopard 10.5.1 Zephyroth
Dell C521 (half-height case)
AMD Sempron 3400+ (64bit)
nForce 430 Chipset MCP51 (under new MeDevil AppleNForceATA.kext)
GeForce 7300GS (under Natit)
SATA controllers for both HD and DVD R/W



If someone could help me that would be phenomenal!
Otherwise everything else works GREAT!
And I can't thank the community enough. I'm standing on the shoulders of hundreds of thousands of people's dedicated hours to problem solving and driver development. And because of the forums and the Wiki. I didn't have to harass a single soul to get as far as I am.. (lol until now!)

Best!
Arthur

#2
arthur5005

arthur5005

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Oh and I forgot to include this information:
===DVD R/W===

Serial-ATA Bus:

ASUS	DRW-1814BLT:

  Model:	ASUS	DRW-1814BLT
  Revision:	1.04
  Serial Number:	
  Detachable Drive:	No
  Protocol:	atapi
  Unit Number:	0
  Socket Type:	Serial-ATA

ASUS DRW-1814BLT:

  Firmware Revision:	1.04
  Interconnect:	ATAPI
  Burn Support:	Yes (Generic Drive Support)
  Profile Path:	None
  Cache:	2048 KB
  Reads DVD:	Yes
  CD-Write:	-R, -RW
  DVD-Write:	-R, -R DL, -RAM, -RW, +R, +R DL, +RW
  Write Strategies:	CD-TAO, CD-SAO, CD-Raw, DVD-DAO
  Media:	Insert media and refresh to show available burn speeds



===HD===

Serial-ATA Bus:

WDC WD800JD-75MSA3:

  Capacity:	74.51 GB
  Model:	WDC WD800JD-75MSA3
  Revision:	10.01E04
  Serial Number:	WD-WMAM9MR28033
  Removable Media:	No
  Detachable Drive:	No
  BSD Name:	disk0
  Protocol:	ata
  Unit Number:	0
  Socket Type:	Serial-ATA
  Mac OS 9 Drivers:	No
  Partition Map Type:	MBR (Master Boot Record)
  S.M.A.R.T. status:	Verified
  Volumes:
macosx:
  Capacity:	20.24 GB
  Available:	12.93 GB
  Writable:	Yes
  File System:	Journaled HFS+
  BSD Name:	disk0s2
  Mount Point:	/


#3
zandera

zandera

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Prague

Oh and I forgot to include this information:

===DVD R/W===
 
 Serial-ATA Bus:
 
 ASUS	DRW-1814BLT:
 
   Model:	ASUS	DRW-1814BLT
   Revision:	1.04
   Serial Number:	
   Detachable Drive:	No
   Protocol:	atapi
   Unit Number:	0
   Socket Type:	Serial-ATA
 
 ASUS DRW-1814BLT:
 
   Firmware Revision:	1.04
   Interconnect:	ATAPI
   Burn Support:	Yes (Generic Drive Support)
   Profile Path:	None
   Cache:	2048 KB
   Reads DVD:	Yes
   CD-Write:	-R, -RW
   DVD-Write:	-R, -R DL, -RAM, -RW, +R, +R DL, +RW
   Write Strategies:	CD-TAO, CD-SAO, CD-Raw, DVD-DAO
   Media:	Insert media and refresh to show available burn speeds
 
 
 
 ===HD===
 
 Serial-ATA Bus:
 
 WDC WD800JD-75MSA3:
 
   Capacity:	74.51 GB
   Model:	WDC WD800JD-75MSA3
   Revision:	10.01E04
   Serial Number:	WD-WMAM9MR28033
   Removable Media:	No
   Detachable Drive:	No
   BSD Name:	disk0
   Protocol:	ata
   Unit Number:	0
   Socket Type:	Serial-ATA
   Mac OS 9 Drivers:	No
   Partition Map Type:	MBR (Master Boot Record)
   S.M.A.R.T. status:	Verified
   Volumes:
 macosx:
   Capacity:	20.24 GB
   Available:	12.93 GB
   Writable:	Yes
   File System:	Journaled HFS+
   BSD Name:	disk0s2
   Mount Point:	/

artur, please, if somewere is writen READ before post its meant as READ ALSO YOUR DEBUGS.
if u do that ull see that u have 2 of AppleNforceSATA kexts loaded with same 1.0.3. version... anyhow last buld is unfortunately 1.0.3 (and previous also) with release date in my specs and could be downloaded from first page of NFORCE SATA Controller thread (new one).

in installation must be one kext. and under leo it must be in /system/library/extensions/IOATAfamily.kext/contens/plugins
latest kext has "corrected DVD problem" as writen in post by Medevil

#4
arthur5005

arthur5005

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

artur, please, if somewere is writen READ before post its meant as READ ALSO YOUR DEBUGS.
if u do that ull see that u have 2 of AppleNforceSATA kexts loaded with same 1.0.3. version... anyhow last buld is unfortunately 1.0.3 (and previous also) with release date in my specs and could be downloaded from first page of NFORCE SATA Controller thread (new one).

in installation must be one kext. and under leo it must be in /system/library/extensions/IOATAfamily.kext/contens/plugins
latest kext has "corrected DVD problem" as writen in post by Medevil



Thanks for the info there Zandera, you'll have to excuse me, there's COUNTLESS threads on how people suggest you get this installed, and most threads I read had you putting the AppleNForceATA.kext in both places. So I got rid of the other one in the System/Library/Extensions and made sure my other kext was UP TO DATE (Downloaded from the first page of the new NForce thread by MeDevil) and in "/system/library/extensions/IOATAfamily.kext/contens/plugins".


Problem is the link to that AppleNForecATA.kext seems to match his January 11th post, but the INFORMATION on the .kext is self says that it was made and created back on December 31st, and as you can imagine, my Asus DVD-R/W drive still isn't properly mounting or reading any of my media. Again thank you for responding, sorry for the late reply been busy with school in my comp-sci program. if what I need to do is compile the source, that's no problem for me, I have a POSIX-Linux background, but I just want to make sure I'm downloading it from the RIGHT PLACE!

Should all else fail, could you post a link to the January 11th kext for me?

Best
Arthur

#5
arthur5005

arthur5005

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Ok, got XCODE, and compiled a new .kext from source, and still no dice.

Could there be something else making my SATA DVD rom drive useless? I mean it works during install. When I put an Audio CD in, it loads up the track lengths, but won't play the tracks. And whenever any media goes in, my console always tells me: 'SAM Multimedia: READ or WRITE failed etc.'

Any help would be appreciated,

Best
Arthur

#6
zandera

zandera

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Prague

Ok, got XCODE, and compiled a new .kext from source, and still no dice.

Could there be something else making my SATA DVD rom drive useless? I mean it works during install. When I put an Audio CD in, it loads up the track lengths, but won't play the tracks. And whenever any media goes in, my console always tells me: 'SAM Multimedia: READ or WRITE failed etc.'

Any help would be appreciated,

Best
Arthur

i know that is can look {censored} but do you know wich port (primary/secondary controller) is yout DVD connected? On same cable as HDD or different.
if on different try remove a 0x0----- coresponding to DVD port... may be it will get to work. If you ve a DVD working with plain install may this help.

#7
arthur5005

arthur5005

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

i know that is can look {censored} but do you know wich port (primary/secondary controller) is yout DVD connected? On same cable as HDD or different.
if on different try remove a 0x0----- coresponding to DVD port... may be it will get to work. If you ve a DVD working with plain install may this help.


Yes, I know for a fact, that my DVD Drive is on a secondary SATA Port off my motherboard. I'll have time to try what you're suggesting when I get back home tonight. problem is figuring out which drive is on which port. Thanks for the tip!

#8
arthur5005

arthur5005

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

i know that is can look {censored} but do you know wich port (primary/secondary controller) is yout DVD connected? On same cable as HDD or different.
if on different try remove a 0x0----- coresponding to DVD port... may be it will get to work. If you ve a DVD working with plain install may this help.



Well gave that a try and no difference. Still seems to be detecting it

changed 0x026710DE
to 26710DE and it made no difference..

I figured I'd also post my new start up info that I get with the compiled driver, again I'm at a loss when it comes to understanding half of this stuff.
17/02/08 9:41:52 PM kernel AppleNForceATA: NVIDIA nForce MCP 51 Serial ATA by MeDevil (CMD 0x970, CTR 0xb70, IRQ 23, BM 0xe008) 
17/02/08 9:41:52 PM kernel AppleNForceATA::provideBusInfo( 0x4448000, 0x43885a0 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA: NVIDIA nForce MCP 51 Serial ATA by MeDevil (CMD 0x9f0, CTR 0xbf0, IRQ 23, BM 0xe000) 
17/02/08 9:41:52 PM kernel AppleNForceATA::provideBusInfo( 0x4455e00, 0x4569ae0 )AppleNForceATA::provideBusInfo( 0x4448000, 0x4569160 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA::getConfig( 0x4455e00, 0x4569140, 0 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA::selectConfig( 0x4455e00, 0x4569140, 0 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA::selectTimingParameter( 0x4455e00, 0 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA: selected PIO mode 4 
17/02/08 9:41:52 PM kernel AppleNForceATA: selected Ultra mode 4AppleNForceATA::getConfig( 0x4448000, 0x4569040, 0 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA::selectConfig( 0x4448000, 0x4569040, 0 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA::selectTimingParameter( 0x4448000, 0 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA: selected PIO mode 4 
17/02/08 9:41:52 PM kernel AppleNForceATA: selected Ultra mode 6 
17/02/08 9:41:52 PM kernel PCI_IDE_ENABLE   0x07 
17/02/08 9:41:52 PM kernel PCI_IDE_ENABLE   0x07 
17/02/08 9:41:52 PM kernel PCI_IDE_CONFIG   0x00 
17/02/08 9:41:52 PM kernel PCI_FIFO_CONFIG  0x00 
17/02/08 9:41:52 PM kernel PCI_ULTRA_TIMING 0xc700c500 
17/02/08 9:41:52 PM kernel [ Ch1 Drive0 ] 
17/02/08 9:41:52 PM kernel PCI_IDE_CONFIG   0x00 
17/02/08 9:41:52 PM kernel PCI_FIFO_CONFIG  0x00 
17/02/08 9:41:52 PM kernel PCI_ULTRA_TIMING 0xc700c500 
17/02/08 9:41:52 PM kernel [ Ch0 Drive0 ] 
17/02/08 9:41:52 PM kernel Command Active   90 ns 
17/02/08 9:41:52 PM kernel Command Active   90 ns 
17/02/08 9:41:52 PM kernel Command Recovery 30 ns 
17/02/08 9:41:52 PM kernel Address Setup	60 ns 
17/02/08 9:41:52 PM kernel Data Active	  90 ns 
17/02/08 9:41:52 PM kernel Data Recovery	30 ns 
17/02/08 9:41:52 PM kernel Command Recovery 30 ns 
17/02/08 9:41:52 PM kernel Address Setup	60 ns 
17/02/08 9:41:52 PM kernel Data Active	  90 ns 
17/02/08 9:41:52 PM kernel Data Recovery	30 ns 
17/02/08 9:41:52 PM kernel UDMA Timing	  0xc7 
17/02/08 9:41:52 PM kernel UDMA Timing	  0xc5 
17/02/08 9:41:52 PM kernel AppleNForceATA::getConfig( 0x4455e00, 0x4569140, 0 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA::getConfig( 0x4448000, 0x4569040, 0 ) 
17/02/08 9:41:52 PM kernel FireWire (OHCI) VendorID 1033 ID f2 PCI now active, GUID 00004c0107000394; max speed s400. 
17/02/08 9:41:52 PM kernel Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SAT1@E/AppleNForceATARoot/PRI0@0/AppleNForceATA/ATADeviceNub@0/IOATABlockStorageDriver/IOATABlockStorageDevice/IOBlockStorageDriver/WDC WD800JD-75MSA3 Media/IOFDiskPartitionScheme/Untitled 2@2 
17/02/08 9:41:52 PM kernel BSD root: disk0s2, major 14, minor 2 
17/02/08 9:41:52 PM kernel AppleNForceATA: warning: phy connection failed. status=0x00000000 
17/02/08 9:41:52 PM kernel AppleNForceATA: warning: phy connection failed. status=0x00000000 
17/02/08 9:41:52 PM kernel AppleNForceATA: found 0 units. 
17/02/08 9:41:52 PM kernel AppleNForceATA::free( 0x4461c00 ) 
17/02/08 9:41:52 PM kernel AppleNForceATA: found 0 units. 
17/02/08 9:41:52 PM kernel AppleNForceATA::free( 0x4461e00 )

I've included the non AppleNForceATA stuff in there as well.. I noticed something regarding PIO mode.. I thought that was a read mode workaround before this .kext appeared..

I think now, my DVD-Rom drive is a bit of a lost cause, and I'll pretend my machine is like a macbook air or something :(. lol. just use the computer next to me to get stuff off and on to a DVD. Although I figured I'll keep this up for pastorates sake, or anyone else who might be having a similar problem!

Again, thanks for all the attention to to this matter!

Best Regards
Arthur

#9
zandera

zandera

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Prague

Well gave that a try and no difference. Still seems to be detecting it

changed 0x026710DE
to 26710DE and it made no difference..

I figured I'd also post my new start up info that I get with the compiled driver, again I'm at a loss when it comes to understanding half of this stuff.

17/02/08 9:41:52 PM kernel AppleNForceATA: NVIDIA nForce MCP 51 Serial ATA by MeDevil (CMD 0x970, CTR 0xb70, IRQ 23, BM 0xe008) 
 17/02/08 9:41:52 PM kernel AppleNForceATA::provideBusInfo( 0x4448000, 0x43885a0 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA: NVIDIA nForce MCP 51 Serial ATA by MeDevil (CMD 0x9f0, CTR 0xbf0, IRQ 23, BM 0xe000) 
 17/02/08 9:41:52 PM kernel AppleNForceATA::provideBusInfo( 0x4455e00, 0x4569ae0 )AppleNForceATA::provideBusInfo( 0x4448000, 0x4569160 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA::getConfig( 0x4455e00, 0x4569140, 0 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA::selectConfig( 0x4455e00, 0x4569140, 0 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA::selectTimingParameter( 0x4455e00, 0 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA: selected PIO mode 4 
 17/02/08 9:41:52 PM kernel AppleNForceATA: selected Ultra mode 4AppleNForceATA::getConfig( 0x4448000, 0x4569040, 0 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA::selectConfig( 0x4448000, 0x4569040, 0 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA::selectTimingParameter( 0x4448000, 0 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA: selected PIO mode 4 
 17/02/08 9:41:52 PM kernel AppleNForceATA: selected Ultra mode 6 
 17/02/08 9:41:52 PM kernel PCI_IDE_ENABLE   0x07 
 17/02/08 9:41:52 PM kernel PCI_IDE_ENABLE   0x07 
 17/02/08 9:41:52 PM kernel PCI_IDE_CONFIG   0x00 
 17/02/08 9:41:52 PM kernel PCI_FIFO_CONFIG  0x00 
 17/02/08 9:41:52 PM kernel PCI_ULTRA_TIMING 0xc700c500 
 17/02/08 9:41:52 PM kernel [ Ch1 Drive0 ] 
 17/02/08 9:41:52 PM kernel PCI_IDE_CONFIG   0x00 
 17/02/08 9:41:52 PM kernel PCI_FIFO_CONFIG  0x00 
 17/02/08 9:41:52 PM kernel PCI_ULTRA_TIMING 0xc700c500 
 17/02/08 9:41:52 PM kernel [ Ch0 Drive0 ] 
 17/02/08 9:41:52 PM kernel Command Active   90 ns 
 17/02/08 9:41:52 PM kernel Command Active   90 ns 
 17/02/08 9:41:52 PM kernel Command Recovery 30 ns 
 17/02/08 9:41:52 PM kernel Address Setup	60 ns 
 17/02/08 9:41:52 PM kernel Data Active	  90 ns 
 17/02/08 9:41:52 PM kernel Data Recovery	30 ns 
 17/02/08 9:41:52 PM kernel Command Recovery 30 ns 
 17/02/08 9:41:52 PM kernel Address Setup	60 ns 
 17/02/08 9:41:52 PM kernel Data Active	  90 ns 
 17/02/08 9:41:52 PM kernel Data Recovery	30 ns 
 17/02/08 9:41:52 PM kernel UDMA Timing	  0xc7 
 17/02/08 9:41:52 PM kernel UDMA Timing	  0xc5 
 17/02/08 9:41:52 PM kernel AppleNForceATA::getConfig( 0x4455e00, 0x4569140, 0 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA::getConfig( 0x4448000, 0x4569040, 0 ) 
 17/02/08 9:41:52 PM kernel FireWire (OHCI) VendorID 1033 ID f2 PCI now active, GUID 00004c0107000394; max speed s400. 
 17/02/08 9:41:52 PM kernel Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SAT1@E/AppleNForceATARoot/PRI0@0/AppleNForceATA/ATADeviceNub@0/IOATABlockStorageDriver/IOATABlockStorageDevice/IOBlockStorageDriver/WDC WD800JD-75MSA3 Media/IOFDiskPartitionScheme/Untitled 2@2 
 17/02/08 9:41:52 PM kernel BSD root: disk0s2, major 14, minor 2 
 17/02/08 9:41:52 PM kernel AppleNForceATA: warning: phy connection failed. status=0x00000000 
 17/02/08 9:41:52 PM kernel AppleNForceATA: warning: phy connection failed. status=0x00000000 
 17/02/08 9:41:52 PM kernel AppleNForceATA: found 0 units. 
 17/02/08 9:41:52 PM kernel AppleNForceATA::free( 0x4461c00 ) 
 17/02/08 9:41:52 PM kernel AppleNForceATA: found 0 units. 
 17/02/08 9:41:52 PM kernel AppleNForceATA::free( 0x4461e00 )

I've included the non AppleNForceATA stuff in there as well.. I noticed something regarding PIO mode.. I thought that was a read mode workaround before this .kext appeared..

I think now, my DVD-Rom drive is a bit of a lost cause, and I'll pretend my machine is like a macbook air or something B) . lol. just use the computer next to me to get stuff off and on to a DVD. Although I figured I'll keep this up for pastorates sake, or anyone else who might be having a similar problem!

Again, thanks for all the attention to to this matter!

Best Regards
Arthur

missunderstand : remove 0x026710DE (if this is a controller for your DVD SATA CHANEL
and when u think is about an PIO search if SATA DVD have any. (may need to remove PIO support from sources.... or give it a detection of DVD mechniques...)

#10
arthur5005

arthur5005

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

missunderstand : remove 0x026710DE (if this is a controller for your DVD SATA CHANEL
and when u think is about an PIO search if SATA DVD have any. (may need to remove PIO support from sources.... or give it a detection of DVD mechniques...)


Hmm ok, I think I see what you're trying to say. All in all, removed that from the ID from the list, still no success. I'll look around and see about removing PIO support all together in my install.

I still get a series of these when ever I put any media in..

18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM diskarbitrationd[50] unable to probe /dev/disk1 (status code 0xFFFFFFFC). 
18/02/08 4:58:34 PM kernel disk1: I/O error. 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01

I just want to repeat my self though, the help on these forums have been spectacular, and getting everything working thus far. So if it's a DVD Rom drive I can't get working, it won't be the end of me!

Best
Arthur

#11
zandera

zandera

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Prague

Hmm ok, I think I see what you're trying to say. All in all, removed that from the ID from the list, still no success. I'll look around and see about removing PIO support all together in my install.

I still get a series of these when ever I put any media in..

18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM diskarbitrationd[50] unable to probe /dev/disk1 (status code 0xFFFFFFFC). 
18/02/08 4:58:34 PM kernel disk1: I/O error. 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01 
18/02/08 4:58:34 PM kernel SAM Multimedia: READ or WRITE failed, SENSE_KEY = 0x02, ASC = 0x04, ASCQ = 0x01

I just want to repeat my self though, the help on these forums have been spectacular, and getting everything working thus far. So if it's a DVD Rom drive I can't get working, it won't be the end of me!

Best
Arthur


it looks like it tries to write to a disk
only thing u can do is contact directly Medevil

#12
sllyname

sllyname

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I see the same problems with this driver on my 10.4.10 install on mcp55s chipset,
(gigabyte GA-M57-SLI-S4). Multiple sata disk drives work but not the DVD burner.
It's detected, shown in the profiler, but does not mount a disk.

#13
SP1950

SP1950

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
i have the same drive, almost the same chipset (nforce 405) and same problem!!!
but i am using zeph's 10.5.2.
please help us!
i saw my dvd drive (disk2) in disk util, but it cannot be unmounted (yeah, it shows unmount on the button)
thanks:)

#14
8ender

8ender

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
I also have this problem with my LG burner on an nForce 570 chipset. Interestingly it seems to sit there with the access light on after boot for a long time (5 minutes) before finally popping up a window telling me that a blank disc has been inserted. The disc in the drive isn't blank.

#15
arthur5005

arthur5005

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

I also have this problem with my LG burner on an nForce 570 chipset. Interestingly it seems to sit there with the access light on after boot for a long time (5 minutes) before finally popping up a window telling me that a blank disc has been inserted. The disc in the drive isn't blank.


Yeah, I figured I wasn't the only one with this problem, I haven't had the galls (or more importantly the time) to contact MeDevil about this correctly (all information about chipset, type of dvd r/w drive etc.) if someone else would! I'd highly advise a really a polite post about the issue.. Otherwise I'll probably get to it by the end of the week.

#16
8ender

8ender

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Looked like MeDevil quiety updated his first post in this thread with a fix for this error:
http://forum.insanel...showtopic=77071

Unfortunately while it does allow me to now read DVDs again I still cant seem to burn anything. Either way its some progress.

#17
MuftiMan

MuftiMan

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Looked like MeDevil quiety updated his first post in this thread with a fix for this error:
http://forum.insanel...showtopic=77071

Unfortunately while it does allow me to now read DVDs again I still cant seem to burn anything. Either way its some progress.



Hate to bump an old thread, but how exactly did you go about doing this?

I'm having EXACTLY the same problem at the moment but I haven't been able to understand how to install the new kext from MeDevil.

Any help is greatly appreciated.

#18
Russell Holman

Russell Holman

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Errors during install

"SAM Multimedia: READ or WRITE failed"
"com.apple.system.fs ErrNo 5"

I was having a simliar issue with my DVD-RW drive while trying to install OSX (iDeneb 1.3), as it happens it was a problem with how I had physically installed the drive, the main thing that seemed to fix the issue was that I replaced the IDE cable which was 40 wire with an 80 wire one (actually recommended for my Pioneer DVR-110D). I also set the drive as primary master these seemed to fix my issues. I know that my post might seem out of place but it occurs to me that this could also help with issues that are happening post install.

Also, just a note that my previous configuration had been working flawlessly under my Win XP install for countless years, it was only when I attempted my OSX install that I realised that my drive might work better with the 80 wire IDE cable.

#19
geiman

geiman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 349 posts
You probably already tried this, but when I had this problem I used the TESTAppleNForceata kext instead of the regular one. This one gave me much faster read/write times for my harddrive, but also it gave me my optical drive back.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy