Jump to content

windowserver failure - Vanilla install - Freezing GUI


  • Please log in to reply
1 reply to this topic

#1
LTL

LTL

    InsanelyMac Sage

  • Donators
  • 287 posts
  • Gender:Male
  • Location:Thailand
My GUI freezes up soon after boot. I never even have to turn on any programs, it just happens. I opened up my Console and saw a lot of the following (see attached file for full Console Log):

2/9/08 4:40:46 PM com.apple.WindowServer[119] mach_msg (CGXKickEventHandler) failed (ipc/send) timed out
2/9/08 4:40:46 PM com.apple.WindowServer[119] mach_msg (CGXKickEventHandler) failed (ipc/send) timed out
2/9/08 4:40:46 PM com.apple.WindowServer[119] mach_msg (CGXKickEventHandler) failed (ipc/send) timed out
2/9/08 4:40:46 PM com.apple.WindowServer[119] mach_msg (CGXKickEventHandler) failed (ipc/send) timed out
2/9/08 4:40:46 PM com.apple.WindowServer[119] mach_msg (CGXKickEventHandler) failed (ipc/send) timed out
2/9/08 4:40:46 PM com.apple.WindowServer[119] mach_msg (CGXKickEventHandler) failed (ipc/send) timed out

So I went into /var/logs/ and looked for a panic.log (was not there)

Then went into windowserver.log and saw a lot of the following starting on the 9th which was the day I booted it up and left it running overnight (see attached file for full log):

Feb 09 16:18:29 [122] Server is starting up
Feb 09 16:18:35 [122] CGXMappedDisplayStart: Unit 0: no display alias property
Feb 09 16:18:35 [122] CGXMappedDisplayStart: Unit 1: no display alias property
Feb 09 16:18:35 [122] CGXPerformInitialDisplayConfiguration
Feb 09 16:18:35 [122] Display 0x3c098681: MappedDisplay Unit 1; Vendor 0x22f0 Model 0x261a S/N 0; online enabled (0,0)[1920 x 1200], base addr 0x1800000
Feb 09 16:18:35 [122] Display 0x3f003c: MappedDisplay Unit 0; Vendor 0xffffffff Model 0xffffffff S/N -1; offline enabled (2944,0)[1 x 1], base addr 0x1800000
Feb 09 16:18:48 [122] GLCompositor: GL renderer id 0x00022608, GL mask 0x00000003, accelerator 0x00002813, unit 0, caps 0x00000003, vram 512 MB
Feb 09 16:18:48 [122] GLCompositor: GL renderer id 0x00022608, GL mask 0x00000003, texture units 4, texture max 8192, viewport max {8192, 8192} extensions 0x00000007
Feb 09 16:18:49 [122] kCGErrorIllegalArgument: CGXSetWindowListTags: Operation on a window 0x2 not owned by caller SecurityAgent
Feb 09 16:18:49 [122] kCGErrorIllegalArgument: Set a breakpoint at CGErrorBreakpoint() to catch errors as they are returned
Feb 09 16:18:50 [122] kCGErrorIllegalArgument: CGXOrderWindow: Operation on a window 0x2 not owned by caller SecurityAgent
Feb 09 16:29:33 [119] Server is starting up
Feb 09 16:29:37 [119] CGXMappedDisplayStart: Unit 0: no display alias property
Feb 09 16:29:37 [119] CGXMappedDisplayStart: Unit 1: no display alias property
Feb 09 16:29:37 [119] CGXPerformInitialDisplayConfiguration
Feb 09 16:29:37 [119] Display 0x3c098681: MappedDisplay Unit 1; Vendor 0x22f0 Model 0x261a S/N 0; online enabled (0,0)[1920 x 1200], base addr 0x1800000
Feb 09 16:29:37 [119] Display 0x3f003c: MappedDisplay Unit 0; Vendor 0xffffffff Model 0xffffffff S/N -1; offline enabled (2944,0)[1 x 1], base addr 0x1800000
Feb 09 16:29:39 [119] kCGErrorIllegalArgument: CGXSetWindowListTags: Operation on a window 0x2 not owned by caller SecurityAgent
Feb 09 16:29:39 [119] kCGErrorIllegalArgument: Set a breakpoint at CGErrorBreakpoint() to catch errors as they are returned
Feb 09 16:29:40 [119] GLCompositor: GL renderer id 0x00022608, GL mask 0x00000003, accelerator 0x00002813, unit 0, caps 0x00000003, vram 512 MB
Feb 09 16:29:40 [119] GLCompositor: GL renderer id 0x00022608, GL mask 0x00000003, texture units 4, texture max 8192, viewport max {8192, 8192} extensions 0x00000007
Feb 09 16:29:40 [119] kCGErrorIllegalArgument: CGXOrderWindow: Operation on a window 0x2 not owned by caller SecurityAgent
Feb 09 16:29:51 [119] kCGErrorIllegalArgument: CGXSetWindowListTags: Operation on a window 0x6 not owned by caller UserNotificationCenter
Feb 09 16:30:43 [119] kCGErrorIllegalArgument: CGXSetWindowListTags: Operation on a window 0x6 not owned by caller SystemUIServer
Feb 09 16:34:26 [119] kCGErrorIllegalArgument: CGXOrderWindow: Operation on a window 0x6 not owned by caller System Preferences
Feb 09 16:40:04 [119] kCGErrorIllegalArgument: CGXSetWindowListTags: Operation on a window 0x6 not owned by caller DiskImages UI Agent
Feb 09 16:44:39 [119] kCGErrorIllegalArgument: CGXSetWindowListTags: Operation on a window 0x6 not owned by caller CoreServicesUIAgent
Feb 09 16:48:28 [119] kCGErrorFailure: CGXDisableUpdate: UI updates were forcibly disabled by application "Finder" for over 1 second. Server has re-enabled them.
Feb 09 16:49:23 [119] kCGErrorIllegalArgument: CGXGetWindowWorkspace: invalid window id: 9d
Feb 09 16:52:56 [119] kCGErrorIllegalArgument: CGXGetWindowWorkspace: invalid window id: b2
Feb 09 16:54:04 [119] kCGErrorIllegalArgument: CGXGetWindowWorkspace: invalid window id: b5
Feb 09 16:54:05 [119] kCGErrorFailure: CGXDisableUpdate: UI updates were forcibly disabled by application "Finder" for over 1 second. Server has re-enabled them.
Feb 09 16:55:24 [119] kCGErrorIllegalArgument: CGXGetWindowWorkspace: invalid window id: d5
Feb 09 16:57:11 [119] kCGErrorFailure: CGXDisableUpdate: UI updates were forcibly disabled by application "Finder" for over 1 second. Server has re-enabled them.
Feb 09 16:59:03 [117] Server is starting up
Feb 09 16:59:05 [117] CGXMappedDisplayStart: Unit 0: no display alias property
Feb 09 16:59:06 [117] CGXMappedDisplayStart: Unit 1: no display alias property
Feb 09 16:59:06 [117] CGXPerformInitialDisplayConfiguration
Feb 09 16:59:06 [117] Display 0x3c098681: MappedDisplay Unit 1; Vendor 0x22f0 Model 0x261a S/N 0; online enabl


The errors go on and on.

I am trying to troubleshoot the cause of this...

My thoughts are:

*that its related to the Video Card (8800GT 512) and the drivers that I'm trying to use:
http://scottdangel.com/blog/?p=18

*Could it be a kernel panic? If it were a kernel panic, wouldn't i see a panic.log?

Attached File  Archive.zip   10.31KB   24 downloads

Let me know what you guys think =)

thank you

#2
MrSTiMPy

MrSTiMPy

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

10.5.2 update:

I followed these directions and all is well

http://netkas.org/?p=50

I am running really stable now and worked out the windowserver bug, it was cuz of my vmware and video drivers


Hey LTL,

I have read the quoted post on another thread, would you mind elaborating how did you work around the windowserver thingy? I have this problem after running iMovie for a while...

Having the same issue, even though our hardware is different, as I saw you don't like it when ppl doesn't have their specs here go mine:

Dell Latitude D630
HD 160GB
Video: nVidia Quadro NVS135m

MBR Partition Scheme
A Vanilla 10.5.6 HFS+ partition and a HFS+ boot partition with Chameleon Hard Disk and a custom .mkext on the Extra folder:
Contents of the .mkext:
ACPIBattery.kext
AppleACPIPS2Nub.kext
AppleBCM5751Ethernet.kext
ApplePS2Controller.kext
ClamshellDisplay.kext
dsmos.kext
GenericCPUPowerManagement.kext
IntelCPUPMDisabler.kext
LaptopDisplay.kext
NVResolver.kext (nVidia injector from superhai, as NVKush would not recognize my card)
OpenHaltRestart_1.0.3.kext (Tried this kext to try and work around the shutdown issue, which I also do have, with no luck :D )
SMBIOSResolver.kext

I guess it is as complete as I could do it.

Thanks in advance,

-=MrSTiMPy=-





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy