Jump to content

How I got my Realtek 8111B Ethernet working in 10.4.11


  • Please log in to reply
5 replies to this topic

#1
~pcwiz

~pcwiz

    InsanelyMac V.I.P.

  • Retired
  • 5,900 posts
  • Gender:Male
Hi,

I have a Gigabyte GA-P35-DS3P motherboard and after I updated to 10.4.11 with EFI, my Realtek 8111B ethernet stopped working, even with DaemonES's RealtekR1000.kext. Fortunately, I found a very easy solution to this problem. I downloaded an "official" Realtek R8111B driver and installed and it works PERFECT.

Driver:

ftp://210.51.181.211/cn/nic/RTGMac_v1.1.6.zip

Works great :hysterical:
~pcwiz

#2
LTL

LTL

    InsanelyMac Sage

  • Donators
  • 287 posts
  • Gender:Male
  • Location:Thailand

Hi,

I have a Gigabyte GA-P35-DS3P motherboard and after I updated to 10.4.11 with EFI, my Realtek 8111B ethernet stopped working, even with DaemonES's RealtekR1000.kext. Fortunately, I found a very easy solution to this problem. I downloaded an "official" Realtek R8111B driver and installed and it works PERFECT.

Driver:

ftp://210.51.181.211/cn/nic/RTGMac_v1.1.6.zip

Works great :wacko:
~pcwiz



Does your AFP and Bonjour work?

#3
~pcwiz

~pcwiz

    InsanelyMac V.I.P.

  • Retired
  • 5,900 posts
  • Gender:Male
I'm not sure...how do I test that, I'll test it for you if you would like :dev: All I know is that this driver works for all versions of 10.5 too. My ethernet didn't work after the Kalyway 10.5.1 install and it started working after I installed this. I'm pretty sure that this one is the official Realtek driver for OS X.

#4
taurusrecords

taurusrecords

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
that didnt worked for me..
im using zephyroth 10.5.2 and installed that driver.. says succesfull installed but after the restart i cant get access to the network..
u got an idea?

#5
OnePlane

OnePlane

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 304 posts
  • Gender:Male
  • Location:Here
Didn't work for me.. Is PPC?

#6
~pcwiz

~pcwiz

    InsanelyMac V.I.P.

  • Retired
  • 5,900 posts
  • Gender:Male
The driver is Intel only. It worked for me on:

Uphuck 10.4.9 1.4iR3 + PascalW 10.4.10 Delta Update + EFI v8 + 10.4.11 Apple Update

and on:

Kalyway 10.5.1 with EFI v8 on MBR partition

and this too:

Kalyway 10.5.1 with EFI v8 on MBR + Kalyway 10.5.2 Update + Kalyway kernels package + Leopard Graphics Update 1.0 + netkas 9.2.0 SpeedStep kernel


Worked on all those configs perfectly.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy