Jump to content

Intel Wireless 2100, 2200bg, 2915bg, 3945abg, 4965agn


  • This topic is locked This topic is locked
3410 replies to this topic

#3401
Artisstra

Artisstra

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hello,i have question. Im on 10.4.5. with 2200 BG. I installed from code.google... the stable driver,all is fine. After reboot i go to network selector and all works fine. It detects my router SWEEX LW050 and asks pasw after that its getting ip adres and shows NO INTERNET CONNECTION. Airport didnot show also. Where is problem ? Is it driver or computer or my router ? I tryed to ping that ip what shows in netselector and all is fine but still no internet adress. My laptop is Aopen 1551 with 512mb ram and1.3 celeron. Some help ?

#3402
tommie_laiho

tommie_laiho

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi i'm new here ... sorry for my english (i'm italian) ... since a lot of tries with iwi3945 i've found something:

i have an asus a6jc and i started my hackintosh with iatkos 10.5.5 few mounths ago but nothing to do with iwi3945,
the card is listed in network preferences but network selector won't list my wifi networks, so i installed iDeneb 10.5.6, do the same things with iwi3945.kext and magically i was able to scan my wifi networks, after iDeneb combo update 10.5.8 i came back on the same thing ... no wifi results ... i don't know why ... so i bought a d-link dwl-g122 and i was able to connect but yesterday a strange thing happened ... i pressed down for a few seconds (5 - 6 seconds) Fn+F2 and my usb mouse went so slow ... very slowl ... i plugged out my d-link and my system freezed but surprisely my intel wifi led turn on ... unfurtunately after reboot nothing changed and now i'm back to initial state but if i repeat the same thing, my system freeze and my led turn on.

i don't know if this can be useful but i don't found nothing about that in google.

#3403
L'homme

L'homme

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I have tried the 3945AGN latest driver and this is the screen I got.

Posted Image


#3404
jwebb

jwebb

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Tried iwl3945abg kext.
Log from system.log attached.
Attached File  iwl3945.txt   1.99KB   697 downloads

Peeace.

#3405
ants

ants

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
installed iwi3945 last release from iwidarwin.

If I boot with the wireless switch on, boot ok but no results at all: no card in the pref pane and nothing hapens with the network selector (can't find my network).

if I boot with the switch off: kernel panic.


Attached File  dmesg.txt   4KB   92 downloads
Attached File  ioreg.txt   35.45KB   38 downloads
Attached File  system.txt   466.87KB   55 downloads

Keep on testing!

HP dv6366ea
Intel centrino duo T5300, 1,73ghz • Ram 2Gb DDR 533Mhz • HD Hitachi SATA 160 Gb • Nvidia Geforce GO 7400, 128 Mb • Firewire 400 mb • DVD TSST TS L632D • conexant Cx20549Venice • WiFi intel 3945abg • ethernet

#3406
shd

shd

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
oh man, nothing yet?
:( :(

#3407
itjstagame

itjstagame

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

I have tried the 3945AGN latest driver and this is the screen I got.

Posted Image


Yup, I just got the same thing using that driver. Has anyone tried just hacking the IO802 kext to just recognize our 3945ABG?

#3408
itjstagame

itjstagame

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
I tried hacking the IO802 as someone else mentioned and it didn't do anything, my dmesg looks like all should be wellIOPCCard info: iwl3945: Intel® PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.23d
IOPCCard info: iwl3945: Copyright© 2003-2007 Intel Corporation
ieee80211_alloc_hw [OK]
PCI device enabled [OK]
IOPCCard info: iwl3945: Detected Intel PRO/Wireless 3945ABG Network Connection
init_waitqueue_head stubbed out!
IOPCCard debug: wmaster1: Selected rate control algorithm 'iwl-3945-rs'
PCI device enabled [OK]
__ IN iwl3945_alive_start __
IOPCCard info: iwl3945: Tunable channels: 11 802.11bg, 13 802.11a channels
Sending RXON
* without RXON_FILTER_ASSOC_MSK
* channel = 1
* bssid = 00:00:00:00:00:00
__ OUT iwl3945_alive_start __
IOPCCard debug: HW CONFIG: channel=1 freq=2412 phymode=3
Sending RXON* without RXON_FILTER_ASSOC_MSK
* channel = 1
* bssid = 00:00:00:00:00:00
no netif_running
Someone called createOutputQueue()
darwinp_iowwie3r9 4s5t:a:tceo n(figur1e)I
nterface()


That sounds more like the iwidarin drivers, it finds it successfully and gets stats. So it's some issue with OSX not recognizing it as a wifi, but the underlying unix does.

#3409
diabloid

diabloid

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Last Mercurysquad's message on Facebook this morning:
"WOW guys it does NOT mean the driver is ready -- I meant the 3945 laptop is here for this week SO I'm gonna try and finish the driver by next weekend cuz it's so much easier now."

It's time for 3945! ;)


#3410
jalavoui

jalavoui

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,144 posts
it's time to start a new thread for iwidarwin

please close this one


thank you all for helping

#3411
Elmo Man

Elmo Man

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
when a new thread starts can someone post the link into this thread so i continue to keep a watch on the progression of these drivers....well done and thanks to all people who have contributed to the coding. :)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy