Jump to content

[Compilation] Dell XPS M1330, M1530, Vostro 1400, 1700, Inspiron 1420, 1520, 1720

* * * * * 1 votes

  • Please log in to reply
4332 replies to this topic

#1421
delirumhappy

delirumhappy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Thx macgirl for putting this discussion up! Very useful for our dells!

Now here's my problem...

I installed the Sigmatel 9228 sound drivers (the ones matching my sound card) with that DellPackage v3.0b


And I'm glad I finally get sound through speakers and headphone jack! But why does the sound still come out throught the speakers
when I plug in headphones???
Plz help! This is very confusing!

#1422
7oby

7oby

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

And I'm glad I finally get sound through speakers and headphone jack! But why does the sound still come out throught the speakers when I plug in headphones???


I think because the sound driver is not yet finished and good.

Dell M1530 and M1330 users do not have that problem. Those notebooks have two headphone jacks. And in Mac OS X we have two output devices:

Mac OS X internal Speakers = Dell internal Speakers AND (!) 1st Headphone jack
Mac OS X Earphone = 2nd Headphone jack

So those users can select Earphone output device in sound preferences and have sound ONLY on 2nd Headphone.

Maybe you want to try that on your notebook, but chances are low that it helps. Otherwise go here (Author of the sound driver you are using):
http://wiki.taruga.net/tiki-index.php

Register and post in the forum on this site the problem you're having. Chances are still kind of low that it gets immediate attention and fix.

#1423
purlah

purlah

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

After installing

. AppleACPIPlatform.kext.zip under section FILES of MacGirls first post here (have to install this one or older, otherwise Sleep trick doesn't work for me for X3100 display)
. SMBResolver.kext and PowerManagement.bundle from http://www.superhai.com/darwin.html

I had the same effect: Sleep causes the laptop to sleep and instantaneous wake up.

Installing EHCISleepEnabler from
http://forum.insanel...mp;#entry775607

fixed that problem and I could sleep.


Okay, I was missing SMBIOSResolver.kext, which allowed me to sleep, and TurnLidOn.kext, which allowed me to wake from sleep. So, working perfectly now.

So, a note to others, as it hasn't been made explicit yet: SuperHai's TurnLidOn.kext works for M1530 as well.

I used Sonotone's DellPackage to speed things along initially (2.8) which was great, and that should have SMBIOSResolver, EHCISleepEnabler, PowerManagementbundle, and TurnLidOn added to it. (ideally as default options for M1530, if sonotone gets that far with it :D

So, awesome. Now all I have left is getting my Novatel 5270 embedded CDMA card (413c:8134) to show up as a USB modem so I can use it to connect. System Profiler identifies it on the USB bus, but it doesn't show up as an interface in Network system preferences panel. (it takes AT command sets like a regular serial modem... should be the same for all dell-supplied embedded WWAN cards if we can get it to work). Seems like getting it to show up as a USB modem should probably be just a matter of identifying it as such in a plist somewhere, anyone know where (or have other ideas)?

#1424
racou

racou

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
1st sorry for my bad english..


I need some help to set media keys on ACER ASPIRE 5920G (PLAY/PAUSE , STOP, REW and FF)

I know that I have to change ApplePS2Keyboard.kext source ( ApplePS2Keyboard.cpp and ApplePS2Keyboard.h )


1-How can I have ApplePS2Keyboard source?
2-What I must know about my keyboard and how? (I mean how can I know codes of my media keys)
3-How can I map these keys into ApplePS2Keyboard.cpp and ApplePS2Keyboard.h? (an exemple will be great)

Any suggestion is welcome

Here is my keyboard's photo Posted Image

#1425
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

Thx macgirl for putting this discussion up! Very useful for our dells!

Now here's my problem...

I installed the Sigmatel 9228 sound drivers (the ones matching my sound card) with that DellPackage v3.0b
And I'm glad I finally get sound through speakers and headphone jack! But why does the sound still come out throught the speakers
when I plug in headphones???
Plz help! This is very confusing!

Is not because it was designed that way, remember that all AppleHDA kexts are patched with Taruga's patcher or directly by Taruga, they are not compiled code from sources.

So you can't expect that everything works right. That kext was designed to the original sound card of real Macs, and somehow with some patches they work (not fully) on other cards, Is like having a Lamborghini tires on a Volkswagen Bora, probably you need to deflate the tires to fit in, and probably they can do the same.

1st sorry for my bad english..


I need some help to set media keys on ACER ASPIRE 5920G (PLAY/PAUSE , STOP, REW and FF)

I know that I have to change ApplePS2Keyboard.kext source ( ApplePS2Keyboard.cpp and ApplePS2Keyboard.h )
1-How can I have ApplePS2Keyboard source?
2-What I must know about my keyboard and how? (I mean how can I know codes of my media keys)
3-How can I map these keys into ApplePS2Keyboard.cpp and ApplePS2Keyboard.h? (an exemple will be great)

Any suggestion is welcome

Here is my keyboard's photo Posted Image

You can download the kext sources from Apple's developer site.

For a example see here: http://forum.insanel...showtopic=40646 on post #8 jape attach a diff file to the original kext source.

#1426
musikusmint

musikusmint

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts
Hello, i have installed 10.5.3 Update on my Dell XPS 1330 with 9.3.0 Kernel (PC_EFI V8). Now i have problems with my "IONetworkingFamily.kext". Whitch *.kext is the right one ?

Thanx for help, musikusmint

#1427
racou

racou

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Is not because it was designed that way, remember that all AppleHDA kexts are patched with Taruga's patcher or directly by Taruga, they are not compiled code from sources.

So you can't expect that everything works right. That kext was designed to the original sound card of real Macs, and somehow with some patches they work (not fully) on other cards, Is like having a Lamborghini tires on a Volkswagen Bora, probably you need to deflate the tires to fit in, and probably they can do the same.


You can download the kext sources from Apple's developer site.

For a example see here: http://forum.insanel...showtopic=40646 on post #8 jape attach a diff file to the original kext source.


I need something else. How can I get play/pause's code for exempleaccording to my laptop knowing that this multimedia key work with touch ( It's not a boutton) and under leo I can't get codes of multimedia keys in the left or the right with "full key codes". It's possible to make them active?

Thx for help

#1428
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

Hello, i have installed 10.5.3 Update on my Dell XPS 1330 with 9.3.0 Kernel (PC_EFI V8). Now i have problems with my "IONetworkingFamily.kext". Whitch *.kext is the right one ?

Thanx for help, musikusmint

You shoudn't have a problem with that, because none of the network devices on the M1330 works with that kext, The Dell Wireless cards use IO80211Family.kext

Anyway you can recover IONetworkingFamily.kext from your installation DVD, extract it with Pacifist.

I need something else. How can I get play/pause's code for exempleaccording to my laptop knowing that this multimedia key work with touch ( It's not a boutton) and under leo I can't get codes of multimedia keys in the left or the right with "full key codes". It's possible to make them active?

Thx for help

You need to test the keycodes of your keyboard on other opertaing systme that recognize them (ie windows) the with the keycode of each key you can modofy the code.

But posibly those keys are not part of the keyboard and they use a special driver on windows.

#1429
N3maN

N3maN

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hey mac girl,
Thanks again for all the work you have done with this. I am finally able to post this reply off my Dell-Mac. AWESOME!

How do you guys find battery life using Leopard? So far i have found it seems a little worse than when running Vista; anyone find this or know of any way to increase it?

Apart from this, i can find almost no flaws... having to sleep for sound is a little annoying, and not having perfect shutdown/restart is a bit of a bummer, but apart from that, its perfect!

I only hope there is soon support for my Intel 3945 Wireless, as it is much more stable and picks up much better reception than the 1390.

The only other thing i want to know is; can i allow Leopard to use my Vista partition at all? Unfortunately i was only able to free up 6.8 gig for my Mac partition... not particularly much when i try to get things like imovie, office, photoshop etc. going.

Thanks
Cam

#1430
drpeppir

drpeppir

    InsanelyMac Protégé

  • Donators
  • 11 posts
  • Gender:Male
  • Location:Dallas TX
  • Interests:Computers, Hardware, Software, Medicine, Science.

What I had to do was first delete my AppleHDA.kext, and ACLinject.kext as well as my mkext and once that was done
repair permissions and then re-boot. After reboot drag the downloaded sound dump to the HDA patcher and it will install the
kexts as well as repair permissions. Once done, reboot and you should have sound.
This is the only method that worked for me and it is still working after updating to 10.5.3 although I had to repeat the above process after
the upgrade and sound still works after numerous reboots.


Well I am glad it is working for you, however I just tried the same method and can confirm it does not work, dragging anything into HDAPatcher whether is 1.13 or 1.16, gives me no result, in other words it just sits there.

#1431
musikusmint

musikusmint

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts
@macgirl. > i dont know why but there was a problem with the IONetworkingFamily.kext (now i use the kext of my home-system and now w-lan works). > i changed the w-lan card in my 1330 to a dell truemobile 1490.


thanx, musikusmint

#1432
7oby

7oby

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

dragging anything into HDAPatcher whether is 1.13 or 1.16, gives me no result, in other words it just sits there.


Just to make sure we're talking about the same thing:

works: Drag codec dump onto HDAPatcher application icon, while HDAPatcher is not running.

does not work: Launch HDAPatcher. Windows opens. Either dragging codec dump into HDAPatcher Window or HDAPatcher application icon does not work.

Did you try the first way?

#1433
purlah

purlah

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Dell Embedded WWAN Card for Sprint/Nextel (Novatel 5720) now working fully!

Just took a bit of fiddling to figure out where things need to go.

in the file

/System/Library/Extensions/IOSerialFamily.kext/Contents/Plugins/AppleWWANSupport.kext/Contents/Info.plist

you need to be updated to reflect the device id. replace the AppleWanDeviceNovatelUSB stanza with:

<key>AppleWANDeviceNovatelUSB</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleWWANSupport</string>
<key>IOClass</key>
<string>AppleWWANSupport</string>
<key>IOProbeScore</key>
<integer>10000</integer>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>idProduct</key>
<integer>33076</integer>
<key>idVendor</key>
<integer>16700</integer>
</dict>


and also, in the file:

/System/Library/Extensions/IOSerialFamily.kext/Contents/Plugins/AppleWWANSupport1.kext/Contents/Info.plist

update the idProduct and idVendor values as above in both the AppleVerizonInterface0NovatelUSB and AppleVerizonInterface1NovatelUSB stanzas. It may just be easier to search/replace all '8464' with '33076' and all '5130' with '16700' in both files. (I did that, and it worked fine)

now do:

touch /System/Library/Extensions

and bring up the System Prefs -> Networking dialog. Hit the + button, and it should say its installing a new device, Novatel Wireless CDMA. Create the Novatel Wireless CDMA connection type and select it.

Hit Advanced below login/password, select the WWAN tab, and change Vendor to Novatel, and Model to CDMA. Hit Okay. Now hit Apply. (Explicitly Applying before trying to connect is critical) Then Connect, and watch it go.

This message was posted over my embedded card via the sprint network. Speedtest with this configuration shows 600kbps down / 350kbps up.

This should probably work for other dell embedded WWAN devices as well, just change your device/vendor id to suit. Also note that it creates the device /dev/cu.wwan, which you can talk to directly with AT commands.

Update November 29. 08: Success reported by a Verizon user with their version of the 5720. The idProduct value needs to be 33075 instead of 33076 above, but otherwise it should just work.

#1434
jmvBMW

jmvBMW

    Insanely Bimmer

  • Members
  • PipPipPipPip
  • 194 posts
  • Gender:Male
  • Location:Chile

Can you paste in the kernel panic?

Here is another version which should also activate it after 60 seconds, but it really shouldn't make any difference. And it seem like the powermanagment system is not updating if you are on ac power or not so it is able to sleep also when ac power is connected.


Thanks Superhai!!, works great for me too!! :P

#1435
Superhai

Superhai

    InsanelyMac Legend

  • Retired Developers
  • 1,425 posts
Ok, TurnLidOn has been retired and replaced with ClamshellDisplay.kext and should work much better now.

#1436
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

@macgirl. > i dont know why but there was a problem with the IONetworkingFamily.kext (now i use the kext of my home-system and now w-lan works). > i changed the w-lan card in my 1330 to a dell truemobile 1490.
thanx, musikusmint

Maybe IO80211Family.kext uses something from IONetworkingFamily.kext

Dell Embedded WWAN Card for Sprint/Nextel (Novatel 5720) now working fully!

Thank you very much :D

EDIT:
Included in 1st post

Ok, TurnLidOn has been retired and replaced with ClamshellDisplay.kext and should work much better now.

Cool :thumbsup_anim:

EDIT:
Included in 1st post

#1437
musikusmint

musikusmint

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts
sorry, what means "TurnLidOn" ???

#1438
fiteon

fiteon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male

Maybe IO80211Family.kext uses something from IONetworkingFamily.kext


Thank you very much :)

EDIT:
Included in 1st post


Cool :(

EDIT:
Included in 1st post


Hey macgirl!

Does ClamshellDisplay.kext work fine on the m1330? I currently am 'manually' clicking Apple->Sleep to invoke Sleep...From Sonetone's installer, i didn't install the LidSleep (which I am assuming is the old kext)...

Your thoughts?

Thanks again!

#1439
f41qu3

f41qu3

    Insanely Retired Guru

  • Retired
  • 458 posts
  • Gender:Male
  • Location:Brazil
Hi sweet MacGirl, fine?

Do you have something for Dell 620? I Try install but had lots of incompatibilities.

Can help in this bit?

Many thanx.

#1440
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

sorry, what means "TurnLidOn" ???

TurnLidOn was a kext that allow some laptops to sleep when the Lid is closed, but turns out that on some the sleep of the display resets the state of the TurnLidOn, now with ClamshellDisplay that is resolved.


Hey macgirl!

Does ClamshellDisplay.kext work fine on the m1330? I currently am 'manually' clicking Apple->Sleep to invoke Sleep...From Sonetone's installer, i didn't install the LidSleep (which I am assuming is the old kext)...

Your thoughts?

Thanks again!

Yes it is working perfectly, you can check the AppleClamshellCausesSleep state with this on Terminal:
ioreg -n IOPMrootDomain | grep AppleClamshellCausesSleep

try it with and without the kexts and you'll see the difference.

There is also another entry AppleClamshellState which tells if the Lid is open or close
ioreg -n IOPMrootDomain | grep AppleClamshellState

Of course you can type this on Terminal with the Lid closed but you can log remotely and see how changes its value when Lid is close.


Hi sweet MacGirl, fine?

Do you have something for Dell 620? I Try install but had lots of incompatibilities.

Can help in this bit?

Many thanx.

I think that model is one generation before so maybe the Devilhood's guide is better.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy