Jump to content

[Compilation] Dell XPS M1330, M1530, Vostro 1400, 1700, Inspiron 1420, 1520, 1720

* * * * * 1 votes

  • Please log in to reply
4332 replies to this topic

#421
jake123

jake123

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 270 posts

Sorry to bother, but i have a real problem here : i want to use my vga port for a conference with a slideshow, and i can't succeed to make it work, although i tried to instal the derivers (nvinject or nvinject go, with final 0.33 kext) and even tried to change nvcap values, but can't figure out why is this non-working. Each time i plug the external display i have at home, and i ask to detect display, my internal screen just goes black and my external don't turn up either.
So i was wondering if any of you had succedded to make it work on the dell xps m1330 with 8400m GS card, and if yes with which nvcap value or other drivers ?
thanks in advance and sorry to bother again, but this is a big problem if i can't come to make it work before tuesday.

ditto, I have to do a presentation Wednesday, and every time I connect VGA my screen goes black! Is there a fix?

#422
debianx

debianx

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:N.C. USA
Hi,

I about to pull he trigger and buy a Inspiron 1720 so I can keep Windows on one hdd and install OSX on the other one. My question is does anyone know if I choose the internal Sound Blaster HD Audigy over the standard HD Audio would it work OOB or with a kext install? Also does the Dell 1395 b/g wireless card work?

Thanks for any and all help.

#423
jake123

jake123

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 270 posts

Hi,

I about to pull he trigger and buy a Inspiron 1720 so I can keep Windows on one hdd and install OSX on the other one. My question is does anyone know if I choose the internal Sound Blaster HD Audigy over the standard HD Audio would it work OOB or with a kext install? Also does the Dell 1395 b/g wireless card work?

Thanks for any and all help.

BUY A MAC!!!!!!!!! I REGRET NOT BUYING ONE!

Anyways, the HD Audigy is just a driver... its "Software addition", no added hardware, just software... a waste of money on my previous m1210.

#424
ranova

ranova

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts

BUY A MAC!!!!!!!!! I REGRET NOT BUYING ONE!

Anyways, the HD Audigy is just a driver... its "Software addition", no added hardware, just software... a waste of money on my previous m1210.


why do you regret not buying a mac. The m1330 has macbook pro specs but smaller and cheaper than a regular macbook. If you based that conclusion just on the fact of OSX compatibility, why did you buy a regular laptop in the first place..

#425
jake123

jake123

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 270 posts

why do you regret not buying a mac. The m1330 has macbook pro specs but smaller and cheaper than a regular macbook. If you based that conclusion just on the fact of OSX compatibility, why did you buy a regular laptop in the first place..

Mac's are good looking, they work... my computer with OS X is always crashing, or not working.. due to it not being a real mac.... If I had a Mac, I would have a perfect laptop.

#426
debianx

debianx

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:N.C. USA
Thanks Jake123 for the answer. I'm just going to stick with the standard audio.

#427
dave66

dave66

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
So you can also add me to the list of people who have sleep working (vostro 1400). I think I have found a repeatable way to get it working though there is probably a better way.

So I had an iatkos 1.0 install then I used the kalyway combo update with the kalyway kernel pack to udate to 10.5.2.

Then I ran one of the various nvidia installers (I think these kexts are somehow required for sleep)

Then I ran the script posted here answering yes to everything except write new MBR and TOH kernel. i do not really know how much of this (if any) is necesary.

Then I had to run the 10.5.2 kernel installer again or at least the package inside the kalyway kernel package that actually installs the kernels

Now hopefully I didn't forget something and your computer still runs. The thing that finally fixed sleep for me was replacing my appleacpiplatform.kext with the one that I uploaded. This might be included in the script folder (but not installed) but I can't remember so I'm uploading it anyway. If it is not in there I have no idea where I got it from. Just so you know it is version 1.05 so if you try using it without doing the above steps you may have to edit the info.plist of other kexts as macgirl has said.

I should probably say that I have two OS X installs on separate partitions so running the install packages was easier for me.

Also this does not ruin the battery meter.

So anyway sleep works nicely and wakes up reliably except that it "does not properly eject usb mass storage devices." Since people have said usb causes sleep to not work, that could be the reason why sleep is working for me.

Attached Files



#428
parpwhick

parpwhick

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
IMPORTANT: CLICKING HARD DRIVES

Many hard drives shipped lately with laptops click a bit too much - it's the headers going to sleep and waking immediately after.
This can have serious consequences, as the number of clicks is limited with corresponding loss of lifetime!
All operating systems except windows are affected:
https://bugs.launchp...port/ bug/59695 (all the details, analisys, estimates of damage,solutionsforlinux)

The bug stems from an incorrect setting in the HDD firmware, making it sleep too often. All operating systems follow the hardware defaults - except for windows , the only unaffected by this problem.

There's a way to make it stop:
In linux: hdparm -B 200 /dev/sda (if your disk is sda)
In MacOs: download hdapm (http://mckinlay.net.nz/hdapm/)andhaveitrunatstartup,itwilldisabletheclicking

I have a vostro 1500, in a couple of weeks of clicking(usingubuntu) there went 10% of the lifetime of the disk, this shouldn't be taken lightly.
Please, Macgirl, add some of this info to your first post!

#429
Ridicule

Ridicule

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
  • Gender:Male
  • Location:England

IMPORTANT: CLICKING HARD DRIVES

Many hard drives shipped lately with laptops click a bit too much - it's the headers going to sleep and waking immediately after...


Doesn't seem to work on my m1330,

[root@Hackintosh:~]# hdapm disk0 max
disk0: SAMSUNG HM160HI
Setting APM level to 0xfe: FAILED: APM not supported
[root@Hackintosh:~]#

:( mine doesn't seem to click that much anyway..

#430
chchchchia

chchchchia

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Thanks a bunch parpwhick, this is exactly what I was looking for.

#431
jstad

jstad

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
On my Vostro 1400, it seems that my CPU utilization seems consistently high. As I use just safari i can see the CPU % shoot up to 50% and stay around there. Anyone else noticing these on their hackintosh? I am wondering if it is due to my 1.4GHz CPU or just the fact is a hackintosh. Seems to run fine under Vista.

Let me know :D

#432
debianx

debianx

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:N.C. USA
Hey does anyone have or know if the Dell 1395 wireless works OOB like the 1390, 1490, and 1505?

Thanks

#433
nreis02

nreis02

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Oregon
Ok, I got a Dell Inspiron 1720 with a 8600M vid card. I got everything up and running fine, But when I play WoW ( I know another WoW player) I only get 5 to 6 FPS now matter what settings I change in game. I have also tried all the drivers that me and my buddy can find. Anyone got any info to fix this problem? So far WoW is the only game that i have tried. I will not try others till I get this working ( wife also plays WoW, so it's priority) thx much :)


EDIT: Ok I fixed the problem. I read in an earlier post on this thread about audio not working and reading that putting the laptop in sleep mode for a few seconds would fix the problem with audio. I figure I would give it a shot for the Video, and sure enough it worked. So if you are getting low frames rates from games try sleep mode, it may just fix the problem. If this was already posted ,I apologize for the redundancy.

#434
ixFOCUSxi

ixFOCUSxi

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:US New Jesrey Passaic
Dell XPS 420 / ATI Radeon 2400 does not work


any know what i can to about This?

#435
changturkey

changturkey

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Can the drivers for Broadcom 59xx be ported from Linux/FreeBSD? In Linux, the driver used is the tigon tg3 driver, not sure about FreeBSD, but it should be the same as well.

#436
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
I installed Kalyway twice one with 10.5.2 update and later without it, same results, wakes instantly after pressing the apple menu/sleep.

Then on my orignal Install Disk I move out the AppleUSBEHCI.kext (plugin of IOUSBFamily.kext) and now I can make the lappy sleep, of course without that kexts all USB devices are like a USB 1.0 (12Mbit max).

So if that does not bother you, you can move out that kext and get propper sleep

I will try other EHCI kexts, also investigate if sources permit modifications to change behavior.

#437
yeye

yeye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 292 posts
but will a fix be released because if we can't have USB 2.0 it's not very cool!
Does that fix reboot/shutdown too?
And is it due to our vostro/inspiron or is it due to the 8600m GT?

Thanks for your answers

#438
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
It does not fix the shutdown/reboot problem.

the shutdown/reboot issue has to do with the Nvidia kexts, whithout them loaded it shutdown or reboot fine.

Fortunately the USB kexts have sources available, unfornately my programming skills are not that good to change them easily :(

So if anyone has programm skills there is a thread of PC-Gen USB EHCI kext here: http://forum.insanel...showtopic=28559

#439
ranova

ranova

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts

Mac's are good looking, they work... my computer with OS X is always crashing, or not working.. due to it not being a real mac.... If I had a Mac, I would have a perfect laptop.


ummmm, the m1330 works with what its SUPPOSED to work for... windows. You should never assume osx86 will run without any problems. After updating to 10.5.2, I do not get ANY crashes at all.

#440
markiemark

markiemark

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
The only time osx86 (10.5.2) crashes complety when i'm using Itunes and start importing music. Any of you have the same experience?





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy