Jump to content

Wired NIC Dynamode NC-100TX-DL (a.k.a Realtek 8139D)


  • Please log in to reply
3 replies to this topic

#1
geez

geez

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Hi all,

I went and bought a cheapo Dynamode NC-100TX-DL internal PCI NIC (after unsuccessfully trying a few NICs we had lying around in the office).

DCPI Manager reports that I have:

1904:8139
Hangzhou Silan Microelectronics Co., Ltd.
RTL8139D [Realtek] PCI 10/100BaseTX ethernet adaptor

So I've been looking for drivers for Realtek RTL8139D cards. I've tried PCGenRTL8139Ethernet.kext and John Stormdrake's AppleRTL8139Ethernet for Leopard. I've also tried adding the vendor and device ID to the .plist.

This is on a completely fresh install of Kalyway. Nothing appears to be happening at all.

In System Profiler, I can't see any of these extensions being loaded.

If I try adding the device and vendor ID in the usual way to the out-the-box 'AppleRTL8139Ethernet.kext', I get the following:

14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: chip reset timed out
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: initAdapter() failed
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: vendorID = 0x1904 deviceID = 0x8139 revisionID = 0x0001
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: found PIO accessor at dcdfff00
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: found MMIO accessor at CC01
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: using PIO access mode...
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: io access at csrBase=548e2f00.
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: Software reset failed...
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: Attempting hard reset...
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: chip reset timed out
14/01/2008 10:55:28 kernel com_apple_driver_RTL8139: initAdapter() failed

Should any of these drivers work? Am I missing something obvious. Is there another way?!

Can anyone help me? Thanks!

#2
Pr0v4

Pr0v4

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
Hi, sorry, but you have solved the problem with this card??

#3
vkd

vkd

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Rio de Janeiro
Has ANYONE managed to get this particular card going? Foolish me just went and bought the exact same one so now I'm in this boat riddled with holes too... ;)

Any comments at all very welcome... :D

#4
jamesveale_5

jamesveale_5

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Hi all,

I went and bought a cheapo Dynamode NC-100TX-DL internal PCI NIC (after unsuccessfully trying a few NICs we had lying around in the office).

DCPI Manager reports that I have:

So I've been looking for drivers for Realtek RTL8139D cards. I've tried PCGenRTL8139Ethernet.kext and John Stormdrake's AppleRTL8139Ethernet for Leopard. I've also tried adding the vendor and device ID to the .plist.

This is on a completely fresh install of Kalyway. Nothing appears to be happening at all.

In System Profiler, I can't see any of these extensions being loaded.

If I try adding the device and vendor ID in the usual way to the out-the-box 'AppleRTL8139Ethernet.kext', I get the following:

Should any of these drivers work? Am I missing something obvious. Is there another way?!

Can anyone help me? Thanks!


i have the same one, its not working for me either :(





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy