Jump to content

CardBus/PCMCIA PC Cards for Tiger


  • Please log in to reply
160 replies to this topic

#121
joecas

joecas

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

It is mistake in IOPCIFamily. Try to change the version. For example this



Thanks Slice
I'll try

#122
joecas

joecas

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Something has changed...

IOPCI2PCIBridge: cardbus memory range 524288 bytes @ 0xfce02000
IOPCI2PCIBridge: cardbus I/O range 2048 bytes at 0x0000d000
IOPCCard info: Intel PCIC probe:
IOPCCard notice: Bad bridge mapping at 0xfce01000!
IOPCCardBridge::start failed
IOPCCard notice: AdjustResourceInfo: Unknown error code 0xffffffff
IOPCCardBridge::start failed
IOPCCard info: Intel PCIC probe:
IOPCCard notice: Bad bridge mapping at 0xfce01000!
IOPCCardBridge::
start failed
IOPCCard info: Intel PCIC probe:
IOPCCard notice:

#123
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,182 posts
  • Gender:Male
  • Location:Moscow
upload your ioreg made by
ioreg -l -x -w 2048 >ioregJoecas.txt
Zip it!
I try to study it.

#124
~Eureka

~Eureka

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 400 posts

Something has changed...

IOPCI2PCIBridge: cardbus memory range 524288 bytes @ 0xfce02000
IOPCI2PCIBridge: cardbus I/O range 2048 bytes at 0x0000d000
IOPCCard info: Intel PCIC probe:
IOPCCard notice: Bad bridge mapping at 0xfce01000!
IOPCCardBridge::start failed
IOPCCard notice: AdjustResourceInfo: Unknown error code 0xffffffff
IOPCCardBridge::start failed
IOPCCard info: Intel PCIC probe:
IOPCCard notice: Bad bridge mapping at 0xfce01000!
IOPCCardBridge::
start failed
IOPCCard info: Intel PCIC probe:
IOPCCard notice:


Hi joecas,

Have you tried IOPCIFamily.10.4.11.beta.zip on this topic? If you haven't, you can give it a try. Let me know the result. Don't forget to backup your original kext files. Thanks.

Chun-Nan

#125
joecas

joecas

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
With IOPCIFamily.10.4.11.beta.zip i have a kernel panic
I attach the result of ioreg with previous kexts

Attached Files



#126
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,182 posts
  • Gender:Male
  • Location:Moscow

With IOPCIFamily.10.4.11.beta.zip i have a kernel panic
I attach the result of ioreg with previous kexts

Two CardBridge is a hard task for IOPCCardFamily. It is probably not working with your config. I don't know.
But one notice. You have AGP chipset. As previously found there is a problem for compatibility. For resolving the issue I made new version of AGPGart 2.6.x. It correct some PCI setting. May be it help you. I am not sure.

#127
~Eureka

~Eureka

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 400 posts

With IOPCIFamily.10.4.11.beta.zip i have a kernel panic
I attach the result of ioreg with previous kexts


Hi joecas,

I forgot to mention that it may cause kernel panic when you have AGPGart installed. In addition, if you have tried to replace other kext files to make your pccard work before, you may have to restore those kext files you replaced first or it may cause kernel panic.

Chun-Nan

#128
bluedogmike

bluedogmike

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
  • Gender:Male
  • Location:Nashville

Version for Tiger without debuging

Checked with

1.Laptop Samsung P29Celeron M 1,3ATI IXP 150 - workATI AC97 sound - workCardBus Ricoh RL5C475 - work, tested with Adaptec SlimSCSI 1480Firewire Ricoh R5C551 - appears as working but not testedUSB Nec - workRadeon 9100IGP - in progress (no freeze, no crashes)
JaS 10.4.6 with ATI drivers (ATA, AC97, Radeon) and new IOPCIFamily.

2.Core2 DuoGigabyte 965P-S3PCIE, USB and SATA busesGA nVidia 7300LE 128Mb PCIEMacOSX Kalyway 10.4.10All works fine




Slice,Your IOPCIFamily.kext works great w/Upchuck 10.4.9, Thank you, see log below :D

Mar 9 20:34:07 localhost kernel[0]: IOPCI2PCIBridge: cardbus memory range 524288 bytes @ 0xe0204000
Mar 9 20:34:07 localhost kernel[0]: IOPCI2PCIBridge: cardbus I/O range 2048 bytes at 0x00003100
Mar 9 20:34:07 localhost kernel[0]: IOPCCard info: Intel PCIC probe: Ricoh RL5C476 rev a9
Mar 9 20:34:07 localhost kernel[0]: IOPCCard info: Intel PCIC probe: , Ricoh RL5C476 rev a9

:thumbsup_anim:

#129
poopmonkey

poopmonkey

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
where do I put these files?

#130
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,182 posts
  • Gender:Male
  • Location:Moscow

where do I put these files?

What do you want? IOPCIFamily for Tiger?
Chun-Nan version is in topic.
My version in thread New AGPGart

#131
poopmonkey

poopmonkey

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
I just want to know how to get my firewire card working. I am trying to put these two files in but they cause a kernal panic on reboot.

#132
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,182 posts
  • Gender:Male
  • Location:Moscow

I just want to know how to get my firewire card working. I am trying to put these two files in but they cause a kernal panic on reboot.

Use new IOPCIFamily.kext but delete IOPCCardFamily.kext. It is known to conflict with FireWire.
Clear BIOS of your comp and erase Extension.kextcache and .mkext.
If you have AGP bus you need also AGPGart else kernel panic.

#133
poopmonkey

poopmonkey

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
Nope it still panics on bootup. Did I mention that this is a firewire cardbus card?

#134
poopmonkey

poopmonkey

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
Well, I still cannot get my cardbus working in Tiger. I am running 10.4.9 Jas on a Acer Aspire 5601AWLMi.
Can anyone help me?

#135
sebhag

sebhag

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

Hi sebhag,

I have added TI 7420 chips on the beta3 edition. I also asked EqUaTe to help build the installation package. Maybe tomorrow or later, it will be posted on the forum. However, right now it is for only Leopard, not Tiger.

You can download the source code, add your pccard chip to it, and compile it.

Chun-Nan


Hi Chun Nan,

I'm trying to add the TI 7420 myself and just wanted to check something... do i just need to add references for the 7420 to ti113x.h and then compile. I had a quick look and it seems pretty straight forward, but i'm not sure.

Many thanks,
Seb.

#136
sebhag

sebhag

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

Hi Chun Nan,

I'm trying to add the TI 7420 myself and just wanted to check something... do i just need to add references for the 7420 to ti113x.h and then compile. I had a quick look and it seems pretty straight forward, but i'm not sure.

Many thanks,
Seb.


Edited, compiled and it worked!!! :) I can't believe it. Thanks sooo much Chun Nan!

#137
SamK

SamK

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
rev3 works a treat on my Acer Travelmate 2420 with an ENE CB1410 cardbus and 10.4.11 :)

However - do not just use disk utility to reset permissions, use the full chmod chown thingy through terminal.

1 quick question - Is there an easy way to put a device name in? It shows as 'Unknown Vendor'...

Sam.

#138
the_Wave

the_Wave

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi All!
JaS Tiger 10.4.8 doesn't boot after overwriting IOPCIFamily.kext from Chun-Nan's rev3. System stops responding at the grey screen with Apple logo. After hard reset it shows kernel panic.

Hardware - laptop Compaq Evo n610c.

What I've done wrong? Thanks.

Pic:

Attached Files



#139
the_Wave

the_Wave

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Ok, after the fifth times, I made it work. Now searching for PCMCIA-card drivers =))) Thanks to Developers for everything. :D

#140
pizzaa

pizzaa

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hello thanks for working on them drivers they are AWSOME!!!

This post is aimed at a PCMCIA firewire controller (SIGG Firewire Dual-port Cardbus - NN-PCM222)

I have tryed all the drivers available (r1 + r2 +r3) suprisinly they all work, I used Kext Helper b7 to install them, my PCMCIA card swiches on (blue light visible) through the boot up process. once tiger has booted a new icon appears on the bar across the top(it says unknown vender/firewirecontroller/power off card) the card also appears in system profiler/PC Cards, so the r1/r2/r3 drivers for the card works.

Heres the problem, When i plug my sound card in to the pcmcia card, it does nothing. I have installd the new soundcard drivers (MOTU) but still no activity.
Are there any generic firewire drivers about that mite help solve the problem.
It seems to be the connection between the card and the soundcard

Any help would be great

Thanks again :blink: :( :D :D :D :D :D





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy