Jump to content

CardBus/PCMCIA PC Cards for Leopard


  • Please log in to reply
1071 replies to this topic

#521
shemozzle

shemozzle

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I don't know if the new added devices will work or not. However, you can give it a try and let me know the result. In addition, if your pccard slot works under linux and it is not listed on the above the list (and if you believe it may work under mac), let me know the device id and I will try to add it to the next revision.
[/quote]

hi Chun-Nan

Would first like to offer my thanks for all your investment of time and effort.

Believe this might be a new device for you to add, TI7420 built-in chip on my Sony Vaio VGN-A series laptop and also on many other Sony's ie. FS FE FJ series.

Noticed in the device id capture below that it is linked in with flash mermory - a bit different.

Reports in windows device manager as TI17420 Integrated FlashMedia Controller.

It is recognised and useable under Linux.

Attached File  snapshot1.jpg   128.93KB   97 downloads

If you need furture info please PM me.

Thanks again.

#522
applehacker

applehacker

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 383 posts
Hey, Ive got an update. I installed that kext. I ran the command, and it scanned, nothing bout a Tixx12, but it say 3 things about 3 different pci ports. does this mean this laptop has pci ports I can use!!?!?!

#523
~Eureka

~Eureka

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 400 posts

I don't know if the new added devices will work or not. However, you can give it a try and let me know the result. In addition, if your pccard slot works under linux and it is not listed on the above the list (and if you believe it may work under mac), let me know the device id and I will try to add it to the next revision.


hi Chun-Nan

Would first like to offer my thanks for all your investment of time and effort.

Believe this might be a new device for you to add, TI7420 built-in chip on my Sony Vaio VGN-A series laptop and also on many other Sony's ie. FS FE FJ series.

Noticed in the device id capture below that it is linked in with flash mermory - a bit different.

Reports in windows device manager as TI17420 Integrated FlashMedia Controller.

It is recognised and useable under Linux.

.....

If you need furture info please PM me.

Thanks again.


Hi shemozzle,

I've been busy with school recently. I will try to add your pccard controller to the list this weekend. Thanks.

Chun-Nan

Hey, Ive got an update. I installed that kext. I ran the command, and it scanned, nothing bout a Tixx12, but it say 3 things about 3 different pci ports. does this mean this laptop has pci ports I can use!!?!?!


Hi applehacker,

Can you show the demsg result under singleuser mode (or standard mode)? Thanks.

Chun-Nan

#524
nchellzz

nchellzz

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

PCI Configuration changed (bridge=0 device=0 yenta=1)
  mbinit: done
  Security auditing service present
  BSM auditing present
  From path: "uuid"
  Waiting for boot volume with UUID 838557A5-763C-3B3C-B550-1563C3AA8D8E
  Waiting on <dict ID="0"><key>IOProvideClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>
  
  IOPCCard info:		Intel PCIC Probe:	Ricoh RL5C475 Rev 81
  
  Machine check capabilities (cpu 0) 0x0000000000000105:
  5 error-reporting banks
  Control MSR present
  
  Machine check status 0x0000000000000004
  machine check in progress
  
  MCA error-reporting registers:
  IA32_MC0_STATUS (0x401):	0x0000000000000000	invalid
  IA32_MC1_STATUS (0x405):	0x0000000000000000	invalid
  IA32_MC2_STATUS (0x409):	0x0000000000000000	invalid
  IA32_MC3_STATUS (0x40d):	0x0000000000000000	invalid
  IA32_MC4_STATUS (0x411):	0xb200000000070f0f	valid
  
  MCA error code		: 0x0f0f
  Model specific error code	: 0x0007
  Other information		: 0x00000000
  
  Status bits:
  Processor context corrupt
  Error enabled
  Uncorrected error
  
  panic (cpu 0 caller 0x001A7717): Machine-check at 0x348n001b, thread: 0x45c54f0, code 0x12, registers;
  CRO: 0x8001003b,	 CR2: 0x348b9000,	CR3: 0x01a01000,	 CR4: 0x000006e0
  EAX: 0x000000ff,	EBX: 0x348b9040,	ECX: 0x00000000,	EDX: 0x00000008
  ESP: 0x2eb63bd8,	EBP: 0x2eb63bd8,	ESI: 0x0461c80c,	EDI: 0x046acb08
  EFL: 0x00000202,	EIP: 0x348b001b
  
  debugger called: <panic>
  Backtrace, format-frame: Return Address (4 potential args on stack)
  
  0x4edf18:	0x12b0e1 (0x456a2c	0x4edf4c	0x1332a3		0x0)
  0x4edf68:	0x1a7717 (0x45f27c	0x348b001b	0x45c54f0	0x12)
  0x4edfe8:	0x19f825 (0x12		0x0	0x0	0x0)
  
  Backtrace terminated-invalid frame pointer 0
  
  BSD process name corresponding to current thread: kernel_task
  
  MacOS Version:
  not yet set
  
  Kernel Version:
  Darwin Kernel Version 9.1.0: Fri Nov 16 14.50:43 SCT 2007; made by ToH; xnu-1228.0.2~1/BUILD/obj/RELEASE_I386


update for this error:

I've tried using beta PCCard.10.5.2.Beta2, no longer kernel panic, but the screen moves so fast i couldn't really read what's happening..

it's shows IOPCCard info: Intel PCIC Probe: Ricoh RL5C475 Rev 81
and then
something about bad mapping etc
then it boots into osx

does anyone knows what is happening here?

#525
~Eureka

~Eureka

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 400 posts

update for this error:

I've tried using beta PCCard.10.5.2.Beta2, no longer kernel panic, but the screen moves so fast i couldn't really read what's happening..

it's shows IOPCCard info: Intel PCIC Probe: Ricoh RL5C475 Rev 81
and then
something about bad mapping etc
then it boots into osx

does anyone knows what is happening here?


Hi nchellzz,

Try to boot with "-s" to enter singleuser mode and post the dmesg result on the forum. Thanks.

Chun-Nan

#526
sebhag

sebhag

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

Hi shemozzle,

I've been busy with school recently. I will try to add your pccard controller to the list this weekend. Thanks.

Chun-Nan


Thanks for all your time and effort Chun-Nan!

Would be amazing if you could add the TI 7420. Been trying to get this working under 10.4.11 for the past week and it's starting to drive me crazy.

Is there anything i can do to add this myself if you don't have time, i.e. hex editing IOPCIFamily or adding anything to info.plist in IOPCCardFamily?

Many thanks,
Seb.

#527
~Eureka

~Eureka

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 400 posts

Thanks for all your time and effort Chun-Nan!

Would be amazing if you could add the TI 7420. Been trying to get this working under 10.4.11 for the past week and it's starting to drive me crazy.

Is there anything i can do to add this myself if you don't have time, i.e. hex editing IOPCIFamily or adding anything to info.plist in IOPCCardFamily?

Many thanks,
Seb.


Hi sebhag,

I have added TI 7420 chips on the beta3 edition. I also asked EqUaTe to help build the installation package. Maybe tomorrow or later, it will be posted on the forum. However, right now it is for only Leopard, not Tiger.

You can download the source code, add your pccard chip to it, and compile it.

Chun-Nan

#528
quinielascom

quinielascom

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 749 posts
  • Location:M�xico

Great work Chun-Nan.

I have a multicard reader on my Dell Laptop (SD, MMC, MS, etc) and it is Ricoh chipset based and it is attached on the PCI bus instead of the USB. I am wondering if this could work, what do you think?


Same question for Acer Aspire 4320 with cardreader Ricoh RL5C822.

Best regards.

Note: After applied the newones files with the rev8, my Airport no work anymore, then restore original files and the Airport Brc4311 is working fine again.

#529
nchellzz

nchellzz

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Hi nchellzz,

Try to boot with "-s" to enter singleuser mode and post the dmesg result on the forum. Thanks.

Chun-Nan


hi Chun-Nan, thanks for the reply, here's the dmesg |grep PC result:

Checking PCI bus 2
Checking PCI bus 1
Checking PCI bus 3
Checking PCI bus 4
Checking PCI bus 5
Checking PCI bus 6

PCI Configuration changed (bridge=0 device=12 yenta=1)

IOPCCard info	: Mac OSX PCMCIA Card Services 3.1.22
IOPCCard info	: options: [pci] [cardbus] [pnp]
IOPCCard info	: Intel PCIC Probe:
IOPCCard notice	: Bad bridge mapping at 0x001000000!
IOPCCard Bridge	: start failed

Got boot device: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IDE0@6/AppleNForceATAroot/PRI0@0/AppleNForceATA/ATADevice nub@0/IOATABlockStorageDriver/IOATABlockStorageDevice/IOBlockStorageDriver/ST380011A Media/IOFDiskPartitionScheme/Untitled3@3
Firewire (OHCI) Vendor ID 1106 ID3044 PCI now active, GUID 6000000019e870bb; max speed s100


#530
~Eureka

~Eureka

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 400 posts

Same question for Acer Aspire 4320 with cardreader Ricoh RL5C822.

Best regards.

Note: After applied the newones files with the rev8, my Airport no work anymore, then restore original files and the Airport Brc4311 is working fine again.


Hi quinielascom,

You need another driver for cardreader controller which is different from pccard controller.

If you are trying to make your pccard work, you can either give 10.5.2.beta2 a try or wait till 10.5.2.beta3 is posted. Thanks.

Chun-Nan

hi Chun-Nan, thanks for the reply, here's the dmesg |grep PC result:

..........


Hi nchellzz,

Once 10.5.2.beta3 is posted, you can try it to see if it fixes the problems. Thanks.

Chun-Nan

#531
almostastr8boy

almostastr8boy

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
Thanks Chun-Nan this worked perfect on my toshiba laptop. Now on to the internal multi carde reader and everything will be functional on 10.5.2 :wacko:

#532
EnVmyZ

EnVmyZ

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts

Jim: You should always boot with -v

Are you sure you installed the kext correctly? And had you previously updated to 10.5.2 ?
What hardware do you have?
I've attached the beta2 kext installer here, as per the latest release from Chun-Nan. I'll leave him to post details of what's changed :D
This replaces ONLY IOPCIFamily and IOPCCardFamily.
I'll be doing a stock kext thing later.
For reference, what release is everyone using?


Worked perfect on my Acer 5570z-2997, now have my 4311 card working!

Thank you soooo much!!

#533
sebhag

sebhag

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

Hi sebhag,

I have added TI 7420 chips on the beta3 edition. I also asked EqUaTe to help build the installation package. Maybe tomorrow or later, it will be posted on the forum. However, right now it is for only Leopard, not Tiger.

You can download the source code, add your pccard chip to it, and compile it.

Chun-Nan


That's great news, thanks Chun-Nan. Shame i can't use Leopard (no ati x600 support)... ah well, i'll be patiently waiting for the new tiger update. :D

Thanks a lot,
Seb.

#534
balder

balder

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Norway
Hi

A chance of anyone help me out on this.

Have an Acer 9815 laptop, replaced my wireless, now its regonized by OS, and showss up like Airport its an BCM 4311 card (Dell1390), only problem is I cant get it turned on with switch in front of lappy, or in any other way running Kalyway 10.5.1 with 10.5.2 upgrade, Intel 945 chipset

balder

#535
homer007

homer007

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts
  • Location:England
omg thankyou so much this made my built in wifi and ethernet card work!!!!!!!!!!!!!!!!!!!!!

#536
EnVmyZ

EnVmyZ

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts
Yeah this package is like pure gold to Acer users.... once again, thank you thank you!

#537
~Eureka

~Eureka

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 400 posts

Hi

A chance of anyone help me out on this.

Have an Acer 9815 laptop, replaced my wireless, now its regonized by OS, and showss up like Airport its an BCM 4311 card (Dell1390), only problem is I cant get it turned on with switch in front of lappy, or in any other way running Kalyway 10.5.1 with 10.5.2 upgrade, Intel 945 chipset

balder


Hi balder,

It seems that the switch prevented your Dell1390 from powering on. I think there are some articles related to this issue on the forum. Try to search them.

Chun-Nan

#538
homer007

homer007

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts
  • Location:England

Hi

A chance of anyone help me out on this.

Have an Acer 9815 laptop, replaced my wireless, now its regonized by OS, and showss up like Airport its an BCM 4311 card (Dell1390), only problem is I cant get it turned on with switch in front of lappy, or in any other way running Kalyway 10.5.1 with 10.5.2 upgrade, Intel 945 chipset

balder


if it is recognized as airport go to system perferences, click on network, then airport then click on turn on and the light of the wireless should comeon after that!!!, after that connect to ur network then restart and ur wireless card should automatically be powered on after that!!!

#539
applehacker

applehacker

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 383 posts
ok here is my output from sudo dmesg | grep PC


sudo dmesg | grep PC
Password:
Checking PCI bus 1
Checking PCI bus 6
Checking PCI bus 8
PCI configuration changed (bridge=1 device=12 yenta=0)
AppleIntelPIIXPATA: Secondary PCI IDE channel is disabled
Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/PRT0@0/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/Hitachi HTS541680J9SA00 Media/IOFDiskPartitionScheme/Untitled 2@2

so is there any hope for my card?

#540
aych

aych

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
the package crashed my leopard. im running a ricoh rl5c476II on my laptop. After replacing it will not boot up, something about deps. sigh.. i guess it wont work. either pcmcia works or the window manager works =(





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy