Jump to content

[Aiuto] Acer 5920G e piccoli problemi con leopard


  • Please log in to reply
27 replies to this topic

#1
MacPhisto

MacPhisto

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
ciao a tutti ... ho cercato sul forum ma a quanto pare nessuno ha lo stesso mio problema

ho un acer 5920G installato leopard prima ToH (ma avevo qualche problemino con EFI), poi iatkos 1.0r1 e ora iatkos 1.0r2

sia con kernel vanilla che con lo speedstep e con tutte le release provate ho il seguente problema:

ogni tanto all'avvio si blocca e l'ultima riga che leggo con il parametro di avvio a -v quasi sempre: Waiting for boot Volume ... Waiting on IOProviderClass ...(ma altre volte ne ho altre)

altre volte (invece) si avvia correttamente ma la mia tastiera del portatile non funziona (ApplePS2Controller: Timed out on keyboard)

altre volte ancora si avvia perfettamente

un grazie anticipato a chi sapr aiutarmi

#2
MacPhisto

MacPhisto

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
a quanto pare non un problema di boot device (un paio di volte si bloccato dopo il messaggio got boot volume)

nessuno ha avuto questo stesso problema?

ora sto provando a disabilitare PS2, firewire e USB .. vediamo se qualcuno di questi il problema
(forse il tv tuner dvb-t integrato che risulta attaccato all'USB)

oppure ... mi consigliate di provare kalyway?

#3
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
Ti consiglio caldamente di provare la Kalyway!!

#4
MacPhisto

MacPhisto

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
appena torno a casa vedo di procurarmela e di instalarla ...
l'unico dubbio che siccome il problema si presentato con ToH, iAtkos, con EFI, senza EFI, con kernel speedstep e vanilla... vorrei cercare prima di risolverlo sulla iAtkos..

P.S.: se installo KalyWay subito dopo XP ... si autoconfigura Darwin come iAtkos e ToH: menu di boot per scegliere la partizione da avviare?

#5
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
Scusa, se posti la tua configurazione, possiamo autarti un pochino di pi, no??

Cmq se hai quasi la mia stessa configurazione (mi pare sia cos il 5920G, come cpu, ram, chipset, audio, etc...), ho fatto una bella guida su come fare un bellissimo Trial-boot gestito dal bootloader di vista.. dagli un'occhiata e fammi domande se c' qualcosa che non capisci...

#6
MacPhisto

MacPhisto

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
innanzitutto grazie mille per le tue risposte
ho letto la tua guida ed veramente ben fatta

(io il tri-boot l'ho fatto con XP-gentoo-osx gestito direttamente da grub)

diciamo che l'installazione che ho attualmente (iAtkos) perfetta ma ho "solo" quel problemino...

ieri notte sono riuscito a capire il reale problema ... ma non ho ancora risolto
il problema l'USB; in particolare

rimuovendo il kext IOUSBFamily non ho pi problemi di blocco dell'avvio... mettendo altri kext ho dei messaggi di errore

visto che il mio portatile lo ha molta altra gente che per non ha di questi problemi sono arrivato a una conclusione (ancora da accertare)
il mio modello (a differenza di altri 5920G) ha il TV Tuner integrato attaccato a un BUS USB.
e sembra che sia proprio questo che causa problemi...

ora ... sto cercando un modo per disabilitare una periferica USB o tutto il bus incriminato impostando l'ID da qualche parte: parametri di avvio o kext

non una cosa facile ma ... speriamo di riuscirci

A presto

#7
dinamodj

dinamodj

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

innanzitutto grazie mille per le tue risposte
ho letto la tua guida ed veramente ben fatta

(io il tri-boot l'ho fatto con XP-gentoo-osx gestito direttamente da grub)

diciamo che l'installazione che ho attualmente (iAtkos) perfetta ma ho "solo" quel problemino...

ieri notte sono riuscito a capire il reale problema ... ma non ho ancora risolto
il problema l'USB; in particolare

rimuovendo il kext IOUSBFamily non ho pi problemi di blocco dell'avvio... mettendo altri kext ho dei messaggi di errore

visto che il mio portatile lo ha molta altra gente che per non ha di questi problemi sono arrivato a una conclusione (ancora da accertare)
il mio modello (a differenza di altri 5920G) ha il TV Tuner integrato attaccato a un BUS USB.
e sembra che sia proprio questo che causa problemi...

ora ... sto cercando un modo per disabilitare una periferica USB o tutto il bus incriminato impostando l'ID da qualche parte: parametri di avvio o kext

non una cosa facile ma ... speriamo di riuscirci

A presto


Scusa l'intrusione nel vostro discorso... io ho un ACER 5920g ma senza il TV tuner e ho il tuo stesso problema.
la mia configurazione:
ACER 5920G intel 2 duo - 2ghz 4mb cache - 2 gb ram - 250 gb HD - nvidia 8600m GS 256 vram
no bluetooh - no TV tuner
installato 10.5 toh con efi 5.2
aggiornato con 10.5.1 da apple con kernel originale
ho la prima partizione con XP e la seconda con MAC e le gestisco con Acronis OS selector
il problema e' il medesimo: a volte parte a volte no e a volte senza la tastiera.
pare che al boot con -f -legacy la cosa si risolva.
ma non definitivamente, cc'e' qualcosa che ci sfugge ancora.

#8
Petz

Petz

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Ciao a tutti,

confermo il comportamento anche con il mio 5920g senza dvb-t e senza bluetooth con hd da 160GB e cpu da 2Ghz.
Ho notato solo che quando non fa il boot, il boot successivo senza tastiera, bisogna riavviarlo ancora una volta per avere il sistema funzionante.
Mah!
Volevo per raccontarvi quello che mi successo: stavo scrivendo un testo su OSX senza problemi alimentato dalla batteria che mi improvvisamente finita e quindi il pc si spento di botto. Quando l'ho riavviato il lato sinistra della tastiera non funzionava pi (i tasti q,w,a,s,z,x,<,shift, caps lock, tab,esc e i tast F1, F2) ne da OSX, ne da WinVista ne da Linux. Ho portato il pc all'Acer per la riparazione e mi hanno cambiato la scheda madre.
Non ho ancora capito se il problema stato generato da OSX in concomitanza alla mancata alimentazione....

Ciao ciao
Petz

#9
MacPhisto

MacPhisto

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
ancora non riesco a farlo funzionare ...
cmq sono sicuro che il problema dovuto all'USB

se rimuovo IOUSBFamily.kext non si blocca pi all'avvio
cambiando il kext incriminato con quello (ufficiale Apple) con il debug attivo vedo, passando -f come parametro di avvio, che la stringa dove si blocca proprio quella di riconoscimento USB.

il BUS che "non viene riconosciuto" proprio quello interno a cui sono attaccate webcam e DVB-T

se solo riuscissi a disabilitarlo all'avvio

ho cercato ovunque ma niente

continuiamo a provarci ... peccato ... con leopard questo portatile veramente una bomba

#10
Psyco

Psyco

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Anch'io ho un acer 5920g

il mio la primissima versione, quella col T7300 e SENZA tvtuner

........anch'io ho avuto quel dannato problema con la RC2.......
....ma "nn ho detto nulla a nessuno" ed ho formattato tranquillamente, soprattutto x il fatto che mancavano ancora un sacco di driver!............ :)

.....ora invece, la situazione sembra migliorata!!!!!
..........addirittura esiste un driver della scheda video funzionante!!!! ;)

Mi son scaricato la nuova Kalyway che integra il kernel vanilla............tra qualche gg la installer e vedr cosa salta fuori!!! ;) ;) ;) ;) ;) ;)

seeya

#11
Psyco

Psyco

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
GOOD NEWS GUYS!!!!!!!!!!!

Installata la Kalyway!!!!

Leggete la mia firma....................

:P ;) ;) ;) ;) ;) ;)

#12
MacPhisto

MacPhisto

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Ho provato anche la kalyway ... e anche con quella ho avuto gli stessi problemi sull'USB
ho provato con i kext usb delle versioni 10.4.x (le ultime 2)

l'unica cosa che posso dire che mettendo il parametro -legacy non ho avuto pi blocchi sulla tastiera (almeno uno stato risolto)

ma con -legacy... funziona in modalit 32bit invece di 64 ??

Psyco: tu hai riscontrato solo il problema della tastiera o anche quello del blocco all'avvio (che sembra essere causato dal driver USB?)

#13
Psyco

Psyco

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Ho provato anche la kalyway ... e anche con quella ho avuto gli stessi problemi sull'USB
ho provato con i kext usb delle versioni 10.4.x (le ultime 2)

l'unica cosa che posso dire che mettendo il parametro -legacy non ho avuto pi blocchi sulla tastiera (almeno uno stato risolto)

ma con -legacy... funziona in modalit 32bit invece di 64 ??

Psyco: tu hai riscontrato solo il problema della tastiera o anche quello del blocco all'avvio (che sembra essere causato dal driver USB?)


Allora......con kalyway e vanilla ho provato 2 volte, ma al riavvio, dopo l'installazione nn trovava la tastiera!!!!
...........senza il vanilla mi funziona (per ora) tutto ok!

............cmq mi era successo alle volte che si bloccasse tutto al boot (ricordo che la spia dell'HD rimaneva spenta!!!)........
......ma nn so se fosse effettivamente dato dall'USB!!!

....nn so che dirti...... :(

#14
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
si, con il -legacy si forza a 32 bit...

#15
MacPhisto

MacPhisto

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
joeandmat: perche scrivi "Non funzionante per poco" riferito allla webcam? ci stanno lavorando?

anche se ho qualche "problemino" al boot sapere che un'altra componente del mio portatile funziona fa sempre piacere

Grazie

#16
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
no, non funzionante per poco significa che alcuni programmi mac mi danno schermata nera, mentre altri (dicono), che la web funziona... per esempio amsn... solo che per adesso non ho connessione sul mac, e quindi non lo posso testare... ciao!

#17
rubealan

rubealan

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Ciao Ragazzi! questo il primo post... anche io sono possessore del 5920g versione con T7300 , 2gb ram , 8600m gt 256 , hd 200 , bt , ecc...
Anche io vorrei installare la kalyway... per vi chiedo...
HO letto la guida dei vari multi boot, ma non sono ancora sicuro...
Praticamente sul mio portatile ho gi un quadriboot Vista/Xp/Ubuntu/part. di ripristino...
Ora io vorrei piallare la part di ripristino e mettere l Leo... come posso fare? la piallo prima? oppure l'installer di Leo mi permette di vedere e lavorare sulle partizioni?
non vorrei rischiare di perdere i miei dati...

grazie per l'aiuto!

#18
Psyco

Psyco

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Ciao Ragazzi! questo il primo post... anche io sono possessore del 5920g versione con T7300 , 2gb ram , 8600m gt 256 , hd 200 , bt , ecc...
Anche io vorrei installare la kalyway... per vi chiedo...
HO letto la guida dei vari multi boot, ma non sono ancora sicuro...
Praticamente sul mio portatile ho gi un quadriboot Vista/Xp/Ubuntu/part. di ripristino...
Ora io vorrei piallare la part di ripristino e mettere l Leo... come posso fare? la piallo prima? oppure l'installer di Leo mi permette di vedere e lavorare sulle partizioni?
non vorrei rischiare di perdere i miei dati...

grazie per l'aiuto!


Meglio se la pialli prima e fai spazio a leo

..........e poi dopo basta che la inizializzi al momento dell'installazione!!!

ciao

#19
hendelstudio2008

hendelstudio2008

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
anche io ragazzi ho acer 5920g con tv tuner...ho installato kaly ma ho problemi al boot...con la tastiera che non viene riconosciuta...eccc....che si fa a questo punto?...un saluto

#20
Psyco

Psyco

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

anche io ragazzi ho acer 5920g con tv tuner...ho installato kaly ma ho problemi al boot...con la tastiera che non viene riconosciuta...eccc....che si fa a questo punto?...un saluto



io ho risolto NON installando il vanilla kernel





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy