Jump to content

Sigmatel 9205 with iATKOS (Leopard)


  • Please log in to reply
340 replies to this topic

#281
mferreira85

mferreira85

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Brazil - Curitiba
Hello Guys,

Finally i got my sound card sigmatel 9205 working 100% (mute button, jack plugs, etc). I will attach a package with everything u need to get 100% audio working.

1) Distro of Leopard - Kalyway 10.5.2 or iATKOS 1.0r2
2) Sigmatel9223CodecDump_2.txt (yes this dump is the best one)
3) AppleHDAPatcherv1.20
4) AppleHDA.kext
5) Repair & Set Permissions.command (it's just a shellscript to repair permissions automagically)

a) Save your original copy of AppleHDA.kext
:) After that, remove it
c) Apply the dump file to the Taruga's patcher
d) Copy the AppleHDA.kext to the Extensions Directory (replace the one created by the patcher)
e) Run the shellscript to repair all the permissions
f) Reboot System

Everything should work fine :-)

Ps: I also included other dumps in the package in case you think you could use.

Hope that can help others trying to make the audio sigmatel 9205 work.

Attached Files



#282
reecepeart

reecepeart

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Hello Guys,

Finally i got my sound card sigmatel 9205 working 100% (mute button, jack plugs, etc). I will attach a package with everything u need to get 100% audio working.

1) Distro of Leopard - Kalyway 10.5.2 or iATKOS 1.0r2
2) Sigmatel9223CodecDump_2.txt (yes this dump is the best one)
3) AppleHDAPatcherv1.20
4) AppleHDA.kext
5) Repair & Set Permissions.command (it's just a shellscript to repair permissions automagically)

a) Save your original copy of AppleHDA.kext
-_- After that, remove it
c) Apply the dump file to the Taruga's patcher
d) Copy the AppleHDA.kext to the Extensions Directory (replace the one created by the patcher)
e) Run the shellscript to repair all the permissions
f) Reboot System

Everything should work fine :-)

Ps: I also included other dumps in the package in case you think you could use.

Hope that can help others trying to make the audio sigmatel 9205 work.


Hi There,
Do you mean the internal Mic Is working too?

And if not is there any solution?

Thanks, Guys

Reece

#283
mferreira85

mferreira85

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Brazil - Curitiba
Didn't test it because i'm using external mic. One only thing i didn't notice is that when the new AppleHDA.kext and the ALCinject.kext are in place, the shutdown led keeps turned on whe u shutdown the system. I think this issue is known as well as the mic that u have talked about. I would say that for me now it's a very good progression and we are find the complete solution very very soon.

#284
D3mon

D3mon

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hello Guys,

Finally i got my sound card sigmatel 9205 working 100% (mute button, jack plugs, etc). I will attach a package with everything u need to get 100% audio working.

1) Distro of Leopard - Kalyway 10.5.2 or iATKOS 1.0r2
2) Sigmatel9223CodecDump_2.txt (yes this dump is the best one)
3) AppleHDAPatcherv1.20
4) AppleHDA.kext
5) Repair & Set Permissions.command (it's just a shellscript to repair permissions automagically)

a) Save your original copy of AppleHDA.kext
:) After that, remove it
c) Apply the dump file to the Taruga's patcher
d) Copy the AppleHDA.kext to the Extensions Directory (replace the one created by the patcher)
e) Run the shellscript to repair all the permissions
f) Reboot System

Everything should work fine :-)

Ps: I also included other dumps in the package in case you think you could use.

Hope that can help others trying to make the audio sigmatel 9205 work.

Finally, I have sound on my laptop dell inspiron 1521.
But the sound not smooth. What is problem?
p.s: srry for my english skill

#285
mferreira85

mferreira85

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Brazil - Curitiba
Well, for now is what we have. They are improving...be pacient :-)

#286
marcx987

marcx987

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
For everybody that has a Dell Vostro 1500/1700/etc try this to get sound working.


1)Using AppleHDAPatcherv1.20: patch with a codec dump of audio 9205.(This doesn't have to be dumed using linux. I will provide one with this post to use)

2)Download AppleHDA.kext(which ever one will work. go through post 50-150 for many versions to see if any will work) and Kext Helper b7.

3)Using Kext Helper b7 replace the AppleHDA.kext

4)Reboot

5)When You reboot your media V-up/down and , the mute should work depending on the kext you used.


I have done this over and over again to get sound after reinstalling. The only thing that isn't working is the internal mic.

Other than my sleep not working my laptop runs really well.

For those with WIFI problems go get a dell 1505 wireless-n minicard for your laptop will work automatically with installed I080211Family.kext

To get any of the other unsupported cards to work will require a lot of time and playing to get the driver to actually load.



Attached File  Stac9205.txt   4.91KB   450 downloads(dump of audio codec)
Attached File  Kext_Helper_b7.zip   1.2MB   291 downloads
Attached File  AppleHDAPatcherv1.20.zip   1020.08KB   296 downloads
Attached File  AppleHDA.kext_2.zip   317KB   404 downloads(Kext file also known as AppleHDA.kext version3 of paulo's ones)

#287
reecepeart

reecepeart

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi Again,
Guys, I know this is a stupid question but why is the Internal Microphone
in the Dell Inspiron 1520 so hard to get working? Is there a known driver
for Linux that we can dump the code of? And if there is a viable solution for this
issue how is the progress going, who is creating it?

I would really appreciate any response.

Thanks
Reece

#288
truetorak

truetorak

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
My dell sound is now working using marcone-xiii method here don't know if mics work not needed, but external speakers only work don't know how to switch too internal, (if someone could help me here?)

#289
FruitbatNT

FruitbatNT

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Tried 5 different tutorials on this thread - still no dice. marcon-iii, macx987, and a couple older ones.

Vostro 1500 w/ 9205 (Dev id 76a0)
- running iATKOS 10.5.1 with the Kalyways 10.5.2 update and a 9.2.0 kernel
- Showing "No Audio Device" in mac info, never has

Also, I don't quite understand why all the instructions have us running the HDA patcher, then immediately replacing the HDA kext with a downloaded copy....?????

#290
kurenai

kurenai

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Tried 5 different tutorials on this thread - still no dice. marcon-iii, macx987, and a couple older ones.

Vostro 1500 w/ 9205 (Dev id 76a0)
- running iATKOS 10.5.1 with the Kalyways 10.5.2 update and a 9.2.0 kernel
- Showing "No Audio Device" in mac info, never has

Also, I don't quite understand why all the instructions have us running the HDA patcher, then immediately replacing the HDA kext with a downloaded copy....?????


i just used TheMarine's EFI guide (http://forum.insanel...howtopic=104078) last nite, and it worked great on my vostro1500. should be the same internals as yours i'd imagine. give it a shot. ;)

#291
Dell_M6300

Dell_M6300

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
Hello all. Hopefully there's still some smart people around who dealt with this problem with everyone else... I'm bringing a new model to the table I believe.

I have a Precision M6300 w/Quadro FX3600m 512 video, Core2Dup 2.4, 4GB RAM, basically loaded save for Blue-Ray and the fingerprint reader :D I'm very close to getting it all working on Kalyway 10.5.2 I'll be picking up a Dell 1505 card to replace the Intel 4965 that isn't supported (and don't think it ever will be with encryption). Using a Belkin stick in the interim. Video works perfectly with stock nvidia 512 driver. Running vanilla kernel. 2-finger scroll working. Ethernet - I don't care. Broadcom 57xx. Sound is a 9205.

I tried all sorts of patches and finally one of the kexts from this thread fired it up. I don't know if the whole codec patch did anything, the kext from here is what got it going. I have vol up/down/mute working, and I see it autoswitch in SysPrefs. Works fine with headphone connector. Speakers NOT working.

I downloaded a Ubuntu live CD. Confirmed speakers work. Mounted XP and Leopard drives in Read-Only. Awesome. Did the dump, its attached. Dropped that in to the 1.8 patcher, repair permissions and reboot. Lost everything save for vol up/down. Overwrote kext as instructed and rebooted. I'm back in the same spot - no mic in or internal speakers working.
;) :P :wallbash:



I'm going to compare a bit to the codec dumps from here as well as plist files I guess and see what I can come up with, but I'm starting cold in terms of figuring out how all this works so any help would be appreciated.

I'll FedEx good Canadian beer to anyone who can get it working for me ! ;)

-Adam

PS: Note to anyone else trying to install Kalyway 10.5.2 to this laptop... It appears to fail on boot of the DVD. Boot it up and wait for it to stop. Go on a date, or take the kids to the park, or mow your lawn. Come back, and it has about a 50% chance of being at the "Choose a language" screen. Other times it will just fail. I've successfully booted it twice ... YMMV.

Edit: Forgot to attach dump.

Attached Files



#292
Dell_M6300

Dell_M6300

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
Update: Tried the "SFX Script" method with same results... Only headphone out works.

If you have any other suggestions for me please let me know if I should revert to ALCinject to try them.

Thx

-A

#293
rimmi2002

rimmi2002

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 153 posts

Hello Guys,

Finally i got my sound card sigmatel 9205 working 100% (mute button, jack plugs, etc). I will attach a package with everything u need to get 100% audio working.

1) Distro of Leopard - Kalyway 10.5.2 or iATKOS 1.0r2
2) Sigmatel9223CodecDump_2.txt (yes this dump is the best one)
3) AppleHDAPatcherv1.20
4) AppleHDA.kext
5) Repair & Set Permissions.command (it's just a shellscript to repair permissions automagically)

a) Save your original copy of AppleHDA.kext
;) After that, remove it
c) Apply the dump file to the Taruga's patcher
d) Copy the AppleHDA.kext to the Extensions Directory (replace the one created by the patcher)
e) Run the shellscript to repair all the permissions
f) Reboot System

Everything should work fine :-)

Ps: I also included other dumps in the package in case you think you could use.

Hope that can help others trying to make the audio sigmatel 9205 work.


Tried this for Inspiron 1520...worked like a charm on iatkos 1.0

#294
Keys_3429

Keys_3429

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Good news :

My Sigmatel 9205 is working (not fully) on my Latitude D830. in fact only speakers work :(
What doesn′t work :
Jack : when i plug sthg, it doesn′t stop speakers and i don t hear anything in.
Input : doesn′t work at all.
Sound buttons work except mute one.

Hear is my AppleHDA.kext
Edit : sorry, i have problem with the internet.
To make it work, apply the codec file to HdaPatcher, and then replace the info.plist inside :D

It is based on the one made by HdaPatcher, and i modified the info.plist file according to my codec file.

EDIT 2 : kext : http://www.zshare.ne...621698666c9cfe/



How do you apply the codec file? I've had my Mac OS X86 running for a couple of days.
Everything running well except no sound (Dell Vostro 1500). Tried the AppleHDA.kext and installed, but didn't work. Although, I don't know what I'm doing with kexts.

Any help would be greatly appreciated.

#295
NickRolando1

NickRolando1

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

Hello Guys,

Finally i got my sound card sigmatel 9205 working 100% (mute button, jack plugs, etc). I will attach a package with everything u need to get 100% audio working.

1) Distro of Leopard - Kalyway 10.5.2 or iATKOS 1.0r2
2) Sigmatel9223CodecDump_2.txt (yes this dump is the best one)
3) AppleHDAPatcherv1.20
4) AppleHDA.kext
5) Repair & Set Permissions.command (it's just a shellscript to repair permissions automagically)

a) Save your original copy of AppleHDA.kext
:blink: After that, remove it
c) Apply the dump file to the Taruga's patcher
d) Copy the AppleHDA.kext to the Extensions Directory (replace the one created by the patcher)
e) Run the shellscript to repair all the permissions
f) Reboot System

Everything should work fine :-)

Ps: I also included other dumps in the package in case you think you could use.

Hope that can help others trying to make the audio sigmatel 9205 work.


I was wondering im trying to drap and drop the codecdump2 .txt file into the applehdapatcherv1.20 and it wont let me drag and drop it. it wont go into the patcher?

#296
reecepeart

reecepeart

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
C'mon people has anyone found a way to get the internal microphone
working on the Dell Inspiron 1520?! If not why is it so hard to find a way
can anybody help me find a way round this?

Thank you
Reece

#297
Atomic34

Atomic34

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I am also having problems with patcher, have removed Azalia but still wont let me drop into patcher :)

Please help

#298
Atomic34

Atomic34

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Ok got a fix for us guys where the patcher is'nt working,

Drag the patcher icon to your Applications folder, Then right click on dump file and open with HDA patcher.

Job done :)

#299
Atomic34

Atomic34

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
BTW this method worked perfectly for me, A big ty to all involved developing this guide and the workaround for us :)

#300
greener1986

greener1986

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
anybody know how to get the 9205 working in kalyway 10.5.2. i've tried the iAktos fixes but they dont seem to work





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy