Jump to content

Need testers for one of the components of next v2.00 Patcher


  • This topic is locked This topic is locked
313 replies to this topic

#1
Taruga

Taruga

    Retired

  • Retired Developers
  • 532 posts
  • Gender:Male
  • Location:Portugal
* 02/02/2008 New version to test and send output (Changes: Detection of other codec addresses, hope it works now)
* 05/01/2008 New version to test and send output

Hi guys, I need some testers for a component of my next patcher. (This test is very important for the release of the new patcher)


What should you do:
  • Download the attached kext, unzip it.
  • Copy it to root ( / )
  • Set permissions
    chown -R root:wheel /HDAudio.kext
    chmod -R 755 /HDAudio.kext
  • Boot with -s (no need to mount file system, but maybe it´s needed if you want to save results with dmesg > /report.txt since the file system is at read-only mode if you don´t mount it read/write)
  • kextload /HDAudio.kext
It should read the codec info and report something like this on v3:
Dec 11 15:01:07 taruga kernel[0]: HDAudio[0x9f24c00]::CodecDetection-started(0x4caa880) by Taruga
Dec 11 15:01:07 taruga kernel[0]: HDAudio::D27:F0 Irq: 19 Vid: 8086 Pid: 27d8
Dec 11 15:01:08 taruga kernel[0]: HDAudio::Cad Address: 0
Dec 11 15:01:08 taruga kernel[0]: HDAudio::Vid/Pid	: 0x10ec0882
Dec 11 15:01:08 taruga kernel[0]: HDAudio::Subsystem  : 0x1043e601
Dec 11 15:01:08 taruga kernel[0]: HDAudio::Revision   : 0x00100101
Dec 11 15:01:08 taruga kernel[0]: HDAudio[0x9f24c00]::CodecDetection-ended(0x1)

Or something like this on v5:
Jan  5 21:56:09 taruga kernel[0]: HDAudio[0xfd75800]::CodecDetection-started(0x4ea5180) by Taruga
Jan  5 21:56:09 taruga kernel[0]: HDAudio::D27:F0 Irq: 19 Vid: 8086 Pid: 27d8
Jan  5 21:56:09 taruga kernel[0]: codec_mask =  0x00000000
Jan  5 21:56:09 taruga kernel[0]: HDAudio::Cad Address: 0
Jan  5 21:56:09 taruga kernel[0]: HDAudio::Vid/Pid	: 0x10ec0882 
Jan  5 21:56:09 taruga kernel[0]: HDAudio::Subsystem  : 0x1043e601
Jan  5 21:56:09 taruga kernel[0]: HDAudio::Revision   : 0x00100101
Jan  5 21:56:09 taruga kernel[0]: STATESTS	   : 0x00000000
Jan  5 21:56:09 taruga kernel[0]: FGroups:	   : 0x00010001
Jan  5 21:56:09 taruga kernel[0]: Widgets:	   : 0x00020025
Jan  5 21:56:09 taruga kernel[0]: FGroupType	 : 0x00000001
Jan  5 21:56:09 taruga kernel[0]: First/Last Nid : 2 37
Jan  5 21:56:09 taruga kernel[0]: Nid 0x02			   0x00000011 DAC
Jan  5 21:56:09 taruga kernel[0]: Nid 0x03			   0x00000011 DAC
Jan  5 21:56:10 taruga kernel[0]: Nid 0x04			   0x00000011 DAC
Jan  5 21:56:10 taruga kernel[0]: Nid 0x05			   0x00000011 DAC
Jan  5 21:56:10 taruga kernel[0]: Nid 0x06			   0x00000211 DAC Digital
Jan  5 21:56:10 taruga kernel[0]: Nid 0x07			   0x0010011b ADC
Jan  5 21:56:10 taruga kernel[0]: Nid 0x08			   0x0010011b ADC
Jan  5 21:56:10 taruga kernel[0]: Nid 0x09			   0x0010011b ADC
Jan  5 21:56:10 taruga kernel[0]: Nid 0x0a			   0x00100391 ADC Digital
Jan  5 21:56:10 taruga kernel[0]: Nid 0x0b			   0x0020010b Mixer
Jan  5 21:56:10 taruga kernel[0]: Nid 0x0c			   0x0020010f Mixer
Jan  5 21:56:10 taruga kernel[0]: Nid 0x0d			   0x0020010f Mixer
Jan  5 21:56:10 taruga kernel[0]: Nid 0x0e			   0x0020010f Mixer
Jan  5 21:56:12 taruga kernel[0]: Nid 0x0f			   0x0020010f Mixer
Jan  5 21:56:12 taruga kernel[0]: Nid 0x14 A:0x01 S:0x00 0x01014c10 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x15 A:0x01 S:0x02 0x01011c12 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x16 A:0x01 S:0x01 0x01016c11 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x17 A:0x01 S:0x04 0x01012c14 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x18 A:0x04 S:0x00 0x01a19c40 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x19 A:0x05 S:0x00 0x02a19c50 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x1a A:0x04 S:0x01 0x01813c41 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x1b A:0x02 S:0x00 0x02214c20 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x1c A:0x04 S:0x0f 0x9933014f Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x1d A:0x0f S:0x00 0x411111f0 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x1e A:0x03 S:0x00 0x01451130 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x1f A:0x0f S:0x00 0x411111f0 Pin Complex
Jan  5 21:56:12 taruga kernel[0]: Nid 0x22			   0x0020010f Mixer
Jan  5 21:56:12 taruga kernel[0]: Nid 0x23			   0x0020010f Mixer
Jan  5 21:56:12 taruga kernel[0]: Nid 0x24			   0x0020010f Mixer

I need to check if it´s reading the info correctly on different chipsets and codecs
If you have you ownr linux codec dump, report if there is any difference on: Address and Subsystem

Thanx for your help

Not Detected Codecs Seems that it´s not detecting codecs that show Address 2 in linux dump (and maybe Address 1 also) I need to find a way to detect them as the new patcher will use this detection method. If I cannot detect a codec, the new patcher will not work with them a most worse, I cannot program the codec initialization. I hope to find what´s wrong.

Edited by Taruga, 03 February 2008 - 02:38 AM.


#2
Dainix

Dainix

    Level 12 Warmage

  • Members
  • PipPipPipPip
  • 204 posts
  • Gender:Male
  • Location:In a Toaster Oven
  • Interests:15% APR for three years. After that, it's 20%.
HDAudio[0x3cfce00]::CodecDetection-started(0x397cb80) by Taruga
HDAudio::D27:F0 Irq: 22 Vid: 8086 Pid: 27d8
HDAudio::Cad Address: 0
HDAudio::Vid/Pid	: 0x83847634
HDAudio::Subsystem  : 0x107b0281
HDAudio::Revision   : 0x00100101
HDAudio[0x3cfce00]::CodecDetection-ended(0x1)

Seems okay to me for a Sigmatel 9250.

Edited by Taruga, 11 December 2007 - 02:50 PM.
Thanx for your report


#3
avk

avk

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
test on: HP nx6310 EY512ES CoreDuo T2050 sys: Jas 10.4.8 (yet no sound :mellow:)
sound: Soundmax HD Audio 24bit ADI 1981 HD

output:
HDAudio[0x1ca2800]::CodecDetecrion-started(0x19ab080) by Tagura
HDAudio::D27:F0 Irq: 21 Vid: 8086 Pid: 27d8
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x11d41981
HDAudio::0x103c30aa
HDAudio::0x00100200
HDAudio[0x1ca2800]::CodecDetection-ended(0x1)

#4
Gord

Gord

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Worked just fine! It identified my chipset properly. As a test I moved the kext from / into /System/Library/Extensions and it works great.
No mic input, but I am not too worried about that.

Dec 10 23:33:47 localhost kernel[0]: HDAudio[0x3f30c00]::CodecDetection-started(0x3c79c00) by Taruga
Dec 10 23:33:47 localhost kernel[0]: HDAudio::D27:F0 Irq: 17 Vid: 8086 Pid: 27d8
Dec 10 23:33:47 localhost kernel[0]: HDAudio::Cad Address: 0
Dec 10 23:33:47 localhost kernel[0]: HDAudio::Vid/Pid : 0x11d41981
Dec 10 23:33:47 localhost kernel[0]: HDAudio::Subsystem : 0x17aa2025Dec 10 23:33:47 localhost kernel[0]: HDAudio::Revision : 0x00100200
Dec 10 23:33:48 localhost kernel[0]: HDAudio[0x3f30c00]::CodecDetection-ended(0x1)



Thanks!
Gord.

Edited by Gord, 11 December 2007 - 04:30 PM.
It should appear at /var/log/system.


#5
SticMACâ„¢

SticMACâ„¢

    "Nobody likes a SmartASS"

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,590 posts
  • Gender:Male
  • Location:Da Bathroom!!
Sigmatel 9227 on Dell Dimension 9200 (XPS410)

ALC Inject Settings Pin Configurations <Data not Shown>
ALC Inject Settings Built IN <Data not Shown>
ALC Inject Settings Layout ID <Data not Shown>
HDAudio[0x72ad000]::CodecDetecrion-started(0x6ea7300) by Tagura
HDAudio::D27:F0 Irq: 16 Vid: 8086 Pid: 284b
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x00000000
HDAudio::Subsystem : 0x00000000
HDAudio::Revision : 0x00000000
HDAudio[0x72ad000]::CodecDetection-ended(0x1)

#6
jl7854

jl7854

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
This is for a Sigmatel 9205


HDAudio[0x42cd800]::CodecDetection-started(0x3f1f200) by Taruga
HDAudio::D27:F0 Irq: 21 Vid: 8086 Pid: 284b
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x838476a0
HDAudio::Subsystem : 0x102801f2
HDAudio::Revision : 0x00100204
HDAudio[0x42cd800]::CodecDetection-ended(0x1)

#7
antic

antic

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
Realtek alc882

output:
HDAudio[0x3cb3000]::CodecDetection-started(0x395f300) by Tagura
HDAudio::D27:F0 Irq: 19 Vid: 8086 Pid: 27d8
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x10ec0882
HDAudio::Subsystem :0x1043e601
HDAudio::Revision : 0x00100101
HDAudio[0x3cb3000]::CodecDetection-ended(0x1)

#8
New2OSx

New2OSx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
Realtek alc861

output:

HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x10ec0861
HDAudio::Subsystem :0x11791205
HDAudio::Revision : 0x00100300

#9
bongo

bongo

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
This is for ALC 861-VD on Lenovo


HDAudio[0x34f3e00]::CodecDetection-started(0x31dbd80) by Taruga
HDAudio::D27:F0 Irq: 22 Vid: 8086 Pid: 27d8
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x10ec0862
HDAudio::Subsystem : 0x17aa8e2d
HDAudio::Revision : 0x00100001
HDAudio[0x34f3e00]::CodecDetection-ended(0x1)



By the way, with new version patchers after 1.18 and alc861testing.zip, as well as with ALC861_Subsystem_Id_0x10430000_alfa_driver_by_Taruga after applying codedump from linux it can recognize my codec properly, no SPDIF:

AppleHDA Patcher - 2006/2007 by Taruga v1.20


* Patching AppleHDA.kext to 0x10ec0862 Done
* Checking AppleHDA for patch Done
0001f4a0 cmpl $0x10ec0862,%eax
00020584 cmpl $0x10ec0862,%eax
* Checking for SPDIF Out Not Detected
* Checking for SPDIF In Not Detected
* Using the following nodes in pathmap

Speaker :

* Copying new config to destination Done
* Repairing Permissions Done
* Deleting Extensions Cache Done

** Done patching - You can reboot now **



After reboot, It can't load kext:

kextload /System/Library/Extensions/AppleHDA.kext/
can't add kernel extension /System/Library/Extensions/AppleHDA.kext/ (not a bundle) (run kextload on this kext with -t for diagnostic output)

-t option didn't give me more information.

In system Profiler about Audio:

Intel High Definition Audio:

Device ID: 0x17AA3802
Audio ID: 12

... and no, the permissions are just OK:

chown -R root:wheel /System/Library/Extensions/AppleHDA.kext/
chmod -R 755 /System//Library/Extensions/AppleHDA.kext/
kextload /System/Library/Extensions/AppleHDA.kext/
can't add kernel extension /System/Library/Extensions/AppleHDA.kext/ (not a bundle) (run kextload on this kext with -t for diagnostic output)


Sorry for this big off-topic, but I have only 4 posts and always trying to help with more information.
I'm with Leopard.
Taruga:0x10ec0862 was never suported by the patcher, that´s why. Wait for 2.00 and maybe you´ll get better luck

Attached Files


Edited by Taruga, 11 December 2007 - 05:35 PM.
That was for 861, not 861-VD and you didn´t set permissions right also. And please, this thread is another subject, don´t mix stuff here.


#10
elviejo

elviejo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 273 posts
This is for Biostar 945GZ Micro775 SE mobo with ALC861-vd

KEXTLOAD: /HDAudio.kext loaded succesfully
HDAudio[0x3e03000] : : Codec Detection Started(0x3b31900) by Taruga
HDAudio : : D27 : F0 Irq: 16 Vid: 8086 Pid: 27d8
: /root# HDAudio : : Card Address : 0
HDAudio : : Vid/Pid : 0x00000000
HDAudio : : Subsystem : 0x00000000
HDAudio : : Revision : 0x00000000
HDAudio[0x3e03000] : : CodecDetection-ended(0x1)

Attached File  alc861_vd.txt   6.87KB   136 downloads

Edited by Taruga, 11 December 2007 - 08:11 PM.
Try kext #2 please


#11
SticMACâ„¢

SticMACâ„¢

    "Nobody likes a SmartASS"

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,590 posts
  • Gender:Male
  • Location:Da Bathroom!!
You better hope you don't get into trouble like I did for giving "US" all those 0x00000000

SticMAN :lol:

This is for Biostar 945GZ Micro775 SE mobo with ALC861-vd

KEXTLOAD: /HDAudio.kext loaded succesfully
HDAudio[0x3e03000] : : Codec Detection Started(0x3b31900) by Taruga
HDAudio : : D27 : F0 Irq: 16 Vid: 8086 Pid: 27d8
: /root# HDAudio : : Card Address : 0
HDAudio : : Vid/Pid : 0x00000000
HDAudio : : Subsystem : 0x00000000
HDAudio : : Revision : 0x00000000
HDAudio[0x3e03000] : : CodecDetection-ended(0x1)

Attached File  alc861_vd.txt   6.87KB   136 downloads


Taruga:Try kext #2, please

#12
NYC Coyote

NYC Coyote

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 238 posts
  • Location:New York, NY
This is what I got with a Sigmatel 9200 running on a Dell Inspiron E1505/6400

HDAudio[0x3cf5400]::CodecDetection-started(0x397cb80) by Taruga
HDAudio::D27:F0 Irq: 21 Vid: 8086 Pid: 27d8
HDAudio::Vid/Pid : 0x83847690
HDAudio::Subsystem : 0x102801bd
HDAudio::Revision : 0x00102201
HDAudio[0x3cf5400]::CodecDetection-ended(0x1)

Edited by Taruga, 11 December 2007 - 05:38 PM.
Missing Cad Address


#13
SticMACâ„¢

SticMACâ„¢

    "Nobody likes a SmartASS"

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,590 posts
  • Gender:Male
  • Location:Da Bathroom!!
Taruga, Honestly that is what comes up!

I ONLY TYPE:
kextload /hdaudio.kext at the root and NOTHING else!!

my screen dump:

:/ root# kextload /hdaudio.kext
kextload: /hdaudio.kext loaded successfully
:/root# ALCinject: Starting.
ALC Inject Settings Pin Configurations <Data not Shown>
ALC Inject Settings Built IN <Data not Shown>
ALC Inject Settings Layout ID <Data not Shown>
HDAudio[0x7286000]::CodecDetecrion-started(0x6ea7300) by Tagura
HDAudio::D27:F0 Irq: 16 Vid: 8086 Pid: 284b
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x00000000
HDAudio::Subsystem : 0x00000000
HDAudio::Revision : 0x00000000
HDAudio[0x7286000]::CodecDetection-ended(0x1)

Is there ANY way i can do a text dump in -s mode to forward to you?
the only thing that changes is the
HDAudio[0x7286000]::CodecDetecrion-started(0x6ea7300) by Tagura
HDAudio[0x7286000]::CodecDetection-ended(0x1)

the 0x7286000 changes to a different number each time!



Taruga:You´re not in trouble SticMAN, some people don´t do as I say (I don´t know if it´s your case, but it seems so) and then I get false results
If you did as I say, then why the hell do you have ALCinject ouput before my kext output ?!

Edited by Taruga, 11 December 2007 - 05:50 PM.
If you´re doing things right then we have a big problem why it doens´t report codec info. You can get the output from /var/log/system


#14
caracols

caracols

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
HDAudio.kext
HDAudio[0x3bc5600]::CodecDetection-started(0x397dc80) by Taruga
HDAudio::D27:F0 Irq: 16 Vid: 8086 Pid: 27d8
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x10ec0888
HDAudio::Subsystem : 0x18491e01
HDAudio::Revision : 0x00100001
HDAudio[0x3bc5600]::CodecDetection-ended(0x1)

HDAudio3.kext
HDAudio[0x3bc5600]::CodecDetection-started(0x397dc80) by Taruga
HDAudio::D27:F0 Irq: 16 Vid: 8086 Pid: 27d8
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x10ec0888 0x00000000 0x00000000
HDAudio::Subsystem : 0x18491e01
HDAudio::Revision : 0x00100001
HDAudio[0x3bc5600]::CodecDetection-ended(0x1)

There's no difference between these and the linux codec dump on Address or Subsystem

Edited by caracols, 13 December 2007 - 05:45 PM.
Thanx, the problem is that some linux distros report incorrect subsystem info. It happened with me.


#15
neihn

neihn

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Dec 11 10:55:25 localhost kernel[0]: HDAudio[0x4ca1200]::CodecDetection-started(0x473ce00) by Taruga
Dec 11 10:55:25 localhost kernel[0]: HDAudio::D27:F0 Irq: 16 Vid: 8086 Pid: 27d8
Dec 11 10:55:25 localhost kernel[0]: HDAudio::Cad Address: 0
Dec 11 10:55:25 localhost kernel[0]: HDAudio::Vid/Pid : 0x83847682
Dec 11 10:55:25 localhost kernel[0]: HDAudio::Subsystem : 0x10192950
Dec 11 10:55:25 localhost kernel[0]: HDAudio::Revision : 0x00103601
Dec 11 10:55:25 localhost kernel[0]: HDAudio[0x4ca1200]::CodecDetection-ended(0x1)


This is for the sigmatel 9221. Yes, it is as same as the codec dump under Linux.

Thanks.

#16
cloudrainstar

cloudrainstar

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
Linux Codec Dump:
Codec: Realtek ALC262
Address: 0
Vendor Id: 0x10ec0262
Subsystem Id: 0x10cf0100
Revision Id: 0x100202

Taruga Codec Detection:
HDAudio[0x3c85200]::CodecDetection-started(0x38c8400) by Taruga
HDAudio::D27:F0 Irq: 21 Vid: 8086 Pid: 284b
HDAudio::Cad Address: 0
HDAudio::Vid/Pid	: 0x10ec0262
HDAudio::Subsystem  : 0x10cf0100
HDAudio::Revision   : 0x00100202
HDAudio[0x3c85200]::CodecDetection-ended(0x1)


#17
SticMACâ„¢

SticMACâ„¢

    "Nobody likes a SmartASS"

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,590 posts
  • Gender:Male
  • Location:Da Bathroom!!
UPDATE::

I removed both the ALC inject.kext and AplleHDA.kext file, they keep my sound going, rebooted into -s
then ityped:

kextload /hdaudio.kext at the root

my screen dump:

:/ root# kextload /hdaudio.kext
kextload: /hdaudio.kext loaded successfully
HDAudio[0x6587400]::CodecDetecrion-started(0x6ea7300) by Tagura
HDAudio::D27:F0 Irq: 16 Vid: 8086 Pid: 284b
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x00000000
HDAudio::Subsystem : 0x00000000
HDAudio::Revision : 0x00000000
HDAudio[0x6587400]::CodecDetection-ended(0x1)

Hopethis helps??

Edited by Taruga, 11 December 2007 - 06:57 PM.
Do you have your own linux codec dump ? If so, check what is the address number.


#18
Nuphor

Nuphor

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
HDAudio[0x3cfce00]::CodecDetection-started(0x397cb80) by Taruga
HDAudio::D27:F0 Irq: 22 Vid: 8086 Pid: 27d8
HDAudio::Cad Address: 0
HDAudio::Vid/Pid	: 0x00000000
HDAudio::Subsystem  : 0x00000000
HDAudio::Revision   : 0x00000000
HDAudio[0x3cfce00]::CodecDetection-ended(0x1)

SigmaTel STAC9274D (Bad Axe 2 Mainboard), attached is a copy of a Linux dump I took.

Nothing executed other than

kextload /HDAudio.kext

EDIT

Retried with kext 3:

HDAudio[0x3d17a00]::CodecDetection-started(0x3964c80) by Taruga
HDAudio::D27:F0 Irq: 22 Vid: 8086 Pid: 27d8
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x00000000 0x00000000 0x00000000
HDAudio::Subsystem : 0x00000000
HDAudio::Revision : 0x00000000
HDAudio[0x3d17a00]::CodecDetection-ended(0x1)

Attached Files


Edited by Nuphor, 22 December 2007 - 04:30 PM.
Try kext #2 please


#19
SticMACâ„¢

SticMACâ„¢

    "Nobody likes a SmartASS"

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,590 posts
  • Gender:Male
  • Location:Da Bathroom!!
I used your AppleHDAPatcher 1.16 with the STAC9227_83847618.TXT file to get the LineOUT working

then

the STAC9227_83847618.zip (testing file) on your posting to get the rest up and running!

I've never had a Codec dump file as this method ALWAYS worked great?!

SticMAN

Edited by Taruga, 11 December 2007 - 08:10 PM.
Try kext #2 please


#20
Max1980

Max1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
Realtek ALC 268 on Leopard 10.5.1 (HP Pavillion DV6626us)
HDAudio[0x29b3000]::CodecDetecrion-started(0x2656380) by Taruga
HDAudio::D27:F0 Irq: 22 Vid: 8086 Pid: 284b
HDAudio::Cad Address: 0
HDAudio::Vid/Pid : 0x10ec0268
HDAudio::Subsystem : 0x103c30cc
HDAudio::Revision : 0x00100003
HDAudio[0x29b3000]::CodecDetection-ended(0x1)


The codec dump in linux gives an erroneus codec dump:
Codec: Motorola Si3054
Address: 1
Vendor Id: 0x10573055
Subsystem Id: 0x10573055
Revision Id: 0x100700

Edited by Taruga, 24 December 2007 - 10:28 PM.
I think you took the modem codec from linux






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy