Jump to content

getting laptop lcds to work......


  • Please log in to reply
10 replies to this topic

#1
maverick_pranav

maverick_pranav

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
having tried almost every thing from natit to titan....couldnt get my lcd to work...though qe/ci works on external monitor.....
going through the ioregs..i felt that maybe the reason why the internal lcds are not working is bacause they are not apple makes'.
i could be wrong but just thought its worth giving a thought.....in display overides folder they have information of about all the displays in use with the macs..and reason why vga works is because its supposed to work with any external display device..even in case of a mac!
maybe the display overides contain more information than just max resolution information etc...
maybe titan,natit etc only make the gfx card functional and not the lcd!..

it could be worth a while to try and delete the display informations in display overides folder and see if a mac book also behaves in a similar way..thats output only coming on the vga out and not the internal lcd!!..
i dont have access to a mac otherwise would have tried it myself!..

i could be totally wrong...but it might be the reason why lcds arent working..

#2
Jingu

Jingu

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
Getting laptop lcd's to work with NVidia 512MB cards without bios flashing has already successfully been done since last month.

I have an Acer Aspire Laptop, intel core 2 duo NVidia Geforce Go 7900GS 512MB.

Up until last month, the only way to get a 512MB NVidia card working was to flash it's VGA bios according to Gotoh's instructions.

But I have discovered that by using any OSX86 10.4.10 and above or Leopard, along with Natit 3rd release, QE/CI is enabled no problem without the lcd internal display problem.

Since then, Gotoh has released an NVinjectGo-512MB-0.1.0 that enables QE/CI on NVidia 512MB laptops. It has worked well for me and for many others.

So, you need Leopard or any OSX86 10.4.10 and above along with NVinjectGo512MB-0.1.0 if you have an NVidia 512MB.

I even get dual screen by hot-plugging. There is an additional trick that might not work for every card but is working well for me:

to enable the VGA output, I change the NVCAP to 04000000 00000d00 02000000 00000007 00000000

to enable the DVI output, I change back the NVCAP to 04000000 00000300 0c000000 00000007 00000000

#3
maverick_pranav

maverick_pranav

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male

Getting laptop lcd's to work with NVidia 512MB cards without bios flashing has already successfully been done since last month.

I have an Acer Aspire Laptop, intel core 2 duo NVidia Geforce Go 7900GS 512MB.

Up until last month, the only way to get a 512MB NVidia card working was to flash it's VGA bios according to Gotoh's instructions.

But I have discovered that by using any OSX86 10.4.10 and above or Leopard, along with Natit 3rd release, QE/CI is enabled no problem without the lcd internal display problem.

Since then, Gotoh has released an NVinjectGo-512MB-0.1.0 that enables QE/CI on NVidia 512MB laptops. It has worked well for me and for many others.

So, you need Leopard or any OSX86 10.4.10 and above along with NVinjectGo512MB-0.1.0 if you have an NVidia 512MB.

I even get dual screen by hot-plugging. There is an additional trick that might not work for every card but is working well for me:

to enable the VGA output, I change the NVCAP to 04000000 00000d00 02000000 00000007 00000000

to enable the DVI output, I change back the NVCAP to 04000000 00000300 0c000000 00000007 00000000

I am having Geforce go 7400,it has 64mb dedicated memory!....still white screen problem persists....
i am right now using jas 10.4.8...it would be great if u could help me out....would upgrading 10.4.8 or leapord make the internal lcd to work???
it would be great if u could help me out a bit.....
thanx

#4
Jingu

Jingu

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
I am surprised you are having problems with a 64mb card. Is it AGP or PCI express interface? You should not need to go all the way to leopard to get your lcd working.
10.4.10 is when my laptop lcd first started working for me. What outputs do you have VGA, DVI?

Actually, to tell you the truth, I also got my lcd to work in 10.4.9 by copying over to 10.4.9 all the NVidia kexts from 10.4.10 and the OpenGL.framework folder from 10.4.10, as well as using Natit 3rd release as the enabler. But now I use, NVinjectGo512MB-0.1.0 as the enabler.

I am not too sure how it will work out for your card, but before trying to upgrade, why not simply use a different enabler like NVinjectGo. You can find all the NVinjectGo files at:

http://nvinject.free.fr/downloads.php

There is also a lot of tips for getting NVidia cards to work at the NVinject forum:

http://nvinject.free.fr/forums/

Be advised: I have just read on the NVinjectGo forum that many users are having lcd problems with their Sony Vaio NVidia 7400 Go laptop

#5
errandwolfe

errandwolfe

    Usurper of Wilson, King of Prussia

  • Donators
  • 1,429 posts
  • Gender:Male
  • Location:Miami Beach, FL
Many people are having the exact same problem described in post 1 with their GMA X3100 based laptops.

#6
maverick_pranav

maverick_pranav

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
just a thought....reading through forums...i came across several people who got qe/ci working but not resolution changing...and there are users having dell..who report a working lcd screen with geforce go 7400.....
so where is the problem??????.....ay idea...any one....
even if we are able to find a way to have qe/ci without resolution changing(that is system not identifying the monitor)..we can do the same with applications such as qe/ci..
anyone who can give any info...
tried display utility to create a display override..but i am not sure its getting loaded...can anyone please help me in this...

#7
g0ldr4k3

g0ldr4k3

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
I got a sony vaio fe series and I can't use my internal lcd monitor...with natit or nvinjectGO or other, when my 7600go is recognized works only the external monitor.....It's a big issue for me and the other vaio's users

#8
maverick_pranav

maverick_pranav

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
has anyone tried leapord... is the white screen problem in leapord also.....
a important thing that i noticed was....when the mac doesnt recognise a display the display overide corresponding to it is vendor id:756e6b6e and product id is 717.......not sure though.....

can anyone with expertise in this can help!...

#9
razorrazor

razorrazor

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Same for Toshiba laptops (i'm on P20)...

#10
maverick_pranav

maverick_pranav

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
today tried deleting display overides folder on imac!..it did boot!....
but differnce in system profiler..it just showed display!..and ioreg showed that edid was being read!..
thats not the case with us!..and most prob the prblem!
anyone with ideas!..clues,solutions!!!...no point just saying that "same prob with me!"
lets get the things working!

#11
M-KLOME

M-KLOME

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:London

today tried deleting display overides folder on imac!..it did boot!....
but differnce in system profiler..it just showed display!..and ioreg showed that edid was being read!..
thats not the case with us!..and most prob the prblem!
anyone with ideas!..clues,solutions!!!...no point just saying that "same prob with me!"
lets get the things working!


check this out....

it may work for you

http://forum.netkas....topic,63.0.html





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy