Jump to content

AppleHDA Patcher Results


  • This topic is locked This topic is locked
243 replies to this topic

#61
daviddl

daviddl

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Computer Type: Laptop
Sound Card Vendor: Conexant
Sound Card Model: 5045
Vendor Id: 0x14f15045

Working: build in speaker
Not Working: Pink (mic) jack, Green (headphone) jack, build in mic

Patcher Version used: 1.19
System Version: Leopard

Please help i really wanna make the sound work on my laptop
Thx


Same setup here. Note that the built in speaker is only working using AppleAzaliaAudio.kext.

#62
banini_jeque

banini_jeque

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
I had to do "cat /proc/asound/card0/codec97#0/ac97#0-0 > ~/Desktop/codec_dump.txt" and it came out like this:

0-0/0: C-Media Electronics CMI9761A+

PCI Subsys Vendor: 0x1849
PCI Subsys Device: 0x9761

Revision : 0x02
Compat. Class : 0x03
Subsys. Vendor ID: 0x8086
Subsys. ID : 0x1234

Capabilities :
DAC resolution : 16-bit
ADC resolution : 16-bit
3D enhancement : No 3D Stereo Enhancement

Current setup
Mic gain : +0dB [+0dB]
POP path : pre 3D
Sim. stereo : off
3D enhancement : off
Loudness : off
Mono output : MIX
Mic select : Mic1
ADC/DAC loopback : off
Double rate slots: 10/11
Extended ID : codec=0 rev=2 AMAP LDAC SDAC CDAC DSA=0 DRA
Extended status : SPCV LDAC SDAC CDAC

#63
greatneo

greatneo

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male
  • Location:Mac OSX86 Arena
Computer Type : PC
Asus P5GC-MX motherboard

Sound Card Vendor : Realtek

Sound Card Model : ALC883

Vendor ID : 0x10ec0883

Working : Line In, Line Out, SPDIF Out

Not Working : SPDIF In

System Version : 10.4.11, 10.5.2

Patcher Version : 1.20

Attached Files



#64
Trolav

Trolav

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Norway
Computer Type: Laptop (Acer TM-6292)
Sound Card Vendor: Realtek
Sound Card Model: ALC268
Vendor Id: 0x10ec0268

Working: Nothing
Not Working: Everything else

Patcher Version used: 1.20
System Version: Leopard 10.5.1

obs: Detected by System Profiler as Intel High Definition Audio, Device ID: 0x1025011B,Audio ID: 12

Linux dump attached.

Attached Files



#65
songlee

songlee

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
  • Interests:CPU:DualCore Pentium E2160, OC 3.0G<br />MB:ASRock P43R1600Twins-WiFi(P43,ICH10R)<br...
Computer Type: Notebook(945GM ICH7M)
Sound Card Vendor: Realtek
Sound Card Model: Alc861
Vendor Id: 0x10ec0861
Subsystem Id: 0x15840000
Revision Id: 0x100300

Working: Nothing
Not Working: Everything

Patcher Version used: 1.20
System Version: Leopard 10.5.1
Attached File  codec.txt   5.6KB   78 downloads


Taruga: Try this ALC861 kext

Edited by Taruga, 18 December 2007 - 12:35 PM.
Kext for testing


#66
Zoologico

Zoologico

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I got mine to work after reading kevingy's post:

http://forum.insanel...&...st&p=535721

Computer Type: Laptop - Dell Latitude D820
Sound Card Vendor: SigmaTel
Sound Card Model: STAC9200
Vendor Id: 0x83847690

Working: Everything

Patcher Version used: 1.20
System Version: Leo 10.5.1

#67
MetalFishX

MetalFishX

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Florida, Uruguay
Hi, i didnt has any one working (of the currents 888 dumps), maybe because i am on ICH9, so the dump from linux worked for my Realtek ALC888 ICH9 Familly.
Its attached. Thanks!

Attached Files



#68
MacintizeD

MacintizeD

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
  • Location:Mach_Kernel
Computer Type: Laptop
Sound Card Vendor: Realtek
Sound Card Model: ALC861
Vendor Id: 0x10ec0861

Working: Everything! Attached Screenshots
Not Working: None (Speakers make 'popping' sound occasionally and on startup)

Patcher Version used: new alc861.kext
System Version: Leopard
Attached File  sound.tiff   10.81KB   120 downloadsAttached File  output.tiff   957.3KB   116 downloadsAttached File  input.tiff   965.53KB   99 downloads


Note: the output image is the input image, vice versa. Sorry!

Thank you Taruga! My speakers are finally working on OS X! :hysterical:

#69
닭발은세개

닭발은세개

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Computer Type: PC(ASUS P5K-E WiFi Edition)
Sound Card Vendor: ADI
Sound Card Model: AD1988B (ICH9R)
Vendor Id: 0x11d4198b

Revison 100300 ?

more info(P5K-E WiFi Chipset Ven&Dev)
- M/B :
Ven 8086
Dev 293e
Sub 8277
Sys 1043

Working: None
Not Working: All

Patcher Version used: All Version.( ~ v1.2.0 )
System Version: Tiger 10.4.11 & Leopard 10.5.1

Taruga thank you. :unsure: 1988B support please

#70
NYC Coyote

NYC Coyote

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 238 posts
  • Location:New York, NY
Are you saying that you can get the mic, mute and jack out to work? I got sound with the internal speakers but that's it.I am having the same problem with the shutdown.

Computer Type: Laptop - Dell Latitude D820Sound Card Vendor: SigmaTelSound Card Model: STAC9200Vendor Id: 0x83847690Working: EverythingPatcher Version used: 1.20System Version: Leo 10.5.1My only problem is after sound is patched (I tried different patcher versions 1.12-1.19 as well) and I cannot complete a shutdown. The screen goes black, but the power stays on. I need to power off the laptop by holding the power button.If I replace AppleHDA.kext with the original Leopard version - laptop shuts down fine. I even tried my working kext from 10.4.11 and same problem.

I got mine to work after reading kevingy's post:http://forum.insanel...&...st&p=535721Computer Type: Laptop - Dell Latitude D820Sound Card Vendor: SigmaTelSound Card Model: STAC9200Vendor Id: 0x83847690Working: EverythingPatcher Version used: 1.20System Version: Leo 10.5.1

Which linux dump and patcher did you use? I only get sound out of my internal speakers...not getting mic or line out, or mute.I have a dell e1505 with the same card.

#71
Max1980

Max1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
Computer Type: Laptop HP Pavillion dv6626us
Sound Card Vendor: Realtek
Sound Card Model: ALC 268
Vendor Id: 0x10ec0268
Subsystem Id: 0x103c30cc

Not Working: Internal Speaker (with appleazalia the output is recognized but no sound) Internal Mic, Headphones, Mic Line In)

Patcher Version used: 1.20, 1.19(non-working)
System Version: Leopard 5.1

Attached Files



#72
userx

userx

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 124 posts

Computer Type: Laptop
Sound Card Vendor: Conexant
Sound Card Model: 5045
Vendor Id: 0x14f15045

Working: build in speaker
Not Working: Pink (mic) jack, Green (headphone) jack, build in mic

Patcher Version used: 1.19
System Version: Leopard

Please help i really wanna make the sound work on my laptop
Thx


I have the same set-up as you. I'm using a USB Headphone/Mic Adaptor, works great to get sound out, mic in working for now.

Here is a link to what I'm using. It's Plug-n-play, works great!

http://www.macnn.com...microphone.html

#73
sese

sese

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Location:Sherwood Park, Alberta
Computer Type: Laptop
Sound Card Vendor: Sigmatel
Sound Card Model: 9228
Vendor Id: 0x83847616

Working: 1 of 2 headphone ports
Not Working: internal speakers, 2nd headphone port, internal mic and mic out port

Patcher Version used: 1.17
System Version: TIger

Attached File  dump.txt   5.93KB   57 downloads

#74
NightSt@lk3r

NightSt@lk3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
  • Gender:Male
  • Location:Wiltshire, England
Computer Type : PC
Gigabyte 965P S3 Rev3.3

Sound Card Vendor : Realtek

Sound Card Model : ALC888

Vendor ID : 0x10ec0888

Working : Line In, Line Out, Headphones , SPDIF Out

Not Working : SPDIF In

System Version : 10.5.0

Patcher Version : 1.20

After abit of chopping up of multiple codec dumps i manage to make one that works with this board.

Attached Files



#75
Nekoi

Nekoi

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Location:Montains City
Computer Type: Intel Desktop Board D946GZIS
Sound Card Vendor: Sigmatel
Sound Card Model: ST9227
Vendor Id: 0x83847618

Working: "Internal Speaker" but not sound
Not Working:Green Out, Blue In, Pink Mic.

Patcher Version used: 1.16 (Also tried 1.17,1.18, 1.19, 1.20 but only 1.16 it's more accurate)
System Version: Leopard 10.5 Kernel 9.0.0

obs: Internal Speaker seems to be working, but dont ear anything.

When leopard are starting i ear a little noise from speaker but the sound don't came out...

What do you think?

Attached Files



#76
beebox50

beebox50

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
  • Gender:Male
Computer Type: laptop Sony Vaio VGN-SZ73B ICH7 950GM
Sound Card Vendor: SigmaTel ID 7662
Sound Card Model: SigmaTel ID 7662
Vendor Id: 0x83847662 in codec dump but 0x104D81E6 in Mac OSX
Working: Line Out, SPDIF Out
Not Working: Mic

Patcher Version used: 1.20 with stac9227_83847618_testing kext and sigmatel_7662.txtAttached File  sigmatel_7662.txt   3.56KB   588 downloads
System Version: Leopard 10.5 ToH

#77
mactist

mactist

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Computer Type: Intel Desktop Board D946GZIS
Sound Card Vendor: Sigmatel
Sound Card Model: ST9227
Vendor Id: 0x83847618

Working: "Internal Speaker" but not sound
Not Working:Green Out, Blue In, Pink Mic.

Patcher Version used: 1.16 (Also tried 1.17,1.18, 1.19, 1.20 but only 1.16 it's more accurate)
System Version: Leopard 10.5 Kernel 9.0.0

obs: Internal Speaker seems to be working, but dont ear anything.

When leopard are starting i ear a little noise from speaker but the sound don't came out...

What do you think?


try connecting speakers or headphones to the audio jacks

#78
Nekoi

Nekoi

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Location:Montains City

try connecting speakers or headphones to the audio jacks


i Try unplug and plug agan but not sound, may be upgrading to 10.5.1 work...

#79
elopedthought

elopedthought

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
taruga you made my day!!!
i just tried your new patcher for ad1986 and now i got sound for the first time!!!
THANKS SOOO MUCH!!!!

Computer Type: desktop amd-based pc
Sound Card Vendor: ADI
Sound Card Model: AD1986a
Vendor Id: 0x11d41986

Working: line out sound, digital output (recognized but can't test, sorry)
Not Working: mic (recognized, but not working); volume bar is grey (not usable) so i can set the volume only on my speakers

Patcher Version used: ad1986.zip from today
System Version: Leopard 10.5.1 (zephyroth release)

see the rest of my pc specs in my signature!
anything else you need to know?

Attached Files



#80
llauqsd

llauqsd

    InsanelyMac Geek

  • Donators
  • 137 posts
  • Gender:Male
  • Location:Canada
Computer Type: laptop (asus w3j)
Sound Card Vendor: ADI
Sound Card Model: AD1986a
Vendor Id: 0x11d41986

Working: Displays inputs and outputs
Not Working: Sound in/out, speakers, volume control

Patcher Version used: ad1986a patcher released today
System Version: Leopard 10.5.1

linux codec dump attached
Attached File  w3j.txt   6.87KB   61 downloads

Reason for edit: changed to proper format





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy