Jump to content

"Still waiting for root Device"


  • Please log in to reply
47 replies to this topic

#41
mainetality

mainetality

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:South-Africa
Asus P5b fully working osx Tiger or Leopard! no more waiting for root device!

Hi guys im so excited i got my mac working!
its been weeks and weeks trying to fix it, ja pain in the you know where
flashing bioses trying diff bios settings everything out there but nothing worked!
but there is so much to say i'm not gonna even start!
This is my first time so i dont know this post stuff works pls bare with me.

Specs: core2duo e6300 @ 3.12ghz
Asus P5b standard (bios 1803)
8600gts 256mb
4gig ram
250gig, 250gig, 160gig all sata2 + 80gig ide
asus sata dvdrw

now i'm not gonna waste your time if you getting error "still waiting for root Device"
do this. iam using Iatkos btw but that doesnt matter its a error with any osx dvd.

1.get osx dvd Leo or Tiger or whatever.
3. Sata dvdrw and plug it into sata (ahci) port 2. Thats the bottm
left slot in your motherboard see you have 4 ports in your board normally.
Top left =sata1
bottom left =sata2
top right =sata3
bottom right =sata4
4. 2. go into your bios and change all ide settings to ACHI whereever you see (there's two in mine)
5.restart and boot with your mac dvd

your hard drive must be in top right (sata1 port)
and your dvdrw must be in the port underneath that, bottom left (sata2 port)
if its like that that means they are in one channel same as two ide
drives in 1 ide cable if you know what i mean.
now your mac will boot.
i installed my mac in the ide but thats up to you.

My Iatkos dosnt wanna boot after install witout the disk still in the dvdrw will
post a fix soon as i find one.
Everything works with my iatkos dvd ex drivers for my 8600gts i got those elsewhere
let me know if you need the link. or search "NVInstallerV.41.pkg"
later.

#42
Blacksheepx

Blacksheepx

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Location:Brasil
hi,

I have this same msg when tried to instal osx86 in my pc

my config is:
Intel core2quad 2,5 q9300
Mobo E-vga 790i ultra sli
1 hd Sata2 320g seagate ntfs with Vista ultimate x86
1 hd Sata2 500g Seagate FAT32 empty
DvD-RW Pionner Sata

in my mobo setup dont have the option to set sata drivers to ide,
its have on option that is "jmicron AHCI = Disable/Enable"


can anyone help me?

#43
DONNYTEN

DONNYTEN

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
Blacksheepx:

Not an advanced OSX86 tech support specialist but:

Maybe it has something to do with SATA, Something in your BIOS that needs switchin, or perhaps you could try installing from a different dvd rom drive.

I got the error and switching drives got rid of it.

#44
greensonu

greensonu

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I've a same problem

#45
stanleyhalim

stanleyhalim

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
  • Location:indonesia

I've a same problem


mee too... but i installing from my notebook HD external... how can i fixed that?

#46
oldtopman

oldtopman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 348 posts
  • Gender:Male
  • Location:A galaxy far far away...
Please don't make a habit of replying to year-old threads, make your own. Also, we can't help you if we don't have system specs, installer distro, etc.

#47
Beerkex'd

Beerkex'd

    Content Provider

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,000 posts
  • Gender:Male
  • Location:Belo Horizonte - Brazil
Tried and true solutions for "still waiting for root device"

http://apple2pc.blog...oot-device.html
http://apple2pc.blog...-device-ii.html

#48
Mleo

Mleo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I've a same problem in boot: -V "Failed to load nv30hal.... Still waiting for root device..." My HD MASTER(IDE1 PRIMARY), and DVD MASTER(IDE1 SECUNDARY). My motherboard is a ASUS P4S800-DX(Shipset SIS655FX). How i make to resolve this problem? Thanks!

My config:

Motherboard ASUS P4S800-DX (SIS655FX)
Intel Pentium 4 HT 3.0 GHZ Prescot (SSE2,SSE3...)
2X 512MB DDR
SATA 120 GB Seagate
DVD LG GSA-4163B
NVIDIA Geforce 256MB FX 5200 128 Bits


Hola siento no poder expresarme en ingles, pero espero alguien pueda traducir lo que escribo.

He de decir que yo también tengo una Motherboard Asus PS800-DX(SIS655FX)
CPU P4 HT 3.0 GHz
con 4GB Ram PC2700(400Mhz)
NViDIA GForce 6600GT con 128MB
2 HD ID, de 160GB, conectados a un adaptador from IDE to USB, asi que van como externos
2 HD SATA, de 200GB, conectados a un adaptador de SATA a USB, quedando como externos.s
Es decir todos los HD están conectados a los puertos USB, de 2 tarjeta PCI de 5 puertos cada una.
Ademas tengo 1 DVD-RW IDE y un DVD, ambos conectados atraves de IDE.

Tengo instalado iAtkos V7,en el ordenador cuyas caracteristicas detallo en las lineas de arriba, pero con las mismas condiciones instale Tiger, si bien fue en un portatil, Asus X51RL.
Para la instalación conecte la regrabadora IDE a una adaptador de IDE A USB, de modo que pareciese externa.
Ya instalado Mac Os Leopard, reincide en modo vervose(F8 y -v ) tengo todo a pleno rendimiento, gráficos con aceleración gráfica, audio, ethernet y sistema actualizable, desde el actualizador de software del sistema. Lo único que no va es la wifi, pero conecto una D-Link y G120 y listo.
Entonces pongo la regaladora interna y el HD con el sistema sigue como usb, de ese modo no existe el problema de STILL WAITING FOR ROOT DEVICE, ni antes ni después de la instalación.
El poner como esclavo o maestro los dispositivos, no cambia nada, al menos en mi caso, en diversas instalaciones con Tiger y Leopard, he tenido esa experiencia.
Ejemplo, con Tiger sobre disco duro interno(SATA O IDE) EL INSTALADOR SE QUEDABA EN STILL WAITING FOR……….
Ponia los discos Regrabador y HD externos(mediante los adaptadores a USB)
y la instalación era exitosa.
Vale la pena probarlo todo, experimentar tiene como resultado que al final las cosas salen.
Espero sirva de ayuda.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy