Jump to content

New AGPGart


  • Please log in to reply
940 replies to this topic

#101
zarac

zarac

    The Dude abides

  • Members
  • PipPipPipPipPip
  • 314 posts
  • Gender:Male
  • Location:Zagreb, Croatia
  • Interests:film/video editing and post-production

i'll send you ioreg from that working tiger setup.

and here it is.

hehe, i quoted myself :)

Attached Files



#102
kramer2k

kramer2k

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts
yeah, 2.1 is seriously the money shot...

So on tiger 4.11, no go with the following installed...
Geforce.kext
AGPGart.kext (247)
NV40
NVResman
All other Geforce.bundles and .plugins
NO NVINJECT.kext

Still hangs at hammer bus...

Can't touch this...HAMMER TIME! :)

#103
ronnyweasle

ronnyweasle

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

Thanks, for me 2.1 is working fine as well. My Radeon 9800 Pro is detected now:

ATI Radeon 9800 Pro:

  Chipset Model:	ATY,R350
  Type:	Display
  Bus:	AGP
  VRAM (Total):	128 MB
  Vendor:	ATI (0x1002)
  Device ID:	0x4e48
  Revision ID:	0x0000
  Displays:
Display:
  Resolution:	1024 x 768
  Depth:	32-bit Color
  Core Image:	Supported
  Main Display:	Yes
  Mirror:	Off
  Online:	Yes
  Quartz Extreme:	Supported



dumb question, but that's in tiger right?

#104
Slice

Slice

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,487 posts
  • Gender:Male
  • Location:Moscow

Thanks, for me 2.1 is working fine as well. My Radeon 9800 Pro is detected now:

Good luck!

You have Intel mobo?

He has AMD64. 2.1 never works for Intel.
You have AGP 2.0 and I found that noone with 2.0 can boot... Something wrong with it.
Can you look into your BIOS. May be you can set up AGP 3.0?

yeah, 2.1 is seriously the money shot...

So on tiger 4.11, no go with the following installed...
Geforce.kext
AGPGart.kext (247)
NV40
NVResman
All other Geforce.bundles and .plugins
NO NVINJECT.kext

Still hangs at hammer bus...

Can't touch this...HAMMER TIME! :wacko:

You are my best tester. No other can show me what is wrong.
I shall compare 2.1 and 247 to find a difference but it tooks time for me.

What I think.
Leo has 64-bit architechture. AMD64 too. But AGP bus and Gart table are 32-bits only.
How to reconcile its?

#105
kramer2k

kramer2k

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts
But it's not a problem only to Leo, since the same thing happens in tiger...

Secondly, just because AMD can support 64bit and the same with Leo, does that mean that it automatically uses 64bit?

K

#106
Slice

Slice

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,487 posts
  • Gender:Male
  • Location:Moscow
One more attempt. This version is still 32 bits. So first of all try it in tiger. Then in Leo.
If you can't boot with it try to boot without GA.plugin so you can obtain dmesg for me.
Can't upload here, so link
http://applelife.ru/...a...ost&id=1242

#107
thorne

thorne

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

I continue to develop the AGPGart driver.
Now it supports Intel, nVorce, VIA, SIS and ATI chipsets.
If anyone have trouble with it then report as
[b]ioreg -l -x -w 1024 >ioreg.txt


Here you go.
Attached File  ioRegAnddMesg_Thorne.zip   79.51KB   43 downloads

#108
Slice

Slice

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,487 posts
  • Gender:Male
  • Location:Moscow

Here you go.

OK.
Can you tell me summary what problem do you have?
1. AGPGart+ATIRadeon9700*+Callisto
2. AGPGart+ATIRadeon9700*
2a. without GA.plugin
3. ATIRadeon9700*+Callisto
4. ATIRadeon9700*
4a. ATIRadeon9700* but without GA.plugin

Sorry, 5 minute ago I found that 248 don't works with RS300 bus so use previuos good one.

#109
kramer2k

kramer2k

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts
can anyone host it on rapidshare?
This is what i get after I login there...
У вас нет доступа к этой странице или функции. Если вы не авторизованы, можете сделать это, используя форму ниже, а затем попробовать снова.

#110
Slice

Slice

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,487 posts
  • Gender:Male
  • Location:Moscow

can anyone host it on rapidshare?
This is what i get after I login there...
У вас нет доступа к этой странице или функции. Если вы не авторизованы, можете сделать это, используя форму ниже, а затем попробовать снова..

What is the problem? You don't know Russian?
This means

You have no access to the page or function. If you are not autorized you can do it using the form below and then try again.

If you can't download AGPGart it is here

#111
kramer2k

kramer2k

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts
Still no worky...
Now it does the same error, but 4 times, then this line at the end
AGP: hammerbus DevID=1100 VenID=1002
AGP: hammerbus DevID=1101 VenID=1002
AGP: hammerbus DevID=1102 VenID=1002
AGP: hammerbus DevID=1103 VenID=1002
AGP: hammerbus DevID=ffff VenID=ffff
AGP: hammerbus DevID=ffff VenID=ffff
AGP: hammerbus DevID=ffff VenID=ffff
(same thing 3 more times...then)
AGPAMD apbase=00000078
(Then hangs)

This is either with or without GeforceGA.plugin

#112
Slice

Slice

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,487 posts
  • Gender:Male
  • Location:Moscow
Yes, it is a mistake. Corrected

#113
kramer2k

kramer2k

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts
hey slice, I'm not home to test it yet, but I just want to say that I REALLY appreciate all of the hard work that you are putting into this

#114
kramer2k

kramer2k

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts
Same thing...
except now it also says...

Coherence: Yes
then everything else in the previous post...

with or without geforcega.plugin

#115
a1k0n

a1k0n

    InsanelyMac Legend

  • Retired
  • 568 posts
Any news about AGPGart??

#116
verleihnix

verleihnix

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
Hi Slice,
here are my results for 248a.
The System boots up into a blue screen without mouse cursur.
Then it hangs.

Attached Files



#117
Slice

Slice

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,487 posts
  • Gender:Male
  • Location:Moscow
I am sorry for long misunderstanding of AMD. Now it might work.
Minor changes for Intel systems.
Very new configuration: ATI bus (Xpress 200M or 1260M) + AMD CPU. But AGP driver have no sense until video driver :blink:

Test, please, and report dmesg (or system.log) part with PCI tracing. If successful - xBench.

NEXT

Attached Files



#118
verleihnix

verleihnix

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
same results, blue screen and then it stops.
The kextcache was made by system, this didn't happen before.

Attached Files



#119
rezn

rezn

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Really appreciate the hard work you have done on this project. Tried 2.49 and Tiger boots to blue screen

Here are some logs

Attached Files



#120
kramer2k

kramer2k

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts
Slice, holy-be-jeezous..

I almost made a mess in my pants when loading 249...
The GOOD NEWS - boots to blue screen and PCI Trace!!
The Bad news...boots to blue screen

A-M-A-Z-I-N-G Progress

PCI trace attached!

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy