Jump to content

New AGPGart


  • Please log in to reply
940 replies to this topic

#501
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
Slice i dont think u had my word before.
anyway im back to ATINDRV .10 which gives me artifacts under time machine and games :D that sucks.

#502
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,067 posts
  • Gender:Male
  • Location:Moscow

Slice i dont think u had my word before.
anyway im back to ATINDRV .10 which gives me artifacts under time machine and games :guitar: that sucks.

Now I hear :(
My new project will be ATINDRV like. I'll try to make it X1600AGP compatible.
About ATILead120. Your test is failed as I understand and I shall be very thank you if you tell me exactly a moment at crash. It is not Leo vs Tiger problem cause you successfully use my drivers compiled under Tiger.
Did you try in terminal ?
sudo kextload -t ATILead.kext

#503
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
so SLice first i think ATINDRV is a huge yard and will ask a lot of work (Framebuffer) but if u suceed i respect u; anyway i'll keep using 2D from now on. Cause I dont wanna use blurry effect of ATINDRV 10.4.5.
About IONDRVSUpport ive made test on my mac book pro and i confirm that version 1.4.3 aka 10.4.5 works on Leopard 10.5.2 even on real mac without a glitch. So if u wanna dig in IONDRVSupport just think about AGP nothin has to be added else it works fine even in "mixed" kext mode.

About the ATILead it's weirdo. I'll make the ioreg tonite once im done at work ie kextload -t.

#504
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,067 posts
  • Gender:Male
  • Location:Moscow
Take into account that new version of IONDRVSupport contains more correct support for sleep function and new pixel formats. May be other improvements.

#505
Never Mind

Never Mind

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Melbourne
Hi Slice,

Once again thank you for answering my questions! Here are some more ;-)

2 Never Mind
You are on a right way but did mistakes.

You are wrong. This is for ATIRadeon9700GA.plugin. Not for ATIRadeon9700.kext - revert it!


Okay, I changed the Info.plist file back to the original, I left my DeviceID in there.

So now the IONDRVSupport.kext was in place, the ATIRadeon9700.kext as well, and the ATIRadeon9700 file has been patched with the two perl commands (the second pair of perl commands from http://forum.insanel...mp;#entry685498 actually, as the first two perl commands didn't change anything).

Then I did a rm /System/Library/Extensions.mkext before rebooting (this needs to be done?)

Well after booting I still can't start the Leopard DVD player (a valid video device could not be found). I also tried the VLC player, and that only works (sound only) if I turn off video..

System profiler gives:

Type: Display
Bus: PCI
VRAM (Total): 128 MB
Vendor: ATI (0x1002)
Device ID: 0x4a49
Revision ID: 0x0000
Displays:
Display:
Resolution: 1024 x 768
Depth: 32-bit Color
Core Image: Software
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Not Supported

From IOREG:

| | | +-o ATIRadeon9700 <class ATIRadeon9700, registered, matched, active, busy 0, retain 6>
| | | | +-o IONDRVFramebuffer <class IONDRVFramebuffer, registered, matched, active, busy 0, retain 5>

(IONDRVSupport not mention there, just the above IONDRVFramebuffer, not sure if this is correct?)

From kextstat:
72 0 0x1522a000 0x53000 0x52000 com.apple.ATIRadeon9700 (5.1.8) <56 55 17 12 4 2>
6 1 0x14c9c000 0xf000 0xe000 com.apple.iokit.IONDRVSupport (1.4.3) <55 17 7 6 5 4>

Can you make anything out of this information? |-)

Any other hints to get this working? Do you need more info from me?

This is "Change resolution" property for another driver of class "Framebuffer". For you it is Callisto v8 but it is not compatible with AGP yet. Work in progress.
What do you prefer to have "Change resolution" or "Hardware QE/CI" with "DVD playback"?


Well, let's first get one working, then the other ;-)

But I really also would like to change resolution & refresh rate t.b.h., 60hz it tires the eyes and 1024x768 really isn't a decent resolution ! ;-)

Do you have a link to where Callisto v8 can be downloaded? Then I can follow the work in progress there :D

Many thanks again!

Regards,

N.M.

#506
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,067 posts
  • Gender:Male
  • Location:Moscow
2 Never Mind
Search Callisto here (may be inside ATI package)
http://www.insanelym...php/t36886.html
Did you forget to correct info.plist from ATIRadeon9700GA.plugin?

#507
Never Mind

Never Mind

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Melbourne
Hi Slice,

I didn't change anything in ATIRadeon9700GA.plugin?

What should I change there?

Cheers,

N.M.

2 Never Mind
Search Callisto here (may be inside ATI package)
http://www.insanelym...php/t36886.html
Did you forget to correct info.plist from ATIRadeon9700GA.plugin?



#508
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,067 posts
  • Gender:Male
  • Location:Moscow
<dict>
<key>IOProviderClass</key>
<string>IOFramebuffer</string>
</dict>

#509
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
Slice here is what kextload says
bash-3.2# kextload -t /System/Library/Extensions/ATILead.kext
kernel extension /System/Library/Extensions/ATILead.kext has problems:
Missing dependencies:
{
"com.apple.iokit.IOPCIFamily" =
"A valid compatible version of this dependency cannot be found"
}

#510
Never Mind

Never Mind

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Melbourne
Hi Slice,

<dict>
<key>IOProviderClass</key>
<string>IOFramebuffer</string>
</dict>


Ah, sorry, I didn't get it before as I didn't realize that there was a .plugin directory as well, so I didn't understand it was referring to this one. So I change it into the above in the Info.plist in the GA.plugin directory.

Still, after reboot, no luck...

This has been done:
ATIRadeon9700.kext : DeviceID in Info.plist, ATIRadeon9700 patched with perl commands
ATIRadeon9700GA.plugin : changed the above lines in its Info.plist
IONDRVSupport.kext : 'installed' this one instead of one that was there

Any ideas left? What to check? What to change?

Otherwise I'll give up I guess, can't keep bugging you forever ;-)

Many many thanks for your help!!

Cheers, N.M.

#511
mocher

mocher

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hi,
Can anyone help me please? I have a X1950 AGP 512mb on a 4coredual-VSTA board and cannot get Kalyway 10.5.1 to boot after install.
Fails with the "you must press power button to restart etc"
I think its because of my craphics card being AGP?
So is there anyway I can load a driver for it? and if so how?
(complete noob with OSX)
Any help will be greatly appreciated ;)

#512
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,067 posts
  • Gender:Male
  • Location:Moscow

Slice here is what kextload says
bash-3.2# kextload -t /System/Library/Extensions/ATILead.kext
kernel extension /System/Library/Extensions/ATILead.kext has problems:
Missing dependencies:
{
"com.apple.iokit.IOPCIFamily" =
"A valid compatible version of this dependency cannot be found"
}

It is simple question even for noob.
I write in info.plist dependency IOPCIFamily 2.4.4 as I have.
You may
1. Write your version
2. Use my version of IOPCI. Why not???? Do you still have slow computer?


Ah, sorry, I didn't get it before as I didn't realize that there was a .plugin directory as well, so I didn't understand it was referring to this one. So I change it into the above in the Info.plist in the GA.plugin directory.

Still, after reboot, no luck...

This has been done:
ATIRadeon9700.kext : DeviceID in Info.plist, ATIRadeon9700 patched with perl commands
ATIRadeon9700GA.plugin : changed the above lines in its Info.plist
IONDRVSupport.kext : 'installed' this one instead of one that was there

Any ideas left? What to check? What to change?

Otherwise I'll give up I guess, can't keep bugging you forever ;-)


You probably made all that necessory. I propose you to check twice that kexts is loaded and influence on somehow. What about repair permissions?

Hi,
Can anyone help me please? I have a X1950 AGP 512mb on a 4coredual-VSTA board and cannot get Kalyway 10.5.1 to boot after install.
Fails with the "you must press power button to restart etc"
I think its because of my craphics card being AGP?
So is there anyway I can load a driver for it? and if so how?
(complete noob with OSX)
Any help will be greatly appreciated :)

First of all boot with key -s to see when system crashed.

#513
mocher

mocher

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hi
I booted with -x (sorry thought thats what you said) and its booted up but with no sound device installed.
Is -x safe mode? network is working tho.
Not sure about display driver how would I check?
Sorry for being such a noob but at least im typin this from safari now so thats a start ...

#514
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,067 posts
  • Gender:Male
  • Location:Moscow

Hi
I booted with -x (sorry thought thats what you said) and its booted up but with no sound device installed.
Is -x safe mode? network is working tho.
Not sure about display driver how would I check?
Sorry for being such a noob but at least im typin this from safari now so thats a start ...

O, yes, -x is a safe mode with only needed driver. Without sound and video drivers. As you can boot so your video driver is not good. It is a deep story not for the thread. if you would have success without AGP driver but problems with it come here to discuss.

#515
mocher

mocher

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hi,
I booted with -s and it crashes when the ATIT driver loads .. goes into debug mode.
Is this an AGP problem or just a driver fault do you think?
thanks

#516
Dan Druff

Dan Druff

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male
  • Location:Behind the keyboard!
Hi, been away from my comp for few days, but I'm back!

2 DanDRof can u tell me precisely the version of ATINDRV u run i mean under system profiler, in fact with 10.5.2 ATINDRV I get tearing under Tomb raider Anniversary. Im back to an older ATINDRV but seems to freeze now :unsure: maybe a bug of the grafic update arf.
I dont want to get back to ATINDRV 10.4.5 cause this one gives blurry effect on my LCD 82cm !! :'( damit


I use thevanilla ATINDRV.kext found in the combo update 10.4.5 from Apple, you can extract it with Pacifist.


Also I did some new test with the new material!


#9
Leo 10.5.2
AGPGart 2.6.5.f -> AGP_Base_0xf0000000
IONDRVsupport -> From Slice (V2)
atindrv 10.4.5
IOGraphicsFamily -> Vanilla 10.5.2/Graph Update 1.0
Graph kext -> Vanilla 10.5.2/Graph update 1.0 with mod to ATIRadeonX1000.kext with 71C2 key added

Boot w/o problems, get to the GUI and can use the OS.

Tearing: No
Shading (OpenGL Standard): 1509
GioFX: 438



#10
Leo 10.5.2
AGPGart 2.6.5.b2 -> AGP_Base_0xf0000000
IONDRVsupport -> From Slice (V1441)
atindrv 10.4.5
IOGraphicsFamily -> Vanilla 10.5.2/Graph Update 1.0
Graph kext -> Vanilla 10.5.2/Graph update 1.0 with mod to ATIRadeonX1000.kext with 71C2 key added

Boot to the BSOD (for the noobs, Blue Screen Of Death), nothing can be done except reset.

Tearing: NA
Shading (OpenGL Standard): NA
GioFX: NA



#11
Leo 10.5.2
AGPGart 2.6.5.f -> AGP_Base_0xf0000000
IONDRVsupport -> From Slice (V1441)
atindrv 10.4.5
IOGraphicsFamily -> Vanilla 10.5.2/Graph Update 1.0
Graph kext -> Vanilla 10.5.2/Graph update 1.0 with mod to ATIRadeonX1000.kext with 71C2 key added

Boot w/o problems, get to blue screen with mouse, with blind clicks, can close the computer and GUI breifly appears when I do so.

Tearing: None visible
Shading (OpenGL Standard): NA
GioFX: NA

Hope this help you Slice!

Attached Files



#517
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,067 posts
  • Gender:Male
  • Location:Moscow
2 Dan Druff
Yes, I know that IONDRVSupport 1441 doesn't work with ATIRadeonX1600 and other dual head Radeons.
But sorry, I didn't prepare new version yet. No time for deep programming.
For you and Toadspit some question.
Did you ever try to replace OpenGL.framework to version from 10.4.6 or early?

#518
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
Slice i just bought a fresh config for 200 euros :P
PCIE mobo, 8600GT and no more AGP bug :)

#519
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,067 posts
  • Gender:Male
  • Location:Moscow

Slice i just bought a fresh config for 200 euros :(
PCIE mobo, 8600GT and no more AGP bug :)


Congratulation! It is the best solution.
If I'll buy new laptop the AGP development will be finished.

#520
toadspit

toadspit

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts

For you and Toadspit some question. Did you ever try to replace OpenGL.framework to version from 10.4.6 or early?

yes I did with 10.4.9; result: a sort of metaphysical screen, made of white and black squares.sorry don't know how to describe it better! ;)

Congratulation! It is the best solution.If I'll buy new laptop the AGP development will be finished.

nooo slice don't do something you would be sorrow of! :P





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy