Jump to content

[Guida] From Hack to Mac


  • Please log in to reply
163 replies to this topic

#21
boxer2

boxer2

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Male
  • Location:Puglia
Salve ragazzi,
Ho provato la versione 3 di PC_EFI. Tra l'alto nel readme c' scritto di eliminare solo il kext: appleefiruntime.kext
... e procedere a creare la cartella iamefi con tutto l'ambaradan descritto.

Bene, sia prima che dopo aver installato Pc_EFI il profiler mi continua a rilevare un procio errato:

Nome modello: Mac
Identificatore modello: To Be Filled By O.E.M.
Nome processore: Intel Core 2 Solo
Velocit processore: 2.29 GHz
Numero di processori: 1
Numero totale di nuclei: 1
Cache L2: 2 MB
Memoria: 1 GB
Velocit bus: 1.33 GHz



La differenza sta nelle due prime righe.
Inoltre ho provato a lanciare Geekbench 2 e... sorpresa.. mentre prima il mio PC veniva identificato come un
Hackintosh.... dopo PCI_EFI..... viene rilevato come Mac.

Attached File  GeekBench.tiff   36.35KB   147 downloads


Ora, qualcuno pu indicarmi come verificare che tutto sia stato installato correttamente (altri test?).



PS:Il mio hardware un Asrock1333-D667 (Bios V. 1.30) + C2Duo E6550 e Leo installato con ToH RC2.

#22
tonino_l

tonino_l

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
dove si trova PC_EFI ver.3 io non lo trovo

#23
Kratos87

Kratos87

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
io ho un processore T5600 core 2 duo..
purtroppo pero lo devo farzare a usare un solo core perche se li uso entrambi il video e parecchi dettagli mi vanno a scatti
installando qst patch posso risolvere il mio problema e usare tranquillamente i 2 core???

#24
boxer2

boxer2

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Male
  • Location:Puglia
http://x86osx.com/bb...cd4ada9d8048e10

#25
babyporch

babyporch

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
  • Gender:Male
  • Location:Sicily
Se usi la v3 usa l'SMBIOS della v1, a me cos funziona.

#26
cesare

cesare

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 315 posts
Pongo una domanda anche se puo sembrare stupida maaaa
secondo voi questo hackintosh ........ ha l'efi curata?

Posted Image

Grazie mille !

:) :P :( :( :( :( :(

#27
MarcoPriv

MarcoPriv

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
scusate ma non riesco a capire una cosa, una volta installato pc_efi, devo scaricare un kernel senza patch?

#28
boxer2

boxer2

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Male
  • Location:Puglia
.... personalmente non ho modificato il kernel ma al primo aggiornamento disponibile provo ad installarlo e vediamo come procede.... in teoria dovrebbe andare :(

#29
God93

God93

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:Italia
dopo che l'ho fatto non ha piu funzionato e ho dovuto ripristinare il backup di ieri

#30
jamess

jamess

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

Ho provato ieri sera, ma il Mac si ferma prima della schermata di login.
Non frizzato perch il puntatore del mouse BT si muove tranquillamente ma non procede oltre.
Anche inserendo un disco si sente far qualcosa (non pu neanche pi essere estratto) solo che la schermata non cambia...


Ottengo lo stesso comportamento :)

ho cancellato il file /System/Library/Extensions/AppleSMBIOS.kext

se qualcuno pu inviarmelo in modo da provare a ripristinare quello altrimenti il mio leopard non si avvia pi :)

#31
tonino_l

tonino_l

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
Finalmente ho messo su PC_EFI ver.3
Ho pero riscontrato un problema: la time-machine si bloccava.
Sono andato su http://netkas.freeflux.net/
Ho scaricato IONetworking risistemato a questo link http://tinyurl.com/27frv7
1) scompattato sul desktop
2) sudo su
3) da terminale sono andato sul desktop
4) cp IONetworkingFamily /System/Library/Extensions/IONetworkingFamily.kext/Contents/MacOS/IONetworkingFamily
5) chown 0:0 /System/Library/Extensions/IONetworkingFamily.kext/Contents/MacOS/IONetworkingFamily
6) sudo rm /System/Library/Extensions.mkext
riavviato e tutto OK la time-machine funziona di nuovo :) :)

#32
cesare

cesare

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 315 posts

Pongo una domanda anche se puo sembrare stupida maaaa
secondo voi questo hackintosh ........ ha l'efi curata?

Posted Image

Grazie mille !

:thumbsup_anim: :) :( :( :( :( :(



#33
boxer2

boxer2

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Male
  • Location:Puglia
Guarda con l'SMBIOS curato .... a me appare questo:

Attached File  Hacked_System.tiff   68.39KB   209 downloads

la riga " Versione Boot ROM:Hack.int.0sh" nel profiler dovrebbe indicare la modicfica avvenuta con successo!

#34
cesare

cesare

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 315 posts
grazie mille boxer ! :)

#35
AppleLooney

AppleLooney

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 100 posts
  • Gender:Male

Riavviate il sistema ed al boot (F8) digitate -s

Il sistema si avvier in single user mode (non montate il disco).
Date questi comandi:
cd /iamefi
./startupfiletool /dev/rdiskXsX ./boot (sostituite rdiskXsX con il vostro: nel mio caso "rdisk0s1")
Riavviate.


Ciao potresti spiegarmi come si fa ad avviare in single user mode senza montare il disco???

Grazie

#36
DanielXan

DanielXan

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Se il disco non montato non puoi nemmeno andare nella cartella iamefi, lascia perdere la parte tra parentesi.
Dopo digitato -s al prompt dai i comandi che seguono.

#37
krowten

krowten

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 421 posts
  • Gender:Male

Guarda con l'SMBIOS curato .... a me appare questo:

Attached File  Hacked_System.tiff   68.39KB   209 downloads

la riga " Versione Boot ROM:Hack.int.0sh" nel profiler dovrebbe indicare la modicfica avvenuta con successo!


Versione Boot ROM:Hack.int.0sh
Ti compare perch hai sostituito AppleSMBIOS.kext, non perch hai messo pc_efi.

#38
AppleLooney

AppleLooney

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 100 posts
  • Gender:Male

Se il disco non montato non puoi nemmeno andare nella cartella iamefi, lascia perdere la parte tra parentesi.
Dopo digitato -s al prompt dai i comandi che seguono.


Il discorso ke dopo digitato -s se ne va in panic io credo ke ci va xk io posseggo un Pentium D

#39
cesare

cesare

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 315 posts

Versione Boot ROM:Hack.int.0sh
Ti compare perch hai sostituito AppleSMBIOS.kext, non perch hai messo pc_efi.

ciao krowten
Allora uno cosa deve guardare per vedere se il suo hackintosh e' divenuto ........ similmac ?
grazie mille

#40
tonino_l

tonino_l

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
per saperlo... basta caricare i prossimi aggiornamenti del kernel
oppure prendere dal dvd originale il kernel caricarlo ... dovrebbe andare
Io non ho provato ancora.... per pigrizia ;)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy